source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 720

Revision 720, 24.4 KB checked in by daisuke, 14 years ago (diff)
Line 
1%define nspr_version 4.8
2%define nss_version 3.12.3
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.6.21
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24Summary:        XUL Runtime for Gecko Applications
25Summary(ja):    Gecko アプリケーションのための XUL ランタイム
26Name:           xulrunner
27Version:        1.9.2.2
28Release:        1%{?_dist_release}
29URL:            http://www.mozilla.org/projects/xulrunner/
30License:        MPLv1.1 or GPLv2+ or LGPLv2+
31Group:          Applications/Internet
32Source0:        %{name}-%{version}-source.tar.bz2
33Source10:       %{name}-mozconfig
34Source11:       %{name}-mozconfig-vine5
35Source12:       %{name}-vine-default-prefs.js
36Source21:       %{name}.sh.in
37Source23:       %{name}.1
38
39# locale sources
40%define MOZ_BUILD_LOCALES "ja"
41Source1000:     xulrunner-%{version}-ja.tar.bz2
42
43# build patches
44Patch0:         xulrunner-version.patch
45Patch1:         mozilla-build.patch
46Patch3:         mozilla-jemalloc.patch
47Patch5:         mozilla-jemalloc-526152.patch
48Patch8:         mozilla-plugin.patch
49
50# patches from Fedora
51Patch10:       mozilla-192-pkgconfig.patch
52
53# Upstream patches
54Patch26:        mozilla-ps-pdf-simplify-operators.patch
55
56
57# ---------------------------------------------------
58
59BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
60BuildRequires:  nspr-devel >= %{nspr_version}
61BuildRequires:  nss-devel >= %{nss_version}
62BuildRequires:  cairo-devel >= %{cairo_version}
63BuildRequires:  libpng-devel
64BuildRequires:  libjpeg-devel
65BuildRequires:  bzip2-devel
66BuildRequires:  zlib-devel
67BuildRequires:  lcms-devel
68BuildRequires:  libIDL-devel
69BuildRequires:  gtk2-devel
70BuildRequires:  gnome-vfs2-devel
71BuildRequires:  libgnome-devel
72BuildRequires:  libgnomeui-devel
73BuildRequires:  pango-devel
74BuildRequires:  freetype2-devel >= 2.1.9
75BuildRequires:  libXt-devel
76BuildRequires:  libXrender-devel
77%if %{build_vine6}
78BuildRequires:  sqlite3-devel >= %{sqlite_version}
79%endif
80BuildRequires:  libnotify-devel >= %{libnotify_version}
81BuildRequires:  startup-notification-devel
82BuildRequires:  alsa-lib-devel
83BuildRequires:  lcms-devel
84BuildRequires:  zip
85# For -sqlite.patch
86BuildRequires:  autoconf213
87
88Requires:       nspr >= %{nspr_version}
89Requires:       nss >= %{nss_version}
90
91Provides:       gecko-libs = %{version}
92
93%description
94XULRunner provides the XUL Runtime environment for Gecko applications.
95
96%package devel
97Summary: Development files for Gecko
98Group: Development/Libraries
99
100Obsoletes: mozilla-devel
101Obsoletes: firefox-devel < 2.1
102Obsoletes: xulrunner-devel-unstable
103
104Provides: gecko-devel = %{version}
105Provides: gecko-devel-unstable = %{version}
106
107Requires: xulrunner = %{version}-%{release}
108Requires: nspr-devel >= %{nspr_version}
109Requires: nss-devel >= %{nss_version}
110Requires: cairo-devel >= %{cairo_version}
111Requires: libjpeg-devel
112Requires: zip
113Requires: bzip2-devel
114Requires: zlib-devel
115Requires: lcms-devel
116Requires: libIDL-devel
117Requires: gtk2-devel
118Requires: gnome-vfs2-devel
119Requires: libgnome-devel
120Requires: libgnomeui-devel
121Requires: pango-devel
122Requires: freetype2-devel >= 2.1.9
123Requires: libXt-devel
124Requires: libXrender-devel
125%if %{build_vine6}
126Requires: sqlite3-devel >= %{sqlite_version}
127%endif
128Requires: startup-notification-devel
129Requires: alsa-lib-devel
130
131%description devel
132Gecko development files.
133
134#---------------------------------------------------------------------
135
136%prep
137%setup -q -c -b 1000
138cd %{tarballdir}
139
140sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
141    %{P:%%PATCH0} > version.patch
142%{__patch} -p1 -b --suffix .version < version.patch
143
144%patch1  -p1 -b .build
145%patch3  -p1 -b .jemalloc
146%patch5  -p1 -b .jemalloc-526152
147%patch8  -p1 -b .plugin
148
149%patch10 -p1 -b .pkgconfig
150
151%patch26 -p1 -b .ps-pdf-simplify-operators
152
153%{__rm} -f .mozconfig
154%if %{build_vine6}
155%{__cp} %{SOURCE10} .mozconfig
156%else
157%{__cp} %{SOURCE11} .mozconfig
158%endif
159
160#---------------------------------------------------------------------
161
162%build
163cd %{tarballdir}
164
165INTERNAL_GECKO=%{version_internal}
166MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
167
168# Mozilla builds with -Wall with exception of a few warnings which show up
169# everywhere in the code; so, don't override that.
170MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
171export CFLAGS=$MOZ_OPT_FLAGS
172export CXXFLAGS=$MOZ_OPT_FLAGS
173
174export PREFIX='%{_prefix}'
175export LIBDIR='%{_libdir}'
176
177MOZ_SMP_FLAGS=-j1
178%ifnarch ppc ppc64 s390 s390x
179[ -z "$RPM_BUILD_NCPUS" ] && \
180     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
181[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
182%endif
183
184export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
185make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
186make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
187
188# build locales
189LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
190            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
191for dir in $LOCALEDIRS
192do
193  for lang in %{MOZ_BUILD_LOCALES} ; do
194    make -C $dir/locales AB_CD=$lang
195  done
196done
197
198#---------------------------------------------------------------------
199
200%install
201cd %{tarballdir}
202%{__rm} -rf $RPM_BUILD_ROOT
203
204INTERNAL_GECKO=%{version_internal}
205
206INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
207MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
208
209INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
210MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
211
212#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
213DESTDIR=$RPM_BUILD_ROOT make install
214
215%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
216             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
217             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
218%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
219
220%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
221
222# set up our default preferences
223%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
224%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
225%{__rm} vl-default-prefs
226
227# Start script install
228%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
229%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
230  $RPM_BUILD_ROOT%{_bindir}/%{name}
231%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
232
233%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
234
235cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
236find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
237cd -
238
239# install locales
240for lang in %{MOZ_BUILD_LOCALES} ; do
241  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
242done
243
244# Prepare our devel package
245%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
246%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
247%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
248
249%{__cp} -rL dist/include/* \
250  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
251
252# Copy pc files (for compatibility with 1.9.1)
253%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
254        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
255%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
256        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
257
258# Fix multilib devel conflicts...
259%ifarch x86_64 ia64 s390x ppc64
260%define mozbits 64
261%else
262%define mozbits 32
263%endif
264
265function install_file() {
266genheader=$*
267mv ${genheader}.h ${genheader}%{mozbits}.h
268cat > ${genheader}.h << EOF
269// This file exists to fix multilib conflicts
270#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
271#include "${genheader}64.h"
272#else
273#include "${genheader}32.h"
274#endif
275EOF
276}
277
278pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
279install_file "mozilla-config"
280popd
281
282pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
283install_file "jsautocfg"
284popd
285
286%{__install} -p -c -m 755 dist/bin/xpcshell \
287  dist/bin/xpidl \
288  dist/bin/xpt_dump \
289  dist/bin/xpt_link \
290  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
291
292%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
293%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
294
295%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
296ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
297       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
298
299%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
300ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
301       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
302
303%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
304ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
305       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
306
307%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
308ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
309       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
310
311find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
312find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
313
314%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
315pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
316for i in *.so; do
317    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
318done
319popd
320
321# GRE stuff
322%ifarch x86_64 ia64 ppc64 s390x
323%define gre_conf_file gre64.conf
324%else
325%define gre_conf_file gre.conf
326%endif
327
328MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
329%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
330        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
331chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
332
333# Library path
334%ifarch x86_64 ia64 ppc64 s390x
335%define ld_conf_file xulrunner-64.conf
336%else
337%define ld_conf_file xulrunner-32.conf
338%endif
339
340%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
341%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
342${MOZ_APP_DIR}
343EOF
344                       
345# Copy over the LICENSE
346%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
347
348# Use the system hunspell dictionaries
349%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
350ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
351
352# ghost files
353%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
354touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
355touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
356
357#---------------------------------------------------------------------
358
359%clean
360%{__rm} -rf $RPM_BUILD_ROOT
361
362#---------------------------------------------------------------------
363
364%post
365/sbin/ldconfig
366
367%postun
368/sbin/ldconfig
369
370%preun
371# is it a final removal?
372if [ $1 -eq 0 ]; then
373  %{__rm} -rf ${MOZ_APP_DIR}/components
374fi
375
376%files
377%defattr(-,root,root,-)
378%{_bindir}/xulrunner
379%dir /etc/gre.d
380/etc/gre.d/%{gre_conf_file}
381%dir %{mozappdir}
382%doc %attr(644, root, root) %{mozappdir}/LICENSE
383%doc %attr(644, root, root) %{mozappdir}/README.txt
384%{mozappdir}/chrome
385%{mozappdir}/dictionaries
386%dir %{mozappdir}/components
387%ghost %{mozappdir}/components/compreg.dat
388%ghost %{mozappdir}/components/xpti.dat
389%{mozappdir}/components/*.so
390%{mozappdir}/components/*.xpt
391%attr(644, root, root) %{mozappdir}/components/*.js
392%{mozappdir}/defaults
393%{mozappdir}/greprefs
394%dir %{mozappdir}/icons
395%attr(644, root, root) %{mozappdir}/icons/*
396%{mozappdir}/modules
397%{mozappdir}/plugins
398%{mozappdir}/res
399%{mozappdir}/*.so
400%{mozappdir}/mozilla-xremote-client
401%{mozappdir}/run-mozilla.sh
402%{mozappdir}/regxpcom
403%{mozappdir}/xulrunner
404%{mozappdir}/xulrunner-bin
405%{mozappdir}/xulrunner-stub
406%{mozappdir}/platform.ini
407%{mozappdir}/dependentlibs.list
408%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
409
410# XXX See if these are needed still
411%{mozappdir}/updater*
412%exclude %{mozappdir}/update.locale
413%exclude %{mozappdir}/components/components.list
414
415%files devel
416%defattr(-,root,root,-)
417%dir %{_datadir}/idl/%{name}*%{version_internal}
418%{_datadir}/idl/%{name}*%{version_internal}/*
419%{_includedir}/%{name}*%{version_internal}
420%dir %{_libdir}/%{name}-sdk-*
421%dir %{_libdir}/%{name}-sdk-*/sdk
422%{_libdir}/%{name}-sdk-*/*
423%{_libdir}/%{name}-sdk-*/sdk/*
424%{_libdir}/pkgconfig/*.pc
425%{mozappdir}/xpcshell
426%{mozappdir}/xpidl
427%{mozappdir}/xpt_dump
428%{mozappdir}/xpt_link
429
430#---------------------------------------------------------------------
431
432%changelog
433* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
434- update to 1.9.2.2 (sync with firefox-3.6.2)
435
436* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
437- enable libnotify support
438  - add ac_add_options --enable-libnotify
439- disable Necko wifi monitor
440  - add ac_add_options --disable-necko-wifi
441  - remove BR: wireless-tools-devel
442- fix %%files devel
443- add patch3,5 to fix jemalloc alignment assertion
444- add Patch8 to fix mozilla-plugin.pc
445
446* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
447- add BR: libnotify-devel, wireless-tools-devel
448
449* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
450- update to 1.9.2 (sync with firefox-3.6)
451- obsoletes xulrunner-devel-unstable
452
453* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
454- use internal sqlite3 on vine5
455
456* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
457- update to 1.9.1.7
458
459* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
460- update to 1.9.1.6
461- build with sqlite3-3.6.21
462
463* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
464- update to 1.9.1.5
465
466* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
467- update to 1.9.1.3
468
469* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
470- really update to 1.9.1.2 (<BTS:0748>)
471
472* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
473- update to 1.9.1.2 (sync with firefox-3.5.2)
474
475* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
476- update to 1.9.1.1 (sync with firefox-3.5.1)
477- add missing Requires to -devel
478- add missing BR
479
480* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
481- enable-system-cairo
482
483* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
484- update to 1.9.1 (based on firefox 3.5)
485
486* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
487- update to 1.9.1rc3 (sync with firefox 3.5rc3)
488
489* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
490- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
491- remove old patches
492- require nspr >= 4.8
493
494* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
495- new upstream release
496
497* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
498- update mozconfig
499  - disable-system-cairo for stability
500
501* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
502- new upstream release
503
504* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
505- new upstream release
506- add ja locale
507
508* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
509- new upstream release
510
511* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
512- new upstream release
513
514* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
515- add Patch3
516
517* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
518- update to xulrunner 1.9.0.2 byild 6
519- build with gnome-2.24
520
521* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
522- new upstream release
523
524* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
525- initial build for Vine Linux
526
527* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
528- Update to 1.9 final
529
530* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
531- Simplify PS/PDF operators
532
533* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
534- Upstream patch to fsync() less
535
536* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
537- Ensure we enable startup notification; add BR and modify config
538  (bug #445543)
539
540* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
541- Some files moved to mozilla-filesystem; kill them and add the Req
542
543* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
544- Clean up the %%files list and get rid of the executable bit on some files
545
546* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
547- Fix font scaling
548
549* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
550- Enabled phishing protection (#443403)
551
552* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
553- Changed "__ppc64__" to "__powerpc64__",
554  "__ppc64__" doesn't work anymore
555- Added fix for #443725 - Critical hanging bug with fix
556  available upstream (mozbz#429903)
557
558* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
559- Fixed multilib issues, added starting script instead of a symlink
560  to binary (#436393)
561
562* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
563- Add upstream patches for dpi, toolbar buttons, and invalid keys
564- Re-enable system cairo
565
566* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
567- Spec cleanups
568
569* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
570- Beta 5
571
572* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
573- Beta 5 RC2
574
575* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
576- Update to latest trunk (2008-03-27)
577
578* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
579- Update to latest trunk (2008-03-26)
580
581* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
582- Update to latest trunk (2008-03-25)
583
584* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
585- Update to latest trunk (2008-03-24)
586
587* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
588- Update to latest trunk (2008-03-20)
589
590* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
591- Update to latest trunk (2008-03-17)
592
593* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
594- Revert to trunk from the 15th to fix crashes on HTTPS sites
595
596* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
597- Update to latest trunk (2008-03-16)
598- Add patch to negate a11y slowdown on some pages (#431162)
599
600* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
601- Update to latest trunk (2008-03-15)
602
603* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
604- Avoid conflicts between gecko debuginfo packages
605
606* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
607- Update to latest trunk (2008-03-12)
608
609* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
610- Update to latest trunk (2008-03-11)
611
612* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
613- Update to latest trunk (2008-03-10)
614
615* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
616- Update to latest trunk (2008-03-09)
617
618* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
619- Update to latest trunk (2008-03-07)
620
621* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
622- Update to latest trunk (2008-03-06)
623
624* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
625- Update to latest trunk (2008-03-04)
626
627* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
628- Update to latest trunk (2008-03-02)
629
630* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
631- Update to latest trunk (2008-03-01)
632
633* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
634- Update to latest trunk (2008-02-29)
635
636* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
637- Update to latest trunk (2008-02-28)
638
639* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
640- Update to latest trunk (2008-02-27)
641
642* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
643- Update to latest trunk (2008-02-26)
644
645* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
646- Update to latest trunk (2008-02-23)
647
648* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
649- Update to latest trunk (2008-02-22)
650
651* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
652- Update to latest trunk (2008-02-21)
653
654* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
655- Update to latest trunk (2008-02-20)
656
657* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
658- Update to latest trunk (2008-02-17)
659
660* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
661- Update to latest trunk (2008-02-15)
662
663* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
664- Update to latest trunk (2008-02-14)
665- Use system hunspell
666
667* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
668- Update to latest trunk (2008-02-11)
669
670* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
671- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
672  you know, debuginfo.
673
674* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
675- Update to latest trunk (2008-02-10)
676
677* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
678- Update to latest trunk (2008-02-09)
679
680* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
681- Update to latest trunk (2008-02-06)
682
683* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
684- Update to latest trunk (2008-01-30)
685
686* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
687- rebuild agains new nss
688- enabled gnome vfs
689
690* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
691- fixed stable pkg-config files (#429654)
692- removed sqlite patch
693
694* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
695- Update to latest trunk (2008-01-21)
696
697* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
698- Update to latest trunk (2008-01-15)
699- Now with system extensions directory support
700
701* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
702- Update to latest trunk (2008-01-13)
703- Use CFLAGS instead of configure arguments
704- Random cleanups: BuildRequires, scriptlets, prefs, etc.
705
706* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
707- Provide gecko-devel-unstable as well
708
709* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
710- divided devel package to devel and devel-unstable
711
712* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
713- removed fedora specific pkg-config files
714- updated to the latest trunk (2008-01-07)
715- removed unnecessary patches
716- fixed idl dir (#427965)
717
718* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
719- Re-enable camellia256 support now that NSS supports it
720
721* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
722- updated to the latest trunk (2008-01-03)
723
724* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
725- Don't Provide webclient (xulrunner is not itself a webclient)
726- Don't Obsolete old firefox, only firefox-devel
727- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
728
729* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
730- added java and plugin subdirs to plugin includes
731
732* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
733- dependency fixes, obsoletes firefox < 3 and firefox-devel now
734
735* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
736- updated to Beta 2.
737- moved SDK to xulrunner-sdk
738
739* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
740- fixed mozilla-plugin.pc (#412971)
741
742* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
743- export /etc/gre.d/gre.conf (it's used by python gecko applications)
744
745* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
746- added xulrunner/js include dir to xulrunner-js
747
748* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
749- update to beta 1
750
751* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
752- packed all gecko libraries (#389391)
753
754* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
755- registered xulrunner libs system-wide
756- added xulrunner-gtkmozembed.pc
757
758* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
759- added proper nss/nspr dependencies
760
761* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
762- more build fixes, use system nss libraries
763
764* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
765- build fixes
766
767* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
768- updated to the latest trunk
769
770* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
771- build fixes for ppc/ppc64
772
773* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
774- removed conflicts with the current gecko-based apps
775- added updated ppc64 patch
776
777* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
778- build fixes
779
780* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
781- Initial cut at XULRunner 1.9 Alpha 7
782- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.