source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 6575

Revision 6575, 25.3 KB checked in by daisuke, 12 years ago (diff)

update to 10.0.6 (based on esr release)

Line 
1# Minimal required versions
2%global nspr_version 4.8.9
3%global nss_version 3.13.1
4%global cairo_version 1.10.2
5%global freetype_version 2.1.9
6%global libnotify_version 0.7.0
7
8# gecko_dir_ver should be set to the version in our directory names
9# alpha_version should be set to the alpha number if using an alpha, 0 otherwise
10# beta_version  should be set to the beta number if using a beta, 0 otherwise
11# rc_version    should be set to the RC number if using an RC, 0 otherwise
12%global gecko_dir_ver 2
13%global alpha_version 0
14%global beta_version  0
15%global rc_version    0
16
17%global mozappdir         %{_libdir}/%{name}-%{gecko_dir_ver}
18%global tarballdir  mozilla-esr10
19
20%if %{alpha_version} > 0
21%global pre_version a%{alpha_version}
22%global tarballdir  mozilla-beta
23%endif
24%if %{beta_version} > 0
25%global pre_version b%{beta_version}
26%global tarballdir  mozilla-beta
27%endif
28%if %{rc_version} > 0
29%global pre_version rc%{rc_version}
30%global tarballdir  mozilla-release
31%endif
32
33%if %{defined pre_version}
34%global gecko_verrel %{expand:%%{version}}-%{pre_version}
35%global pre_tag .%{pre_version}
36%else
37%global gecko_verrel %{expand:%%{version}}
38%endif
39
40Summary:        XUL Runtime for Gecko Applications
41Summary(ja):    Gecko アプリケーションのための XUL ランタイム
42Name:           xulrunner
43Version:        10.0.6
44Release:        1%{?_dist_release}
45URL:            http://developer.mozilla.org/En/XULRunner
46License:        MPLv1.1 or GPLv2+ or LGPLv2+
47Group:          Applications/Internet
48# You can get sources at ftp://ftp.mozilla.org/pub/firefox/releases/%{version}%{?pre_ver}/source
49Source0:        %{name}-%{version}%{?pre_version}.source.tar.bz2
50Source10:       %{name}-mozconfig-vine
51Source12:       %{name}-redhat-default-prefs.js
52Source21:       %{name}.sh.in
53
54# build patches
55Patch0:         xulrunner-version.patch
56Patch1:         mozilla-build.patch
57Patch14:        xulrunner-2.0-chromium-types.patch
58Patch17:        xulrunner-10.0-gcc47.patch
59
60
61# Fedora specific patches
62Patch20:        mozilla-193-pkgconfig.patch
63Patch23:        wmclass.patch
64Patch24:        crashreporter-remove-static.patch
65
66# Upstream patches
67Patch38:        mozilla-696393.patch
68# https://bugzilla.mozilla.org/show_bug.cgi?id=707993
69Patch39:        xulrunner-8.0-fix-maemo-checks-in-npapi.patch
70Patch40:        mozilla-682832-proxy.patch
71# cherry-picked from 13afcd4c097c
72Patch41:        xulrunner-9.0-secondary-build-fix.patch
73Patch42:        mozilla-706724.patch
74Patch43:        mozilla-file.patch
75# Needed to detect/use libvpx-1.0.0
76# https://bugzilla.mozilla.org/show_bug.cgi?id=722127
77Patch44:        mozilla-722127.patch
78Patch46:        mozilla-724615.patch
79Patch47:        mozilla-691898.patch
80
81# ---------------------------------------------------
82
83BuildRequires:  nspr-devel >= %{nspr_version}
84BuildRequires:  nss-devel >= %{nss_version}
85BuildRequires:  cairo-devel >= %{cairo_version}
86BuildRequires:  libpng-devel
87BuildRequires:  libjpeg-turbo-devel
88BuildRequires:  zip
89BuildRequires:  bzip2-devel
90BuildRequires:  zlib-devel
91BuildRequires:  libIDL-devel
92BuildRequires:  gtk2-devel
93BuildRequires:  krb5-devel
94BuildRequires:  pango-devel
95BuildRequires:  freetype2-devel >= %{freetype_version}
96BuildRequires:  libXt-devel
97BuildRequires:  libXrender-devel
98BuildRequires:  startup-notification-devel
99BuildRequires:  alsa-lib-devel
100BuildRequires:  libnotify-devel >= %{libnotify_version}
101BuildRequires:  mesa-libGL-devel
102BuildRequires:  curl-devel
103BuildRequires:  yasm
104
105Requires:       nspr
106Requires:       nss
107Provides:       gecko-libs = %{gecko_verrel}
108Conflicts:      firefox < 3.6
109
110Vendor: Project Vine
111Distribution: Vine Linux
112Packager: daisuke
113
114%description
115XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
116applications that are as rich as Firefox and Thunderbird. It provides mechanisms
117for installing, upgrading, and uninstalling these applications. XULRunner also
118provides libxul, a solution which allows the embedding of Mozilla technologies
119in other projects and products.
120
121%package devel
122Summary: Development files for Gecko
123Summary(ja):  Geckoの開発ファイル
124Group: Development/Libraries
125Obsoletes: mozilla-devel < 1.9
126Obsoletes: firefox-devel < 2.1
127Obsoletes: xulrunner-devel-unstable
128Provides: gecko-devel = %{gecko_verrel}
129Provides: gecko-devel-unstable = %{gecko_verrel}
130
131Requires: xulrunner = %{version}-%{release}
132Requires: nspr-devel
133Requires: nss-devel
134Requires: cairo-devel
135Requires: libjpeg-devel
136Requires: zip
137Requires: bzip2-devel
138Requires: zlib-devel
139Requires: libIDL-devel
140Requires: gtk2-devel
141Requires: krb5-devel
142Requires: pango-devel
143Requires: freetype-devel
144Requires: libXt-devel
145Requires: libXrender-devel
146Requires: startup-notification-devel
147Requires: alsa-lib-devel
148Requires: libnotify-devel
149Requires: mesa-libGL-devel
150
151%description devel
152This package contains the libraries amd header files that are needed
153for writing XUL+XPCOM applications with Mozilla XULRunner and Gecko.
154
155#---------------------------------------------------------------------
156
157%prep
158%setup -q -c
159cd %{tarballdir}
160
161sed -e 's/__RPM_VERSION_INTERNAL__/%{gecko_dir_ver}/' %{P:%%PATCH0} \
162    > version.patch
163%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
164
165%patch1  -p2 -b .build
166%patch14 -p1 -b .chromium-types
167%patch17 -p1 -b .gcc47
168
169%patch20 -p2 -b .pk
170%patch23 -p1 -b .wmclass
171%patch24 -p1 -b .static
172
173%patch38 -p2 -b .696393
174%patch39 -p1 -b .707993
175%patch40 -p2 -b .682832
176%patch41 -p2 -b .secondary-build
177%patch42 -p1 -b .706724
178%patch43 -p1 -b .file
179%patch44 -p2 -b .vpx1.0.0
180%patch46 -p1 -b .724615
181%patch47 -p1 -b .691898
182
183%{__rm} -f .mozconfig
184%{__cp} %{SOURCE10} .mozconfig
185
186echo "ac_add_options --disable-system-sqlite" >> .mozconfig
187
188%ifarch armv7hl
189echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
190echo "ac_add_options --with-float-abi=hard" >> .mozconfig
191echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
192echo "ac_add_options --disable-elf-hack" >> .mozconfig
193%endif
194%ifarch armv7hnl
195echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
196echo "ac_add_options --with-float-abi=hard" >> .mozconfig
197echo "ac_add_options --with-fpu=neon" >> .mozconfig
198echo "ac_add_options --disable-elf-hack" >> .mozconfig
199%endif
200%ifarch armv5tel
201echo "ac_add_options --with-arch=armv5te" >> .mozconfig
202echo "ac_add_options --with-float-abi=soft" >> .mozconfig
203echo "ac_add_options --disable-elf-hack" >> .mozconfig
204%endif
205
206%ifnarch %{ix86} x86_64
207echo "ac_add_options --disable-methodjit" >> .mozconfig
208echo "ac_add_options --disable-monoic" >> .mozconfig
209echo "ac_add_options --disable-polyic" >> .mozconfig
210echo "ac_add_options --disable-tracejit" >> .mozconfig
211%endif
212
213#---------------------------------------------------------------------
214
215%build
216cd %{tarballdir}
217
218# -fpermissive is needed to build with gcc 4.6+ which has become stricter
219#
220# Mozilla builds with -Wall with exception of a few warnings which show up
221# everywhere in the code; so, don't override that.
222#
223# Disable C++ exceptions since Mozilla code is not exception-safe
224#
225MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
226                      %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
227export CFLAGS=$MOZ_OPT_FLAGS
228export CXXFLAGS=$MOZ_OPT_FLAGS
229
230export PREFIX='%{_prefix}'
231export LIBDIR='%{_libdir}'
232
233MOZ_SMP_FLAGS=-j1
234# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
235# however builds tend to fail on other arches when building in parallel.
236%ifarch %{ix86} x86_64
237[ -z "$RPM_BUILD_NCPUS" ] && \
238     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
239[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
240[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
241%endif
242
243make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS" MOZ_SERVICES_SYNC="1"
244
245#---------------------------------------------------------------------
246
247%install
248cd %{tarballdir}
249
250# set up our prefs before install, so it gets pulled in to omni.jar
251%{__cp} -p %{SOURCE12} dist/bin/defaults/pref/all-redhat.js
252
253DESTDIR=$RPM_BUILD_ROOT make install
254
255# Start script install
256%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
257%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{gecko_dir_ver},g' > \
258  $RPM_BUILD_ROOT%{_bindir}/%{name}
259%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
260
261%{__rm} -f $RPM_BUILD_ROOT%{mozappdir}/%{name}-config
262
263# Copy pc files (for compatibility with 1.9.1)
264%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
265        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
266%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
267        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
268
269# Fix multilib devel conflicts...
270function install_file() {
271genheader=$*
272mv ${genheader}.h ${genheader}%{__isa_bits}.h
273cat > ${genheader}.h << EOF
274/* This file exists to fix multilib conflicts */
275#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__) || (defined(__sparc__) && defined(__arch64__))
276#include "${genheader}64.h"
277#else
278#include "${genheader}32.h"
279#endif
280EOF
281}
282
283INTERNAL_APP_NAME=%{name}-%{gecko_dir_ver}
284
285pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
286install_file "mozilla-config"
287install_file "js-config"
288popd
289
290# Link libraries in sdk directory instead of copying them:
291pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-devel-%{gecko_dir_ver}/sdk/lib
292for i in *.so; do
293     rm $i
294     ln -s %{mozappdir}/$i $i
295done
296popd
297
298# Library path
299LD_SO_CONF_D=%{_sysconfdir}/ld.so.conf.d
300LD_CONF_FILE=xulrunner-%{__isa_bits}.conf
301
302%{__mkdir_p} ${RPM_BUILD_ROOT}${LD_SO_CONF_D}
303%{__cat} > ${RPM_BUILD_ROOT}${LD_SO_CONF_D}/${LD_CONF_FILE} << EOF
304%{mozappdir}
305EOF
306
307# Copy over the LICENSE
308%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
309
310# ghost files
311%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/components
312touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
313touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
314
315#---------------------------------------------------------------------
316
317%post -p /sbin/ldconfig
318
319%postun -p /sbin/ldconfig
320
321%preun
322# is it a final removal?
323if [ $1 -eq 0 ]; then
324  %{__rm} -rf %{mozappdir}/components
325fi
326
327%files
328%defattr(-,root,root,-)
329%{_bindir}/xulrunner
330%dir %{mozappdir}
331%doc %attr(644, root, root) %{mozappdir}/LICENSE
332%doc %attr(644, root, root) %{mozappdir}/README.txt
333%{mozappdir}/chrome
334%{mozappdir}/chrome.manifest
335%{mozappdir}/dictionaries
336%dir %{mozappdir}/components
337%ghost %{mozappdir}/components/compreg.dat
338%ghost %{mozappdir}/components/xpti.dat
339%{mozappdir}/components/*.so
340%{mozappdir}/components/*.manifest
341%{mozappdir}/omni.ja
342%{mozappdir}/plugins
343%{mozappdir}/*.so
344%{mozappdir}/mozilla-xremote-client
345%{mozappdir}/run-mozilla.sh
346%{mozappdir}/xulrunner
347%{mozappdir}/xulrunner-bin
348%{mozappdir}/xulrunner-stub
349%{mozappdir}/platform.ini
350%{mozappdir}/dependentlibs.list
351%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
352%{mozappdir}/plugin-container
353
354%files devel
355%defattr(-,root,root,-)
356%dir %{_libdir}/%{name}-devel-*
357%{_datadir}/idl/%{name}*%{gecko_dir_ver}
358%{_includedir}/%{name}*%{gecko_dir_ver}
359%{_libdir}/%{name}-devel-*/*
360%{_libdir}/pkgconfig/*.pc
361%{mozappdir}/xpcshell
362
363#---------------------------------------------------------------------
364
365%changelog
366* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.6-1
367- update to 10.0.6 (based on firefox-10.0.6esr source)
368
369* Wed Mar 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.3-1
370- update to 10.0.3 (based on firefox-10.0.3esr source)
371- clean up spec
372
373* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
374- rebuild with libnotify-0.7
375
376* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
377- modify gre.conf to promote internal gecko version.
378
379* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
380- update to 2.0.1 (sync with firefox-4.0.1)
381
382* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
383- update to 2.0 (sync with firefox-4.0)
384- BR: libjpeg-turbo-devel >= 1.1.0
385- BR: nspr-devel >= 4.8.7
386- BR: nss-devel >= 3.12.9
387- BR: cairo-devel >= 1.10.2-2
388- add Patch130 to use omni.jar (upstream patch)
389
390* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
391- update to 1.9.2.15 (sync with firefox-3.6.15)
392
393* Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
394- update to 1.9.2.14 (sync with firefox-3.6.14)
395
396* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
397- update to 1.9.2.13 (sync with firefox-3.6.13)
398
399* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
400- update to 1.9.2.11 (sync with firefox-3.6.11)
401
402* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
403- rebuild with rpm-4.8.1 for pkg-config file
404
405* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
406- update to 1.9.2.9 (sync with firefox-3.6.9)
407- add patch10 to build with libjpeg-turbo
408- build with sqlite-3.7.2
409- BR: nspr >= 4.8.6
410
411* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
412- update tp 1.9.2.8 (sync with firefox-3.6.8)
413
414* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
415- update tp 1.9.2.7 (sync with firefox-3.6.7)
416
417* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
418- enable ipc only on ix86/x86_64 arches
419
420* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
421- update to 1.9.2.4 (sync with firefox-3.6.4)
422- add patch10 to fix build failure
423
424* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
425- update to 1.9.2.3 (sync with firefox-3.6.3)
426
427* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
428- update to 1.9.2.2 (sync with firefox-3.6.2)
429- add patch7,9 for fix build failure
430
431* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
432- enable libnotify support
433  - add ac_add_options --enable-libnotify
434- disable Necko wifi monitor
435  - add ac_add_options --disable-necko-wifi
436  - remove BR: wireless-tools-devel
437- fix %%files devel
438- add patch3,5 to fix jemalloc alignment assertion
439- add Patch8 to fix mozilla-plugin.pc
440
441* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
442- add BR: libnotify-devel, wireless-tools-devel
443
444* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
445- update to 1.9.2 (sync with firefox-3.6)
446- obsoletes xulrunner-devel-unstable
447
448* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
449- use internal sqlite3 on vine5
450
451* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
452- update to 1.9.1.7
453
454* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
455- update to 1.9.1.6
456- build with sqlite3-3.6.21
457
458* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
459- update to 1.9.1.5
460
461* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
462- update to 1.9.1.3
463
464* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
465- really update to 1.9.1.2 (<BTS:0748>)
466
467* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
468- update to 1.9.1.2 (sync with firefox-3.5.2)
469
470* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
471- update to 1.9.1.1 (sync with firefox-3.5.1)
472- add missing Requires to -devel
473- add missing BR
474
475* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
476- enable-system-cairo
477
478* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
479- update to 1.9.1 (based on firefox 3.5)
480
481* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
482- update to 1.9.1rc3 (sync with firefox 3.5rc3)
483
484* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
485- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
486- remove old patches
487- require nspr >= 4.8
488
489* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
490- new upstream release
491
492* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
493- update mozconfig
494  - disable-system-cairo for stability
495
496* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
497- new upstream release
498
499* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
500- new upstream release
501- add ja locale
502
503* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
504- new upstream release
505
506* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
507- new upstream release
508
509* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
510- add Patch3
511
512* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
513- update to xulrunner 1.9.0.2 byild 6
514- build with gnome-2.24
515
516* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
517- new upstream release
518
519* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
520- initial build for Vine Linux
521
522* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
523- Update to 1.9 final
524
525* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
526- Simplify PS/PDF operators
527
528* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
529- Upstream patch to fsync() less
530
531* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
532- Ensure we enable startup notification; add BR and modify config
533  (bug #445543)
534
535* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
536- Some files moved to mozilla-filesystem; kill them and add the Req
537
538* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
539- Clean up the %%files list and get rid of the executable bit on some files
540
541* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
542- Fix font scaling
543
544* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
545- Enabled phishing protection (#443403)
546
547* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
548- Changed "__ppc64__" to "__powerpc64__",
549  "__ppc64__" doesn't work anymore
550- Added fix for #443725 - Critical hanging bug with fix
551  available upstream (mozbz#429903)
552
553* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
554- Fixed multilib issues, added starting script instead of a symlink
555  to binary (#436393)
556
557* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
558- Add upstream patches for dpi, toolbar buttons, and invalid keys
559- Re-enable system cairo
560
561* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
562- Spec cleanups
563
564* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
565- Beta 5
566
567* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
568- Beta 5 RC2
569
570* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
571- Update to latest trunk (2008-03-27)
572
573* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
574- Update to latest trunk (2008-03-26)
575
576* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
577- Update to latest trunk (2008-03-25)
578
579* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
580- Update to latest trunk (2008-03-24)
581
582* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
583- Update to latest trunk (2008-03-20)
584
585* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
586- Update to latest trunk (2008-03-17)
587
588* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
589- Revert to trunk from the 15th to fix crashes on HTTPS sites
590
591* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
592- Update to latest trunk (2008-03-16)
593- Add patch to negate a11y slowdown on some pages (#431162)
594
595* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
596- Update to latest trunk (2008-03-15)
597
598* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
599- Avoid conflicts between gecko debuginfo packages
600
601* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
602- Update to latest trunk (2008-03-12)
603
604* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
605- Update to latest trunk (2008-03-11)
606
607* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
608- Update to latest trunk (2008-03-10)
609
610* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
611- Update to latest trunk (2008-03-09)
612
613* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
614- Update to latest trunk (2008-03-07)
615
616* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
617- Update to latest trunk (2008-03-06)
618
619* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
620- Update to latest trunk (2008-03-04)
621
622* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
623- Update to latest trunk (2008-03-02)
624
625* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
626- Update to latest trunk (2008-03-01)
627
628* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
629- Update to latest trunk (2008-02-29)
630
631* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
632- Update to latest trunk (2008-02-28)
633
634* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
635- Update to latest trunk (2008-02-27)
636
637* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
638- Update to latest trunk (2008-02-26)
639
640* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
641- Update to latest trunk (2008-02-23)
642
643* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
644- Update to latest trunk (2008-02-22)
645
646* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
647- Update to latest trunk (2008-02-21)
648
649* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
650- Update to latest trunk (2008-02-20)
651
652* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
653- Update to latest trunk (2008-02-17)
654
655* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
656- Update to latest trunk (2008-02-15)
657
658* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
659- Update to latest trunk (2008-02-14)
660- Use system hunspell
661
662* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
663- Update to latest trunk (2008-02-11)
664
665* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
666- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
667  you know, debuginfo.
668
669* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
670- Update to latest trunk (2008-02-10)
671
672* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
673- Update to latest trunk (2008-02-09)
674
675* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
676- Update to latest trunk (2008-02-06)
677
678* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
679- Update to latest trunk (2008-01-30)
680
681* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
682- rebuild agains new nss
683- enabled gnome vfs
684
685* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
686- fixed stable pkg-config files (#429654)
687- removed sqlite patch
688
689* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
690- Update to latest trunk (2008-01-21)
691
692* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
693- Update to latest trunk (2008-01-15)
694- Now with system extensions directory support
695
696* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
697- Update to latest trunk (2008-01-13)
698- Use CFLAGS instead of configure arguments
699- Random cleanups: BuildRequires, scriptlets, prefs, etc.
700
701* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
702- Provide gecko-devel-unstable as well
703
704* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
705- divided devel package to devel and devel-unstable
706
707* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
708- removed fedora specific pkg-config files
709- updated to the latest trunk (2008-01-07)
710- removed unnecessary patches
711- fixed idl dir (#427965)
712
713* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
714- Re-enable camellia256 support now that NSS supports it
715
716* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
717- updated to the latest trunk (2008-01-03)
718
719* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
720- Don't Provide webclient (xulrunner is not itself a webclient)
721- Don't Obsolete old firefox, only firefox-devel
722- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
723
724* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
725- added java and plugin subdirs to plugin includes
726
727* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
728- dependency fixes, obsoletes firefox < 3 and firefox-devel now
729
730* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
731- updated to Beta 2.
732- moved SDK to xulrunner-sdk
733
734* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
735- fixed mozilla-plugin.pc (#412971)
736
737* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
738- export /etc/gre.d/gre.conf (it's used by python gecko applications)
739
740* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
741- added xulrunner/js include dir to xulrunner-js
742
743* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
744- update to beta 1
745
746* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
747- packed all gecko libraries (#389391)
748
749* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
750- registered xulrunner libs system-wide
751- added xulrunner-gtkmozembed.pc
752
753* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
754- added proper nss/nspr dependencies
755
756* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
757- more build fixes, use system nss libraries
758
759* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
760- build fixes
761
762* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
763- updated to the latest trunk
764
765* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
766- build fixes for ppc/ppc64
767
768* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
769- removed conflicts with the current gecko-based apps
770- added updated ppc64 patch
771
772* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
773- build fixes
774
775* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
776- Initial cut at XULRunner 1.9 Alpha 7
777- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.