source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 4616

Revision 4616, 26.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define nspr_version 4.8.7
2%define nss_version 3.12.9
3%define cairo_version 1.10.2-2
4%define libnotify_version 0.4
5%define tarballdir mozilla-2.0
6%define libjpeg-turbo_version 1.1.0
7
8%define build_vine6 0
9%define build_vine5 0
10%if "%{?_dist_release}" == "vl7"
11%define build_vine6 1
12%define build_vine5 1
13%endif
14%if "%{?_dist_release}" == "vl6"
15%define build_vine6 1
16%define build_vine5 1
17%endif
18%if "%{?_dist_release}" == "vl5"
19%define build_vine5 1
20%endif
21
22%if %build_vine6
23%define sqlite_version 3.7.5
24%endif
25
26%define version_internal  2.0
27%define mozappdir         %{_libdir}/%{name}-%{version_internal}
28
29# Separated plugins are supported on x86(64) only
30%ifarch %{ix86} x86_64
31%define separated_plugins 1
32%else
33%define separated_plugins 0
34%endif
35
36Summary:        XUL Runtime for Gecko Applications
37Summary(ja):    Gecko アプリケーションのための XUL ランタイム
38Name:           xulrunner
39Version:        2.0.1
40Release:        3%{?_dist_release}
41URL:            http://www.mozilla.org/projects/xulrunner/
42License:        MPLv1.1 or GPLv2+ or LGPLv2+
43Group:          Applications/Internet
44Source0:        %{name}-%{version}.source.tar.bz2
45Source10:       %{name}-mozconfig
46Source11:       %{name}-mozconfig-vine5
47Source12:       %{name}-vine-default-prefs.js
48Source21:       %{name}.sh.in
49Source23:       %{name}.1
50
51# locale sources
52%define MOZ_BUILD_LOCALES "ja"
53Source1000:     xulrunner-%{version}-ja.tar.bz2
54
55# build patches
56Patch0:         xulrunner-version.patch
57Patch1:         mozilla-build.patch
58Patch7:         xulrunner-1.9.2.1-build.patch
59#Patch8:         mozilla-plugin.patch
60Patch9:         mozilla-build-sbrk.patch
61Patch10:        mozilla-libjpeg-turbo.patch
62
63# patches from Fedora
64Patch100:       mozilla-193-pkgconfig.patch
65
66# Upstream patches
67Patch130:        xulrunner-omnijar.patch
68
69
70
71# ---------------------------------------------------
72
73BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
74BuildRequires:  nspr-devel >= %{nspr_version}
75BuildRequires:  nss-devel >= %{nss_version}
76BuildRequires:  cairo-devel >= %{cairo_version}
77BuildRequires:  libpng-devel
78BuildRequires:  libjpeg-turbo-devel >= %{libjpeg-turbo_version}
79BuildRequires:  bzip2-devel
80BuildRequires:  zlib-devel
81BuildRequires:  lcms-devel
82BuildRequires:  libIDL-devel
83BuildRequires:  gtk2-devel
84BuildRequires:  gnome-vfs2-devel
85BuildRequires:  libgnome-devel
86BuildRequires:  libgnomeui-devel
87BuildRequires:  pango-devel
88BuildRequires:  freetype2-devel >= 2.1.9
89BuildRequires:  libXt-devel
90BuildRequires:  libXrender-devel
91%if %{build_vine6}
92BuildRequires:  sqlite3-devel >= %{sqlite_version}
93%endif
94BuildRequires:  libnotify-devel >= %{libnotify_version}
95BuildRequires:  startup-notification-devel
96BuildRequires:  alsa-lib-devel
97BuildRequires:  lcms-devel
98BuildRequires:  zip
99# For -sqlite.patch
100BuildRequires:  autoconf213
101BuildRequires:  libvpx-devel
102
103Requires:       nspr >= %{nspr_version}
104Requires:       nss >= %{nss_version}
105
106Provides:       gecko-libs = %{version}
107
108Vendor: Project Vine
109Distribution: Vine Linux
110
111%description
112XULRunner provides the XUL Runtime environment for Gecko applications.
113
114%package devel
115Summary: Development files for Gecko
116Group: Development/Libraries
117
118Obsoletes: mozilla-devel
119Obsoletes: firefox-devel < 2.1
120Obsoletes: xulrunner-devel-unstable
121
122Provides: gecko-devel = %{version}
123Provides: gecko-devel-unstable = %{version}
124
125Requires: xulrunner = %{version}-%{release}
126Requires: nspr-devel >= %{nspr_version}
127Requires: nss-devel >= %{nss_version}
128Requires: cairo-devel >= %{cairo_version}
129Requires: libjpeg-turbo-devel >= %{libjpeg-turbo_version}
130Requires: zip
131Requires: bzip2-devel
132Requires: zlib-devel
133Requires: lcms-devel
134Requires: libIDL-devel
135Requires: gtk2-devel
136Requires: gnome-vfs2-devel
137Requires: libgnome-devel
138Requires: libgnomeui-devel
139Requires: pango-devel
140Requires: freetype2-devel >= 2.1.9
141Requires: libXt-devel
142Requires: libXrender-devel
143%if %{build_vine6}
144Requires: sqlite3-devel >= %{sqlite_version}
145%endif
146Requires: startup-notification-devel
147Requires: alsa-lib-devel
148
149%description devel
150Gecko development files.
151
152#---------------------------------------------------------------------
153
154%prep
155%setup -q -c -b 1000
156cd %{tarballdir}
157
158sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
159    %{P:%%PATCH0} > version.patch
160%{__patch} -p1 -b --suffix .version < version.patch
161
162%patch1  -p2 -b .build
163%patch7  -p2 -b .del
164%patch9  -p2 -b .sbrk
165%patch10 -p2 -b .libjpeg-turbo
166
167%patch100 -p2 -b .pkgconfig
168%patch130 -p1 -b .omnijar
169
170
171%{__rm} -f .mozconfig
172%if %{build_vine6}
173%{__cp} %{SOURCE10} .mozconfig
174%else
175%{__cp} %{SOURCE11} .mozconfig
176%endif
177
178%if !%{?separated_plugins}
179echo "ac_add_options --disable-ipc" >> .mozconfig
180%endif
181
182#---------------------------------------------------------------------
183
184%build
185cd %{tarballdir}
186
187INTERNAL_GECKO=%{version_internal}
188MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
189
190# Mozilla builds with -Wall with exception of a few warnings which show up
191# everywhere in the code; so, don't override that.
192MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
193export CFLAGS=$MOZ_OPT_FLAGS
194export CXXFLAGS=$MOZ_OPT_FLAGS
195
196export PREFIX='%{_prefix}'
197export LIBDIR='%{_libdir}'
198
199MOZ_SMP_FLAGS=-j1
200%ifnarch ppc ppc64 s390 s390x
201[ -z "$RPM_BUILD_NCPUS" ] && \
202     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
203[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
204%endif
205
206export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
207make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
208make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
209
210# build locales
211LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
212            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
213for dir in $LOCALEDIRS
214do
215  for lang in %{MOZ_BUILD_LOCALES} ; do
216    make -C $dir/locales AB_CD=$lang
217  done
218done
219
220#---------------------------------------------------------------------
221
222%install
223cd %{tarballdir}
224%{__rm} -rf $RPM_BUILD_ROOT
225
226INTERNAL_GECKO=%{version_internal}
227
228INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
229MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
230
231INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
232MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
233
234# set up our default preferences
235%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
236%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
237%{__rm} vl-default-prefs
238
239DESTDIR=$RPM_BUILD_ROOT make install
240
241%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
242             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
243             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
244
245%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
246
247# Start script install
248%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
249%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
250  $RPM_BUILD_ROOT%{_bindir}/%{name}
251%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
252
253%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
254
255cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
256find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
257cd -
258
259# install locales
260#for lang in %{MOZ_BUILD_LOCALES} ; do
261#  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
262#done
263
264# Prepare our devel package
265%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
266%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
267%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
268
269%{__cp} -rL dist/include/* \
270  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
271
272# Copy pc files (for compatibility with 1.9.1)
273%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
274        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
275%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
276        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
277
278# Fix multilib devel conflicts...
279%ifarch x86_64 ia64 s390x ppc64
280%define mozbits 64
281%else
282%define mozbits 32
283%endif
284
285function install_file() {
286genheader=$*
287mv ${genheader}.h ${genheader}%{mozbits}.h
288cat > ${genheader}.h << EOF
289// This file exists to fix multilib conflicts
290#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
291#include "${genheader}64.h"
292#else
293#include "${genheader}32.h"
294#endif
295EOF
296}
297
298pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
299install_file "mozilla-config"
300install_file "jsautocfg"
301install_file "js-config"
302popd
303
304%{__install} -p -c -m 755 dist/bin/xpcshell \
305  dist/bin/xpidl \
306  dist/bin/xpt_dump \
307  dist/bin/xpt_link \
308  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
309
310%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
311%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
312
313%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
314ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
315       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
316
317%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
318ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
319       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
320
321%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
322ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
323       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
324
325%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
326ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
327       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
328
329find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
330find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
331
332%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
333pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
334for i in *.so; do
335    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
336done
337popd
338
339# GRE stuff
340%ifarch x86_64 ia64 ppc64 s390x
341%define gre_conf_file gre64.conf
342%else
343%define gre_conf_file gre.conf
344%endif
345
346MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
347%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
348        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
349sed -i -e "s/\[%{version}\]/\[$INTERNAL_GECKO\]/g" $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
350chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
351
352# Library path
353%ifarch x86_64 ia64 ppc64 s390x
354%define ld_conf_file xulrunner-64.conf
355%else
356%define ld_conf_file xulrunner-32.conf
357%endif
358
359%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
360%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
361${MOZ_APP_DIR}
362EOF
363                       
364# Copy over the LICENSE
365%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
366
367# Use the system hunspell dictionaries
368%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
369ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
370
371# ghost files
372%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
373touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
374touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
375
376#---------------------------------------------------------------------
377
378%clean
379%{__rm} -rf $RPM_BUILD_ROOT
380
381#---------------------------------------------------------------------
382
383%post
384/sbin/ldconfig
385
386%postun
387/sbin/ldconfig
388
389%preun
390# is it a final removal?
391if [ $1 -eq 0 ]; then
392  %{__rm} -rf ${MOZ_APP_DIR}/components
393fi
394
395%files
396%defattr(-,root,root,-)
397%{_bindir}/xulrunner
398%dir /etc/gre.d
399/etc/gre.d/%{gre_conf_file}
400%dir %{mozappdir}
401%doc %attr(644, root, root) %{mozappdir}/LICENSE
402%doc %attr(644, root, root) %{mozappdir}/README.txt
403%{mozappdir}/chrome
404%{mozappdir}/chrome.manifest
405%{mozappdir}/dictionaries
406%dir %{mozappdir}/components
407%ghost %{mozappdir}/components/compreg.dat
408%ghost %{mozappdir}/components/xpti.dat
409%{mozappdir}/components/*.so
410#%{mozappdir}/components/*.xpt
411%{mozappdir}/components/*.manifest
412#%attr(644, root, root) %{mozappdir}/components/*.js
413%{mozappdir}/defaults
414%dir %{mozappdir}/icons
415%attr(644, root, root) %{mozappdir}/icons/*
416%{mozappdir}/omni.jar
417#%{mozappdir}/modules
418%{mozappdir}/plugins
419#%{mozappdir}/res
420%{mozappdir}/*.so
421%{mozappdir}/mozilla-xremote-client
422%{mozappdir}/run-mozilla.sh
423%{mozappdir}/xulrunner
424%{mozappdir}/xulrunner-bin
425%{mozappdir}/xulrunner-stub
426%if %{?separated_plugins}
427%{mozappdir}/plugin-container
428%endif
429%{mozappdir}/platform.ini
430%{mozappdir}/dependentlibs.list
431#%{mozappdir}/greprefs.js
432%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
433
434# XXX See if these are needed still
435%{mozappdir}/updater*
436%exclude %{mozappdir}/update.locale
437
438%files devel
439%defattr(-,root,root,-)
440%{_datadir}/idl/%{name}*%{version_internal}
441%{_includedir}/%{name}*%{version_internal}
442%{_libdir}/%{name}-sdk-*/
443%{_libdir}/pkgconfig/*.pc
444%{mozappdir}/xpcshell
445%{mozappdir}/xpidl
446%{mozappdir}/xpt_dump
447%{mozappdir}/xpt_link
448
449#---------------------------------------------------------------------
450
451%changelog
452* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
453- rebuild with libnotify-0.7
454
455* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
456- modify gre.conf to promote internal gecko version.
457
458* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
459- update to 2.0.1 (sync with firefox-4.0.1)
460
461* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
462- update to 2.0 (sync with firefox-4.0)
463- BR: libjpeg-turbo-devel >= 1.1.0
464- BR: nspr-devel >= 4.8.7
465- BR: nss-devel >= 3.12.9
466- BR: cairo-devel >= 1.10.2-2
467- add Patch130 to use omni.jar (upstream patch)
468
469* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
470- update to 1.9.2.15 (sync with firefox-3.6.15)
471
472* Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
473- update to 1.9.2.14 (sync with firefox-3.6.14)
474
475* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
476- update to 1.9.2.13 (sync with firefox-3.6.13)
477
478* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
479- update to 1.9.2.11 (sync with firefox-3.6.11)
480
481* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
482- rebuild with rpm-4.8.1 for pkg-config file
483
484* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
485- update to 1.9.2.9 (sync with firefox-3.6.9)
486- add patch10 to build with libjpeg-turbo
487- build with sqlite-3.7.2
488- BR: nspr >= 4.8.6
489
490* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
491- update tp 1.9.2.8 (sync with firefox-3.6.8)
492
493* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
494- update tp 1.9.2.7 (sync with firefox-3.6.7)
495
496* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
497- enable ipc only on ix86/x86_64 arches
498
499* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
500- update to 1.9.2.4 (sync with firefox-3.6.4)
501- add patch10 to fix build failure
502
503* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
504- update to 1.9.2.3 (sync with firefox-3.6.3)
505
506* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
507- update to 1.9.2.2 (sync with firefox-3.6.2)
508- add patch7,9 for fix build failure
509
510* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
511- enable libnotify support
512  - add ac_add_options --enable-libnotify
513- disable Necko wifi monitor
514  - add ac_add_options --disable-necko-wifi
515  - remove BR: wireless-tools-devel
516- fix %%files devel
517- add patch3,5 to fix jemalloc alignment assertion
518- add Patch8 to fix mozilla-plugin.pc
519
520* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
521- add BR: libnotify-devel, wireless-tools-devel
522
523* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
524- update to 1.9.2 (sync with firefox-3.6)
525- obsoletes xulrunner-devel-unstable
526
527* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
528- use internal sqlite3 on vine5
529
530* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
531- update to 1.9.1.7
532
533* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
534- update to 1.9.1.6
535- build with sqlite3-3.6.21
536
537* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
538- update to 1.9.1.5
539
540* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
541- update to 1.9.1.3
542
543* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
544- really update to 1.9.1.2 (<BTS:0748>)
545
546* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
547- update to 1.9.1.2 (sync with firefox-3.5.2)
548
549* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
550- update to 1.9.1.1 (sync with firefox-3.5.1)
551- add missing Requires to -devel
552- add missing BR
553
554* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
555- enable-system-cairo
556
557* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
558- update to 1.9.1 (based on firefox 3.5)
559
560* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
561- update to 1.9.1rc3 (sync with firefox 3.5rc3)
562
563* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
564- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
565- remove old patches
566- require nspr >= 4.8
567
568* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
569- new upstream release
570
571* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
572- update mozconfig
573  - disable-system-cairo for stability
574
575* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
576- new upstream release
577
578* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
579- new upstream release
580- add ja locale
581
582* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
583- new upstream release
584
585* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
586- new upstream release
587
588* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
589- add Patch3
590
591* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
592- update to xulrunner 1.9.0.2 byild 6
593- build with gnome-2.24
594
595* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
596- new upstream release
597
598* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
599- initial build for Vine Linux
600
601* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
602- Update to 1.9 final
603
604* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
605- Simplify PS/PDF operators
606
607* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
608- Upstream patch to fsync() less
609
610* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
611- Ensure we enable startup notification; add BR and modify config
612  (bug #445543)
613
614* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
615- Some files moved to mozilla-filesystem; kill them and add the Req
616
617* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
618- Clean up the %%files list and get rid of the executable bit on some files
619
620* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
621- Fix font scaling
622
623* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
624- Enabled phishing protection (#443403)
625
626* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
627- Changed "__ppc64__" to "__powerpc64__",
628  "__ppc64__" doesn't work anymore
629- Added fix for #443725 - Critical hanging bug with fix
630  available upstream (mozbz#429903)
631
632* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
633- Fixed multilib issues, added starting script instead of a symlink
634  to binary (#436393)
635
636* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
637- Add upstream patches for dpi, toolbar buttons, and invalid keys
638- Re-enable system cairo
639
640* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
641- Spec cleanups
642
643* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
644- Beta 5
645
646* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
647- Beta 5 RC2
648
649* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
650- Update to latest trunk (2008-03-27)
651
652* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
653- Update to latest trunk (2008-03-26)
654
655* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
656- Update to latest trunk (2008-03-25)
657
658* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
659- Update to latest trunk (2008-03-24)
660
661* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
662- Update to latest trunk (2008-03-20)
663
664* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
665- Update to latest trunk (2008-03-17)
666
667* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
668- Revert to trunk from the 15th to fix crashes on HTTPS sites
669
670* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
671- Update to latest trunk (2008-03-16)
672- Add patch to negate a11y slowdown on some pages (#431162)
673
674* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
675- Update to latest trunk (2008-03-15)
676
677* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
678- Avoid conflicts between gecko debuginfo packages
679
680* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
681- Update to latest trunk (2008-03-12)
682
683* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
684- Update to latest trunk (2008-03-11)
685
686* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
687- Update to latest trunk (2008-03-10)
688
689* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
690- Update to latest trunk (2008-03-09)
691
692* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
693- Update to latest trunk (2008-03-07)
694
695* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
696- Update to latest trunk (2008-03-06)
697
698* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
699- Update to latest trunk (2008-03-04)
700
701* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
702- Update to latest trunk (2008-03-02)
703
704* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
705- Update to latest trunk (2008-03-01)
706
707* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
708- Update to latest trunk (2008-02-29)
709
710* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
711- Update to latest trunk (2008-02-28)
712
713* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
714- Update to latest trunk (2008-02-27)
715
716* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
717- Update to latest trunk (2008-02-26)
718
719* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
720- Update to latest trunk (2008-02-23)
721
722* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
723- Update to latest trunk (2008-02-22)
724
725* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
726- Update to latest trunk (2008-02-21)
727
728* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
729- Update to latest trunk (2008-02-20)
730
731* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
732- Update to latest trunk (2008-02-17)
733
734* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
735- Update to latest trunk (2008-02-15)
736
737* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
738- Update to latest trunk (2008-02-14)
739- Use system hunspell
740
741* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
742- Update to latest trunk (2008-02-11)
743
744* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
745- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
746  you know, debuginfo.
747
748* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
749- Update to latest trunk (2008-02-10)
750
751* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
752- Update to latest trunk (2008-02-09)
753
754* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
755- Update to latest trunk (2008-02-06)
756
757* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
758- Update to latest trunk (2008-01-30)
759
760* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
761- rebuild agains new nss
762- enabled gnome vfs
763
764* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
765- fixed stable pkg-config files (#429654)
766- removed sqlite patch
767
768* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
769- Update to latest trunk (2008-01-21)
770
771* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
772- Update to latest trunk (2008-01-15)
773- Now with system extensions directory support
774
775* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
776- Update to latest trunk (2008-01-13)
777- Use CFLAGS instead of configure arguments
778- Random cleanups: BuildRequires, scriptlets, prefs, etc.
779
780* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
781- Provide gecko-devel-unstable as well
782
783* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
784- divided devel package to devel and devel-unstable
785
786* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
787- removed fedora specific pkg-config files
788- updated to the latest trunk (2008-01-07)
789- removed unnecessary patches
790- fixed idl dir (#427965)
791
792* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
793- Re-enable camellia256 support now that NSS supports it
794
795* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
796- updated to the latest trunk (2008-01-03)
797
798* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
799- Don't Provide webclient (xulrunner is not itself a webclient)
800- Don't Obsolete old firefox, only firefox-devel
801- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
802
803* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
804- added java and plugin subdirs to plugin includes
805
806* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
807- dependency fixes, obsoletes firefox < 3 and firefox-devel now
808
809* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
810- updated to Beta 2.
811- moved SDK to xulrunner-sdk
812
813* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
814- fixed mozilla-plugin.pc (#412971)
815
816* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
817- export /etc/gre.d/gre.conf (it's used by python gecko applications)
818
819* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
820- added xulrunner/js include dir to xulrunner-js
821
822* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
823- update to beta 1
824
825* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
826- packed all gecko libraries (#389391)
827
828* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
829- registered xulrunner libs system-wide
830- added xulrunner-gtkmozembed.pc
831
832* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
833- added proper nss/nspr dependencies
834
835* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
836- more build fixes, use system nss libraries
837
838* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
839- build fixes
840
841* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
842- updated to the latest trunk
843
844* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
845- build fixes for ppc/ppc64
846
847* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
848- removed conflicts with the current gecko-based apps
849- added updated ppc64 patch
850
851* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
852- build fixes
853
854* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
855- Initial cut at XULRunner 1.9 Alpha 7
856- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.