source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 6908

Revision 6908, 24.9 KB checked in by daisuke, 12 years ago (diff)

update to 10.0.8

Line 
1# Minimal required versions
2%global nspr_version 4.8.9
3%global nss_version 3.13.1
4%global cairo_version 1.10.2
5%global freetype_version 2.1.9
6%global libnotify_version 0.7.0
7
8# gecko_dir_ver should be set to the version in our directory names
9# alpha_version should be set to the alpha number if using an alpha, 0 otherwise
10# beta_version  should be set to the beta number if using a beta, 0 otherwise
11# rc_version    should be set to the RC number if using an RC, 0 otherwise
12%global gecko_dir_ver 2
13%global alpha_version 0
14%global beta_version  0
15%global rc_version    0
16
17%global mozappdir         %{_libdir}/%{name}-%{gecko_dir_ver}
18%global tarballdir  mozilla-esr10
19
20Summary:        XUL Runtime for Gecko Applications
21Summary(ja):    Gecko アプリケーションのための XUL ランタイム
22Name:           xulrunner
23Version:        10.0.8
24Release:        1%{?_dist_release}
25URL:            http://developer.mozilla.org/En/XULRunner
26License:        MPLv1.1 or GPLv2+ or LGPLv2+
27Group:          Applications/Internet
28# You can get sources at ftp://ftp.mozilla.org/pub/firefox/releases/%{version}/source
29Source0:        %{name}-%{version}esr.source.tar.bz2
30Source10:       %{name}-mozconfig-vine
31Source12:       %{name}-redhat-default-prefs.js
32Source21:       %{name}.sh.in
33
34# build patches
35Patch0:         xulrunner-version.patch
36Patch1:         mozilla-build.patch
37Patch14:        xulrunner-2.0-chromium-types.patch
38Patch17:        xulrunner-10.0-gcc47.patch
39
40
41# Fedora specific patches
42Patch20:        mozilla-193-pkgconfig.patch
43Patch23:        wmclass.patch
44Patch24:        crashreporter-remove-static.patch
45
46# Upstream patches
47Patch38:        mozilla-696393.patch
48# https://bugzilla.mozilla.org/show_bug.cgi?id=707993
49Patch39:        xulrunner-8.0-fix-maemo-checks-in-npapi.patch
50Patch40:        mozilla-682832-proxy.patch
51# cherry-picked from 13afcd4c097c
52Patch41:        xulrunner-9.0-secondary-build-fix.patch
53Patch42:        mozilla-706724.patch
54Patch43:        mozilla-file.patch
55# Needed to detect/use libvpx-1.0.0
56# https://bugzilla.mozilla.org/show_bug.cgi?id=722127
57Patch44:        mozilla-722127.patch
58Patch46:        mozilla-724615.patch
59Patch47:        mozilla-691898.patch
60
61# ---------------------------------------------------
62
63BuildRequires:  nspr-devel >= %{nspr_version}
64BuildRequires:  nss-devel >= %{nss_version}
65BuildRequires:  cairo-devel >= %{cairo_version}
66BuildRequires:  libpng-devel
67BuildRequires:  libjpeg-turbo-devel
68BuildRequires:  zip
69BuildRequires:  bzip2-devel
70BuildRequires:  zlib-devel
71BuildRequires:  libIDL-devel
72BuildRequires:  gtk2-devel
73BuildRequires:  krb5-devel
74BuildRequires:  pango-devel
75BuildRequires:  freetype2-devel >= %{freetype_version}
76BuildRequires:  libXt-devel
77BuildRequires:  libXrender-devel
78BuildRequires:  startup-notification-devel
79BuildRequires:  alsa-lib-devel
80BuildRequires:  libnotify-devel >= %{libnotify_version}
81BuildRequires:  mesa-libGL-devel
82BuildRequires:  curl-devel
83BuildRequires:  yasm
84
85Requires:       nspr
86Requires:       nss
87Provides:       gecko-libs = %{gecko_verrel}
88Conflicts:      firefox < 3.6
89
90Vendor: Project Vine
91Distribution: Vine Linux
92Packager: daisuke
93
94%description
95XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
96applications that are as rich as Firefox and Thunderbird. It provides mechanisms
97for installing, upgrading, and uninstalling these applications. XULRunner also
98provides libxul, a solution which allows the embedding of Mozilla technologies
99in other projects and products.
100
101%package devel
102Summary: Development files for Gecko
103Summary(ja):  Geckoの開発ファイル
104Group: Development/Libraries
105Obsoletes: mozilla-devel < 1.9
106Obsoletes: firefox-devel < 2.1
107Obsoletes: xulrunner-devel-unstable
108Provides: gecko-devel = %{gecko_verrel}
109Provides: gecko-devel-unstable = %{gecko_verrel}
110
111Requires: xulrunner = %{version}-%{release}
112Requires: nspr-devel
113Requires: nss-devel
114Requires: cairo-devel
115Requires: libjpeg-devel
116Requires: zip
117Requires: bzip2-devel
118Requires: zlib-devel
119Requires: libIDL-devel
120Requires: gtk2-devel
121Requires: krb5-devel
122Requires: pango-devel
123Requires: freetype-devel
124Requires: libXt-devel
125Requires: libXrender-devel
126Requires: startup-notification-devel
127Requires: alsa-lib-devel
128Requires: libnotify-devel
129Requires: mesa-libGL-devel
130
131%description devel
132This package contains the libraries amd header files that are needed
133for writing XUL+XPCOM applications with Mozilla XULRunner and Gecko.
134
135#---------------------------------------------------------------------
136
137%prep
138%setup -q -c
139cd %{tarballdir}
140
141sed -e 's/__RPM_VERSION_INTERNAL__/%{gecko_dir_ver}/' %{P:%%PATCH0} \
142    > version.patch
143%{__patch} -p1 -b --suffix .version --fuzz=0 < version.patch
144
145%patch1  -p2 -b .build
146%patch14 -p1 -b .chromium-types
147%patch17 -p1 -b .gcc47
148
149%patch20 -p2 -b .pk
150%patch23 -p1 -b .wmclass
151%patch24 -p1 -b .static
152
153%patch38 -p2 -b .696393
154%patch39 -p1 -b .707993
155%patch40 -p2 -b .682832
156%patch41 -p2 -b .secondary-build
157%patch42 -p1 -b .706724
158%patch43 -p1 -b .file
159%patch44 -p2 -b .vpx1.0.0
160%patch46 -p1 -b .724615
161%patch47 -p1 -b .691898
162
163%{__rm} -f .mozconfig
164%{__cp} %{SOURCE10} .mozconfig
165
166echo "ac_add_options --disable-system-sqlite" >> .mozconfig
167
168%ifarch armv7hl
169echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
170echo "ac_add_options --with-float-abi=hard" >> .mozconfig
171echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
172echo "ac_add_options --disable-elf-hack" >> .mozconfig
173%endif
174%ifarch armv7hnl
175echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
176echo "ac_add_options --with-float-abi=hard" >> .mozconfig
177echo "ac_add_options --with-fpu=neon" >> .mozconfig
178echo "ac_add_options --disable-elf-hack" >> .mozconfig
179%endif
180%ifarch armv5tel
181echo "ac_add_options --with-arch=armv5te" >> .mozconfig
182echo "ac_add_options --with-float-abi=soft" >> .mozconfig
183echo "ac_add_options --disable-elf-hack" >> .mozconfig
184%endif
185
186%ifnarch %{ix86} x86_64
187echo "ac_add_options --disable-methodjit" >> .mozconfig
188echo "ac_add_options --disable-monoic" >> .mozconfig
189echo "ac_add_options --disable-polyic" >> .mozconfig
190echo "ac_add_options --disable-tracejit" >> .mozconfig
191%endif
192
193#---------------------------------------------------------------------
194
195%build
196cd %{tarballdir}
197
198# -fpermissive is needed to build with gcc 4.6+ which has become stricter
199#
200# Mozilla builds with -Wall with exception of a few warnings which show up
201# everywhere in the code; so, don't override that.
202#
203# Disable C++ exceptions since Mozilla code is not exception-safe
204#
205MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
206                      %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
207export CFLAGS=$MOZ_OPT_FLAGS
208export CXXFLAGS=$MOZ_OPT_FLAGS
209
210export PREFIX='%{_prefix}'
211export LIBDIR='%{_libdir}'
212
213MOZ_SMP_FLAGS=-j1
214# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
215# however builds tend to fail on other arches when building in parallel.
216%ifarch %{ix86} x86_64
217[ -z "$RPM_BUILD_NCPUS" ] && \
218     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
219[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
220[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
221%endif
222
223make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS" MOZ_SERVICES_SYNC="1"
224
225#---------------------------------------------------------------------
226
227%install
228cd %{tarballdir}
229
230# set up our prefs before install, so it gets pulled in to omni.jar
231%{__cp} -p %{SOURCE12} dist/bin/defaults/pref/all-redhat.js
232
233DESTDIR=$RPM_BUILD_ROOT make install
234
235# Start script install
236%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
237%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{gecko_dir_ver},g' > \
238  $RPM_BUILD_ROOT%{_bindir}/%{name}
239%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
240
241%{__rm} -f $RPM_BUILD_ROOT%{mozappdir}/%{name}-config
242
243# Copy pc files (for compatibility with 1.9.1)
244%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
245        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
246%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
247        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
248
249# Fix multilib devel conflicts...
250function install_file() {
251genheader=$*
252mv ${genheader}.h ${genheader}%{__isa_bits}.h
253cat > ${genheader}.h << EOF
254/* This file exists to fix multilib conflicts */
255#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__) || (defined(__sparc__) && defined(__arch64__))
256#include "${genheader}64.h"
257#else
258#include "${genheader}32.h"
259#endif
260EOF
261}
262
263INTERNAL_APP_NAME=%{name}-%{gecko_dir_ver}
264
265pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
266install_file "mozilla-config"
267install_file "js-config"
268popd
269
270# Link libraries in sdk directory instead of copying them:
271pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-devel-%{gecko_dir_ver}/sdk/lib
272for i in *.so; do
273     rm $i
274     ln -s %{mozappdir}/$i $i
275done
276popd
277
278# Library path
279LD_SO_CONF_D=%{_sysconfdir}/ld.so.conf.d
280LD_CONF_FILE=xulrunner-%{__isa_bits}.conf
281
282%{__mkdir_p} ${RPM_BUILD_ROOT}${LD_SO_CONF_D}
283%{__cat} > ${RPM_BUILD_ROOT}${LD_SO_CONF_D}/${LD_CONF_FILE} << EOF
284%{mozappdir}
285EOF
286
287# Copy over the LICENSE
288%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
289
290# ghost files
291%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/components
292touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
293touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
294
295#---------------------------------------------------------------------
296
297%post -p /sbin/ldconfig
298
299%postun -p /sbin/ldconfig
300
301%preun
302# is it a final removal?
303if [ $1 -eq 0 ]; then
304  %{__rm} -rf %{mozappdir}/components
305fi
306
307%files
308%defattr(-,root,root,-)
309%{_bindir}/xulrunner
310%dir %{mozappdir}
311%doc %attr(644, root, root) %{mozappdir}/LICENSE
312%doc %attr(644, root, root) %{mozappdir}/README.txt
313%{mozappdir}/chrome
314%{mozappdir}/chrome.manifest
315%{mozappdir}/dictionaries
316%dir %{mozappdir}/components
317%ghost %{mozappdir}/components/compreg.dat
318%ghost %{mozappdir}/components/xpti.dat
319%{mozappdir}/components/*.so
320%{mozappdir}/components/*.manifest
321%{mozappdir}/omni.ja
322%{mozappdir}/plugins
323%{mozappdir}/*.so
324%{mozappdir}/mozilla-xremote-client
325%{mozappdir}/run-mozilla.sh
326%{mozappdir}/xulrunner
327%{mozappdir}/xulrunner-bin
328%{mozappdir}/xulrunner-stub
329%{mozappdir}/platform.ini
330%{mozappdir}/dependentlibs.list
331%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
332%{mozappdir}/plugin-container
333
334%files devel
335%defattr(-,root,root,-)
336%dir %{_libdir}/%{name}-devel-*
337%{_datadir}/idl/%{name}*%{gecko_dir_ver}
338%{_includedir}/%{name}*%{gecko_dir_ver}
339%{_libdir}/%{name}-devel-*/*
340%{_libdir}/pkgconfig/*.pc
341%{mozappdir}/xpcshell
342
343#---------------------------------------------------------------------
344
345%changelog
346* Wed Oct 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.8-1
347- update to 10.0.8esr
348
349* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.6-1
350- update to 10.0.6 (based on firefox-10.0.6esr source)
351
352* Wed Mar 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.3-1
353- update to 10.0.3 (based on firefox-10.0.3esr source)
354- clean up spec
355
356* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
357- rebuild with libnotify-0.7
358
359* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
360- modify gre.conf to promote internal gecko version.
361
362* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
363- update to 2.0.1 (sync with firefox-4.0.1)
364
365* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
366- update to 2.0 (sync with firefox-4.0)
367- BR: libjpeg-turbo-devel >= 1.1.0
368- BR: nspr-devel >= 4.8.7
369- BR: nss-devel >= 3.12.9
370- BR: cairo-devel >= 1.10.2-2
371- add Patch130 to use omni.jar (upstream patch)
372
373* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
374- update to 1.9.2.15 (sync with firefox-3.6.15)
375
376* Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
377- update to 1.9.2.14 (sync with firefox-3.6.14)
378
379* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
380- update to 1.9.2.13 (sync with firefox-3.6.13)
381
382* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
383- update to 1.9.2.11 (sync with firefox-3.6.11)
384
385* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
386- rebuild with rpm-4.8.1 for pkg-config file
387
388* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
389- update to 1.9.2.9 (sync with firefox-3.6.9)
390- add patch10 to build with libjpeg-turbo
391- build with sqlite-3.7.2
392- BR: nspr >= 4.8.6
393
394* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
395- update tp 1.9.2.8 (sync with firefox-3.6.8)
396
397* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
398- update tp 1.9.2.7 (sync with firefox-3.6.7)
399
400* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
401- enable ipc only on ix86/x86_64 arches
402
403* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
404- update to 1.9.2.4 (sync with firefox-3.6.4)
405- add patch10 to fix build failure
406
407* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
408- update to 1.9.2.3 (sync with firefox-3.6.3)
409
410* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
411- update to 1.9.2.2 (sync with firefox-3.6.2)
412- add patch7,9 for fix build failure
413
414* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
415- enable libnotify support
416  - add ac_add_options --enable-libnotify
417- disable Necko wifi monitor
418  - add ac_add_options --disable-necko-wifi
419  - remove BR: wireless-tools-devel
420- fix %%files devel
421- add patch3,5 to fix jemalloc alignment assertion
422- add Patch8 to fix mozilla-plugin.pc
423
424* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
425- add BR: libnotify-devel, wireless-tools-devel
426
427* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
428- update to 1.9.2 (sync with firefox-3.6)
429- obsoletes xulrunner-devel-unstable
430
431* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
432- use internal sqlite3 on vine5
433
434* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
435- update to 1.9.1.7
436
437* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
438- update to 1.9.1.6
439- build with sqlite3-3.6.21
440
441* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
442- update to 1.9.1.5
443
444* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
445- update to 1.9.1.3
446
447* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
448- really update to 1.9.1.2 (<BTS:0748>)
449
450* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
451- update to 1.9.1.2 (sync with firefox-3.5.2)
452
453* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
454- update to 1.9.1.1 (sync with firefox-3.5.1)
455- add missing Requires to -devel
456- add missing BR
457
458* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
459- enable-system-cairo
460
461* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
462- update to 1.9.1 (based on firefox 3.5)
463
464* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
465- update to 1.9.1rc3 (sync with firefox 3.5rc3)
466
467* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
468- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
469- remove old patches
470- require nspr >= 4.8
471
472* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
473- new upstream release
474
475* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
476- update mozconfig
477  - disable-system-cairo for stability
478
479* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
480- new upstream release
481
482* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
483- new upstream release
484- add ja locale
485
486* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
487- new upstream release
488
489* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
490- new upstream release
491
492* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
493- add Patch3
494
495* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
496- update to xulrunner 1.9.0.2 byild 6
497- build with gnome-2.24
498
499* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
500- new upstream release
501
502* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
503- initial build for Vine Linux
504
505* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
506- Update to 1.9 final
507
508* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
509- Simplify PS/PDF operators
510
511* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
512- Upstream patch to fsync() less
513
514* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
515- Ensure we enable startup notification; add BR and modify config
516  (bug #445543)
517
518* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
519- Some files moved to mozilla-filesystem; kill them and add the Req
520
521* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
522- Clean up the %%files list and get rid of the executable bit on some files
523
524* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
525- Fix font scaling
526
527* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
528- Enabled phishing protection (#443403)
529
530* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
531- Changed "__ppc64__" to "__powerpc64__",
532  "__ppc64__" doesn't work anymore
533- Added fix for #443725 - Critical hanging bug with fix
534  available upstream (mozbz#429903)
535
536* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
537- Fixed multilib issues, added starting script instead of a symlink
538  to binary (#436393)
539
540* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
541- Add upstream patches for dpi, toolbar buttons, and invalid keys
542- Re-enable system cairo
543
544* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
545- Spec cleanups
546
547* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
548- Beta 5
549
550* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
551- Beta 5 RC2
552
553* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
554- Update to latest trunk (2008-03-27)
555
556* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
557- Update to latest trunk (2008-03-26)
558
559* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
560- Update to latest trunk (2008-03-25)
561
562* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
563- Update to latest trunk (2008-03-24)
564
565* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
566- Update to latest trunk (2008-03-20)
567
568* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
569- Update to latest trunk (2008-03-17)
570
571* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
572- Revert to trunk from the 15th to fix crashes on HTTPS sites
573
574* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
575- Update to latest trunk (2008-03-16)
576- Add patch to negate a11y slowdown on some pages (#431162)
577
578* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
579- Update to latest trunk (2008-03-15)
580
581* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
582- Avoid conflicts between gecko debuginfo packages
583
584* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
585- Update to latest trunk (2008-03-12)
586
587* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
588- Update to latest trunk (2008-03-11)
589
590* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
591- Update to latest trunk (2008-03-10)
592
593* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
594- Update to latest trunk (2008-03-09)
595
596* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
597- Update to latest trunk (2008-03-07)
598
599* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
600- Update to latest trunk (2008-03-06)
601
602* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
603- Update to latest trunk (2008-03-04)
604
605* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
606- Update to latest trunk (2008-03-02)
607
608* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
609- Update to latest trunk (2008-03-01)
610
611* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
612- Update to latest trunk (2008-02-29)
613
614* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
615- Update to latest trunk (2008-02-28)
616
617* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
618- Update to latest trunk (2008-02-27)
619
620* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
621- Update to latest trunk (2008-02-26)
622
623* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
624- Update to latest trunk (2008-02-23)
625
626* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
627- Update to latest trunk (2008-02-22)
628
629* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
630- Update to latest trunk (2008-02-21)
631
632* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
633- Update to latest trunk (2008-02-20)
634
635* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
636- Update to latest trunk (2008-02-17)
637
638* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
639- Update to latest trunk (2008-02-15)
640
641* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
642- Update to latest trunk (2008-02-14)
643- Use system hunspell
644
645* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
646- Update to latest trunk (2008-02-11)
647
648* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
649- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
650  you know, debuginfo.
651
652* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
653- Update to latest trunk (2008-02-10)
654
655* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
656- Update to latest trunk (2008-02-09)
657
658* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
659- Update to latest trunk (2008-02-06)
660
661* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
662- Update to latest trunk (2008-01-30)
663
664* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
665- rebuild agains new nss
666- enabled gnome vfs
667
668* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
669- fixed stable pkg-config files (#429654)
670- removed sqlite patch
671
672* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
673- Update to latest trunk (2008-01-21)
674
675* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
676- Update to latest trunk (2008-01-15)
677- Now with system extensions directory support
678
679* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
680- Update to latest trunk (2008-01-13)
681- Use CFLAGS instead of configure arguments
682- Random cleanups: BuildRequires, scriptlets, prefs, etc.
683
684* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
685- Provide gecko-devel-unstable as well
686
687* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
688- divided devel package to devel and devel-unstable
689
690* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
691- removed fedora specific pkg-config files
692- updated to the latest trunk (2008-01-07)
693- removed unnecessary patches
694- fixed idl dir (#427965)
695
696* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
697- Re-enable camellia256 support now that NSS supports it
698
699* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
700- updated to the latest trunk (2008-01-03)
701
702* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
703- Don't Provide webclient (xulrunner is not itself a webclient)
704- Don't Obsolete old firefox, only firefox-devel
705- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
706
707* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
708- added java and plugin subdirs to plugin includes
709
710* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
711- dependency fixes, obsoletes firefox < 3 and firefox-devel now
712
713* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
714- updated to Beta 2.
715- moved SDK to xulrunner-sdk
716
717* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
718- fixed mozilla-plugin.pc (#412971)
719
720* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
721- export /etc/gre.d/gre.conf (it's used by python gecko applications)
722
723* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
724- added xulrunner/js include dir to xulrunner-js
725
726* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
727- update to beta 1
728
729* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
730- packed all gecko libraries (#389391)
731
732* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
733- registered xulrunner libs system-wide
734- added xulrunner-gtkmozembed.pc
735
736* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
737- added proper nss/nspr dependencies
738
739* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
740- more build fixes, use system nss libraries
741
742* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
743- build fixes
744
745* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
746- updated to the latest trunk
747
748* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
749- build fixes for ppc/ppc64
750
751* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
752- removed conflicts with the current gecko-based apps
753- added updated ppc64 patch
754
755* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
756- build fixes
757
758* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
759- Initial cut at XULRunner 1.9 Alpha 7
760- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.