source: projects/specs/trunk/x/xorg-x11-xsm/xorg-x11-xsm-vl.spec @ 7648

Revision 7648, 6.8 KB checked in by Takemikaduchi, 11 years ago (diff)

xserver-1.14.1

Line 
1%define pkgname xsm
2
3Summary: X.Org X11 X Session Manager
4Summary(ja): X.Org X11 X セッションマネージャ
5Name: xorg-x11-%{pkgname}
6# NOTE: The Version field should be the version of the xsm tarball.
7Version: 1.0.3
8# Bump the release on rebuilds/bugfixes/etc.
9Release: 1%{?_dist_release}
10License: MIT
11Group: User Interface/X
12URL: http://www.x.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.3.tar.bz2
16Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.5.tar.bz2
17Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
18
19# Patches for xsm (10-19)
20
21# Patches for smproxy (20-29)
22
23
24# Patches for rstart (30-39)
25Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
26
27# FIXME: Temporary dependency on automake/autoconf while they're still needed.
28BuildRequires: automake autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: xorg-x11-util-macros
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
34BuildRequires: rsh
35
36# NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
37# monolithic X releases to modular X releases to work properly.
38Requires(pre): xorg-x11-filesystem
39# rstart script invokes xauth, rsh
40Requires: xauth, rsh
41
42Provides: xsm, smproxy, rstart, rstartd
43
44# NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
45Obsoletes: XFree86
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51X.Org X11 X Session Manager
52
53%prep
54%setup -q -c %{name}-%{version} -a1 -a2
55%patch30 -p0 -b .rstart-installation-location-fixes
56
57
58%build
59# Build everything
60{
61   for pkg in xsm smproxy rstart ; do
62      pushd $pkg-*
63
64      sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
65      aclocal ; automake ; autoconf
66
67      %configure --disable-xprint
68      make
69      popd
70   done
71}
72
73%install
74rm -rf $RPM_BUILD_ROOT
75
76# Install everything
77{
78   for pkg in xsm smproxy rstart ; do
79      pushd $pkg-*
80      make install DESTDIR=$RPM_BUILD_ROOT
81      popd
82   done
83}
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(-,root,root,-)
90# FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
91# can't use the %%version macro here until a upstream xsm is released as
92# version 1.0.2 or higher.
93#%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
94#%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
95%doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
96%doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
97
98%{_bindir}/rstart
99%{_bindir}/rstartd
100%{_bindir}/smproxy
101%{_bindir}/xsm
102%dir %{_datadir}/X11
103%dir %{_datadir}/X11/rstart
104%dir %{_datadir}/X11/rstart/commands
105%{_datadir}/X11/rstart/commands/@List
106%{_datadir}/X11/rstart/commands/ListContexts
107%{_datadir}/X11/rstart/commands/ListGenericCommands
108%dir %{_datadir}/X11/rstart/commands/x11r6
109%{_datadir}/X11/rstart/commands/x11r6/@List
110%{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
111%{_datadir}/X11/rstart/commands/x11r6/Terminal
112%dir %{_datadir}/X11/rstart/contexts
113%{_datadir}/X11/rstart/contexts/@List
114%{_datadir}/X11/rstart/contexts/default
115%{_datadir}/X11/rstart/contexts/x
116%{_datadir}/X11/rstart/contexts/x11
117%{_datadir}/X11/rstart/contexts/x11r6
118%{_datadir}/X11/app-defaults/XSm
119%dir %{_libdir}/X11
120%dir %{_libdir}/X11/rstart
121# NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
122%{_libdir}/X11/rstart/rstartd.real
123#%dir %{_mandir}/man1x
124%{_mandir}/man1/rstart.1*
125%{_mandir}/man1/rstartd.1*
126%{_mandir}/man1/smproxy.1*
127%{_mandir}/man1/xsm.1*
128%dir %{_sysconfdir}/X11
129%dir %{_sysconfdir}/X11/rstart
130%config %{_sysconfdir}/X11/rstart/config
131%dir %{_sysconfdir}/X11/xsm
132%config %{_sysconfdir}/X11/xsm/system.xsm
133
134%changelog
135* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
136- update to 1.0.3
137- remove Patch10 (xsm-1.0.2-xsm-installation-location-fixes.patch)
138
139* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-5
140- smproxy-1.0.5
141
142* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
143- delete Obsoletes: xorg-x11
144
145* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
146- xsm-1.0.2
147- smproxy-1.0.4
148- rstart-1.0.4
149- update Patch10, Patch30
150- fix %%files
151
152* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
153- smproxy-1.0.3
154- rstart-1.0.3
155
156* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
157- initial build for Vine Linux
158
159* Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
160- Fix license tag.
161
162* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
163- Autorebuild for GCC 4.3
164
165* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
166- Rebuild for build id
167
168* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
169- Fix man page globs and rebuild for FC7.
170
171* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
172- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
173- Add 'dist' tag to package release string.
174
175* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
176- rebuild
177
178* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
179- Added xsm documentation to doc macro.
180- The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
181  an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
182  in a few places temporarily until xsm-1.0.2 is available.
183
184* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
185- Fix BuildRequires (#191802)
186
187* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
188- Update smproxy and rstart
189
190* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
191- bump again for double-long bug on ppc(64)
192
193* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
194- rebuilt for new gcc4.1 snapshot and glibc changes
195
196* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
197- Updated all apps to version 1.0.1 from X11R7.0
198
199* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
200- Updated all apps to version 1.0.0 from X11R7 RC4.
201- Changed manpage dir from man1x to man1 to match upstream default.
202
203* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
204- Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
205- Added rstart-0.99.1-rstart-installation-location-fixes.patch and
206  xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
207 /etc and data files in /usr/share where they belong.
208- Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
209
210* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
211- require newer filesystem package (#172610)
212
213* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
214- Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
215- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
216
217* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
218- Initial build of xsm, smproxy, and rstart from X11R7 RC1
Note: See TracBrowser for help on using the repository browser.