source: projects/specs/trunk/x/xorg-x11-xsm/xorg-x11-xsm-vl.spec @ 4616

Revision 4616, 6.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pkgname xsm
2
3Summary: X.Org X11 X Session Manager
4Summary(ja): X.Org X11 X セッションマネージャ
5Name: xorg-x11-%{pkgname}
6# NOTE: The Version field should be the version of the xsm tarball.
7Version: 1.0.2
8# Bump the release on rebuilds/bugfixes/etc.
9Release: 5%{?_dist_release}
10License: MIT
11Group: User Interface/X
12URL: http://www.x.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.2.tar.bz2
16Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.5.tar.bz2
17Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
18
19# Patches for xsm (10-19)
20Patch10: xsm-1.0.2-xsm-installation-location-fixes.patch
21
22# Patches for smproxy (20-29)
23
24
25# Patches for rstart (30-39)
26Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
27
28# FIXME: Temporary dependency on automake/autoconf while they're still needed.
29BuildRequires: automake autoconf
30
31BuildRequires: pkgconfig
32BuildRequires: xorg-x11-util-macros
33BuildRequires: xorg-x11-proto-devel
34BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
35BuildRequires: rsh
36
37# NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
38# monolithic X releases to modular X releases to work properly.
39Requires(pre): xorg-x11-filesystem
40# rstart script invokes xauth, rsh
41Requires: xauth, rsh
42
43Provides: xsm, smproxy, rstart, rstartd
44
45# NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
46Obsoletes: XFree86
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52X.Org X11 X Session Manager
53
54%prep
55%setup -q -c %{name}-%{version} -a1 -a2
56%patch10 -p0 -b .xsm-installation-location-fixes
57%patch30 -p0 -b .rstart-installation-location-fixes
58
59
60%build
61# Build everything
62{
63   for pkg in xsm smproxy rstart ; do
64      pushd $pkg-*
65
66      sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
67      aclocal ; automake ; autoconf
68
69      %configure --disable-xprint
70      make
71      popd
72   done
73}
74
75%install
76rm -rf $RPM_BUILD_ROOT
77
78# Install everything
79{
80   for pkg in xsm smproxy rstart ; do
81      pushd $pkg-*
82      make install DESTDIR=$RPM_BUILD_ROOT
83      popd
84   done
85}
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%files
91%defattr(-,root,root,-)
92# FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
93# can't use the %%version macro here until a upstream xsm is released as
94# version 1.0.2 or higher.
95#%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
96#%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
97%doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
98%doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
99
100%{_bindir}/rstart
101%{_bindir}/rstartd
102%{_bindir}/smproxy
103%{_bindir}/xsm
104%dir %{_datadir}/X11
105%dir %{_datadir}/X11/rstart
106%dir %{_datadir}/X11/rstart/commands
107%{_datadir}/X11/rstart/commands/@List
108%{_datadir}/X11/rstart/commands/ListContexts
109%{_datadir}/X11/rstart/commands/ListGenericCommands
110%dir %{_datadir}/X11/rstart/commands/x11r6
111%{_datadir}/X11/rstart/commands/x11r6/@List
112%{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
113%{_datadir}/X11/rstart/commands/x11r6/Terminal
114%dir %{_datadir}/X11/rstart/contexts
115%{_datadir}/X11/rstart/contexts/@List
116%{_datadir}/X11/rstart/contexts/default
117%{_datadir}/X11/rstart/contexts/x
118%{_datadir}/X11/rstart/contexts/x11
119%{_datadir}/X11/rstart/contexts/x11r6
120%{_datadir}/X11/app-defaults/XSm
121%dir %{_libdir}/X11
122%dir %{_libdir}/X11/rstart
123# NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
124%{_libdir}/X11/rstart/rstartd.real
125#%dir %{_mandir}/man1x
126%{_mandir}/man1/rstart.1*
127%{_mandir}/man1/rstartd.1*
128%{_mandir}/man1/smproxy.1*
129%{_mandir}/man1/xsm.1*
130%dir %{_sysconfdir}/X11
131%dir %{_sysconfdir}/X11/rstart
132%config %{_sysconfdir}/X11/rstart/config
133%dir %{_sysconfdir}/X11/xsm
134%config %{_sysconfdir}/X11/xsm/system.xsm
135
136%changelog
137* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-5
138- smproxy-1.0.5
139
140* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
141- delete Obsoletes: xorg-x11
142
143* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
144- xsm-1.0.2
145- smproxy-1.0.4
146- rstart-1.0.4
147- update Patch10, Patch30
148- fix %%files
149
150* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
151- smproxy-1.0.3
152- rstart-1.0.3
153
154* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
155- initial build for Vine Linux
156
157* Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
158- Fix license tag.
159
160* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
161- Autorebuild for GCC 4.3
162
163* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
164- Rebuild for build id
165
166* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
167- Fix man page globs and rebuild for FC7.
168
169* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
170- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
171- Add 'dist' tag to package release string.
172
173* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
174- rebuild
175
176* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
177- Added xsm documentation to doc macro.
178- The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
179  an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
180  in a few places temporarily until xsm-1.0.2 is available.
181
182* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
183- Fix BuildRequires (#191802)
184
185* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
186- Update smproxy and rstart
187
188* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
189- bump again for double-long bug on ppc(64)
190
191* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
192- rebuilt for new gcc4.1 snapshot and glibc changes
193
194* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
195- Updated all apps to version 1.0.1 from X11R7.0
196
197* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
198- Updated all apps to version 1.0.0 from X11R7 RC4.
199- Changed manpage dir from man1x to man1 to match upstream default.
200
201* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
202- Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
203- Added rstart-0.99.1-rstart-installation-location-fixes.patch and
204  xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
205 /etc and data files in /usr/share where they belong.
206- Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
207
208* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
209- require newer filesystem package (#172610)
210
211* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
212- Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
213- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
214
215* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
216- Initial build of xsm, smproxy, and rstart from X11R7 RC1
Note: See TracBrowser for help on using the repository browser.