source: projects/specs/trunk/x/xorg-x11-xsm/xorg-x11-xsm-vl.spec @ 9775

Revision 9775, 7.0 KB checked in by Takemikaduchi, 8 years ago (diff)

kernel-4.1, xserver-1.17.2, VirtualBox?-4.3.32, etc.

Line 
1%define pkgname xsm
2
3Summary: X.Org X11 X Session Manager
4Summary(ja): X.Org X11 X セッションマネージャ
5Name: xorg-x11-%{pkgname}
6# NOTE: The Version field should be the version of the xsm tarball.
7Version: 1.0.3
8# Bump the release on rebuilds/bugfixes/etc.
9Release: 3%{?_dist_release}
10License: MIT
11Group: User Interface/X
12URL: http://www.x.org
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Source0: ftp://ftp.x.org/pub/individual/app/xsm-1.0.3.tar.bz2
16Source1: ftp://ftp.x.org/pub/individual/app/smproxy-1.0.6.tar.bz2
17Source2: ftp://ftp.x.org/pub/individual/app/rstart-1.0.4.tar.bz2
18
19# Patches for xsm (10-19)
20
21# Patches for smproxy (20-29)
22
23
24# Patches for rstart (30-39)
25Patch30: rstart-1.0.4-rstart-installation-location-fixes.patch
26
27# FIXME: Temporary dependency on automake/autoconf while they're still needed.
28BuildRequires: automake autoconf
29
30BuildRequires: pkgconfig
31BuildRequires: xorg-x11-util-macros
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: libXaw-devel libXext-devel libXt-devel libXpm-devel
34BuildRequires: rsh
35
36# NOTE: xorg-x11-filesystem >= 0.99.2-3 is required for OS upgrades from
37# monolithic X releases to modular X releases to work properly.
38Requires(pre): xorg-x11-filesystem
39# rstart script invokes xauth, rsh
40Requires: xauth, rsh
41
42Provides: xsm, smproxy, rstart, rstartd
43
44# NOTE: xsm, smproxy, rstart used to be part of the XFree86/xorg-x11 package
45Obsoletes: XFree86
46
47Vendor: Project Vine
48Distribution: Vine Linux
49Packager: Takemikaduchi
50
51%description
52X.Org X11 X Session Manager
53
54%prep
55%setup -q -c %{name}-%{version} -a1 -a2
56%patch30 -p0 -b .rstart-installation-location-fixes
57
58
59%build
60# Build everything
61{
62   for pkg in xsm smproxy rstart ; do
63      pushd $pkg-*
64
65      sed -i '/XAW_/ s/)/, xaw7)/; /XAW_/ s/XAW_CHECK_XPRINT_SUPPORT/PKG_CHECK_MODULES/' configure.ac
66      autoreconf -if
67
68      %configure --disable-xprint
69      make
70      popd
71   done
72}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76
77# Install everything
78{
79   for pkg in xsm smproxy rstart ; do
80      pushd $pkg-*
81      make install DESTDIR=$RPM_BUILD_ROOT
82      popd
83   done
84}
85
86%clean
87rm -rf $RPM_BUILD_ROOT
88
89%files
90%defattr(-,root,root,-)
91# FIXME: The rpm package version was accidentally bumped to 1.0.2, so we
92# can't use the %%version macro here until a upstream xsm is released as
93# version 1.0.2 or higher.
94#%doc xsm-%{version}/AUTHORS xsm-%{version}/COPYING xsm-%{version}/INSTALL
95#%doc xsm-%{version}/NEWS xsm-%{version}/README xsm-%{version}/ChangeLog
96%doc xsm-1.0.2/AUTHORS xsm-1.0.2/COPYING xsm-1.0.2/INSTALL
97%doc xsm-1.0.2/NEWS xsm-1.0.2/README xsm-1.0.2/ChangeLog
98
99%{_bindir}/rstart
100%{_bindir}/rstartd
101%{_bindir}/smproxy
102%{_bindir}/xsm
103%dir %{_datadir}/X11
104%dir %{_datadir}/X11/rstart
105%dir %{_datadir}/X11/rstart/commands
106%{_datadir}/X11/rstart/commands/@List
107%{_datadir}/X11/rstart/commands/ListContexts
108%{_datadir}/X11/rstart/commands/ListGenericCommands
109%dir %{_datadir}/X11/rstart/commands/x11r6
110%{_datadir}/X11/rstart/commands/x11r6/@List
111%{_datadir}/X11/rstart/commands/x11r6/LoadMonitor
112%{_datadir}/X11/rstart/commands/x11r6/Terminal
113%dir %{_datadir}/X11/rstart/contexts
114%{_datadir}/X11/rstart/contexts/@List
115%{_datadir}/X11/rstart/contexts/default
116%{_datadir}/X11/rstart/contexts/x
117%{_datadir}/X11/rstart/contexts/x11
118%{_datadir}/X11/rstart/contexts/x11r6
119%{_datadir}/X11/app-defaults/XSm
120%dir %{_libdir}/X11
121%dir %{_libdir}/X11/rstart
122# NOTE: This binary can and probably should sit in /usr/sbin, but oh well.
123%{_libdir}/X11/rstart/rstartd.real
124#%dir %{_mandir}/man1x
125%{_mandir}/man1/rstart.1*
126%{_mandir}/man1/rstartd.1*
127%{_mandir}/man1/smproxy.1*
128%{_mandir}/man1/xsm.1*
129%dir %{_sysconfdir}/X11
130%dir %{_sysconfdir}/X11/rstart
131%config %{_sysconfdir}/X11/rstart/config
132%dir %{_sysconfdir}/X11/xsm
133%config %{_sysconfdir}/X11/xsm/system.xsm
134
135%changelog
136* Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-3
137- smproxy-1.0.6
138
139* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-2
140- rebuild with VineSeed environment
141
142* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.3-1
143- update to 1.0.3
144- remove Patch10 (xsm-1.0.2-xsm-installation-location-fixes.patch)
145
146* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-5
147- smproxy-1.0.5
148
149* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-4
150- delete Obsoletes: xorg-x11
151
152* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.2-3
153- xsm-1.0.2
154- smproxy-1.0.4
155- rstart-1.0.4
156- update Patch10, Patch30
157- fix %%files
158
159* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
160- smproxy-1.0.3
161- rstart-1.0.3
162
163* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
164- initial build for Vine Linux
165
166* Tue Jul 15 2008 Adam Jackson <ajax@redhat.com> 1.0.2-8
167- Fix license tag.
168
169* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.2-7
170- Autorebuild for GCC 4.3
171
172* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-6
173- Rebuild for build id
174
175* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 1.0.2-5
176- Fix man page globs and rebuild for FC7.
177
178* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4.fc6
179- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
180- Add 'dist' tag to package release string.
181
182* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-3.1
183- rebuild
184
185* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
186- Added xsm documentation to doc macro.
187- The 1.0.2-1 build had the version accidentally bumped to 1.0.2 before
188  an xsm-1.0.2 was available, so I had to hard code the actual 1.0.1 version
189  in a few places temporarily until xsm-1.0.2 is available.
190
191* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-2
192- Fix BuildRequires (#191802)
193
194* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
195- Update smproxy and rstart
196
197* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
198- bump again for double-long bug on ppc(64)
199
200* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
201- rebuilt for new gcc4.1 snapshot and glibc changes
202
203* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
204- Updated all apps to version 1.0.1 from X11R7.0
205
206* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
207- Updated all apps to version 1.0.0 from X11R7 RC4.
208- Changed manpage dir from man1x to man1 to match upstream default.
209
210* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
211- Add "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to avoid bug (#173384).
212- Added rstart-0.99.1-rstart-installation-location-fixes.patch and
213  xsm-0.99.2-xsm-installation-location-fixes.patch to put config files in
214 /etc and data files in /usr/share where they belong.
215- Added "Requires: xauth, rsh" as rstart invokes xauth, rsh.
216
217* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
218- require newer filesystem package (#172610)
219
220* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.1-2
221- Added "Obsoletes: XFree86, xorg-x11", as all of these used to be in there.
222- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
223
224* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
225- Initial build of xsm, smproxy, and rstart from X11R7 RC1
Note: See TracBrowser for help on using the repository browser.