source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 9775

Revision 9775, 22.6 KB checked in by Takemikaduchi, 9 years ago (diff)

kernel-4.1, xserver-1.17.2, VirtualBox?-4.3.32, etc.

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8#%define gputoolsdate 20130611
9%define gputoolsdate 1.12
10%else
11%define accel sna
12%define gputoolsdate 20110817
13%endif
14
15Summary:   Xorg X11 Intel video driver
16Summary(ja):   Xorg X11 Intel ビデオドライバ
17Name:      xorg-x11-drv-intel
18Epoch:     1
19Version:   2.99.917
20Release:   2%{?_dist_release}
21URL:       http://intellinuxgraphics.org/
22License:   MIT
23Group:     User Interface/X Hardware Support
24
25Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
26Source2:   intel.xinf
27#Source3:   intel-gpu-tools-%{gputoolsdate1}.tar.bz2
28Source3:   intel-gpu-tools-1.12.tar.bz2
29
30# vine patch
31Patch0:    xf86-video-intel-2.99.917-git20151019.patch
32
33
34ExclusiveArch: %{ix86} x86_64 ia64
35BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36BuildRequires: autoconf, automake, libtool
37BuildRequires: xorg-x11-server-sdk >= 1.7.99
38BuildRequires: libXvMC-devel
39BuildRequires: libGL-devel >= 7.10
40BuildRequires: libdrm-devel >= 2.4.25
41BuildRequires: kernel-headers >= 2.6.33
42BuildRequires: eudev-libudev-devel
43BuildRequires: libxcb-devel >= 1.5
44BuildRequires: xcb-util-devel
45BuildRequires: cairo-devel
46
47Requires:  hwdata
48Requires:  xorg-x11-server-Xorg
49Requires:  xcb-util
50
51Obsoletes: xorg-x11-drv-i810
52Provides: xorg-x11-drv-i810
53
54#Conflicts:  kudzu < 1.2.42-1
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60%description
61X.Org X11 Intel video driver.
62
63%package devel
64Summary:   Xorg X11 Intel video driver XvMC development package
65Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
66Group:     Development/System
67Requires:  %{name} = %{epoch}:%{version}-%{release}
68Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
69
70%description devel
71X.Org X11 Intel video driver XvMC development package.
72
73%package -n intel-gpu-tools
74Summary:    Debugging tools for Intel graphics chips
75Group:      Development/Tools
76
77%description -n intel-gpu-tools
78Debugging tools for Intel graphics chips
79
80
81%prep
82%setup -q -n xf86-video-intel-%{version} -b3
83%patch0 -p1
84
85%build
86autoreconf -vi
87
88%if "%{?_dist_release}" < "vl7"
89export CFLAGS="-I/usr/include/X11/dri"
90%endif
91
92%configure \
93  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
94  --enable-dri --enable-xvmc \
95  --enable-sna --enable-uxa \
96  --with-default-accel=%{accel} \
97  --enable-xaa=no
98make
99
100pushd ../intel-gpu-tools-%{gputoolsdate}
101autoreconf -v --install
102%configure --disable-nouveau --disable-dumper --without-libunwind
103make
104popd
105
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110make install DESTDIR=$RPM_BUILD_ROOT
111mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
112install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
113
114pushd ../intel-gpu-tools-%{gputoolsdate}
115make install DESTDIR=$RPM_BUILD_ROOT
116popd
117
118rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
119
120find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
121
122
123%clean
124rm -rf $RPM_BUILD_ROOT
125
126%triggerpostun -- XOrg < 7.0
127if (grep -q i810 /etc/X11/xorg.conf)
128then
129  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
130  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
131fi ||:
132
133%files
134%defattr(-,root,root,-)
135%{driverdir}/intel_drv.so
136%{_datadir}/hwdata/videoaliases/intel.xinf
137%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
138%{_libdir}/libI810XvMC.so.*
139%{_libdir}/libIntelXvMC.so.*
140%{_libexecdir}/xf86-video-intel-backlight-helper
141%{_mandir}/man4/i*
142
143%files devel
144%defattr(-,root,root,-)
145%{_libdir}/libI810XvMC.so
146%{_libdir}/libIntelXvMC.so
147
148%files -n intel-gpu-tools
149%defattr(-,root,root,-)
150%{_bindir}/*
151%{_libdir}/intel_aubdump.so
152%{_libexecdir}/intel-gpu-tools/
153%{_datadir}/intel-gpu-tools/
154%{_mandir}/man1/intel_*.1*
155
156
157%changelog
158* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-2
159- update Source3 (intel-gpu-tools-1.12.tar.bz2)
160- update Patch0 (xf86-video-intel-2.99.917-git20151019.patch)
161- remove Patch1 (intel-gpu-tools-1.10-git20150410.patch)
162- Source4 (intel-gpu-tools-20110817.tar.bz2)
163
164* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
165- update to 2.99.917
166- update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
167- update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
168- update Source3 (intel-gpu-tools-1.10.tar.bz2)
169
170* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
171- add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
172- update Source3 (intel-gpu-tools-1.8.tar.bz2)
173
174* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
175- update to 2.99.916
176
177* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
178- update to 2.99.912
179
180* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
181- change BuildRequires: eudev-libudev-devel instead of libudev-devel
182
183* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
184- rebuild with VineSeed environment
185
186* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
187- new upstream release
188
189* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
190- new upstream release
191- change default accel method to sna.
192
193* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
194- new upstream release
195
196* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
197- new upstream release
198
199* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
200- new upstream release
201
202* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
203- new upstream release
204
205* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
206- new upstream release
207
208* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
209- new upstream release
210
211* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
212- new upstream release
213
214* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
215- new upstream release
216
217* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
218- new upstream release
219
220* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
221- new upstream release
222
223* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
224- rebuild with xcb-util-0.3.9
225
226* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
227- disable sna, enable uxa
228
229* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
230- new upstream release
231
232* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
233- rebuild with xserver-1.12.0
234
235* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
236- new upstream release
237- enable sna
238
239* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
240- disable sna/vmap
241
242* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
243- new upstram release
244- disable copy-fb patch
245
246* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
247- rebuild with xserver-1.11.1.902
248
249* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
250- add --enable-sna --enable-vmap
251
252* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
253- new upstream release
254
255* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
256- rebuild with xcb-util-0.3.8
257- drop Patch200
258
259* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
260- update to disable copy_fb on sandybridge/ivybridge
261
262* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
263- update intel.xinf
264- add patch10 from fedora
265  - Clamp VGA pixel clock to 250MHz,
266    anything higher's going to look awful anyway. (#559426)
267
268* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
269- drop patch1-3 and replaced with new patch1 from git master
270- add Patch200 to disable DRI on SandyBridge/IvyBridge
271- update intel-gpu-tools
272
273* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
274- add Patch1-3 from upstream
275
276* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
277- new upstream release
278- drop upstream patches: 107-115
279- temporary disabled patch101
280- BR: libdrm >= 2.4.25
281
282* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
283- add Patch101-115 from ubuntu/debian package
284  - Patch101: Plymouth integration patch
285  - Patch107: Check null return from uxa_acquire_solid()
286  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
287  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
288  - Patch110,114: Cherry picks to fix a large number of build warnings.
289  - Patch111: Fix clipped window plane offset
290  - Patch112: Fix issue where vertical green line and strange colors
291              shows up when playing gstreamer with certain videos,
292              when dragged.  (LP 460677)
293  - Patch113: Fixes GPU lockup during login with
294              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
295              error messages listed in the gpu dump text. (LP 710321)
296  - Patch115: Don't fill up Xorg.0.log with
297              "get vblank counter failed: Invalid argument" warnings.
298   
299* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
300- rebuild with xserver-1.10.0
301
302* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
303- new upstream release
304
305* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
306- new upstream release
307
308* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
309- rebuild with xserver-1.9.2
310
311* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
312- new upstream release
313- add Patch40: fix uxa planemask (backported)
314- add Patch61: add support for backlight on macbooks
315- add Patch62: disable page flipping for stability
316
317* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
318- new upstream release
319- drop patch70
320
321* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
322- rebuild again with xserver-1.8rc
323
324* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
325- add intel-gpu-tools as sub-package
326- rebuild with libdrm-2.4.18
327
328* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
329- new upstream release
330- import Patch1,2,60,70 from fedora
331- add BR: kernel-headers >= 2.6.33 (new drm header required)
332- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
333- add BR; libudev-devel and autoreconf for Patch60
334
335* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
336- rebuild with libdrm-2.4.17
337
338* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
339- new upstream release
340
341* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
342- new upstream release (hopefully fixes severe issues w/ efifb)
343- drop all patches already upstreamed; import Patch20/21 from Fedora
344
345* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
346- import Patch121,122 from ubuntu
347- build with libdrm-2.4.12 which fixes vt switch crash
348
349* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
350- apply patch114 to fix Xv with non-GEM kernel
351
352* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
353- update to 2.6.3
354- add patch106,107,115,118,119,120 from ubuntu
355  - add Patch106: remove triple buffering
356  - add Patch107: remove page flipping
357  - add Patch115: fix crash Xv overlay
358  - add Patch118: drop legacy3d
359  - add Patch119: fix crashes in drm bo
360  - add Patch120: fix vt switch
361- add patch130-134 from upstream git
362  - add Patch130: fix another vt switch leak
363  - add Patch131: Create known output configuration at EnterVT time
364  - add Patch132: fix leak of some 965 render state on VT switch
365  - add Patch133: fix crash with fake bufmgr and UXA
366  - add Patch134: fix EnterVT/LeaveVT
367  - add Patch135: add new chip supoprt
368
369
370* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
371- revert to 2.6.1, add Epoch
372- add Patch103-121 from ubuntu
373
374* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
375- new upstream release
376
377* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
378- new upstream release
379
380* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
381- new upstream release
382
383* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
384- add Patch5 - Dont die on irq handler failure
385
386* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
387- new upstream release
388- add BR: libdrm-devel >= 2.4.0-3
389
390* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
391- import Patch10,11,12 from ubuntu
392
393* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
394- new upstream release
395- add triggerpostun script to replace i810 driver to intel driver
396
397* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
398- new upstream release
399
400* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
401- new upstream release
402- rename i810.xinf to intel.xinf
403- update intel.xinf (add Intel 4 series)
404
405* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
406- rebuild with new xserver
407
408* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
409- new upstream release
410
411* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
412- new upstream release
413
414* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
415- new upstream release
416
417* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
418- initial build for Vine Linux
419
420* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
421- Rebuild for new server ABI.
422- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
423
424* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
425- hook up ch7017 (bz#408471)
426
427* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
428- xf86-video-intel 2.2.0
429
430* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
431- xf86-video-intel 2.1.99.
432- Drop the i810 driver.  Time to move on.
433- Require xserver 1.4.99.1
434
435* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
436- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
437
438* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
439- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
440  for textured Xv to use as an offscreen pixmap so xv actually works under
441  compiz - granted it may be unusably slow but at least stuff shows up.
442
443* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
444- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
445- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
446
447* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
448- intel-2.1.1-quirk-update.patch - update quirks from master
449
450* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
451- i810.xinf: Flip everything over to -intel by default now.  Still install
452  i810 driver just in case.
453
454* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
455- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
456
457* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
458- xf86-video-intel 2.1.1.
459
460* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
461- xf86-video-intel 2.1.0.
462
463* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
464- Update Requires and BuildRequires.
465
466* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
467- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
468  965GME, G33, Q33, and Q35 chips.
469
470* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
471- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
472  DRI clients are active, for better battery life.
473
474* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
475- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
476
477* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
478- xf86-video-intel 2.0.0.  Change the version number to match, why not.
479- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
480  rename this at some point.
481
482* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
483- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
484  915GM.
485
486* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
487- i810.xinf: More intel whitelisting (#214011, #234877)
488
489* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
490- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
491- i810.xinf: Point 965GM support at the intel driver since it's not present
492  in old i810.
493
494* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
495- xf86-video-intel-1.9.93 (RC3).
496
497* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
498- fix typo with 945GM pci id from my laptop
499
500* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
501- xf86-video-intel 1.9.92 (RC2).
502
503* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
504- Updated modesetting driver to one that will actually work with a 1.3 server.
505
506* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
507- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
508- Remove ivch and ch7017 from the install since they aren't hooked up to the
509  code anywhere
510- Disown the module
511
512* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
513- update modesetting driver to git snapshot from today
514
515* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
516- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
517
518* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
519- rebuilt for unwind info generation, broken in gcc-4.1.1-21
520
521* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
522- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
523  actually require kudzu to run.
524
525* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
526- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
527
528* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
529- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
530- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
531  driver match the corresponding terrible heuristic in the server.
532
533* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
534- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
535  correctly distinguish between Mac Mini and Macbook Pro.
536
537* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
538- i810.xinf: PCI IDs for i965.
539
540* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
541- i810.xinf: Uppercase PCI IDs.
542
543* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
544- Update i810 to 1.6.5, should fix DRI.
545- Add kuzdu requires.
546- i810.xinf: Start whitelisting devices over to intel.
547
548* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
549- intel-driver-rename.patch: Fix the driver name in more places so it'll,
550  you know, load.
551
552* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
553- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
554  LFP special casing in favor of the blacklist.
555
556* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
557- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
558  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
559  and is selected with Driver "intel" in xorg.conf.  Individual devices will
560  whitelist over to "intel" until that branch gets merged into head.
561- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
562- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
563  the BIOS is known to lie.
564
565* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
566- Today's snapshot: I2C bus creation fix.
567
568* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
569- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
570  clock when computing the modes list.
571- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
572  in centimeters as the size of the display in pixels.
573
574* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
575- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
576  probing.
577
578* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
579- Update again for a mode comparison bugfix.
580
581* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
582- Update to today's git; crash fixes, better pre-915 support, slightly better
583  autoconfigurability.
584
585* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
586- rebuild
587
588* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
589- Fix Revision number to match naming policy.
590
591* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
592- Add back modesetting changes.
593
594* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
595- Roll back modesetting changes and build for fc5 aiglx repo.
596
597* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
598- Snapshot of the git modesetting branch.
599
600* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
601- Update i810.xinf to include entries for E7221 and 945GM.
602
603* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
604- Add with_dri macro to spec file, and conditionalize build time DRI support
605
606* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
607- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
608  to pick up proto-devel as well.
609
610* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
611- Rebuild for 7.1 ABI fix.
612
613* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
614- Bump for fc5-bling build.
615
616* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
617- Update to 1.6.0 from 7.1RC1.
618
619* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
620- Add patch to add missing #include's, specifically assert.h.
621
622* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
623- Update to CVS snapshot of 20060322.
624
625* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
626- rebuilt for new gcc4.1 snapshot and glibc changes
627
628* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
629- Added 8086:2772 mapping to i810.xinf for bug (#178451)
630
631* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
632- Added 8086:2592 mapping to i810.xinf for bug (#172884)
633
634* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
635- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
636
637* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
638- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
639- Removed 'x' suffix from manpage dirs to match RC4 upstream.
640
641* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
642- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
643
644* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
645- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
646- Fix *.la file removal.
647- Added 'devel' subpackage for XvMC .so
648- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
649
650* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
651- Update BuildRoot to use Fedora Packaging Guidelines.
652- Deglob file manifest.
653- Limit "ExclusiveArch" to x86, x86_64, ia64
654
655* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
656- Initial spec file for i810 video driver generated automatically
657  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.