source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 10229

Revision 10229, 22.8 KB checked in by Takemikaduchi, 8 years ago (diff)

xserver-1.18.3

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8#%define gputoolsdate 20130611
9%define gputoolsdate 1.14
10%else
11%define accel sna
12%define gputoolsdate 20110817
13%endif
14
15Summary:   Xorg X11 Intel video driver
16Summary(ja):   Xorg X11 Intel ビデオドライバ
17Name:      xorg-x11-drv-intel
18Epoch:     1
19Version:   2.99.917
20Release:   3%{?_dist_release}
21URL:       http://intellinuxgraphics.org/
22License:   MIT
23Group:     User Interface/X Hardware Support
24
25Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
26Source2:   intel.xinf
27Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
28
29# vine patch
30Patch0:    xf86-video-intel-2.99.917-git20160430.patch
31
32
33ExclusiveArch: %{ix86} x86_64 ia64
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35BuildRequires: autoconf, automake, libtool
36BuildRequires: xorg-x11-server-sdk >= 1.7.99
37BuildRequires: libXvMC-devel
38BuildRequires: libXfont-devel
39BuildRequires: libGL-devel >= 7.10
40BuildRequires: libdrm-devel >= 2.4.25
41BuildRequires: kernel-headers >= 2.6.33
42BuildRequires: eudev-libudev-devel
43BuildRequires: libxcb-devel >= 1.5
44BuildRequires: xcb-util-devel
45BuildRequires: cairo-devel
46
47Requires:  hwdata
48Requires:  xorg-x11-server-Xorg
49Requires:  xcb-util
50
51Obsoletes: xorg-x11-drv-i810
52Provides: xorg-x11-drv-i810
53
54#Conflicts:  kudzu < 1.2.42-1
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60%description
61X.Org X11 Intel video driver.
62
63%package devel
64Summary:   Xorg X11 Intel video driver XvMC development package
65Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
66Group:     Development/System
67Requires:  %{name} = %{epoch}:%{version}-%{release}
68Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
69
70%description devel
71X.Org X11 Intel video driver XvMC development package.
72
73%package -n intel-gpu-tools
74Summary:    Debugging tools for Intel graphics chips
75Group:      Development/Tools
76
77%description -n intel-gpu-tools
78Debugging tools for Intel graphics chips
79
80
81%prep
82%setup -q -n xf86-video-intel-%{version} -b3
83%patch0 -p1
84
85%build
86autoreconf -vi
87
88%if "%{?_dist_release}" < "vl7"
89export CFLAGS="-I/usr/include/X11/dri"
90%endif
91
92%configure \
93  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
94  --enable-dri --enable-xvmc \
95  --enable-sna --enable-uxa \
96  --with-default-accel=%{accel} \
97  --enable-xaa=no
98make
99
100pushd ../intel-gpu-tools-%{gputoolsdate}
101#autoreconf -v --install
102%configure \
103        --disable-nouveau \
104        --disable-dumper \
105        --disable-gtkdoc \
106        --without-libunwind
107make
108popd
109
110
111%install
112rm -rf $RPM_BUILD_ROOT
113
114make install DESTDIR=$RPM_BUILD_ROOT
115mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
116install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
117
118pushd ../intel-gpu-tools-%{gputoolsdate}
119make install DESTDIR=$RPM_BUILD_ROOT
120popd
121
122rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
123
124find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
125
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%triggerpostun -- XOrg < 7.0
131if (grep -q i810 /etc/X11/xorg.conf)
132then
133  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
134  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
135fi ||:
136
137%files
138%defattr(-,root,root,-)
139%{driverdir}/intel_drv.so
140%{_datadir}/hwdata/videoaliases/intel.xinf
141%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
142%{_libdir}/libI810XvMC.so.*
143%{_libdir}/libIntelXvMC.so.*
144%{_libexecdir}/xf86-video-intel-backlight-helper
145%{_mandir}/man4/i*
146
147%files devel
148%defattr(-,root,root,-)
149%{_libdir}/libI810XvMC.so
150%{_libdir}/libIntelXvMC.so
151
152%files -n intel-gpu-tools
153%defattr(-,root,root,-)
154%{_bindir}/*
155%{_libdir}/intel_aubdump.so
156%{_libexecdir}/intel-gpu-tools/
157%{_datadir}/intel-gpu-tools/
158%{_mandir}/man1/intel_*.1*
159
160
161%changelog
162* Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-3
163- update Source3 (intel-gpu-tools-1.14.tar.bz2)
164- update Patch0 (xf86-video-intel-2.99.917-git20160430.patch)
165- add BuildRequires: libXfont-devel
166
167* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-2
168- update Source3 (intel-gpu-tools-1.12.tar.bz2)
169- update Patch0 (xf86-video-intel-2.99.917-git20151019.patch)
170- remove Patch1 (intel-gpu-tools-1.10-git20150410.patch)
171- remove Source4 (intel-gpu-tools-20110817.tar.bz2)
172
173* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
174- update to 2.99.917
175- update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
176- update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
177- update Source3 (intel-gpu-tools-1.10.tar.bz2)
178
179* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
180- add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
181- update Source3 (intel-gpu-tools-1.8.tar.bz2)
182
183* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
184- update to 2.99.916
185
186* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
187- update to 2.99.912
188
189* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
190- change BuildRequires: eudev-libudev-devel instead of libudev-devel
191
192* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
193- rebuild with VineSeed environment
194
195* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
196- new upstream release
197
198* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
199- new upstream release
200- change default accel method to sna.
201
202* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
203- new upstream release
204
205* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
206- new upstream release
207
208* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
209- new upstream release
210
211* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
212- new upstream release
213
214* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
215- new upstream release
216
217* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
218- new upstream release
219
220* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
221- new upstream release
222
223* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
224- new upstream release
225
226* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
227- new upstream release
228
229* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
230- new upstream release
231
232* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
233- rebuild with xcb-util-0.3.9
234
235* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
236- disable sna, enable uxa
237
238* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
239- new upstream release
240
241* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
242- rebuild with xserver-1.12.0
243
244* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
245- new upstream release
246- enable sna
247
248* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
249- disable sna/vmap
250
251* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
252- new upstram release
253- disable copy-fb patch
254
255* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
256- rebuild with xserver-1.11.1.902
257
258* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
259- add --enable-sna --enable-vmap
260
261* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
262- new upstream release
263
264* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
265- rebuild with xcb-util-0.3.8
266- drop Patch200
267
268* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
269- update to disable copy_fb on sandybridge/ivybridge
270
271* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
272- update intel.xinf
273- add patch10 from fedora
274  - Clamp VGA pixel clock to 250MHz,
275    anything higher's going to look awful anyway. (#559426)
276
277* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
278- drop patch1-3 and replaced with new patch1 from git master
279- add Patch200 to disable DRI on SandyBridge/IvyBridge
280- update intel-gpu-tools
281
282* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
283- add Patch1-3 from upstream
284
285* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
286- new upstream release
287- drop upstream patches: 107-115
288- temporary disabled patch101
289- BR: libdrm >= 2.4.25
290
291* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
292- add Patch101-115 from ubuntu/debian package
293  - Patch101: Plymouth integration patch
294  - Patch107: Check null return from uxa_acquire_solid()
295  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
296  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
297  - Patch110,114: Cherry picks to fix a large number of build warnings.
298  - Patch111: Fix clipped window plane offset
299  - Patch112: Fix issue where vertical green line and strange colors
300              shows up when playing gstreamer with certain videos,
301              when dragged.  (LP 460677)
302  - Patch113: Fixes GPU lockup during login with
303              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
304              error messages listed in the gpu dump text. (LP 710321)
305  - Patch115: Don't fill up Xorg.0.log with
306              "get vblank counter failed: Invalid argument" warnings.
307   
308* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
309- rebuild with xserver-1.10.0
310
311* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
312- new upstream release
313
314* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
315- new upstream release
316
317* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
318- rebuild with xserver-1.9.2
319
320* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
321- new upstream release
322- add Patch40: fix uxa planemask (backported)
323- add Patch61: add support for backlight on macbooks
324- add Patch62: disable page flipping for stability
325
326* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
327- new upstream release
328- drop patch70
329
330* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
331- rebuild again with xserver-1.8rc
332
333* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
334- add intel-gpu-tools as sub-package
335- rebuild with libdrm-2.4.18
336
337* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
338- new upstream release
339- import Patch1,2,60,70 from fedora
340- add BR: kernel-headers >= 2.6.33 (new drm header required)
341- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
342- add BR; libudev-devel and autoreconf for Patch60
343
344* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
345- rebuild with libdrm-2.4.17
346
347* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
348- new upstream release
349
350* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
351- new upstream release (hopefully fixes severe issues w/ efifb)
352- drop all patches already upstreamed; import Patch20/21 from Fedora
353
354* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
355- import Patch121,122 from ubuntu
356- build with libdrm-2.4.12 which fixes vt switch crash
357
358* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
359- apply patch114 to fix Xv with non-GEM kernel
360
361* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
362- update to 2.6.3
363- add patch106,107,115,118,119,120 from ubuntu
364  - add Patch106: remove triple buffering
365  - add Patch107: remove page flipping
366  - add Patch115: fix crash Xv overlay
367  - add Patch118: drop legacy3d
368  - add Patch119: fix crashes in drm bo
369  - add Patch120: fix vt switch
370- add patch130-134 from upstream git
371  - add Patch130: fix another vt switch leak
372  - add Patch131: Create known output configuration at EnterVT time
373  - add Patch132: fix leak of some 965 render state on VT switch
374  - add Patch133: fix crash with fake bufmgr and UXA
375  - add Patch134: fix EnterVT/LeaveVT
376  - add Patch135: add new chip supoprt
377
378
379* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
380- revert to 2.6.1, add Epoch
381- add Patch103-121 from ubuntu
382
383* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
384- new upstream release
385
386* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
387- new upstream release
388
389* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
390- new upstream release
391
392* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
393- add Patch5 - Dont die on irq handler failure
394
395* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
396- new upstream release
397- add BR: libdrm-devel >= 2.4.0-3
398
399* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
400- import Patch10,11,12 from ubuntu
401
402* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
403- new upstream release
404- add triggerpostun script to replace i810 driver to intel driver
405
406* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
407- new upstream release
408
409* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
410- new upstream release
411- rename i810.xinf to intel.xinf
412- update intel.xinf (add Intel 4 series)
413
414* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
415- rebuild with new xserver
416
417* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
418- new upstream release
419
420* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
421- new upstream release
422
423* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
424- new upstream release
425
426* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
427- initial build for Vine Linux
428
429* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
430- Rebuild for new server ABI.
431- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
432
433* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
434- hook up ch7017 (bz#408471)
435
436* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
437- xf86-video-intel 2.2.0
438
439* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
440- xf86-video-intel 2.1.99.
441- Drop the i810 driver.  Time to move on.
442- Require xserver 1.4.99.1
443
444* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
445- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
446
447* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
448- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
449  for textured Xv to use as an offscreen pixmap so xv actually works under
450  compiz - granted it may be unusably slow but at least stuff shows up.
451
452* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
453- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
454- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
455
456* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
457- intel-2.1.1-quirk-update.patch - update quirks from master
458
459* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
460- i810.xinf: Flip everything over to -intel by default now.  Still install
461  i810 driver just in case.
462
463* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
464- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
465
466* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
467- xf86-video-intel 2.1.1.
468
469* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
470- xf86-video-intel 2.1.0.
471
472* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
473- Update Requires and BuildRequires.
474
475* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
476- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
477  965GME, G33, Q33, and Q35 chips.
478
479* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
480- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
481  DRI clients are active, for better battery life.
482
483* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
484- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
485
486* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
487- xf86-video-intel 2.0.0.  Change the version number to match, why not.
488- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
489  rename this at some point.
490
491* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
492- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
493  915GM.
494
495* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
496- i810.xinf: More intel whitelisting (#214011, #234877)
497
498* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
499- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
500- i810.xinf: Point 965GM support at the intel driver since it's not present
501  in old i810.
502
503* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
504- xf86-video-intel-1.9.93 (RC3).
505
506* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
507- fix typo with 945GM pci id from my laptop
508
509* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
510- xf86-video-intel 1.9.92 (RC2).
511
512* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
513- Updated modesetting driver to one that will actually work with a 1.3 server.
514
515* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
516- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
517- Remove ivch and ch7017 from the install since they aren't hooked up to the
518  code anywhere
519- Disown the module
520
521* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
522- update modesetting driver to git snapshot from today
523
524* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
525- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
526
527* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
528- rebuilt for unwind info generation, broken in gcc-4.1.1-21
529
530* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
531- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
532  actually require kudzu to run.
533
534* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
535- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
536
537* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
538- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
539- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
540  driver match the corresponding terrible heuristic in the server.
541
542* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
543- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
544  correctly distinguish between Mac Mini and Macbook Pro.
545
546* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
547- i810.xinf: PCI IDs for i965.
548
549* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
550- i810.xinf: Uppercase PCI IDs.
551
552* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
553- Update i810 to 1.6.5, should fix DRI.
554- Add kuzdu requires.
555- i810.xinf: Start whitelisting devices over to intel.
556
557* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
558- intel-driver-rename.patch: Fix the driver name in more places so it'll,
559  you know, load.
560
561* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
562- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
563  LFP special casing in favor of the blacklist.
564
565* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
566- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
567  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
568  and is selected with Driver "intel" in xorg.conf.  Individual devices will
569  whitelist over to "intel" until that branch gets merged into head.
570- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
571- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
572  the BIOS is known to lie.
573
574* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
575- Today's snapshot: I2C bus creation fix.
576
577* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
578- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
579  clock when computing the modes list.
580- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
581  in centimeters as the size of the display in pixels.
582
583* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
584- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
585  probing.
586
587* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
588- Update again for a mode comparison bugfix.
589
590* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
591- Update to today's git; crash fixes, better pre-915 support, slightly better
592  autoconfigurability.
593
594* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
595- rebuild
596
597* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
598- Fix Revision number to match naming policy.
599
600* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
601- Add back modesetting changes.
602
603* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
604- Roll back modesetting changes and build for fc5 aiglx repo.
605
606* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
607- Snapshot of the git modesetting branch.
608
609* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
610- Update i810.xinf to include entries for E7221 and 945GM.
611
612* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
613- Add with_dri macro to spec file, and conditionalize build time DRI support
614
615* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
616- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
617  to pick up proto-devel as well.
618
619* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
620- Rebuild for 7.1 ABI fix.
621
622* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
623- Bump for fc5-bling build.
624
625* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
626- Update to 1.6.0 from 7.1RC1.
627
628* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
629- Add patch to add missing #include's, specifically assert.h.
630
631* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
632- Update to CVS snapshot of 20060322.
633
634* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
635- rebuilt for new gcc4.1 snapshot and glibc changes
636
637* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
638- Added 8086:2772 mapping to i810.xinf for bug (#178451)
639
640* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
641- Added 8086:2592 mapping to i810.xinf for bug (#172884)
642
643* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
644- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
645
646* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
647- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
648- Removed 'x' suffix from manpage dirs to match RC4 upstream.
649
650* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
651- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
652
653* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
654- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
655- Fix *.la file removal.
656- Added 'devel' subpackage for XvMC .so
657- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
658
659* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
660- Update BuildRoot to use Fedora Packaging Guidelines.
661- Deglob file manifest.
662- Limit "ExclusiveArch" to x86, x86_64, ia64
663
664* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
665- Initial spec file for i810 video driver generated automatically
666  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.