source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 9501

Revision 9501, 22.4 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8#%define gputoolsdate 20130611
9%define gputoolsdate 1.10
10%else
11%define accel sna
12%define gputoolsdate 20110817
13%endif
14
15Summary:   Xorg X11 Intel video driver
16Summary(ja):   Xorg X11 Intel ビデオドライバ
17Name:      xorg-x11-drv-intel
18Epoch:     1
19Version:   2.99.917
20Release:   1%{?_dist_release}
21URL:       http://intellinuxgraphics.org/
22License:   MIT
23Group:     User Interface/X Hardware Support
24
25Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
26Source2:   intel.xinf
27#Source3:   intel-gpu-tools-%{gputoolsdate1}.tar.bz2
28Source3:   intel-gpu-tools-1.10.tar.bz2
29Source4:   intel-gpu-tools-%{gputoolsdate2}.tar.bz2
30
31# vine patch
32Patch0:    xf86-video-intel-2.99.917-git20150409.patch
33Patch1:    intel-gpu-tools-1.10-git20150410.patch
34
35
36ExclusiveArch: %{ix86} x86_64 ia64
37BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
38BuildRequires: autoconf, automake, libtool
39BuildRequires: xorg-x11-server-sdk >= 1.7.99
40BuildRequires: libXvMC-devel
41BuildRequires: libGL-devel >= 7.10
42BuildRequires: libdrm-devel >= 2.4.25
43BuildRequires: kernel-headers >= 2.6.33
44BuildRequires: eudev-libudev-devel
45BuildRequires: libxcb-devel >= 1.5
46BuildRequires: xcb-util-devel
47BuildRequires: cairo-devel
48
49Requires:  hwdata
50Requires:  xorg-x11-server-Xorg
51Requires:  xcb-util
52
53Obsoletes: xorg-x11-drv-i810
54Provides: xorg-x11-drv-i810
55
56#Conflicts:  kudzu < 1.2.42-1
57
58Vendor: Project Vine
59Distribution: Vine Linux
60Packager: daisuke
61
62%description
63X.Org X11 Intel video driver.
64
65%package devel
66Summary:   Xorg X11 Intel video driver XvMC development package
67Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
68Group:     Development/System
69Requires:  %{name} = %{epoch}:%{version}-%{release}
70Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
71
72%description devel
73X.Org X11 Intel video driver XvMC development package.
74
75%package -n intel-gpu-tools
76Summary:    Debugging tools for Intel graphics chips
77Group:      Development/Tools
78
79%description -n intel-gpu-tools
80Debugging tools for Intel graphics chips
81
82
83%prep
84%setup -q -n xf86-video-intel-%{version} -b3 -b4
85%patch0 -p1
86pushd ../intel-gpu-tools-%{gputoolsdate}
87%patch1 -p1
88popd
89
90%build
91autoreconf -vi
92
93%if "%{?_dist_release}" < "vl7"
94export CFLAGS="-I/usr/include/X11/dri"
95%endif
96
97%configure \
98  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
99  --enable-dri --enable-xvmc \
100  --enable-sna --enable-uxa \
101  --with-default-accel=%{accel} \
102  --enable-xaa=no
103make
104
105pushd ../intel-gpu-tools-%{gputoolsdate}
106autoreconf -v --install
107%configure --disable-nouveau --disable-dumper --without-libunwind
108make
109popd
110
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115make install DESTDIR=$RPM_BUILD_ROOT
116mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
117install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
118
119pushd ../intel-gpu-tools-%{gputoolsdate}
120make install DESTDIR=$RPM_BUILD_ROOT
121popd
122
123rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
124
125find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
126
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%triggerpostun -- XOrg < 7.0
132if (grep -q i810 /etc/X11/xorg.conf)
133then
134  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
135  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
136fi ||:
137
138%files
139%defattr(-,root,root,-)
140%{driverdir}/intel_drv.so
141%{_datadir}/hwdata/videoaliases/intel.xinf
142%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
143%{_libdir}/libI810XvMC.so.*
144%{_libdir}/libIntelXvMC.so.*
145%{_libexecdir}/xf86-video-intel-backlight-helper
146%{_mandir}/man4/i*
147
148%files devel
149%defattr(-,root,root,-)
150%{_libdir}/libI810XvMC.so
151%{_libdir}/libIntelXvMC.so
152
153%files -n intel-gpu-tools
154%defattr(-,root,root,-)
155%{_bindir}/*
156%{_mandir}/man1/intel_*.1*
157
158
159%changelog
160* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
161- update to 2.99.917
162- update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
163- update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
164- update Source3 (intel-gpu-tools-1.10.tar.bz2)
165
166* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
167- add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
168- update Source3 (intel-gpu-tools-1.8.tar.bz2)
169
170* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
171- update to 2.99.916
172
173* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
174- update to 2.99.912
175
176* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
177- change BuildRequires: eudev-libudev-devel instead of libudev-devel
178
179* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
180- rebuild with VineSeed environment
181
182* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
183- new upstream release
184
185* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
186- new upstream release
187- change default accel method to sna.
188
189* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
190- new upstream release
191
192* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
193- new upstream release
194
195* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
196- new upstream release
197
198* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
199- new upstream release
200
201* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
202- new upstream release
203
204* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
205- new upstream release
206
207* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
208- new upstream release
209
210* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
211- new upstream release
212
213* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
214- new upstream release
215
216* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
217- new upstream release
218
219* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
220- rebuild with xcb-util-0.3.9
221
222* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
223- disable sna, enable uxa
224
225* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
226- new upstream release
227
228* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
229- rebuild with xserver-1.12.0
230
231* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
232- new upstream release
233- enable sna
234
235* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
236- disable sna/vmap
237
238* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
239- new upstram release
240- disable copy-fb patch
241
242* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
243- rebuild with xserver-1.11.1.902
244
245* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
246- add --enable-sna --enable-vmap
247
248* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
249- new upstream release
250
251* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
252- rebuild with xcb-util-0.3.8
253- drop Patch200
254
255* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
256- update to disable copy_fb on sandybridge/ivybridge
257
258* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
259- update intel.xinf
260- add patch10 from fedora
261  - Clamp VGA pixel clock to 250MHz,
262    anything higher's going to look awful anyway. (#559426)
263
264* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
265- drop patch1-3 and replaced with new patch1 from git master
266- add Patch200 to disable DRI on SandyBridge/IvyBridge
267- update intel-gpu-tools
268
269* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
270- add Patch1-3 from upstream
271
272* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
273- new upstream release
274- drop upstream patches: 107-115
275- temporary disabled patch101
276- BR: libdrm >= 2.4.25
277
278* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
279- add Patch101-115 from ubuntu/debian package
280  - Patch101: Plymouth integration patch
281  - Patch107: Check null return from uxa_acquire_solid()
282  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
283  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
284  - Patch110,114: Cherry picks to fix a large number of build warnings.
285  - Patch111: Fix clipped window plane offset
286  - Patch112: Fix issue where vertical green line and strange colors
287              shows up when playing gstreamer with certain videos,
288              when dragged.  (LP 460677)
289  - Patch113: Fixes GPU lockup during login with
290              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
291              error messages listed in the gpu dump text. (LP 710321)
292  - Patch115: Don't fill up Xorg.0.log with
293              "get vblank counter failed: Invalid argument" warnings.
294   
295* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
296- rebuild with xserver-1.10.0
297
298* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
299- new upstream release
300
301* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
302- new upstream release
303
304* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
305- rebuild with xserver-1.9.2
306
307* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
308- new upstream release
309- add Patch40: fix uxa planemask (backported)
310- add Patch61: add support for backlight on macbooks
311- add Patch62: disable page flipping for stability
312
313* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
314- new upstream release
315- drop patch70
316
317* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
318- rebuild again with xserver-1.8rc
319
320* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
321- add intel-gpu-tools as sub-package
322- rebuild with libdrm-2.4.18
323
324* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
325- new upstream release
326- import Patch1,2,60,70 from fedora
327- add BR: kernel-headers >= 2.6.33 (new drm header required)
328- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
329- add BR; libudev-devel and autoreconf for Patch60
330
331* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
332- rebuild with libdrm-2.4.17
333
334* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
335- new upstream release
336
337* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
338- new upstream release (hopefully fixes severe issues w/ efifb)
339- drop all patches already upstreamed; import Patch20/21 from Fedora
340
341* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
342- import Patch121,122 from ubuntu
343- build with libdrm-2.4.12 which fixes vt switch crash
344
345* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
346- apply patch114 to fix Xv with non-GEM kernel
347
348* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
349- update to 2.6.3
350- add patch106,107,115,118,119,120 from ubuntu
351  - add Patch106: remove triple buffering
352  - add Patch107: remove page flipping
353  - add Patch115: fix crash Xv overlay
354  - add Patch118: drop legacy3d
355  - add Patch119: fix crashes in drm bo
356  - add Patch120: fix vt switch
357- add patch130-134 from upstream git
358  - add Patch130: fix another vt switch leak
359  - add Patch131: Create known output configuration at EnterVT time
360  - add Patch132: fix leak of some 965 render state on VT switch
361  - add Patch133: fix crash with fake bufmgr and UXA
362  - add Patch134: fix EnterVT/LeaveVT
363  - add Patch135: add new chip supoprt
364
365
366* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
367- revert to 2.6.1, add Epoch
368- add Patch103-121 from ubuntu
369
370* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
371- new upstream release
372
373* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
374- new upstream release
375
376* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
377- new upstream release
378
379* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
380- add Patch5 - Dont die on irq handler failure
381
382* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
383- new upstream release
384- add BR: libdrm-devel >= 2.4.0-3
385
386* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
387- import Patch10,11,12 from ubuntu
388
389* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
390- new upstream release
391- add triggerpostun script to replace i810 driver to intel driver
392
393* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
394- new upstream release
395
396* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
397- new upstream release
398- rename i810.xinf to intel.xinf
399- update intel.xinf (add Intel 4 series)
400
401* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
402- rebuild with new xserver
403
404* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
405- new upstream release
406
407* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
408- new upstream release
409
410* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
411- new upstream release
412
413* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
414- initial build for Vine Linux
415
416* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
417- Rebuild for new server ABI.
418- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
419
420* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
421- hook up ch7017 (bz#408471)
422
423* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
424- xf86-video-intel 2.2.0
425
426* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
427- xf86-video-intel 2.1.99.
428- Drop the i810 driver.  Time to move on.
429- Require xserver 1.4.99.1
430
431* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
432- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
433
434* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
435- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
436  for textured Xv to use as an offscreen pixmap so xv actually works under
437  compiz - granted it may be unusably slow but at least stuff shows up.
438
439* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
440- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
441- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
442
443* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
444- intel-2.1.1-quirk-update.patch - update quirks from master
445
446* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
447- i810.xinf: Flip everything over to -intel by default now.  Still install
448  i810 driver just in case.
449
450* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
451- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
452
453* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
454- xf86-video-intel 2.1.1.
455
456* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
457- xf86-video-intel 2.1.0.
458
459* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
460- Update Requires and BuildRequires.
461
462* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
463- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
464  965GME, G33, Q33, and Q35 chips.
465
466* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
467- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
468  DRI clients are active, for better battery life.
469
470* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
471- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
472
473* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
474- xf86-video-intel 2.0.0.  Change the version number to match, why not.
475- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
476  rename this at some point.
477
478* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
479- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
480  915GM.
481
482* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
483- i810.xinf: More intel whitelisting (#214011, #234877)
484
485* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
486- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
487- i810.xinf: Point 965GM support at the intel driver since it's not present
488  in old i810.
489
490* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
491- xf86-video-intel-1.9.93 (RC3).
492
493* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
494- fix typo with 945GM pci id from my laptop
495
496* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
497- xf86-video-intel 1.9.92 (RC2).
498
499* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
500- Updated modesetting driver to one that will actually work with a 1.3 server.
501
502* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
503- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
504- Remove ivch and ch7017 from the install since they aren't hooked up to the
505  code anywhere
506- Disown the module
507
508* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
509- update modesetting driver to git snapshot from today
510
511* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
512- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
513
514* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
515- rebuilt for unwind info generation, broken in gcc-4.1.1-21
516
517* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
518- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
519  actually require kudzu to run.
520
521* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
522- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
523
524* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
525- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
526- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
527  driver match the corresponding terrible heuristic in the server.
528
529* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
530- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
531  correctly distinguish between Mac Mini and Macbook Pro.
532
533* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
534- i810.xinf: PCI IDs for i965.
535
536* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
537- i810.xinf: Uppercase PCI IDs.
538
539* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
540- Update i810 to 1.6.5, should fix DRI.
541- Add kuzdu requires.
542- i810.xinf: Start whitelisting devices over to intel.
543
544* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
545- intel-driver-rename.patch: Fix the driver name in more places so it'll,
546  you know, load.
547
548* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
549- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
550  LFP special casing in favor of the blacklist.
551
552* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
553- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
554  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
555  and is selected with Driver "intel" in xorg.conf.  Individual devices will
556  whitelist over to "intel" until that branch gets merged into head.
557- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
558- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
559  the BIOS is known to lie.
560
561* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
562- Today's snapshot: I2C bus creation fix.
563
564* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
565- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
566  clock when computing the modes list.
567- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
568  in centimeters as the size of the display in pixels.
569
570* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
571- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
572  probing.
573
574* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
575- Update again for a mode comparison bugfix.
576
577* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
578- Update to today's git; crash fixes, better pre-915 support, slightly better
579  autoconfigurability.
580
581* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
582- rebuild
583
584* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
585- Fix Revision number to match naming policy.
586
587* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
588- Add back modesetting changes.
589
590* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
591- Roll back modesetting changes and build for fc5 aiglx repo.
592
593* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
594- Snapshot of the git modesetting branch.
595
596* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
597- Update i810.xinf to include entries for E7221 and 945GM.
598
599* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
600- Add with_dri macro to spec file, and conditionalize build time DRI support
601
602* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
603- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
604  to pick up proto-devel as well.
605
606* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
607- Rebuild for 7.1 ABI fix.
608
609* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
610- Bump for fc5-bling build.
611
612* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
613- Update to 1.6.0 from 7.1RC1.
614
615* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
616- Add patch to add missing #include's, specifically assert.h.
617
618* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
619- Update to CVS snapshot of 20060322.
620
621* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
622- rebuilt for new gcc4.1 snapshot and glibc changes
623
624* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
625- Added 8086:2772 mapping to i810.xinf for bug (#178451)
626
627* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
628- Added 8086:2592 mapping to i810.xinf for bug (#172884)
629
630* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
631- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
632
633* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
634- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
635- Removed 'x' suffix from manpage dirs to match RC4 upstream.
636
637* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
638- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
639
640* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
641- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
642- Fix *.la file removal.
643- Added 'devel' subpackage for XvMC .so
644- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
645
646* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
647- Update BuildRoot to use Fedora Packaging Guidelines.
648- Deglob file manifest.
649- Limit "ExclusiveArch" to x86, x86_64, ia64
650
651* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
652- Initial spec file for i810 video driver generated automatically
653  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.