source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6274

Revision 6274, 19.8 KB checked in by Takemikaduchi, 12 years ago (diff)

startup-notification,xorg-x11-drv-intel: rebuild with xcb-util-0.3.9
others: new upstream release

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.19.0
10Release:   3%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79#%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc \
87  --enable-uxa
88make
89
90pushd ../intel-gpu-tools-%{gputoolsdate}
91autoreconf -v --install
92%configure
93make
94popd
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
102install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
103
104pushd ../intel-gpu-tools-%{gputoolsdate}
105make install DESTDIR=$RPM_BUILD_ROOT
106popd
107
108
109find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%triggerpostun -- XOrg < 7.0
115if (grep -q i810 /etc/X11/xorg.conf)
116then
117  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
118  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
119fi ||:
120
121%files
122%defattr(-,root,root,-)
123%{driverdir}/intel_drv.so
124%{_datadir}/hwdata/videoaliases/intel.xinf
125%{_libdir}/libI810XvMC.so.*
126%{_libdir}/libIntelXvMC.so.*
127%{_mandir}/man4/i*
128
129%files devel
130%defattr(-,root,root,-)
131%{_libdir}/libI810XvMC.so
132%{_libdir}/libIntelXvMC.so
133
134%files -n intel-gpu-tools
135%defattr(-,root,root,-)
136%{_bindir}/intel_*
137%{_mandir}/man1/intel_*.1*
138
139
140%changelog
141* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
142- rebuild with xcb-util-0.3.9
143
144* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
145- disable sna, enable uxa
146
147* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
148- new upstream release
149
150* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
151- rebuild with xserver-1.12.0
152
153* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
154- new upstream release
155- enable sna
156
157* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
158- disable sna/vmap
159
160* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
161- new upstram release
162- disable copy-fb patch
163
164* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
165- rebuild with xserver-1.11.1.902
166
167* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
168- add --enable-sna --enable-vmap
169
170* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
171- new upstream release
172
173* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
174- rebuild with xcb-util-0.3.8
175- drop Patch200
176
177* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
178- update to disable copy_fb on sandybridge/ivybridge
179
180* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
181- update intel.xinf
182- add patch10 from fedora
183  - Clamp VGA pixel clock to 250MHz,
184    anything higher's going to look awful anyway. (#559426)
185
186* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
187- drop patch1-3 and replaced with new patch1 from git master
188- add Patch200 to disable DRI on SandyBridge/IvyBridge
189- update intel-gpu-tools
190
191* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
192- add Patch1-3 from upstream
193
194* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
195- new upstream release
196- drop upstream patches: 107-115
197- temporary disabled patch101
198- BR: libdrm >= 2.4.25
199
200* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
201- add Patch101-115 from ubuntu/debian package
202  - Patch101: Plymouth integration patch
203  - Patch107: Check null return from uxa_acquire_solid()
204  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
205  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
206  - Patch110,114: Cherry picks to fix a large number of build warnings.
207  - Patch111: Fix clipped window plane offset
208  - Patch112: Fix issue where vertical green line and strange colors
209              shows up when playing gstreamer with certain videos,
210              when dragged.  (LP 460677)
211  - Patch113: Fixes GPU lockup during login with
212              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
213              error messages listed in the gpu dump text. (LP 710321)
214  - Patch115: Don't fill up Xorg.0.log with
215              "get vblank counter failed: Invalid argument" warnings.
216   
217* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
218- rebuild with xserver-1.10.0
219
220* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
221- new upstream release
222
223* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
224- new upstream release
225
226* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
227- rebuild with xserver-1.9.2
228
229* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
230- new upstream release
231- add Patch40: fix uxa planemask (backported)
232- add Patch61: add support for backlight on macbooks
233- add Patch62: disable page flipping for stability
234
235* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
236- new upstream release
237- drop patch70
238
239* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
240- rebuild again with xserver-1.8rc
241
242* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
243- add intel-gpu-tools as sub-package
244- rebuild with libdrm-2.4.18
245
246* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
247- new upstream release
248- import Patch1,2,60,70 from fedora
249- add BR: kernel-headers >= 2.6.33 (new drm header required)
250- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
251- add BR; libudev-devel and autoreconf for Patch60
252
253* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
254- rebuild with libdrm-2.4.17
255
256* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
257- new upstream release
258
259* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
260- new upstream release (hopefully fixes severe issues w/ efifb)
261- drop all patches already upstreamed; import Patch20/21 from Fedora
262
263* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
264- import Patch121,122 from ubuntu
265- build with libdrm-2.4.12 which fixes vt switch crash
266
267* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
268- apply patch114 to fix Xv with non-GEM kernel
269
270* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
271- update to 2.6.3
272- add patch106,107,115,118,119,120 from ubuntu
273  - add Patch106: remove triple buffering
274  - add Patch107: remove page flipping
275  - add Patch115: fix crash Xv overlay
276  - add Patch118: drop legacy3d
277  - add Patch119: fix crashes in drm bo
278  - add Patch120: fix vt switch
279- add patch130-134 from upstream git
280  - add Patch130: fix another vt switch leak
281  - add Patch131: Create known output configuration at EnterVT time
282  - add Patch132: fix leak of some 965 render state on VT switch
283  - add Patch133: fix crash with fake bufmgr and UXA
284  - add Patch134: fix EnterVT/LeaveVT
285  - add Patch135: add new chip supoprt
286
287
288* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
289- revert to 2.6.1, add Epoch
290- add Patch103-121 from ubuntu
291
292* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
293- new upstream release
294
295* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
296- new upstream release
297
298* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
299- new upstream release
300
301* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
302- add Patch5 - Dont die on irq handler failure
303
304* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
305- new upstream release
306- add BR: libdrm-devel >= 2.4.0-3
307
308* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
309- import Patch10,11,12 from ubuntu
310
311* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
312- new upstream release
313- add triggerpostun script to replace i810 driver to intel driver
314
315* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
316- new upstream release
317
318* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
319- new upstream release
320- rename i810.xinf to intel.xinf
321- update intel.xinf (add Intel 4 series)
322
323* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
324- rebuild with new xserver
325
326* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
327- new upstream release
328
329* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
330- new upstream release
331
332* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
333- new upstream release
334
335* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
336- initial build for Vine Linux
337
338* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
339- Rebuild for new server ABI.
340- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
341
342* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
343- hook up ch7017 (bz#408471)
344
345* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
346- xf86-video-intel 2.2.0
347
348* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
349- xf86-video-intel 2.1.99.
350- Drop the i810 driver.  Time to move on.
351- Require xserver 1.4.99.1
352
353* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
354- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
355
356* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
357- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
358  for textured Xv to use as an offscreen pixmap so xv actually works under
359  compiz - granted it may be unusably slow but at least stuff shows up.
360
361* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
362- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
363- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
364
365* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
366- intel-2.1.1-quirk-update.patch - update quirks from master
367
368* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
369- i810.xinf: Flip everything over to -intel by default now.  Still install
370  i810 driver just in case.
371
372* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
373- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
374
375* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
376- xf86-video-intel 2.1.1.
377
378* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
379- xf86-video-intel 2.1.0.
380
381* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
382- Update Requires and BuildRequires.
383
384* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
385- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
386  965GME, G33, Q33, and Q35 chips.
387
388* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
389- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
390  DRI clients are active, for better battery life.
391
392* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
393- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
394
395* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
396- xf86-video-intel 2.0.0.  Change the version number to match, why not.
397- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
398  rename this at some point.
399
400* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
401- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
402  915GM.
403
404* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
405- i810.xinf: More intel whitelisting (#214011, #234877)
406
407* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
408- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
409- i810.xinf: Point 965GM support at the intel driver since it's not present
410  in old i810.
411
412* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
413- xf86-video-intel-1.9.93 (RC3).
414
415* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
416- fix typo with 945GM pci id from my laptop
417
418* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
419- xf86-video-intel 1.9.92 (RC2).
420
421* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
422- Updated modesetting driver to one that will actually work with a 1.3 server.
423
424* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
425- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
426- Remove ivch and ch7017 from the install since they aren't hooked up to the
427  code anywhere
428- Disown the module
429
430* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
431- update modesetting driver to git snapshot from today
432
433* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
434- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
435
436* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
437- rebuilt for unwind info generation, broken in gcc-4.1.1-21
438
439* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
440- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
441  actually require kudzu to run.
442
443* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
444- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
445
446* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
447- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
448- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
449  driver match the corresponding terrible heuristic in the server.
450
451* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
452- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
453  correctly distinguish between Mac Mini and Macbook Pro.
454
455* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
456- i810.xinf: PCI IDs for i965.
457
458* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
459- i810.xinf: Uppercase PCI IDs.
460
461* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
462- Update i810 to 1.6.5, should fix DRI.
463- Add kuzdu requires.
464- i810.xinf: Start whitelisting devices over to intel.
465
466* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
467- intel-driver-rename.patch: Fix the driver name in more places so it'll,
468  you know, load.
469
470* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
471- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
472  LFP special casing in favor of the blacklist.
473
474* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
475- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
476  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
477  and is selected with Driver "intel" in xorg.conf.  Individual devices will
478  whitelist over to "intel" until that branch gets merged into head.
479- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
480- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
481  the BIOS is known to lie.
482
483* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
484- Today's snapshot: I2C bus creation fix.
485
486* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
487- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
488  clock when computing the modes list.
489- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
490  in centimeters as the size of the display in pixels.
491
492* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
493- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
494  probing.
495
496* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
497- Update again for a mode comparison bugfix.
498
499* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
500- Update to today's git; crash fixes, better pre-915 support, slightly better
501  autoconfigurability.
502
503* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
504- rebuild
505
506* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
507- Fix Revision number to match naming policy.
508
509* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
510- Add back modesetting changes.
511
512* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
513- Roll back modesetting changes and build for fc5 aiglx repo.
514
515* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
516- Snapshot of the git modesetting branch.
517
518* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
519- Update i810.xinf to include entries for E7221 and 945GM.
520
521* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
522- Add with_dri macro to spec file, and conditionalize build time DRI support
523
524* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
525- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
526  to pick up proto-devel as well.
527
528* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
529- Rebuild for 7.1 ABI fix.
530
531* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
532- Bump for fc5-bling build.
533
534* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
535- Update to 1.6.0 from 7.1RC1.
536
537* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
538- Add patch to add missing #include's, specifically assert.h.
539
540* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
541- Update to CVS snapshot of 20060322.
542
543* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
544- rebuilt for new gcc4.1 snapshot and glibc changes
545
546* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
547- Added 8086:2772 mapping to i810.xinf for bug (#178451)
548
549* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
550- Added 8086:2592 mapping to i810.xinf for bug (#172884)
551
552* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
553- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
554
555* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
556- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
557- Removed 'x' suffix from manpage dirs to match RC4 upstream.
558
559* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
560- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
561
562* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
563- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
564- Fix *.la file removal.
565- Added 'devel' subpackage for XvMC .so
566- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
567
568* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
569- Update BuildRoot to use Fedora Packaging Guidelines.
570- Deglob file manifest.
571- Limit "ExclusiveArch" to x86, x86_64, ia64
572
573* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
574- Initial spec file for i810 video driver generated automatically
575  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.