source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6640

Revision 6640, 19.9 KB checked in by daisuke, 12 years ago (diff)

update to 2.20.2

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.20.2
10Release:   1%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# vine patch
24
25
26ExclusiveArch: %{ix86} x86_64 ia64
27BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
28BuildRequires: autoconf, automake, libtool
29BuildRequires: xorg-x11-server-sdk >= 1.7.99
30BuildRequires: libXvMC-devel
31BuildRequires: libGL-devel >= 7.10
32BuildRequires: libdrm-devel >= 2.4.25
33BuildRequires: kernel-headers >= 2.6.33
34BuildRequires: libudev-devel
35BuildRequires: libxcb-devel >= 1.5
36BuildRequires: xcb-util-devel
37
38Requires:  hwdata
39Requires:  xorg-x11-server-Xorg
40Requires:  xcb-util
41
42Obsoletes: xorg-x11-drv-i810
43Provides: xorg-x11-drv-i810
44
45#Conflicts:  kudzu < 1.2.42-1
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51X.Org X11 Intel video driver.
52
53%package devel
54Summary:   Xorg X11 Intel video driver XvMC development package
55Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
56Group:     Development/System
57Requires:  %{name} = %{epoch}:%{version}-%{release}
58Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
59
60%description devel
61X.Org X11 Intel video driver XvMC development package.
62
63%package -n intel-gpu-tools
64Summary:    Debugging tools for Intel graphics chips
65Group:      Development/Tools
66
67%description -n intel-gpu-tools
68Debugging tools for Intel graphics chips
69
70
71%prep
72%setup -q -n xf86-video-intel-%{version} -b3
73
74%patch10 -p1 -b .vga-clock
75
76%build
77autoreconf -vi
78
79%configure \
80  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
81  --enable-dri --enable-xvmc \
82  --enable-uxa
83make
84
85pushd ../intel-gpu-tools-%{gputoolsdate}
86autoreconf -v --install
87%configure
88make
89popd
90
91
92%install
93rm -rf $RPM_BUILD_ROOT
94
95make install DESTDIR=$RPM_BUILD_ROOT
96mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
97install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
98
99pushd ../intel-gpu-tools-%{gputoolsdate}
100make install DESTDIR=$RPM_BUILD_ROOT
101popd
102
103
104find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
105
106%clean
107rm -rf $RPM_BUILD_ROOT
108
109%triggerpostun -- XOrg < 7.0
110if (grep -q i810 /etc/X11/xorg.conf)
111then
112  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
113  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
114fi ||:
115
116%files
117%defattr(-,root,root,-)
118%{driverdir}/intel_drv.so
119%{_datadir}/hwdata/videoaliases/intel.xinf
120%{_libdir}/libI810XvMC.so.*
121%{_libdir}/libIntelXvMC.so.*
122%{_mandir}/man4/i*
123
124%files devel
125%defattr(-,root,root,-)
126%{_libdir}/libI810XvMC.so
127%{_libdir}/libIntelXvMC.so
128
129%files -n intel-gpu-tools
130%defattr(-,root,root,-)
131%{_bindir}/intel_*
132%{_mandir}/man1/intel_*.1*
133
134
135%changelog
136* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-2
137- new upstream release
138
139* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
140- new upstream release
141
142* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
143- rebuild with xcb-util-0.3.9
144
145* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
146- disable sna, enable uxa
147
148* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
149- new upstream release
150
151* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
152- rebuild with xserver-1.12.0
153
154* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
155- new upstream release
156- enable sna
157
158* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
159- disable sna/vmap
160
161* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
162- new upstram release
163- disable copy-fb patch
164
165* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
166- rebuild with xserver-1.11.1.902
167
168* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
169- add --enable-sna --enable-vmap
170
171* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
172- new upstream release
173
174* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
175- rebuild with xcb-util-0.3.8
176- drop Patch200
177
178* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
179- update to disable copy_fb on sandybridge/ivybridge
180
181* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
182- update intel.xinf
183- add patch10 from fedora
184  - Clamp VGA pixel clock to 250MHz,
185    anything higher's going to look awful anyway. (#559426)
186
187* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
188- drop patch1-3 and replaced with new patch1 from git master
189- add Patch200 to disable DRI on SandyBridge/IvyBridge
190- update intel-gpu-tools
191
192* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
193- add Patch1-3 from upstream
194
195* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
196- new upstream release
197- drop upstream patches: 107-115
198- temporary disabled patch101
199- BR: libdrm >= 2.4.25
200
201* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
202- add Patch101-115 from ubuntu/debian package
203  - Patch101: Plymouth integration patch
204  - Patch107: Check null return from uxa_acquire_solid()
205  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
206  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
207  - Patch110,114: Cherry picks to fix a large number of build warnings.
208  - Patch111: Fix clipped window plane offset
209  - Patch112: Fix issue where vertical green line and strange colors
210              shows up when playing gstreamer with certain videos,
211              when dragged.  (LP 460677)
212  - Patch113: Fixes GPU lockup during login with
213              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
214              error messages listed in the gpu dump text. (LP 710321)
215  - Patch115: Don't fill up Xorg.0.log with
216              "get vblank counter failed: Invalid argument" warnings.
217   
218* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
219- rebuild with xserver-1.10.0
220
221* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
222- new upstream release
223
224* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
225- new upstream release
226
227* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
228- rebuild with xserver-1.9.2
229
230* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
231- new upstream release
232- add Patch40: fix uxa planemask (backported)
233- add Patch61: add support for backlight on macbooks
234- add Patch62: disable page flipping for stability
235
236* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
237- new upstream release
238- drop patch70
239
240* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
241- rebuild again with xserver-1.8rc
242
243* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
244- add intel-gpu-tools as sub-package
245- rebuild with libdrm-2.4.18
246
247* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
248- new upstream release
249- import Patch1,2,60,70 from fedora
250- add BR: kernel-headers >= 2.6.33 (new drm header required)
251- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
252- add BR; libudev-devel and autoreconf for Patch60
253
254* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
255- rebuild with libdrm-2.4.17
256
257* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
258- new upstream release
259
260* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
261- new upstream release (hopefully fixes severe issues w/ efifb)
262- drop all patches already upstreamed; import Patch20/21 from Fedora
263
264* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
265- import Patch121,122 from ubuntu
266- build with libdrm-2.4.12 which fixes vt switch crash
267
268* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
269- apply patch114 to fix Xv with non-GEM kernel
270
271* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
272- update to 2.6.3
273- add patch106,107,115,118,119,120 from ubuntu
274  - add Patch106: remove triple buffering
275  - add Patch107: remove page flipping
276  - add Patch115: fix crash Xv overlay
277  - add Patch118: drop legacy3d
278  - add Patch119: fix crashes in drm bo
279  - add Patch120: fix vt switch
280- add patch130-134 from upstream git
281  - add Patch130: fix another vt switch leak
282  - add Patch131: Create known output configuration at EnterVT time
283  - add Patch132: fix leak of some 965 render state on VT switch
284  - add Patch133: fix crash with fake bufmgr and UXA
285  - add Patch134: fix EnterVT/LeaveVT
286  - add Patch135: add new chip supoprt
287
288
289* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
290- revert to 2.6.1, add Epoch
291- add Patch103-121 from ubuntu
292
293* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
294- new upstream release
295
296* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
297- new upstream release
298
299* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
300- new upstream release
301
302* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
303- add Patch5 - Dont die on irq handler failure
304
305* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
306- new upstream release
307- add BR: libdrm-devel >= 2.4.0-3
308
309* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
310- import Patch10,11,12 from ubuntu
311
312* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
313- new upstream release
314- add triggerpostun script to replace i810 driver to intel driver
315
316* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
317- new upstream release
318
319* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
320- new upstream release
321- rename i810.xinf to intel.xinf
322- update intel.xinf (add Intel 4 series)
323
324* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
325- rebuild with new xserver
326
327* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
328- new upstream release
329
330* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
331- new upstream release
332
333* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
334- new upstream release
335
336* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
337- initial build for Vine Linux
338
339* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
340- Rebuild for new server ABI.
341- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
342
343* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
344- hook up ch7017 (bz#408471)
345
346* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
347- xf86-video-intel 2.2.0
348
349* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
350- xf86-video-intel 2.1.99.
351- Drop the i810 driver.  Time to move on.
352- Require xserver 1.4.99.1
353
354* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
355- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
356
357* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
358- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
359  for textured Xv to use as an offscreen pixmap so xv actually works under
360  compiz - granted it may be unusably slow but at least stuff shows up.
361
362* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
363- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
364- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
365
366* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
367- intel-2.1.1-quirk-update.patch - update quirks from master
368
369* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
370- i810.xinf: Flip everything over to -intel by default now.  Still install
371  i810 driver just in case.
372
373* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
374- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
375
376* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
377- xf86-video-intel 2.1.1.
378
379* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
380- xf86-video-intel 2.1.0.
381
382* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
383- Update Requires and BuildRequires.
384
385* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
386- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
387  965GME, G33, Q33, and Q35 chips.
388
389* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
390- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
391  DRI clients are active, for better battery life.
392
393* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
394- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
395
396* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
397- xf86-video-intel 2.0.0.  Change the version number to match, why not.
398- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
399  rename this at some point.
400
401* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
402- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
403  915GM.
404
405* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
406- i810.xinf: More intel whitelisting (#214011, #234877)
407
408* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
409- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
410- i810.xinf: Point 965GM support at the intel driver since it's not present
411  in old i810.
412
413* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
414- xf86-video-intel-1.9.93 (RC3).
415
416* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
417- fix typo with 945GM pci id from my laptop
418
419* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
420- xf86-video-intel 1.9.92 (RC2).
421
422* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
423- Updated modesetting driver to one that will actually work with a 1.3 server.
424
425* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
426- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
427- Remove ivch and ch7017 from the install since they aren't hooked up to the
428  code anywhere
429- Disown the module
430
431* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
432- update modesetting driver to git snapshot from today
433
434* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
435- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
436
437* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
438- rebuilt for unwind info generation, broken in gcc-4.1.1-21
439
440* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
441- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
442  actually require kudzu to run.
443
444* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
445- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
446
447* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
448- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
449- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
450  driver match the corresponding terrible heuristic in the server.
451
452* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
453- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
454  correctly distinguish between Mac Mini and Macbook Pro.
455
456* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
457- i810.xinf: PCI IDs for i965.
458
459* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
460- i810.xinf: Uppercase PCI IDs.
461
462* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
463- Update i810 to 1.6.5, should fix DRI.
464- Add kuzdu requires.
465- i810.xinf: Start whitelisting devices over to intel.
466
467* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
468- intel-driver-rename.patch: Fix the driver name in more places so it'll,
469  you know, load.
470
471* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
472- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
473  LFP special casing in favor of the blacklist.
474
475* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
476- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
477  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
478  and is selected with Driver "intel" in xorg.conf.  Individual devices will
479  whitelist over to "intel" until that branch gets merged into head.
480- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
481- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
482  the BIOS is known to lie.
483
484* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
485- Today's snapshot: I2C bus creation fix.
486
487* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
488- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
489  clock when computing the modes list.
490- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
491  in centimeters as the size of the display in pixels.
492
493* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
494- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
495  probing.
496
497* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
498- Update again for a mode comparison bugfix.
499
500* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
501- Update to today's git; crash fixes, better pre-915 support, slightly better
502  autoconfigurability.
503
504* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
505- rebuild
506
507* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
508- Fix Revision number to match naming policy.
509
510* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
511- Add back modesetting changes.
512
513* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
514- Roll back modesetting changes and build for fc5 aiglx repo.
515
516* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
517- Snapshot of the git modesetting branch.
518
519* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
520- Update i810.xinf to include entries for E7221 and 945GM.
521
522* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
523- Add with_dri macro to spec file, and conditionalize build time DRI support
524
525* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
526- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
527  to pick up proto-devel as well.
528
529* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
530- Rebuild for 7.1 ABI fix.
531
532* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
533- Bump for fc5-bling build.
534
535* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
536- Update to 1.6.0 from 7.1RC1.
537
538* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
539- Add patch to add missing #include's, specifically assert.h.
540
541* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
542- Update to CVS snapshot of 20060322.
543
544* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
545- rebuilt for new gcc4.1 snapshot and glibc changes
546
547* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
548- Added 8086:2772 mapping to i810.xinf for bug (#178451)
549
550* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
551- Added 8086:2592 mapping to i810.xinf for bug (#172884)
552
553* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
554- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
555
556* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
557- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
558- Removed 'x' suffix from manpage dirs to match RC4 upstream.
559
560* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
561- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
562
563* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
564- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
565- Fix *.la file removal.
566- Added 'devel' subpackage for XvMC .so
567- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
568
569* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
570- Update BuildRoot to use Fedora Packaging Guidelines.
571- Deglob file manifest.
572- Limit "ExclusiveArch" to x86, x86_64, ia64
573
574* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
575- Initial spec file for i810 video driver generated automatically
576  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.