source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 6154

Revision 6154, 19.7 KB checked in by daisuke, 12 years ago (diff)

disable sna, enable uxa

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20110817
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.19.0
10Release:   2%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79#%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc \
87  --enable-uxa
88make
89
90pushd ../intel-gpu-tools-%{gputoolsdate}
91autoreconf -v --install
92%configure
93make
94popd
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
102install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
103
104pushd ../intel-gpu-tools-%{gputoolsdate}
105make install DESTDIR=$RPM_BUILD_ROOT
106popd
107
108
109find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%triggerpostun -- XOrg < 7.0
115if (grep -q i810 /etc/X11/xorg.conf)
116then
117  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
118  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
119fi ||:
120
121%files
122%defattr(-,root,root,-)
123%{driverdir}/intel_drv.so
124%{_datadir}/hwdata/videoaliases/intel.xinf
125%{_libdir}/libI810XvMC.so.*
126%{_libdir}/libIntelXvMC.so.*
127%{_mandir}/man4/i*
128
129%files devel
130%defattr(-,root,root,-)
131%{_libdir}/libI810XvMC.so
132%{_libdir}/libIntelXvMC.so
133
134%files -n intel-gpu-tools
135%defattr(-,root,root,-)
136%{_bindir}/intel_*
137%{_mandir}/man1/intel_*.1*
138
139
140%changelog
141* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
142- disable sna, enable uxa
143
144* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
145- new upstream release
146
147* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
148- rebuild with xserver-1.12.0
149
150* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
151- new upstream release
152- enable sna
153
154* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
155- disable sna/vmap
156
157* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
158- new upstram release
159- disable copy-fb patch
160
161* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
162- rebuild with xserver-1.11.1.902
163
164* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
165- add --enable-sna --enable-vmap
166
167* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
168- new upstream release
169
170* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
171- rebuild with xcb-util-0.3.8
172- drop Patch200
173
174* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
175- update to disable copy_fb on sandybridge/ivybridge
176
177* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
178- update intel.xinf
179- add patch10 from fedora
180  - Clamp VGA pixel clock to 250MHz,
181    anything higher's going to look awful anyway. (#559426)
182
183* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
184- drop patch1-3 and replaced with new patch1 from git master
185- add Patch200 to disable DRI on SandyBridge/IvyBridge
186- update intel-gpu-tools
187
188* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
189- add Patch1-3 from upstream
190
191* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
192- new upstream release
193- drop upstream patches: 107-115
194- temporary disabled patch101
195- BR: libdrm >= 2.4.25
196
197* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
198- add Patch101-115 from ubuntu/debian package
199  - Patch101: Plymouth integration patch
200  - Patch107: Check null return from uxa_acquire_solid()
201  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
202  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
203  - Patch110,114: Cherry picks to fix a large number of build warnings.
204  - Patch111: Fix clipped window plane offset
205  - Patch112: Fix issue where vertical green line and strange colors
206              shows up when playing gstreamer with certain videos,
207              when dragged.  (LP 460677)
208  - Patch113: Fixes GPU lockup during login with
209              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
210              error messages listed in the gpu dump text. (LP 710321)
211  - Patch115: Don't fill up Xorg.0.log with
212              "get vblank counter failed: Invalid argument" warnings.
213   
214* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
215- rebuild with xserver-1.10.0
216
217* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
218- new upstream release
219
220* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
221- new upstream release
222
223* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
224- rebuild with xserver-1.9.2
225
226* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
227- new upstream release
228- add Patch40: fix uxa planemask (backported)
229- add Patch61: add support for backlight on macbooks
230- add Patch62: disable page flipping for stability
231
232* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
233- new upstream release
234- drop patch70
235
236* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
237- rebuild again with xserver-1.8rc
238
239* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
240- add intel-gpu-tools as sub-package
241- rebuild with libdrm-2.4.18
242
243* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
244- new upstream release
245- import Patch1,2,60,70 from fedora
246- add BR: kernel-headers >= 2.6.33 (new drm header required)
247- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
248- add BR; libudev-devel and autoreconf for Patch60
249
250* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
251- rebuild with libdrm-2.4.17
252
253* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
254- new upstream release
255
256* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
257- new upstream release (hopefully fixes severe issues w/ efifb)
258- drop all patches already upstreamed; import Patch20/21 from Fedora
259
260* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
261- import Patch121,122 from ubuntu
262- build with libdrm-2.4.12 which fixes vt switch crash
263
264* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
265- apply patch114 to fix Xv with non-GEM kernel
266
267* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
268- update to 2.6.3
269- add patch106,107,115,118,119,120 from ubuntu
270  - add Patch106: remove triple buffering
271  - add Patch107: remove page flipping
272  - add Patch115: fix crash Xv overlay
273  - add Patch118: drop legacy3d
274  - add Patch119: fix crashes in drm bo
275  - add Patch120: fix vt switch
276- add patch130-134 from upstream git
277  - add Patch130: fix another vt switch leak
278  - add Patch131: Create known output configuration at EnterVT time
279  - add Patch132: fix leak of some 965 render state on VT switch
280  - add Patch133: fix crash with fake bufmgr and UXA
281  - add Patch134: fix EnterVT/LeaveVT
282  - add Patch135: add new chip supoprt
283
284
285* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
286- revert to 2.6.1, add Epoch
287- add Patch103-121 from ubuntu
288
289* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
290- new upstream release
291
292* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
293- new upstream release
294
295* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
296- new upstream release
297
298* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
299- add Patch5 - Dont die on irq handler failure
300
301* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
302- new upstream release
303- add BR: libdrm-devel >= 2.4.0-3
304
305* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
306- import Patch10,11,12 from ubuntu
307
308* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
309- new upstream release
310- add triggerpostun script to replace i810 driver to intel driver
311
312* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
313- new upstream release
314
315* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
316- new upstream release
317- rename i810.xinf to intel.xinf
318- update intel.xinf (add Intel 4 series)
319
320* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
321- rebuild with new xserver
322
323* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
324- new upstream release
325
326* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
327- new upstream release
328
329* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
330- new upstream release
331
332* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
333- initial build for Vine Linux
334
335* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
336- Rebuild for new server ABI.
337- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
338
339* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
340- hook up ch7017 (bz#408471)
341
342* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
343- xf86-video-intel 2.2.0
344
345* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
346- xf86-video-intel 2.1.99.
347- Drop the i810 driver.  Time to move on.
348- Require xserver 1.4.99.1
349
350* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
351- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
352
353* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
354- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
355  for textured Xv to use as an offscreen pixmap so xv actually works under
356  compiz - granted it may be unusably slow but at least stuff shows up.
357
358* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
359- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
360- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
361
362* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
363- intel-2.1.1-quirk-update.patch - update quirks from master
364
365* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
366- i810.xinf: Flip everything over to -intel by default now.  Still install
367  i810 driver just in case.
368
369* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
370- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
371
372* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
373- xf86-video-intel 2.1.1.
374
375* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
376- xf86-video-intel 2.1.0.
377
378* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
379- Update Requires and BuildRequires.
380
381* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
382- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
383  965GME, G33, Q33, and Q35 chips.
384
385* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
386- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
387  DRI clients are active, for better battery life.
388
389* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
390- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
391
392* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
393- xf86-video-intel 2.0.0.  Change the version number to match, why not.
394- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
395  rename this at some point.
396
397* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
398- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
399  915GM.
400
401* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
402- i810.xinf: More intel whitelisting (#214011, #234877)
403
404* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
405- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
406- i810.xinf: Point 965GM support at the intel driver since it's not present
407  in old i810.
408
409* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
410- xf86-video-intel-1.9.93 (RC3).
411
412* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
413- fix typo with 945GM pci id from my laptop
414
415* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
416- xf86-video-intel 1.9.92 (RC2).
417
418* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
419- Updated modesetting driver to one that will actually work with a 1.3 server.
420
421* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
422- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
423- Remove ivch and ch7017 from the install since they aren't hooked up to the
424  code anywhere
425- Disown the module
426
427* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
428- update modesetting driver to git snapshot from today
429
430* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
431- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
432
433* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
434- rebuilt for unwind info generation, broken in gcc-4.1.1-21
435
436* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
437- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
438  actually require kudzu to run.
439
440* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
441- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
442
443* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
444- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
445- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
446  driver match the corresponding terrible heuristic in the server.
447
448* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
449- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
450  correctly distinguish between Mac Mini and Macbook Pro.
451
452* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
453- i810.xinf: PCI IDs for i965.
454
455* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
456- i810.xinf: Uppercase PCI IDs.
457
458* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
459- Update i810 to 1.6.5, should fix DRI.
460- Add kuzdu requires.
461- i810.xinf: Start whitelisting devices over to intel.
462
463* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
464- intel-driver-rename.patch: Fix the driver name in more places so it'll,
465  you know, load.
466
467* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
468- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
469  LFP special casing in favor of the blacklist.
470
471* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
472- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
473  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
474  and is selected with Driver "intel" in xorg.conf.  Individual devices will
475  whitelist over to "intel" until that branch gets merged into head.
476- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
477- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
478  the BIOS is known to lie.
479
480* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
481- Today's snapshot: I2C bus creation fix.
482
483* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
484- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
485  clock when computing the modes list.
486- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
487  in centimeters as the size of the display in pixels.
488
489* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
490- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
491  probing.
492
493* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
494- Update again for a mode comparison bugfix.
495
496* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
497- Update to today's git; crash fixes, better pre-915 support, slightly better
498  autoconfigurability.
499
500* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
501- rebuild
502
503* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
504- Fix Revision number to match naming policy.
505
506* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
507- Add back modesetting changes.
508
509* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
510- Roll back modesetting changes and build for fc5 aiglx repo.
511
512* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
513- Snapshot of the git modesetting branch.
514
515* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
516- Update i810.xinf to include entries for E7221 and 945GM.
517
518* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
519- Add with_dri macro to spec file, and conditionalize build time DRI support
520
521* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
522- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
523  to pick up proto-devel as well.
524
525* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
526- Rebuild for 7.1 ABI fix.
527
528* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
529- Bump for fc5-bling build.
530
531* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
532- Update to 1.6.0 from 7.1RC1.
533
534* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
535- Add patch to add missing #include's, specifically assert.h.
536
537* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
538- Update to CVS snapshot of 20060322.
539
540* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
541- rebuilt for new gcc4.1 snapshot and glibc changes
542
543* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
544- Added 8086:2772 mapping to i810.xinf for bug (#178451)
545
546* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
547- Added 8086:2592 mapping to i810.xinf for bug (#172884)
548
549* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
550- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
551
552* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
553- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
554- Removed 'x' suffix from manpage dirs to match RC4 upstream.
555
556* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
557- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
558
559* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
560- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
561- Fix *.la file removal.
562- Added 'devel' subpackage for XvMC .so
563- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
564
565* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
566- Update BuildRoot to use Fedora Packaging Guidelines.
567- Deglob file manifest.
568- Limit "ExclusiveArch" to x86, x86_64, ia64
569
570* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
571- Initial spec file for i810 video driver generated automatically
572  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.