source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 4692

Revision 4692, 19.1 KB checked in by daisuke, 13 years ago (diff)

xorg-x11-drv-intel: enable sna/vmap

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.16.0
10Release:   2%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc --enable-sna --enable-vmap
87make
88
89pushd ../intel-gpu-tools-%{gputoolsdate}
90autoreconf -v --install
91%configure
92make
93popd
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
101install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
102
103pushd ../intel-gpu-tools-%{gputoolsdate}
104make install DESTDIR=$RPM_BUILD_ROOT
105popd
106
107
108find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%triggerpostun -- XOrg < 7.0
114if (grep -q i810 /etc/X11/xorg.conf)
115then
116  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
117  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
118fi ||:
119
120%files
121%defattr(-,root,root,-)
122%{driverdir}/intel_drv.so
123%{_datadir}/hwdata/videoaliases/intel.xinf
124%{_libdir}/libI810XvMC.so.*
125%{_libdir}/libIntelXvMC.so.*
126%{_mandir}/man4/i*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libI810XvMC.so
131%{_libdir}/libIntelXvMC.so
132
133%files -n intel-gpu-tools
134%defattr(-,root,root,-)
135%{_bindir}/intel_*
136%{_mandir}/man1/intel_*.1*
137
138
139%changelog
140* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
141- add --enable-sna --enable-vmap
142
143* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
144- new upstream release
145
146* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
147- rebuild with xcb-util-0.3.8
148- drop Patch200
149
150* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
151- update to disable copy_fb on sandybridge/ivybridge
152
153* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
154- update intel.xinf
155- add patch10 from fedora
156  - Clamp VGA pixel clock to 250MHz,
157    anything higher's going to look awful anyway. (#559426)
158
159* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
160- drop patch1-3 and replaced with new patch1 from git master
161- add Patch200 to disable DRI on SandyBridge/IvyBridge
162- update intel-gpu-tools
163
164* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
165- add Patch1-3 from upstream
166
167* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
168- new upstream release
169- drop upstream patches: 107-115
170- temporary disabled patch101
171- BR: libdrm >= 2.4.25
172
173* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
174- add Patch101-115 from ubuntu/debian package
175  - Patch101: Plymouth integration patch
176  - Patch107: Check null return from uxa_acquire_solid()
177  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
178  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
179  - Patch110,114: Cherry picks to fix a large number of build warnings.
180  - Patch111: Fix clipped window plane offset
181  - Patch112: Fix issue where vertical green line and strange colors
182              shows up when playing gstreamer with certain videos,
183              when dragged.  (LP 460677)
184  - Patch113: Fixes GPU lockup during login with
185              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
186              error messages listed in the gpu dump text. (LP 710321)
187  - Patch115: Don't fill up Xorg.0.log with
188              "get vblank counter failed: Invalid argument" warnings.
189   
190* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
191- rebuild with xserver-1.10.0
192
193* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
194- new upstream release
195
196* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
197- new upstream release
198
199* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
200- rebuild with xserver-1.9.2
201
202* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
203- new upstream release
204- add Patch40: fix uxa planemask (backported)
205- add Patch61: add support for backlight on macbooks
206- add Patch62: disable page flipping for stability
207
208* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
209- new upstream release
210- drop patch70
211
212* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
213- rebuild again with xserver-1.8rc
214
215* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
216- add intel-gpu-tools as sub-package
217- rebuild with libdrm-2.4.18
218
219* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
220- new upstream release
221- import Patch1,2,60,70 from fedora
222- add BR: kernel-headers >= 2.6.33 (new drm header required)
223- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
224- add BR; libudev-devel and autoreconf for Patch60
225
226* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
227- rebuild with libdrm-2.4.17
228
229* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
230- new upstream release
231
232* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
233- new upstream release (hopefully fixes severe issues w/ efifb)
234- drop all patches already upstreamed; import Patch20/21 from Fedora
235
236* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
237- import Patch121,122 from ubuntu
238- build with libdrm-2.4.12 which fixes vt switch crash
239
240* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
241- apply patch114 to fix Xv with non-GEM kernel
242
243* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
244- update to 2.6.3
245- add patch106,107,115,118,119,120 from ubuntu
246  - add Patch106: remove triple buffering
247  - add Patch107: remove page flipping
248  - add Patch115: fix crash Xv overlay
249  - add Patch118: drop legacy3d
250  - add Patch119: fix crashes in drm bo
251  - add Patch120: fix vt switch
252- add patch130-134 from upstream git
253  - add Patch130: fix another vt switch leak
254  - add Patch131: Create known output configuration at EnterVT time
255  - add Patch132: fix leak of some 965 render state on VT switch
256  - add Patch133: fix crash with fake bufmgr and UXA
257  - add Patch134: fix EnterVT/LeaveVT
258  - add Patch135: add new chip supoprt
259
260
261* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
262- revert to 2.6.1, add Epoch
263- add Patch103-121 from ubuntu
264
265* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
266- new upstream release
267
268* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
269- new upstream release
270
271* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
272- new upstream release
273
274* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
275- add Patch5 - Dont die on irq handler failure
276
277* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
278- new upstream release
279- add BR: libdrm-devel >= 2.4.0-3
280
281* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
282- import Patch10,11,12 from ubuntu
283
284* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
285- new upstream release
286- add triggerpostun script to replace i810 driver to intel driver
287
288* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
289- new upstream release
290
291* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
292- new upstream release
293- rename i810.xinf to intel.xinf
294- update intel.xinf (add Intel 4 series)
295
296* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
297- rebuild with new xserver
298
299* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
300- new upstream release
301
302* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
303- new upstream release
304
305* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
306- new upstream release
307
308* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
309- initial build for Vine Linux
310
311* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
312- Rebuild for new server ABI.
313- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
314
315* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
316- hook up ch7017 (bz#408471)
317
318* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
319- xf86-video-intel 2.2.0
320
321* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
322- xf86-video-intel 2.1.99.
323- Drop the i810 driver.  Time to move on.
324- Require xserver 1.4.99.1
325
326* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
327- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
328
329* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
330- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
331  for textured Xv to use as an offscreen pixmap so xv actually works under
332  compiz - granted it may be unusably slow but at least stuff shows up.
333
334* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
335- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
336- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
337
338* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
339- intel-2.1.1-quirk-update.patch - update quirks from master
340
341* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
342- i810.xinf: Flip everything over to -intel by default now.  Still install
343  i810 driver just in case.
344
345* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
346- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
347
348* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
349- xf86-video-intel 2.1.1.
350
351* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
352- xf86-video-intel 2.1.0.
353
354* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
355- Update Requires and BuildRequires.
356
357* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
358- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
359  965GME, G33, Q33, and Q35 chips.
360
361* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
362- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
363  DRI clients are active, for better battery life.
364
365* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
366- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
367
368* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
369- xf86-video-intel 2.0.0.  Change the version number to match, why not.
370- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
371  rename this at some point.
372
373* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
374- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
375  915GM.
376
377* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
378- i810.xinf: More intel whitelisting (#214011, #234877)
379
380* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
381- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
382- i810.xinf: Point 965GM support at the intel driver since it's not present
383  in old i810.
384
385* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
386- xf86-video-intel-1.9.93 (RC3).
387
388* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
389- fix typo with 945GM pci id from my laptop
390
391* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
392- xf86-video-intel 1.9.92 (RC2).
393
394* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
395- Updated modesetting driver to one that will actually work with a 1.3 server.
396
397* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
398- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
399- Remove ivch and ch7017 from the install since they aren't hooked up to the
400  code anywhere
401- Disown the module
402
403* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
404- update modesetting driver to git snapshot from today
405
406* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
407- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
408
409* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
410- rebuilt for unwind info generation, broken in gcc-4.1.1-21
411
412* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
413- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
414  actually require kudzu to run.
415
416* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
417- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
418
419* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
420- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
421- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
422  driver match the corresponding terrible heuristic in the server.
423
424* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
425- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
426  correctly distinguish between Mac Mini and Macbook Pro.
427
428* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
429- i810.xinf: PCI IDs for i965.
430
431* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
432- i810.xinf: Uppercase PCI IDs.
433
434* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
435- Update i810 to 1.6.5, should fix DRI.
436- Add kuzdu requires.
437- i810.xinf: Start whitelisting devices over to intel.
438
439* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
440- intel-driver-rename.patch: Fix the driver name in more places so it'll,
441  you know, load.
442
443* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
444- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
445  LFP special casing in favor of the blacklist.
446
447* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
448- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
449  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
450  and is selected with Driver "intel" in xorg.conf.  Individual devices will
451  whitelist over to "intel" until that branch gets merged into head.
452- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
453- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
454  the BIOS is known to lie.
455
456* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
457- Today's snapshot: I2C bus creation fix.
458
459* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
460- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
461  clock when computing the modes list.
462- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
463  in centimeters as the size of the display in pixels.
464
465* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
466- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
467  probing.
468
469* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
470- Update again for a mode comparison bugfix.
471
472* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
473- Update to today's git; crash fixes, better pre-915 support, slightly better
474  autoconfigurability.
475
476* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
477- rebuild
478
479* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
480- Fix Revision number to match naming policy.
481
482* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
483- Add back modesetting changes.
484
485* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
486- Roll back modesetting changes and build for fc5 aiglx repo.
487
488* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
489- Snapshot of the git modesetting branch.
490
491* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
492- Update i810.xinf to include entries for E7221 and 945GM.
493
494* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
495- Add with_dri macro to spec file, and conditionalize build time DRI support
496
497* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
498- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
499  to pick up proto-devel as well.
500
501* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
502- Rebuild for 7.1 ABI fix.
503
504* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
505- Bump for fc5-bling build.
506
507* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
508- Update to 1.6.0 from 7.1RC1.
509
510* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
511- Add patch to add missing #include's, specifically assert.h.
512
513* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
514- Update to CVS snapshot of 20060322.
515
516* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
517- rebuilt for new gcc4.1 snapshot and glibc changes
518
519* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
520- Added 8086:2772 mapping to i810.xinf for bug (#178451)
521
522* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
523- Added 8086:2592 mapping to i810.xinf for bug (#172884)
524
525* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
526- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
527
528* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
529- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
530- Removed 'x' suffix from manpage dirs to match RC4 upstream.
531
532* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
533- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
534
535* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
536- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
537- Fix *.la file removal.
538- Added 'devel' subpackage for XvMC .so
539- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
540
541* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
542- Update BuildRoot to use Fedora Packaging Guidelines.
543- Deglob file manifest.
544- Limit "ExclusiveArch" to x86, x86_64, ia64
545
546* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
547- Initial spec file for i810 video driver generated automatically
548  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.