source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 4653

Revision 4653, 18.9 KB checked in by daisuke, 13 years ago (diff)

update to 2.16.0

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.16.0
10Release:   1%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc
87make
88
89pushd ../intel-gpu-tools-%{gputoolsdate}
90autoreconf -v --install
91%configure
92make
93popd
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
101install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
102
103pushd ../intel-gpu-tools-%{gputoolsdate}
104make install DESTDIR=$RPM_BUILD_ROOT
105popd
106
107
108find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%triggerpostun -- XOrg < 7.0
114if (grep -q i810 /etc/X11/xorg.conf)
115then
116  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
117  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
118fi ||:
119
120%files
121%defattr(-,root,root,-)
122%{driverdir}/intel_drv.so
123%{_datadir}/hwdata/videoaliases/intel.xinf
124%{_libdir}/libI810XvMC.so.*
125%{_libdir}/libIntelXvMC.so.*
126%{_mandir}/man4/i*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libI810XvMC.so
131%{_libdir}/libIntelXvMC.so
132
133%files -n intel-gpu-tools
134%defattr(-,root,root,-)
135%{_bindir}/intel_*
136%{_mandir}/man1/intel_*.1*
137
138
139%changelog
140* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
141- new upstream release
142
143* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
144- rebuild with xcb-util-0.3.8
145- drop Patch200
146
147* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
148- update to disable copy_fb on sandybridge/ivybridge
149
150* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
151- update intel.xinf
152- add patch10 from fedora
153  - Clamp VGA pixel clock to 250MHz,
154    anything higher's going to look awful anyway. (#559426)
155
156* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
157- drop patch1-3 and replaced with new patch1 from git master
158- add Patch200 to disable DRI on SandyBridge/IvyBridge
159- update intel-gpu-tools
160
161* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
162- add Patch1-3 from upstream
163
164* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
165- new upstream release
166- drop upstream patches: 107-115
167- temporary disabled patch101
168- BR: libdrm >= 2.4.25
169
170* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
171- add Patch101-115 from ubuntu/debian package
172  - Patch101: Plymouth integration patch
173  - Patch107: Check null return from uxa_acquire_solid()
174  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
175  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
176  - Patch110,114: Cherry picks to fix a large number of build warnings.
177  - Patch111: Fix clipped window plane offset
178  - Patch112: Fix issue where vertical green line and strange colors
179              shows up when playing gstreamer with certain videos,
180              when dragged.  (LP 460677)
181  - Patch113: Fixes GPU lockup during login with
182              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
183              error messages listed in the gpu dump text. (LP 710321)
184  - Patch115: Don't fill up Xorg.0.log with
185              "get vblank counter failed: Invalid argument" warnings.
186   
187* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
188- rebuild with xserver-1.10.0
189
190* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
191- new upstream release
192
193* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
194- new upstream release
195
196* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
197- rebuild with xserver-1.9.2
198
199* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
200- new upstream release
201- add Patch40: fix uxa planemask (backported)
202- add Patch61: add support for backlight on macbooks
203- add Patch62: disable page flipping for stability
204
205* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
206- new upstream release
207- drop patch70
208
209* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
210- rebuild again with xserver-1.8rc
211
212* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
213- add intel-gpu-tools as sub-package
214- rebuild with libdrm-2.4.18
215
216* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
217- new upstream release
218- import Patch1,2,60,70 from fedora
219- add BR: kernel-headers >= 2.6.33 (new drm header required)
220- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
221- add BR; libudev-devel and autoreconf for Patch60
222
223* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
224- rebuild with libdrm-2.4.17
225
226* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
227- new upstream release
228
229* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
230- new upstream release (hopefully fixes severe issues w/ efifb)
231- drop all patches already upstreamed; import Patch20/21 from Fedora
232
233* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
234- import Patch121,122 from ubuntu
235- build with libdrm-2.4.12 which fixes vt switch crash
236
237* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
238- apply patch114 to fix Xv with non-GEM kernel
239
240* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
241- update to 2.6.3
242- add patch106,107,115,118,119,120 from ubuntu
243  - add Patch106: remove triple buffering
244  - add Patch107: remove page flipping
245  - add Patch115: fix crash Xv overlay
246  - add Patch118: drop legacy3d
247  - add Patch119: fix crashes in drm bo
248  - add Patch120: fix vt switch
249- add patch130-134 from upstream git
250  - add Patch130: fix another vt switch leak
251  - add Patch131: Create known output configuration at EnterVT time
252  - add Patch132: fix leak of some 965 render state on VT switch
253  - add Patch133: fix crash with fake bufmgr and UXA
254  - add Patch134: fix EnterVT/LeaveVT
255  - add Patch135: add new chip supoprt
256
257
258* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
259- revert to 2.6.1, add Epoch
260- add Patch103-121 from ubuntu
261
262* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
263- new upstream release
264
265* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
266- new upstream release
267
268* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
269- new upstream release
270
271* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
272- add Patch5 - Dont die on irq handler failure
273
274* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
275- new upstream release
276- add BR: libdrm-devel >= 2.4.0-3
277
278* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
279- import Patch10,11,12 from ubuntu
280
281* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
282- new upstream release
283- add triggerpostun script to replace i810 driver to intel driver
284
285* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
286- new upstream release
287
288* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
289- new upstream release
290- rename i810.xinf to intel.xinf
291- update intel.xinf (add Intel 4 series)
292
293* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
294- rebuild with new xserver
295
296* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
297- new upstream release
298
299* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
300- new upstream release
301
302* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
303- new upstream release
304
305* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
306- initial build for Vine Linux
307
308* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
309- Rebuild for new server ABI.
310- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
311
312* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
313- hook up ch7017 (bz#408471)
314
315* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
316- xf86-video-intel 2.2.0
317
318* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
319- xf86-video-intel 2.1.99.
320- Drop the i810 driver.  Time to move on.
321- Require xserver 1.4.99.1
322
323* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
324- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
325
326* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
327- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
328  for textured Xv to use as an offscreen pixmap so xv actually works under
329  compiz - granted it may be unusably slow but at least stuff shows up.
330
331* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
332- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
333- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
334
335* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
336- intel-2.1.1-quirk-update.patch - update quirks from master
337
338* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
339- i810.xinf: Flip everything over to -intel by default now.  Still install
340  i810 driver just in case.
341
342* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
343- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
344
345* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
346- xf86-video-intel 2.1.1.
347
348* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
349- xf86-video-intel 2.1.0.
350
351* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
352- Update Requires and BuildRequires.
353
354* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
355- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
356  965GME, G33, Q33, and Q35 chips.
357
358* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
359- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
360  DRI clients are active, for better battery life.
361
362* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
363- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
364
365* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
366- xf86-video-intel 2.0.0.  Change the version number to match, why not.
367- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
368  rename this at some point.
369
370* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
371- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
372  915GM.
373
374* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
375- i810.xinf: More intel whitelisting (#214011, #234877)
376
377* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
378- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
379- i810.xinf: Point 965GM support at the intel driver since it's not present
380  in old i810.
381
382* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
383- xf86-video-intel-1.9.93 (RC3).
384
385* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
386- fix typo with 945GM pci id from my laptop
387
388* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
389- xf86-video-intel 1.9.92 (RC2).
390
391* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
392- Updated modesetting driver to one that will actually work with a 1.3 server.
393
394* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
395- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
396- Remove ivch and ch7017 from the install since they aren't hooked up to the
397  code anywhere
398- Disown the module
399
400* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
401- update modesetting driver to git snapshot from today
402
403* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
404- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
405
406* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
407- rebuilt for unwind info generation, broken in gcc-4.1.1-21
408
409* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
410- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
411  actually require kudzu to run.
412
413* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
414- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
415
416* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
417- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
418- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
419  driver match the corresponding terrible heuristic in the server.
420
421* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
422- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
423  correctly distinguish between Mac Mini and Macbook Pro.
424
425* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
426- i810.xinf: PCI IDs for i965.
427
428* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
429- i810.xinf: Uppercase PCI IDs.
430
431* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
432- Update i810 to 1.6.5, should fix DRI.
433- Add kuzdu requires.
434- i810.xinf: Start whitelisting devices over to intel.
435
436* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
437- intel-driver-rename.patch: Fix the driver name in more places so it'll,
438  you know, load.
439
440* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
441- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
442  LFP special casing in favor of the blacklist.
443
444* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
445- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
446  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
447  and is selected with Driver "intel" in xorg.conf.  Individual devices will
448  whitelist over to "intel" until that branch gets merged into head.
449- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
450- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
451  the BIOS is known to lie.
452
453* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
454- Today's snapshot: I2C bus creation fix.
455
456* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
457- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
458  clock when computing the modes list.
459- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
460  in centimeters as the size of the display in pixels.
461
462* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
463- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
464  probing.
465
466* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
467- Update again for a mode comparison bugfix.
468
469* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
470- Update to today's git; crash fixes, better pre-915 support, slightly better
471  autoconfigurability.
472
473* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
474- rebuild
475
476* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
477- Fix Revision number to match naming policy.
478
479* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
480- Add back modesetting changes.
481
482* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
483- Roll back modesetting changes and build for fc5 aiglx repo.
484
485* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
486- Snapshot of the git modesetting branch.
487
488* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
489- Update i810.xinf to include entries for E7221 and 945GM.
490
491* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
492- Add with_dri macro to spec file, and conditionalize build time DRI support
493
494* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
495- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
496  to pick up proto-devel as well.
497
498* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
499- Rebuild for 7.1 ABI fix.
500
501* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
502- Bump for fc5-bling build.
503
504* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
505- Update to 1.6.0 from 7.1RC1.
506
507* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
508- Add patch to add missing #include's, specifically assert.h.
509
510* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
511- Update to CVS snapshot of 20060322.
512
513* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
514- rebuilt for new gcc4.1 snapshot and glibc changes
515
516* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
517- Added 8086:2772 mapping to i810.xinf for bug (#178451)
518
519* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
520- Added 8086:2592 mapping to i810.xinf for bug (#172884)
521
522* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
523- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
524
525* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
526- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
527- Removed 'x' suffix from manpage dirs to match RC4 upstream.
528
529* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
530- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
531
532* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
533- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
534- Fix *.la file removal.
535- Added 'devel' subpackage for XvMC .so
536- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
537
538* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
539- Update BuildRoot to use Fedora Packaging Guidelines.
540- Deglob file manifest.
541- Limit "ExclusiveArch" to x86, x86_64, ia64
542
543* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
544- Initial spec file for i810 video driver generated automatically
545  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.