source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 5089

Revision 5089, 19.2 KB checked in by Takemikaduchi, 13 years ago (diff)

xserver-1.11.1.902 (1.11.2 RC2)

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.16.0
10Release:   3%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc --enable-sna --enable-vmap
87make
88
89pushd ../intel-gpu-tools-%{gputoolsdate}
90autoreconf -v --install
91%configure
92make
93popd
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98
99make install DESTDIR=$RPM_BUILD_ROOT
100mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
101install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
102
103pushd ../intel-gpu-tools-%{gputoolsdate}
104make install DESTDIR=$RPM_BUILD_ROOT
105popd
106
107
108find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
109
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%triggerpostun -- XOrg < 7.0
114if (grep -q i810 /etc/X11/xorg.conf)
115then
116  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
117  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
118fi ||:
119
120%files
121%defattr(-,root,root,-)
122%{driverdir}/intel_drv.so
123%{_datadir}/hwdata/videoaliases/intel.xinf
124%{_libdir}/libI810XvMC.so.*
125%{_libdir}/libIntelXvMC.so.*
126%{_mandir}/man4/i*
127
128%files devel
129%defattr(-,root,root,-)
130%{_libdir}/libI810XvMC.so
131%{_libdir}/libIntelXvMC.so
132
133%files -n intel-gpu-tools
134%defattr(-,root,root,-)
135%{_bindir}/intel_*
136%{_mandir}/man1/intel_*.1*
137
138
139%changelog
140* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
141- rebuild with xserver-1.11.1.902
142
143* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
144- add --enable-sna --enable-vmap
145
146* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
147- new upstream release
148
149* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
150- rebuild with xcb-util-0.3.8
151- drop Patch200
152
153* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
154- update to disable copy_fb on sandybridge/ivybridge
155
156* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
157- update intel.xinf
158- add patch10 from fedora
159  - Clamp VGA pixel clock to 250MHz,
160    anything higher's going to look awful anyway. (#559426)
161
162* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
163- drop patch1-3 and replaced with new patch1 from git master
164- add Patch200 to disable DRI on SandyBridge/IvyBridge
165- update intel-gpu-tools
166
167* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
168- add Patch1-3 from upstream
169
170* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
171- new upstream release
172- drop upstream patches: 107-115
173- temporary disabled patch101
174- BR: libdrm >= 2.4.25
175
176* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
177- add Patch101-115 from ubuntu/debian package
178  - Patch101: Plymouth integration patch
179  - Patch107: Check null return from uxa_acquire_solid()
180  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
181  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
182  - Patch110,114: Cherry picks to fix a large number of build warnings.
183  - Patch111: Fix clipped window plane offset
184  - Patch112: Fix issue where vertical green line and strange colors
185              shows up when playing gstreamer with certain videos,
186              when dragged.  (LP 460677)
187  - Patch113: Fixes GPU lockup during login with
188              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
189              error messages listed in the gpu dump text. (LP 710321)
190  - Patch115: Don't fill up Xorg.0.log with
191              "get vblank counter failed: Invalid argument" warnings.
192   
193* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
194- rebuild with xserver-1.10.0
195
196* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
197- new upstream release
198
199* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
200- new upstream release
201
202* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
203- rebuild with xserver-1.9.2
204
205* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
206- new upstream release
207- add Patch40: fix uxa planemask (backported)
208- add Patch61: add support for backlight on macbooks
209- add Patch62: disable page flipping for stability
210
211* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
212- new upstream release
213- drop patch70
214
215* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
216- rebuild again with xserver-1.8rc
217
218* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
219- add intel-gpu-tools as sub-package
220- rebuild with libdrm-2.4.18
221
222* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
223- new upstream release
224- import Patch1,2,60,70 from fedora
225- add BR: kernel-headers >= 2.6.33 (new drm header required)
226- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
227- add BR; libudev-devel and autoreconf for Patch60
228
229* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
230- rebuild with libdrm-2.4.17
231
232* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
233- new upstream release
234
235* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
236- new upstream release (hopefully fixes severe issues w/ efifb)
237- drop all patches already upstreamed; import Patch20/21 from Fedora
238
239* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
240- import Patch121,122 from ubuntu
241- build with libdrm-2.4.12 which fixes vt switch crash
242
243* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
244- apply patch114 to fix Xv with non-GEM kernel
245
246* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
247- update to 2.6.3
248- add patch106,107,115,118,119,120 from ubuntu
249  - add Patch106: remove triple buffering
250  - add Patch107: remove page flipping
251  - add Patch115: fix crash Xv overlay
252  - add Patch118: drop legacy3d
253  - add Patch119: fix crashes in drm bo
254  - add Patch120: fix vt switch
255- add patch130-134 from upstream git
256  - add Patch130: fix another vt switch leak
257  - add Patch131: Create known output configuration at EnterVT time
258  - add Patch132: fix leak of some 965 render state on VT switch
259  - add Patch133: fix crash with fake bufmgr and UXA
260  - add Patch134: fix EnterVT/LeaveVT
261  - add Patch135: add new chip supoprt
262
263
264* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
265- revert to 2.6.1, add Epoch
266- add Patch103-121 from ubuntu
267
268* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
269- new upstream release
270
271* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
272- new upstream release
273
274* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
275- new upstream release
276
277* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
278- add Patch5 - Dont die on irq handler failure
279
280* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
281- new upstream release
282- add BR: libdrm-devel >= 2.4.0-3
283
284* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
285- import Patch10,11,12 from ubuntu
286
287* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
288- new upstream release
289- add triggerpostun script to replace i810 driver to intel driver
290
291* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
292- new upstream release
293
294* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
295- new upstream release
296- rename i810.xinf to intel.xinf
297- update intel.xinf (add Intel 4 series)
298
299* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
300- rebuild with new xserver
301
302* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
303- new upstream release
304
305* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
306- new upstream release
307
308* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
309- new upstream release
310
311* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
312- initial build for Vine Linux
313
314* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
315- Rebuild for new server ABI.
316- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
317
318* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
319- hook up ch7017 (bz#408471)
320
321* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
322- xf86-video-intel 2.2.0
323
324* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
325- xf86-video-intel 2.1.99.
326- Drop the i810 driver.  Time to move on.
327- Require xserver 1.4.99.1
328
329* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
330- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
331
332* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
333- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
334  for textured Xv to use as an offscreen pixmap so xv actually works under
335  compiz - granted it may be unusably slow but at least stuff shows up.
336
337* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
338- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
339- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
340
341* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
342- intel-2.1.1-quirk-update.patch - update quirks from master
343
344* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
345- i810.xinf: Flip everything over to -intel by default now.  Still install
346  i810 driver just in case.
347
348* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
349- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
350
351* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
352- xf86-video-intel 2.1.1.
353
354* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
355- xf86-video-intel 2.1.0.
356
357* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
358- Update Requires and BuildRequires.
359
360* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
361- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
362  965GME, G33, Q33, and Q35 chips.
363
364* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
365- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
366  DRI clients are active, for better battery life.
367
368* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
369- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
370
371* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
372- xf86-video-intel 2.0.0.  Change the version number to match, why not.
373- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
374  rename this at some point.
375
376* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
377- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
378  915GM.
379
380* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
381- i810.xinf: More intel whitelisting (#214011, #234877)
382
383* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
384- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
385- i810.xinf: Point 965GM support at the intel driver since it's not present
386  in old i810.
387
388* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
389- xf86-video-intel-1.9.93 (RC3).
390
391* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
392- fix typo with 945GM pci id from my laptop
393
394* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
395- xf86-video-intel 1.9.92 (RC2).
396
397* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
398- Updated modesetting driver to one that will actually work with a 1.3 server.
399
400* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
401- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
402- Remove ivch and ch7017 from the install since they aren't hooked up to the
403  code anywhere
404- Disown the module
405
406* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
407- update modesetting driver to git snapshot from today
408
409* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
410- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
411
412* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
413- rebuilt for unwind info generation, broken in gcc-4.1.1-21
414
415* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
416- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
417  actually require kudzu to run.
418
419* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
420- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
421
422* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
423- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
424- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
425  driver match the corresponding terrible heuristic in the server.
426
427* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
428- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
429  correctly distinguish between Mac Mini and Macbook Pro.
430
431* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
432- i810.xinf: PCI IDs for i965.
433
434* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
435- i810.xinf: Uppercase PCI IDs.
436
437* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
438- Update i810 to 1.6.5, should fix DRI.
439- Add kuzdu requires.
440- i810.xinf: Start whitelisting devices over to intel.
441
442* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
443- intel-driver-rename.patch: Fix the driver name in more places so it'll,
444  you know, load.
445
446* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
447- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
448  LFP special casing in favor of the blacklist.
449
450* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
451- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
452  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
453  and is selected with Driver "intel" in xorg.conf.  Individual devices will
454  whitelist over to "intel" until that branch gets merged into head.
455- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
456- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
457  the BIOS is known to lie.
458
459* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
460- Today's snapshot: I2C bus creation fix.
461
462* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
463- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
464  clock when computing the modes list.
465- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
466  in centimeters as the size of the display in pixels.
467
468* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
469- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
470  probing.
471
472* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
473- Update again for a mode comparison bugfix.
474
475* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
476- Update to today's git; crash fixes, better pre-915 support, slightly better
477  autoconfigurability.
478
479* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
480- rebuild
481
482* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
483- Fix Revision number to match naming policy.
484
485* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
486- Add back modesetting changes.
487
488* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
489- Roll back modesetting changes and build for fc5 aiglx repo.
490
491* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
492- Snapshot of the git modesetting branch.
493
494* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
495- Update i810.xinf to include entries for E7221 and 945GM.
496
497* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
498- Add with_dri macro to spec file, and conditionalize build time DRI support
499
500* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
501- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
502  to pick up proto-devel as well.
503
504* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
505- Rebuild for 7.1 ABI fix.
506
507* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
508- Bump for fc5-bling build.
509
510* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
511- Update to 1.6.0 from 7.1RC1.
512
513* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
514- Add patch to add missing #include's, specifically assert.h.
515
516* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
517- Update to CVS snapshot of 20060322.
518
519* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
520- rebuilt for new gcc4.1 snapshot and glibc changes
521
522* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
523- Added 8086:2772 mapping to i810.xinf for bug (#178451)
524
525* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
526- Added 8086:2592 mapping to i810.xinf for bug (#172884)
527
528* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
529- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
530
531* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
532- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
533- Removed 'x' suffix from manpage dirs to match RC4 upstream.
534
535* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
536- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
537
538* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
539- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
540- Fix *.la file removal.
541- Added 'devel' subpackage for XvMC .so
542- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
543
544* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
545- Update BuildRoot to use Fedora Packaging Guidelines.
546- Deglob file manifest.
547- Limit "ExclusiveArch" to x86, x86_64, ia64
548
549* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
550- Initial spec file for i810 video driver generated automatically
551  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.