source: projects/specs/trunk/x/xinetd/xinetd-vl.spec @ 521

Revision 521, 19.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2%define __find_requires %{SOURCE99}
3
4Summary: A secure replacement for inetd.
5Name: xinetd
6Version: 2.3.14
7Release: 1%{?_dist_release}
8License: Distributable (BSD-like)
9Group: System Environment/Daemons
10Source: http://www.xinetd.org/xinetd-%{version}.tar.gz
11Source1: xinetd.init
12Source2: xinetd.conf
13Source3: xinetd-inetdconvert
14Source4: xinetd-ttime
15Source5: xinetd-utime
16Source6: xinetd-tdtime
17Source7: xinetd-udtime
18Source8: xinetd-echo
19Source9: xinetd-uecho
20Source10: xinetd-chargen
21Source11: xinetd-uchargen
22Source12: xinetd.sysconf
23Source13: xinetd-services
24Source99: filter-requires-xinetd.sh
25Patch0: xinetd-2.3.11-pie.patch
26Patch1: xinetd-2.3.13-libwrap.patch
27Patch2: xinetd-2.3.12-tcp_rpc.patch
28Prereq: chkconfig initscripts
29Requires: initscripts setup fileutils
30URL: http://www.xinetd.org/
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Provides: inetd
33
34%description
35Xinetd is a secure replacement for inetd, the Internet services
36daemon. Xinetd provides access control for all services based on the
37address of the remote host and/or on time of access and can prevent
38denial-of-access attacks. Xinetd provides extensive logging, has no
39limit on the number of server arguments, and lets you bind specific
40services to specific IP addresses on your host machine. Each service
41has its own specific configuration file for Xinetd; the files are
42located in the /etc/xinetd.d directory.
43
44%prep
45%setup -q 
46#%patch0 -p0 -b .pie
47#%patch1 -p1 -b .libwrap
48%patch2 -p1 -b .tcp_rpc
49
50%build
51libtoolize --copy --force
52%configure --with-loadavg --with-inet6 --with-libwrap
53make
54
55%install
56rm -rf $RPM_BUILD_ROOT
57mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
58mkdir -p $RPM_BUILD_ROOT/%{_mandir}
59%makeinstall DAEMONDIR=$RPM_BUILD_ROOT/usr/sbin MANDIR=$RPM_BUILD_ROOT/%{_mandir}
60mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d/
61install -m 755 %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/xinetd
62install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/xinetd.conf
63install -m 755 %SOURCE3 $RPM_BUILD_ROOT/usr/sbin/inetdconvert
64install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/xinetd.d/time
65install -m 644 %SOURCE5 $RPM_BUILD_ROOT/etc/xinetd.d/time-udp
66install -m 644 %SOURCE6 $RPM_BUILD_ROOT/etc/xinetd.d/daytime
67install -m 644 %SOURCE7 $RPM_BUILD_ROOT/etc/xinetd.d/daytime-udp
68install -m 644 %SOURCE8 $RPM_BUILD_ROOT/etc/xinetd.d/echo
69install -m 644 %SOURCE9 $RPM_BUILD_ROOT/etc/xinetd.d/echo-udp
70install -m 644 %SOURCE10 $RPM_BUILD_ROOT/etc/xinetd.d/chargen
71install -m 644 %SOURCE11 $RPM_BUILD_ROOT/etc/xinetd.d/chargen-udp
72install -m 644 %SOURCE13 $RPM_BUILD_ROOT/etc/xinetd.d/services
73
74rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/itox*
75rm -f $RPM_BUILD_ROOT/usr/sbin/itox
76rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xconv.pl*
77rm -f $RPM_BUILD_ROOT/usr/sbin/xconv.pl
78rm -f $RPM_BUILD_ROOT/%{_mandir}/*.3
79
80mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
81install -m 644 %SOURCE12 $RPM_BUILD_ROOT/etc/sysconfig/xinetd
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87if [ $1 = 1 ]; then
88    /sbin/chkconfig --add xinetd
89fi
90
91%preun
92if [ $1 = 0 ]; then
93    /sbin/service xinetd stop > /dev/null 2>&1
94    /sbin/chkconfig --del xinetd
95fi
96
97%postun
98if [ $1 -ge 1 ]; then
99    /sbin/service xinetd condrestart >/dev/null 2>&1
100fi
101
102
103%files
104%defattr(-,root,root)
105%doc INSTALL CHANGELOG COPYRIGHT README xinetd/sample.conf
106
107%config(noreplace) /etc/xinetd.conf
108%config(noreplace) /etc/sysconfig/xinetd
109%{_sbindir}/xinetd
110%{_sbindir}/inetdconvert
111%{_mandir}/*/*
112%config /etc/rc.d/init.d/xinetd
113%config(noreplace) /etc/xinetd.d/*
114
115%changelog
116* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.14-1vl5
117- applied new versioning policy
118
119* Sun Nov 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.14-0vl2
120- fix dependencies ([VineSeed:11559,12368], <bts:398>)
121  - remove Conflicts: inetd
122  - add Provides: inetd
123
124* Wed Mar  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.14-0vl1
125- new upstream release
126- drop patch1
127- remove Provides: inetd
128
129* Sun Feb 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.13-2vl3
130- remove Obosletes: inetd, add Conflicts: inetd
131
132* Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl2
133- rebuild
134
135* Sat Sep 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl1
136- build for VineSeed
137- remove Epoch
138- remove patch0
139- remove Requires: filesystem >= 2.0.1
140- remove BuildRequires: glibc-devel (included in build-essential)
141
142* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
143- rebuilt
144
145* Thu Jan 29 2004 Jay Fenlason <fenlason@redhat.com> 2.3.13-1
146- Upgrade to new upstream version, which obsoletes most patches.
147- Add new tcp_rpc patch, to turn on the nolibwrap flag on tcp rpc services,
148  since libwrap cannot be used on them.
149
150* Sun Dec 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
151- use new technology to filter python dep for inetdconvert instead
152  of changing the -x bit on file permissions
153
154* Wed Nov 12 2003 Jay Fenlason <fenlason@redhat.com> 2.3.12-3
155- build in HEAD for pre FC-2
156- merge from xinetd-3E-branch to fix bugzilla #103009
157  also includes:
158   New upstream version, which obsoletes most of my patches
159   Remove %{_mandir}/man8/xconv.pl*  fixing #90730
160   Remove the servers service, which was removed from 2.3.12
161   Change localization: instead of using en_US in /etc/rc.d/init.d/xinetd
162    (overriding the system default and preventing any customization),
163    /etc/sysconfig/xinetd sets XINETD_LANG, which is either a locale to use
164    or the word "none", which causes all locale environment variables to be
165    cleared before xinetd is started.  This fixes #91403
166   #77724 was fixed by the upgrade to 2.3.12
167   include post 2.3.12 patch from upstream (originally by
168    Matthias Andree <ma+xi@dt.e-technik.uni-dortmund.de>) to add a new
169    "libwrap" parameter.
170    This closes bugs (#91555,#91135,#77724) by making xinetd's behavior
171    documented and user-configurable.
172   Removed the old libwrap/TCP/wait patch.  If anyone actually cares,
173    they can add "flags = NOLIBWRAP" to the configuration of TCP/wait
174    services to get the old behavior.
175   Mark /etc/sysconfig/xinetd as a config file in xinetd.spec
176   Add pie support
177
178* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
179- allow compiling without tcp_wrappers
180
181* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
182- rebuilt
183
184* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
185- rebuilt
186
187* Fri Feb 21 2003 Jay Fenlason <fenlason@redhat.com> 2.3.10-5
188- Merge various patches from xinetd-CVS, since 2.3.11 won't be
189  out in time for our Red Hat Linux release.  One improves range checking
190  on file descriptors.  (A potential security problem.)  Another
191  fixes bugzilla #84840: tcpmux doesn't work at all.  A third improves
192  error checking on tcpmux service entries.  The last improves error
193  checking on service startup. 
194
195* Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-4
196- rebuild
197
198* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-3
199- rebuild
200
201* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
202- rebuilt
203
204* Tue Jan  7 2003 Jay Fenlason <fenlason.redhat.com> 2.3.10-1
205- Fix #81770, #80612, #79219, #79274: New upstream version
206- May also fix #79085, #78903, #78699, #77781, #77760, #76727
207- ... #73805, #60049, #58881, #58855
208- Fix #79999: remove xinetd-ipv6 executable
209- Fix #82021: changed preun to turn off the server
210- try to Fix #74198 by quoting "${NETWORKING}" in xinetd.init
211
212
213* Tue Dec 10 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-6
214- Fix Service startup script to check for id=0
215
216* Tue Nov 19 2002 Bill Nottingham <notting@redhat.com> 2.3.7-5
217- add new stream_wait patch (#74696)
218
219* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-4
220- Fix Service Descriptions
221
222* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-3
223- Fix #77710 Fix Service Descriptions
224
225* Thu Aug 15 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 2.3.7-2
226- Fix #71506 (mixed internal services)
227
228* Mon Aug 12 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.7-1
229- 2.3.7 - this fixes #70504
230
231* Mon Aug  5 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-6
232- Initscript fixes (#70730)
233
234* Wed Jul 17 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-5
235- Add patch for improved cross compiling (#55927)
236
237* Wed Jul  3 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-4
238- #67701
239
240* Wed Jun 26 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5=3
241- Fix maks for access control (#65743)
242- some fixes for config file parsing
243
244* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
245- automated rebuild
246
247* Thu May 30 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-1
248- 2.3.5
249
250* Thu May 23 2002 Tim Powers <timp@redhat.com>
251- automated rebuild
252
253* Mon Apr 22 2002 Trond Eivind Glomsr綬d <teg@redhat.com>
254- 2.3.4 final (bah, never announced... has been out for 3 weeks)
255
256* Thu Apr  4 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.8
257- Add a patch to avoid fam haunting the system
258
259* Tue Apr  2 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.7
260- Add patch from Alex Larson in order not to use tcp_wrappers on tcp/wait -
261  they'd always be 0.0.0.0
262
263* Thu Mar 28 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.6
264- 2002-03-26. 2.3.4 final RSN
265
266* Fri Mar  1 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.5
267- 2002-02-28-1
268
269* Sun Jan  6 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.4
270- 2002-01-04
271- Update URLs
272
273* Fri Dec 14 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.3
274- 2001-12-13
275
276* Mon Dec  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.2
277- 2001-12-03 (fixes #57001, #55738)
278
279* Fri Nov 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.1
280- 2001-11-29, which fixes #56487
281- Add configuration files for the xinetd internal services listing
282  current servers and services. It's off by default, and restricted
283  to localhost when enabled (#52707)
284- Use SIGHUP for configuration reload (change in program)
285
286* Wed Aug 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.3-1
287- 2.3.3
288- parser patch now obsolete
289
290* Thu Aug 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.2-1
291- 2.3.2, which contains the memory overwrite patch,
292  the audit fixes, the conn_free patch and the filelog patch.
293- Fix handling of rpc_version with ranges (like "1-2") (#51737)
294
295* Wed Aug 15 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-7
296- Don't apply the skipjunk patch anymore - xinetd now skips files with ".",
297  which include .rpmsave etc.
298- fix memory overwrite bug in env.c:grow()
299
300* Mon Aug 13 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-6
301- conn_free was called twice...
302- add cps = 25 30 to xinetd.conf. Thus, if a service has many
303  connections (25 in a 1 second period), it will be disabled
304  for 30 seconds. Without this, 10 connections to a service in
305  a second would permanently disable the service (#49122)
306
307* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-5
308- add the patch from "Solar Designer"'s audit
309
310* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-4
311- Make it handle stop and status when IPv6 is enabled (#49621)
312
313* Mon Jul 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
314- Add IPv6 support - separate binary, invoked if
315  NETWORKING_IPV6 is set (#49621)
316- Make inetdconvert handle the "/usr/sbin/in.telnetd in.telnetd"
317  scenario of inetd (#46449)
318
319* Tue Jul  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
320- redo skipjunkfile patch
321
322* Fri Jun 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
323- 2.3.0
324
325* Thu Jun 21 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
326- 2.1.8.9pre16
327
328* Mon Jun  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
329- Remove explicit dependancy on initscripts version
330
331* Sun May 20 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
332- 2.1.8.9pre15, which should fix wait=yes with tcp (linuxconf is
333  the only program I know of using this)
334- fix some problems with UDP internal services (#38669)
335- make /etc/xinetd.conf noreplace
336
337* Wed Apr 25 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
338- Add the tcp wait=yes patch from the xinetd version in a different tree
339
340* Wed Apr  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
341- Add /etc/sysconfig/xinetd so users can add extra options (#34321)
342
343* Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
344- noreplace the xinetd.d files
345
346* Mon Feb  5 2001 Preston Brown <pbrown@redhat.com>
347- built against newer tcp_wrappers that fixes name resolution problem (#16949)
348
349* Mon Feb  5 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
350- Patch from nalin@redhat.com for terminating the environment variables properly
351
352* Tue Jan 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
353- remove PID from log_on_failure flags (#22687)
354
355* Tue Jan 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
356- improve gettextization
357- add "UNLISTED" to the internal udp services (#24279)
358
359* Thu Jan 18 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
360- 2.1.8.9pre14
361
362* Wed Jan 17 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
363- gettextize
364
365* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
366- remove python dependency.
367
368* Tue Dec 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
369- remove RECORD from xinetd.conf for security reasons
370  (no known holes, but better safe than sorry #22687)
371
372* Mon Dec 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
373- unset a couple of environment variables(HOME,MAIL) in the initscript.
374  This should avoid problems like bug #21663
375
376* Fri Dec 01 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
377- rebuild
378
379* Tue Nov 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
380- 2.1.8.9pre13, which should fix #19355
381- changes to initscript - set all locale environment variables
382  to en_US, as the server doesn't know what locale the client
383  expects  and error messages can otherwise be confusing
384  (partially #20566)
385
386* Thu Nov 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
387- fix mismatch in documentation vs. reality, introduced
388  when we changed the behaviour of the access control
389  to use server names (#20567)
390
391* Tue Oct 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
392- obsolete netkit-base, which was inetd's home until 6.2
393 
394* Thu Oct 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
395- 2.1.8.9pre12, which has a new "-stayalive" option so
396  xinetd stays alive even if no services are enabled.
397- use the above in the initscript (#18819)
398
399* Tue Oct 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
400- 2.1.8.9pre11, which includes the previous bugfixes.
401- don't convert the internal services, include
402  such files with xinetd (#17331, #18899)
403
404* Mon Oct 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
405- Add patch to fix segfault problem (#18686)
406
407* Fri Oct 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
408- apply patch from nalin@redhat.com for handling tcp
409  connections with wait=yes properly
410
411* Tue Sep 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
412- add explicit dependency on a modern version of initscripts
413  (#17533)
414
415* Wed Aug 30 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
416- 2.1.8.9pre10 - remove tcpwrapper and pidfile patches,
417  as they are now in.
418- change default startup position to 56, so it
419  starts after bind (#17047)
420
421* Thu Aug 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
422- use the server name not the service name for libwrap
423  checking (#16516). The new way was better, but
424  this is sacrificed so old systems will continue to work
425  and the documentation for tcp_wrappers can be correct.
426
427* Wed Aug 16 2000 Than Ngo <than@redhat.com>
428- fix initscript, test network file before source it (Bug #16247)
429
430* Tue Aug 15 2000 Trond Eivind Glomsr綬d <teg@redhat.com
431- make the pidfile 0644, not 0300 (#16256)
432
433* Tue Aug 08 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
434- added support for "-pidfile" option (#15531)
435
436* Fri Aug 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
437- added patch to ignore .rpmsave, .rpmorig, .rpmnew, ~
438  suffixed files (#15304)
439
440* Thu Aug 03 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
441- 2.1.8.9pre9, old patches are now integrated.
442
443* Wed Aug 02 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
444- fix converting of "wait" argument (#13884)
445- remove tcpd and /usr/sbin/tcpd from inetd.conf services
446  before converting - xinetd is linked against tcp_wrappers
447
448* Mon Jul 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
449- fix linuxconf restart problem (#14856)
450- fix conditional restart
451- mark /etc/xinetd.conf as a configuration file
452
453* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
454- um, we *need* to prereq /etc/init.d
455
456* Mon Jul 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
457- Don't require /etc/init.d
458
459* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
460- rebuild
461
462* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
463- fix the sections of the man pages (#14244)
464
465* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
466- remove itox, as it wouldn't do the right thing with our
467  configuration
468- same with xconv.pl
469- some changes to the installation process
470
471* Mon Jul 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
472- move initscript back to /etc/rc.d/init.d
473
474* Fri Jul 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
475- change process name in init file
476
477* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
478- automatic rebuild
479
480* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
481- start the daemon with the "-reuse" flag
482
483* Thu Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
484- "Prereq:", not "Requires:" for /etc/init.d
485
486* Wed Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
487- require /etc/init.d
488
489* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
490- upper the number of instances to 60
491
492* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
493- fix a memory-allocation bug
494
495* Wed Jun 28 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
496- 2.1.8.9pre8
497
498* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
499- moved to /etc/init.d
500
501* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
502- changed specfile and initfile to implement conditional
503  restart
504
505* Sun Jun 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
506- 2.1.8.9pre7
507- now obsoletes inetd
508- use %%{_tmppath}
509
510* Sun Jun 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
511- 2.1.8.9pre6
512- added converter script which can convert specified or
513  remaing uncoverted services
514- use %%{_mandir}
515- removed +x on xinetd.conf
516
517* Wed May 24 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
518- 2.1.8.9pre4
519- authpriv patch no longer needed
520
521* Tue May 23 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
522- /etc/xinetd.d is now part of the filesystem package
523- more fixes to xinetd.init
524
525* Mon May 22 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
526- fixed some obvious bugs in xinetd.init
527- added a default xinetd.conf
528- patched xinetd to understand LOG_AUTHPRIV
529
530* Fri May 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
531- updated version
532- removed a define %ver (we already have %version)
533- removed some extra CFLAGS declarations
534- added configuration directory, /etc/xinetd.d
535
536* Mon Feb 21 2000 Tim Powers <timp@redhat.com>
537- fixed broken postun sections, should have been *preun*
538- fixed broken gzip of manpages
539
540* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
541- 2.1.8.8p8
542- Fix the init script (Bug #7277)
543- remove our patches (no longer required)
544
545* Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
546- add -lnsl
547
548* Tue Sep 7 1999 Tim Powers <timp@redhat.com>
549- modification top install routine
550
551* Mon Jul 26 1999 Tim Powers <timp@redhat.com>
552- updated source to 2.1.8.6b6
553- built for 6.1
554
555* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
556- update to 2.1.8.6b5
557- build for PowerTools
558
559* Mon Jan 10 1999 Bill Nottingham <notting@redhat.com>
560- update to 2.1.8.5p2
561
562* Tue Dec  1 1998 Bill Nottingham <notting@redhat.com>
563- intial build
Note: See TracBrowser for help on using the repository browser.