source: projects/specs/trunk/x/xinetd/xinetd-vl.spec @ 3310

Revision 3310, 19.1 KB checked in by daisuke, 13 years ago (diff)

xinetd: rebuild for Vine6

Line 
1%define _use_internal_dependency_generator 0
2%define __find_requires %{SOURCE99}
3
4Summary: A secure replacement for inetd.
5Name: xinetd
6Version: 2.3.14
7Release: 2%{?_dist_release}
8License: Distributable (BSD-like)
9Group: System Environment/Daemons
10Source: http://www.xinetd.org/xinetd-%{version}.tar.gz
11Source1: xinetd.init
12Source2: xinetd.conf
13Source3: xinetd-inetdconvert
14Source4: xinetd-ttime
15Source5: xinetd-utime
16Source6: xinetd-tdtime
17Source7: xinetd-udtime
18Source8: xinetd-echo
19Source9: xinetd-uecho
20Source10: xinetd-chargen
21Source11: xinetd-uchargen
22Source12: xinetd.sysconf
23Source13: xinetd-services
24Source99: filter-requires-xinetd.sh
25Patch0: xinetd-2.3.11-pie.patch
26Patch1: xinetd-2.3.13-libwrap.patch
27Patch2: xinetd-2.3.12-tcp_rpc.patch
28Prereq: chkconfig initscripts
29Requires: initscripts setup fileutils
30URL: http://www.xinetd.org/
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32Provides: inetd
33
34%description
35Xinetd is a secure replacement for inetd, the Internet services
36daemon. Xinetd provides access control for all services based on the
37address of the remote host and/or on time of access and can prevent
38denial-of-access attacks. Xinetd provides extensive logging, has no
39limit on the number of server arguments, and lets you bind specific
40services to specific IP addresses on your host machine. Each service
41has its own specific configuration file for Xinetd; the files are
42located in the /etc/xinetd.d directory.
43
44%prep
45%setup -q 
46#%patch0 -p0 -b .pie
47#%patch1 -p1 -b .libwrap
48%patch2 -p1 -b .tcp_rpc
49
50%build
51libtoolize --copy --force
52%configure --with-loadavg --with-inet6 --with-libwrap
53make
54
55%install
56rm -rf $RPM_BUILD_ROOT
57mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
58mkdir -p $RPM_BUILD_ROOT/%{_mandir}
59%makeinstall DAEMONDIR=$RPM_BUILD_ROOT/usr/sbin MANDIR=$RPM_BUILD_ROOT/%{_mandir}
60mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d/
61install -m 755 %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/xinetd
62install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/xinetd.conf
63install -m 755 %SOURCE3 $RPM_BUILD_ROOT/usr/sbin/inetdconvert
64install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/xinetd.d/time
65install -m 644 %SOURCE5 $RPM_BUILD_ROOT/etc/xinetd.d/time-udp
66install -m 644 %SOURCE6 $RPM_BUILD_ROOT/etc/xinetd.d/daytime
67install -m 644 %SOURCE7 $RPM_BUILD_ROOT/etc/xinetd.d/daytime-udp
68install -m 644 %SOURCE8 $RPM_BUILD_ROOT/etc/xinetd.d/echo
69install -m 644 %SOURCE9 $RPM_BUILD_ROOT/etc/xinetd.d/echo-udp
70install -m 644 %SOURCE10 $RPM_BUILD_ROOT/etc/xinetd.d/chargen
71install -m 644 %SOURCE11 $RPM_BUILD_ROOT/etc/xinetd.d/chargen-udp
72install -m 644 %SOURCE13 $RPM_BUILD_ROOT/etc/xinetd.d/services
73
74rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/itox*
75rm -f $RPM_BUILD_ROOT/usr/sbin/itox
76rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xconv.pl*
77rm -f $RPM_BUILD_ROOT/usr/sbin/xconv.pl
78rm -f $RPM_BUILD_ROOT/%{_mandir}/*.3
79
80mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
81install -m 644 %SOURCE12 $RPM_BUILD_ROOT/etc/sysconfig/xinetd
82
83%clean
84rm -rf $RPM_BUILD_ROOT
85
86%post
87if [ $1 = 1 ]; then
88    /sbin/chkconfig --add xinetd
89fi
90
91%preun
92if [ $1 = 0 ]; then
93    /sbin/service xinetd stop > /dev/null 2>&1
94    /sbin/chkconfig --del xinetd
95fi
96
97%postun
98if [ $1 -ge 1 ]; then
99    /sbin/service xinetd condrestart >/dev/null 2>&1
100fi
101
102
103%files
104%defattr(-,root,root)
105%doc INSTALL CHANGELOG COPYRIGHT README xinetd/sample.conf
106
107%config(noreplace) /etc/xinetd.conf
108%config(noreplace) /etc/sysconfig/xinetd
109%{_sbindir}/xinetd
110%{_sbindir}/inetdconvert
111%{_mandir}/*/*
112%config /etc/rc.d/init.d/xinetd
113%config(noreplace) /etc/xinetd.d/*
114
115%changelog
116* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.14-2
117- rebuild for Vine 6
118
119* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.14-1vl5
120- applied new versioning policy
121
122* Sun Nov 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.14-0vl2
123- fix dependencies ([VineSeed:11559,12368], <bts:398>)
124  - remove Conflicts: inetd
125  - add Provides: inetd
126
127* Wed Mar  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.14-0vl1
128- new upstream release
129- drop patch1
130- remove Provides: inetd
131
132* Sun Feb 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.13-2vl3
133- remove Obosletes: inetd, add Conflicts: inetd
134
135* Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl2
136- rebuild
137
138* Sat Sep 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl1
139- build for VineSeed
140- remove Epoch
141- remove patch0
142- remove Requires: filesystem >= 2.0.1
143- remove BuildRequires: glibc-devel (included in build-essential)
144
145* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
146- rebuilt
147
148* Thu Jan 29 2004 Jay Fenlason <fenlason@redhat.com> 2.3.13-1
149- Upgrade to new upstream version, which obsoletes most patches.
150- Add new tcp_rpc patch, to turn on the nolibwrap flag on tcp rpc services,
151  since libwrap cannot be used on them.
152
153* Sun Dec 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
154- use new technology to filter python dep for inetdconvert instead
155  of changing the -x bit on file permissions
156
157* Wed Nov 12 2003 Jay Fenlason <fenlason@redhat.com> 2.3.12-3
158- build in HEAD for pre FC-2
159- merge from xinetd-3E-branch to fix bugzilla #103009
160  also includes:
161   New upstream version, which obsoletes most of my patches
162   Remove %{_mandir}/man8/xconv.pl*  fixing #90730
163   Remove the servers service, which was removed from 2.3.12
164   Change localization: instead of using en_US in /etc/rc.d/init.d/xinetd
165    (overriding the system default and preventing any customization),
166    /etc/sysconfig/xinetd sets XINETD_LANG, which is either a locale to use
167    or the word "none", which causes all locale environment variables to be
168    cleared before xinetd is started.  This fixes #91403
169   #77724 was fixed by the upgrade to 2.3.12
170   include post 2.3.12 patch from upstream (originally by
171    Matthias Andree <ma+xi@dt.e-technik.uni-dortmund.de>) to add a new
172    "libwrap" parameter.
173    This closes bugs (#91555,#91135,#77724) by making xinetd's behavior
174    documented and user-configurable.
175   Removed the old libwrap/TCP/wait patch.  If anyone actually cares,
176    they can add "flags = NOLIBWRAP" to the configuration of TCP/wait
177    services to get the old behavior.
178   Mark /etc/sysconfig/xinetd as a config file in xinetd.spec
179   Add pie support
180
181* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
182- allow compiling without tcp_wrappers
183
184* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
185- rebuilt
186
187* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
188- rebuilt
189
190* Fri Feb 21 2003 Jay Fenlason <fenlason@redhat.com> 2.3.10-5
191- Merge various patches from xinetd-CVS, since 2.3.11 won't be
192  out in time for our Red Hat Linux release.  One improves range checking
193  on file descriptors.  (A potential security problem.)  Another
194  fixes bugzilla #84840: tcpmux doesn't work at all.  A third improves
195  error checking on tcpmux service entries.  The last improves error
196  checking on service startup. 
197
198* Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-4
199- rebuild
200
201* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-3
202- rebuild
203
204* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
205- rebuilt
206
207* Tue Jan  7 2003 Jay Fenlason <fenlason.redhat.com> 2.3.10-1
208- Fix #81770, #80612, #79219, #79274: New upstream version
209- May also fix #79085, #78903, #78699, #77781, #77760, #76727
210- ... #73805, #60049, #58881, #58855
211- Fix #79999: remove xinetd-ipv6 executable
212- Fix #82021: changed preun to turn off the server
213- try to Fix #74198 by quoting "${NETWORKING}" in xinetd.init
214
215
216* Tue Dec 10 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-6
217- Fix Service startup script to check for id=0
218
219* Tue Nov 19 2002 Bill Nottingham <notting@redhat.com> 2.3.7-5
220- add new stream_wait patch (#74696)
221
222* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-4
223- Fix Service Descriptions
224
225* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-3
226- Fix #77710 Fix Service Descriptions
227
228* Thu Aug 15 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 2.3.7-2
229- Fix #71506 (mixed internal services)
230
231* Mon Aug 12 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.7-1
232- 2.3.7 - this fixes #70504
233
234* Mon Aug  5 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-6
235- Initscript fixes (#70730)
236
237* Wed Jul 17 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-5
238- Add patch for improved cross compiling (#55927)
239
240* Wed Jul  3 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-4
241- #67701
242
243* Wed Jun 26 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5=3
244- Fix maks for access control (#65743)
245- some fixes for config file parsing
246
247* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
248- automated rebuild
249
250* Thu May 30 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-1
251- 2.3.5
252
253* Thu May 23 2002 Tim Powers <timp@redhat.com>
254- automated rebuild
255
256* Mon Apr 22 2002 Trond Eivind Glomsr綬d <teg@redhat.com>
257- 2.3.4 final (bah, never announced... has been out for 3 weeks)
258
259* Thu Apr  4 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.8
260- Add a patch to avoid fam haunting the system
261
262* Tue Apr  2 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.7
263- Add patch from Alex Larson in order not to use tcp_wrappers on tcp/wait -
264  they'd always be 0.0.0.0
265
266* Thu Mar 28 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.6
267- 2002-03-26. 2.3.4 final RSN
268
269* Fri Mar  1 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.5
270- 2002-02-28-1
271
272* Sun Jan  6 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.4
273- 2002-01-04
274- Update URLs
275
276* Fri Dec 14 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.3
277- 2001-12-13
278
279* Mon Dec  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.2
280- 2001-12-03 (fixes #57001, #55738)
281
282* Fri Nov 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.1
283- 2001-11-29, which fixes #56487
284- Add configuration files for the xinetd internal services listing
285  current servers and services. It's off by default, and restricted
286  to localhost when enabled (#52707)
287- Use SIGHUP for configuration reload (change in program)
288
289* Wed Aug 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.3-1
290- 2.3.3
291- parser patch now obsolete
292
293* Thu Aug 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.2-1
294- 2.3.2, which contains the memory overwrite patch,
295  the audit fixes, the conn_free patch and the filelog patch.
296- Fix handling of rpc_version with ranges (like "1-2") (#51737)
297
298* Wed Aug 15 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-7
299- Don't apply the skipjunk patch anymore - xinetd now skips files with ".",
300  which include .rpmsave etc.
301- fix memory overwrite bug in env.c:grow()
302
303* Mon Aug 13 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-6
304- conn_free was called twice...
305- add cps = 25 30 to xinetd.conf. Thus, if a service has many
306  connections (25 in a 1 second period), it will be disabled
307  for 30 seconds. Without this, 10 connections to a service in
308  a second would permanently disable the service (#49122)
309
310* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-5
311- add the patch from "Solar Designer"'s audit
312
313* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-4
314- Make it handle stop and status when IPv6 is enabled (#49621)
315
316* Mon Jul 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
317- Add IPv6 support - separate binary, invoked if
318  NETWORKING_IPV6 is set (#49621)
319- Make inetdconvert handle the "/usr/sbin/in.telnetd in.telnetd"
320  scenario of inetd (#46449)
321
322* Tue Jul  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
323- redo skipjunkfile patch
324
325* Fri Jun 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
326- 2.3.0
327
328* Thu Jun 21 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
329- 2.1.8.9pre16
330
331* Mon Jun  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
332- Remove explicit dependancy on initscripts version
333
334* Sun May 20 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
335- 2.1.8.9pre15, which should fix wait=yes with tcp (linuxconf is
336  the only program I know of using this)
337- fix some problems with UDP internal services (#38669)
338- make /etc/xinetd.conf noreplace
339
340* Wed Apr 25 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
341- Add the tcp wait=yes patch from the xinetd version in a different tree
342
343* Wed Apr  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
344- Add /etc/sysconfig/xinetd so users can add extra options (#34321)
345
346* Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
347- noreplace the xinetd.d files
348
349* Mon Feb  5 2001 Preston Brown <pbrown@redhat.com>
350- built against newer tcp_wrappers that fixes name resolution problem (#16949)
351
352* Mon Feb  5 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
353- Patch from nalin@redhat.com for terminating the environment variables properly
354
355* Tue Jan 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
356- remove PID from log_on_failure flags (#22687)
357
358* Tue Jan 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
359- improve gettextization
360- add "UNLISTED" to the internal udp services (#24279)
361
362* Thu Jan 18 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
363- 2.1.8.9pre14
364
365* Wed Jan 17 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
366- gettextize
367
368* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
369- remove python dependency.
370
371* Tue Dec 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
372- remove RECORD from xinetd.conf for security reasons
373  (no known holes, but better safe than sorry #22687)
374
375* Mon Dec 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
376- unset a couple of environment variables(HOME,MAIL) in the initscript.
377  This should avoid problems like bug #21663
378
379* Fri Dec 01 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
380- rebuild
381
382* Tue Nov 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
383- 2.1.8.9pre13, which should fix #19355
384- changes to initscript - set all locale environment variables
385  to en_US, as the server doesn't know what locale the client
386  expects  and error messages can otherwise be confusing
387  (partially #20566)
388
389* Thu Nov 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
390- fix mismatch in documentation vs. reality, introduced
391  when we changed the behaviour of the access control
392  to use server names (#20567)
393
394* Tue Oct 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
395- obsolete netkit-base, which was inetd's home until 6.2
396 
397* Thu Oct 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
398- 2.1.8.9pre12, which has a new "-stayalive" option so
399  xinetd stays alive even if no services are enabled.
400- use the above in the initscript (#18819)
401
402* Tue Oct 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
403- 2.1.8.9pre11, which includes the previous bugfixes.
404- don't convert the internal services, include
405  such files with xinetd (#17331, #18899)
406
407* Mon Oct 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
408- Add patch to fix segfault problem (#18686)
409
410* Fri Oct 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
411- apply patch from nalin@redhat.com for handling tcp
412  connections with wait=yes properly
413
414* Tue Sep 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
415- add explicit dependency on a modern version of initscripts
416  (#17533)
417
418* Wed Aug 30 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
419- 2.1.8.9pre10 - remove tcpwrapper and pidfile patches,
420  as they are now in.
421- change default startup position to 56, so it
422  starts after bind (#17047)
423
424* Thu Aug 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
425- use the server name not the service name for libwrap
426  checking (#16516). The new way was better, but
427  this is sacrificed so old systems will continue to work
428  and the documentation for tcp_wrappers can be correct.
429
430* Wed Aug 16 2000 Than Ngo <than@redhat.com>
431- fix initscript, test network file before source it (Bug #16247)
432
433* Tue Aug 15 2000 Trond Eivind Glomsr綬d <teg@redhat.com
434- make the pidfile 0644, not 0300 (#16256)
435
436* Tue Aug 08 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
437- added support for "-pidfile" option (#15531)
438
439* Fri Aug 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
440- added patch to ignore .rpmsave, .rpmorig, .rpmnew, ~
441  suffixed files (#15304)
442
443* Thu Aug 03 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
444- 2.1.8.9pre9, old patches are now integrated.
445
446* Wed Aug 02 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
447- fix converting of "wait" argument (#13884)
448- remove tcpd and /usr/sbin/tcpd from inetd.conf services
449  before converting - xinetd is linked against tcp_wrappers
450
451* Mon Jul 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
452- fix linuxconf restart problem (#14856)
453- fix conditional restart
454- mark /etc/xinetd.conf as a configuration file
455
456* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
457- um, we *need* to prereq /etc/init.d
458
459* Mon Jul 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
460- Don't require /etc/init.d
461
462* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
463- rebuild
464
465* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
466- fix the sections of the man pages (#14244)
467
468* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
469- remove itox, as it wouldn't do the right thing with our
470  configuration
471- same with xconv.pl
472- some changes to the installation process
473
474* Mon Jul 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
475- move initscript back to /etc/rc.d/init.d
476
477* Fri Jul 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
478- change process name in init file
479
480* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
481- automatic rebuild
482
483* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
484- start the daemon with the "-reuse" flag
485
486* Thu Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
487- "Prereq:", not "Requires:" for /etc/init.d
488
489* Wed Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
490- require /etc/init.d
491
492* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
493- upper the number of instances to 60
494
495* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
496- fix a memory-allocation bug
497
498* Wed Jun 28 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
499- 2.1.8.9pre8
500
501* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
502- moved to /etc/init.d
503
504* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
505- changed specfile and initfile to implement conditional
506  restart
507
508* Sun Jun 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
509- 2.1.8.9pre7
510- now obsoletes inetd
511- use %%{_tmppath}
512
513* Sun Jun 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
514- 2.1.8.9pre6
515- added converter script which can convert specified or
516  remaing uncoverted services
517- use %%{_mandir}
518- removed +x on xinetd.conf
519
520* Wed May 24 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
521- 2.1.8.9pre4
522- authpriv patch no longer needed
523
524* Tue May 23 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
525- /etc/xinetd.d is now part of the filesystem package
526- more fixes to xinetd.init
527
528* Mon May 22 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
529- fixed some obvious bugs in xinetd.init
530- added a default xinetd.conf
531- patched xinetd to understand LOG_AUTHPRIV
532
533* Fri May 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
534- updated version
535- removed a define %ver (we already have %version)
536- removed some extra CFLAGS declarations
537- added configuration directory, /etc/xinetd.d
538
539* Mon Feb 21 2000 Tim Powers <timp@redhat.com>
540- fixed broken postun sections, should have been *preun*
541- fixed broken gzip of manpages
542
543* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
544- 2.1.8.8p8
545- Fix the init script (Bug #7277)
546- remove our patches (no longer required)
547
548* Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
549- add -lnsl
550
551* Tue Sep 7 1999 Tim Powers <timp@redhat.com>
552- modification top install routine
553
554* Mon Jul 26 1999 Tim Powers <timp@redhat.com>
555- updated source to 2.1.8.6b6
556- built for 6.1
557
558* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
559- update to 2.1.8.6b5
560- build for PowerTools
561
562* Mon Jan 10 1999 Bill Nottingham <notting@redhat.com>
563- update to 2.1.8.5p2
564
565* Tue Dec  1 1998 Bill Nottingham <notting@redhat.com>
566- intial build
Note: See TracBrowser for help on using the repository browser.