source: projects/specs/trunk/x/xinetd/xinetd-vl.spec @ 7613

Revision 7613, 19.4 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%define _use_internal_dependency_generator 0
2%define __find_requires %{SOURCE99}
3
4Summary: A secure replacement for inetd.
5Name: xinetd
6Version: 2.3.15
7Release: 1%{?_dist_release}
8License: Distributable (BSD-like)
9Group: System Environment/Daemons
10Source: http://www.xinetd.org/xinetd-%{version}.tar.gz
11Source1: xinetd.init
12Source2: xinetd.conf
13Source3: xinetd-inetdconvert
14Source4: xinetd-ttime
15Source5: xinetd-utime
16Source6: xinetd-tdtime
17Source7: xinetd-udtime
18Source8: xinetd-echo
19Source9: xinetd-uecho
20Source10: xinetd-chargen
21Source11: xinetd-uchargen
22Source12: xinetd.sysconf
23Source13: xinetd-services
24Source99: filter-requires-xinetd.sh
25Patch0: xinetd-2.3.11-pie.patch
26Patch1: xinetd-2.3.13-libwrap.patch
27
28Requires(pre): chkconfig initscripts
29Requires: initscripts setup fileutils
30BuildRequires: tcp_wrappers
31URL: http://www.xinetd.org/
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33Provides: inetd
34
35%description
36Xinetd is a secure replacement for inetd, the Internet services
37daemon. Xinetd provides access control for all services based on the
38address of the remote host and/or on time of access and can prevent
39denial-of-access attacks. Xinetd provides extensive logging, has no
40limit on the number of server arguments, and lets you bind specific
41services to specific IP addresses on your host machine. Each service
42has its own specific configuration file for Xinetd; the files are
43located in the /etc/xinetd.d directory.
44
45%prep
46%setup -q 
47#%patch0 -p0 -b .pie
48#%patch1 -p1 -b .libwrap
49#%patch2 -p1 -b .tcp_rpc
50
51%build
52libtoolize --copy --force
53%configure --with-loadavg --with-inet6 --with-libwrap
54make
55
56%install
57rm -rf $RPM_BUILD_ROOT
58mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
59mkdir -p $RPM_BUILD_ROOT/%{_mandir}
60%makeinstall DAEMONDIR=$RPM_BUILD_ROOT/usr/sbin MANDIR=$RPM_BUILD_ROOT/%{_mandir}
61mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d/
62install -m 755 %SOURCE1 $RPM_BUILD_ROOT/etc/rc.d/init.d/xinetd
63install -m 644 %SOURCE2 $RPM_BUILD_ROOT/etc/xinetd.conf
64install -m 755 %SOURCE3 $RPM_BUILD_ROOT/usr/sbin/inetdconvert
65install -m 644 %SOURCE4 $RPM_BUILD_ROOT/etc/xinetd.d/time
66install -m 644 %SOURCE5 $RPM_BUILD_ROOT/etc/xinetd.d/time-udp
67install -m 644 %SOURCE6 $RPM_BUILD_ROOT/etc/xinetd.d/daytime
68install -m 644 %SOURCE7 $RPM_BUILD_ROOT/etc/xinetd.d/daytime-udp
69install -m 644 %SOURCE8 $RPM_BUILD_ROOT/etc/xinetd.d/echo
70install -m 644 %SOURCE9 $RPM_BUILD_ROOT/etc/xinetd.d/echo-udp
71install -m 644 %SOURCE10 $RPM_BUILD_ROOT/etc/xinetd.d/chargen
72install -m 644 %SOURCE11 $RPM_BUILD_ROOT/etc/xinetd.d/chargen-udp
73install -m 644 %SOURCE13 $RPM_BUILD_ROOT/etc/xinetd.d/services
74
75rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/itox*
76rm -f $RPM_BUILD_ROOT/usr/sbin/itox
77rm -f $RPM_BUILD_ROOT/%{_mandir}/man8/xconv.pl*
78rm -f $RPM_BUILD_ROOT/usr/sbin/xconv.pl
79rm -f $RPM_BUILD_ROOT/%{_mandir}/*.3
80
81mkdir -p $RPM_BUILD_ROOT/etc/sysconfig
82install -m 644 %SOURCE12 $RPM_BUILD_ROOT/etc/sysconfig/xinetd
83
84%clean
85rm -rf $RPM_BUILD_ROOT
86
87%post
88if [ $1 = 1 ]; then
89    /sbin/chkconfig --add xinetd
90fi
91
92%preun
93if [ $1 = 0 ]; then
94    /sbin/service xinetd stop > /dev/null 2>&1
95    /sbin/chkconfig --del xinetd
96fi
97
98%postun
99if [ $1 -ge 1 ]; then
100    /sbin/service xinetd condrestart >/dev/null 2>&1
101fi
102
103
104%files
105%defattr(-,root,root)
106%doc INSTALL CHANGELOG COPYRIGHT README xinetd/sample.conf
107
108%config(noreplace) /etc/xinetd.conf
109%config(noreplace) /etc/sysconfig/xinetd
110%{_sbindir}/xinetd
111%{_sbindir}/inetdconvert
112%{_mandir}/*/*
113%config /etc/rc.d/init.d/xinetd
114%config(noreplace) /etc/xinetd.d/*
115
116%changelog
117* Sat Apr 06 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3.15-1
118- new upstream release
119- deleted Patch2 (upstream merged)
120- fixed date in %%changelog
121
122* Wed Apr 06 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.3.14-3
123- add BuildRequires: tcp_wrappers
124
125* Tue Apr 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.14-2
126- rebuild for Vine 6
127
128* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.14-1vl5
129- applied new versioning policy
130
131* Sun Nov 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.3.14-0vl2
132- fix dependencies ([VineSeed:11559,12368], <bts:398>)
133  - remove Conflicts: inetd
134  - add Provides: inetd
135
136* Wed Mar  1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.14-0vl1
137- new upstream release
138- drop patch1
139- remove Provides: inetd
140
141* Sun Feb 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.13-2vl3
142- remove Obosletes: inetd, add Conflicts: inetd
143
144* Sat Feb 12 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl2
145- rebuild
146
147* Sat Sep 18 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.3.13-2vl1
148- build for VineSeed
149- remove Epoch
150- remove patch0
151- remove Requires: filesystem >= 2.0.1
152- remove BuildRequires: glibc-devel (included in build-essential)
153
154* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
155- rebuilt
156
157* Thu Jan 29 2004 Jay Fenlason <fenlason@redhat.com> 2.3.13-1
158- Upgrade to new upstream version, which obsoletes most patches.
159- Add new tcp_rpc patch, to turn on the nolibwrap flag on tcp rpc services,
160  since libwrap cannot be used on them.
161
162* Sun Dec 28 2003 Florian La Roche <Florian.LaRoche@redhat.de>
163- use new technology to filter python dep for inetdconvert instead
164  of changing the -x bit on file permissions
165
166* Wed Nov 12 2003 Jay Fenlason <fenlason@redhat.com> 2.3.12-3
167- build in HEAD for pre FC-2
168- merge from xinetd-3E-branch to fix bugzilla #103009
169  also includes:
170   New upstream version, which obsoletes most of my patches
171   Remove %{_mandir}/man8/xconv.pl*  fixing #90730
172   Remove the servers service, which was removed from 2.3.12
173   Change localization: instead of using en_US in /etc/rc.d/init.d/xinetd
174    (overriding the system default and preventing any customization),
175    /etc/sysconfig/xinetd sets XINETD_LANG, which is either a locale to use
176    or the word "none", which causes all locale environment variables to be
177    cleared before xinetd is started.  This fixes #91403
178   #77724 was fixed by the upgrade to 2.3.12
179   include post 2.3.12 patch from upstream (originally by
180    Matthias Andree <ma+xi@dt.e-technik.uni-dortmund.de>) to add a new
181    "libwrap" parameter.
182    This closes bugs (#91555,#91135,#77724) by making xinetd's behavior
183    documented and user-configurable.
184   Removed the old libwrap/TCP/wait patch.  If anyone actually cares,
185    they can add "flags = NOLIBWRAP" to the configuration of TCP/wait
186    services to get the old behavior.
187   Mark /etc/sysconfig/xinetd as a config file in xinetd.spec
188   Add pie support
189
190* Tue Sep 23 2003 Florian La Roche <Florian.LaRoche@redhat.de>
191- allow compiling without tcp_wrappers
192
193* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
194- rebuilt
195
196* Mon Feb 24 2003 Elliot Lee <sopwith@redhat.com>
197- rebuilt
198
199* Fri Feb 21 2003 Jay Fenlason <fenlason@redhat.com> 2.3.10-5
200- Merge various patches from xinetd-CVS, since 2.3.11 won't be
201  out in time for our Red Hat Linux release.  One improves range checking
202  on file descriptors.  (A potential security problem.)  Another
203  fixes bugzilla #84840: tcpmux doesn't work at all.  A third improves
204  error checking on tcpmux service entries.  The last improves error
205  checking on service startup. 
206
207* Tue Feb 11 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-4
208- rebuild
209
210* Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 2.3.10-3
211- rebuild
212
213* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
214- rebuilt
215
216* Tue Jan  7 2003 Jay Fenlason <fenlason.redhat.com> 2.3.10-1
217- Fix #81770, #80612, #79219, #79274: New upstream version
218- May also fix #79085, #78903, #78699, #77781, #77760, #76727
219- ... #73805, #60049, #58881, #58855
220- Fix #79999: remove xinetd-ipv6 executable
221- Fix #82021: changed preun to turn off the server
222- try to Fix #74198 by quoting "${NETWORKING}" in xinetd.init
223
224
225* Tue Dec 10 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-6
226- Fix Service startup script to check for id=0
227
228* Tue Nov 19 2002 Bill Nottingham <notting@redhat.com> 2.3.7-5
229- add new stream_wait patch (#74696)
230
231* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-4
232- Fix Service Descriptions
233
234* Wed Nov 13 2002 Dan Walsh <dwalsh@redhat.com> 2.3.7-3
235- Fix #77710 Fix Service Descriptions
236
237* Thu Aug 15 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 2.3.7-2
238- Fix #71506 (mixed internal services)
239
240* Mon Aug 12 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.7-1
241- 2.3.7 - this fixes #70504
242
243* Mon Aug  5 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-6
244- Initscript fixes (#70730)
245
246* Wed Jul 17 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-5
247- Add patch for improved cross compiling (#55927)
248
249* Wed Jul  3 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-4
250- #67701
251
252* Wed Jun 26 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5=3
253- Fix maks for access control (#65743)
254- some fixes for config file parsing
255
256* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
257- automated rebuild
258
259* Thu May 30 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.5-1
260- 2.3.5
261
262* Thu May 23 2002 Tim Powers <timp@redhat.com>
263- automated rebuild
264
265* Mon Apr 22 2002 Trond Eivind Glomsr綬d <teg@redhat.com>
266- 2.3.4 final (bah, never announced... has been out for 3 weeks)
267
268* Thu Apr  4 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.8
269- Add a patch to avoid fam haunting the system
270
271* Tue Apr  2 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.7
272- Add patch from Alex Larson in order not to use tcp_wrappers on tcp/wait -
273  they'd always be 0.0.0.0
274
275* Thu Mar 28 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.6
276- 2002-03-26. 2.3.4 final RSN
277
278* Fri Mar  1 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.5
279- 2002-02-28-1
280
281* Sun Jan  6 2002 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.4
282- 2002-01-04
283- Update URLs
284
285* Fri Dec 14 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.3
286- 2001-12-13
287
288* Mon Dec  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.2
289- 2001-12-03 (fixes #57001, #55738)
290
291* Fri Nov 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.4-0.1
292- 2001-11-29, which fixes #56487
293- Add configuration files for the xinetd internal services listing
294  current servers and services. It's off by default, and restricted
295  to localhost when enabled (#52707)
296- Use SIGHUP for configuration reload (change in program)
297
298* Wed Aug 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.3-1
299- 2.3.3
300- parser patch now obsolete
301
302* Thu Aug 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.2-1
303- 2.3.2, which contains the memory overwrite patch,
304  the audit fixes, the conn_free patch and the filelog patch.
305- Fix handling of rpc_version with ranges (like "1-2") (#51737)
306
307* Wed Aug 15 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-7
308- Don't apply the skipjunk patch anymore - xinetd now skips files with ".",
309  which include .rpmsave etc.
310- fix memory overwrite bug in env.c:grow()
311
312* Mon Aug 13 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-6
313- conn_free was called twice...
314- add cps = 25 30 to xinetd.conf. Thus, if a service has many
315  connections (25 in a 1 second period), it will be disabled
316  for 30 seconds. Without this, 10 connections to a service in
317  a second would permanently disable the service (#49122)
318
319* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-5
320- add the patch from "Solar Designer"'s audit
321
322* Thu Aug  9 2001 Trond Eivind Glomsr綬d <teg@redhat.com> 2.3.0-4
323- Make it handle stop and status when IPv6 is enabled (#49621)
324
325* Mon Jul 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
326- Add IPv6 support - separate binary, invoked if
327  NETWORKING_IPV6 is set (#49621)
328- Make inetdconvert handle the "/usr/sbin/in.telnetd in.telnetd"
329  scenario of inetd (#46449)
330
331* Tue Jul  3 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
332- redo skipjunkfile patch
333
334* Fri Jun 29 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
335- 2.3.0
336
337* Thu Jun 21 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
338- 2.1.8.9pre16
339
340* Mon Jun  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
341- Remove explicit dependancy on initscripts version
342
343* Sun May 20 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
344- 2.1.8.9pre15, which should fix wait=yes with tcp (linuxconf is
345  the only program I know of using this)
346- fix some problems with UDP internal services (#38669)
347- make /etc/xinetd.conf noreplace
348
349* Wed Apr 25 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
350- Add the tcp wait=yes patch from the xinetd version in a different tree
351
352* Wed Apr  4 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
353- Add /etc/sysconfig/xinetd so users can add extra options (#34321)
354
355* Tue Feb 27 2001 Preston Brown <pbrown@redhat.com>
356- noreplace the xinetd.d files
357
358* Mon Feb  5 2001 Preston Brown <pbrown@redhat.com>
359- built against newer tcp_wrappers that fixes name resolution problem (#16949)
360
361* Mon Feb  5 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
362- Patch from nalin@redhat.com for terminating the environment variables properly
363
364* Tue Jan 30 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
365- remove PID from log_on_failure flags (#22687)
366
367* Tue Jan 23 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
368- improve gettextization
369- add "UNLISTED" to the internal udp services (#24279)
370
371* Thu Jan 18 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
372- 2.1.8.9pre14
373
374* Wed Jan 17 2001 Trond Eivind Glomsr綬d <teg@redhat.com>
375- gettextize
376
377* Sat Dec 30 2000 Jeff Johnson <jbj@redhat.com>
378- remove python dependency.
379
380* Tue Dec 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
381- remove RECORD from xinetd.conf for security reasons
382  (no known holes, but better safe than sorry #22687)
383
384* Mon Dec 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
385- unset a couple of environment variables(HOME,MAIL) in the initscript.
386  This should avoid problems like bug #21663
387
388* Fri Dec 01 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
389- rebuild
390
391* Tue Nov 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
392- 2.1.8.9pre13, which should fix #19355
393- changes to initscript - set all locale environment variables
394  to en_US, as the server doesn't know what locale the client
395  expects  and error messages can otherwise be confusing
396  (partially #20566)
397
398* Thu Nov 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
399- fix mismatch in documentation vs. reality, introduced
400  when we changed the behaviour of the access control
401  to use server names (#20567)
402
403* Tue Oct 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
404- obsolete netkit-base, which was inetd's home until 6.2
405 
406* Thu Oct 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
407- 2.1.8.9pre12, which has a new "-stayalive" option so
408  xinetd stays alive even if no services are enabled.
409- use the above in the initscript (#18819)
410
411* Tue Oct 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
412- 2.1.8.9pre11, which includes the previous bugfixes.
413- don't convert the internal services, include
414  such files with xinetd (#17331, #18899)
415
416* Mon Oct 09 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
417- Add patch to fix segfault problem (#18686)
418
419* Fri Oct 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
420- apply patch from nalin@redhat.com for handling tcp
421  connections with wait=yes properly
422
423* Tue Sep 26 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
424- add explicit dependency on a modern version of initscripts
425  (#17533)
426
427* Wed Aug 30 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
428- 2.1.8.9pre10 - remove tcpwrapper and pidfile patches,
429  as they are now in.
430- change default startup position to 56, so it
431  starts after bind (#17047)
432
433* Thu Aug 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
434- use the server name not the service name for libwrap
435  checking (#16516). The new way was better, but
436  this is sacrificed so old systems will continue to work
437  and the documentation for tcp_wrappers can be correct.
438
439* Wed Aug 16 2000 Than Ngo <than@redhat.com>
440- fix initscript, test network file before source it (Bug #16247)
441
442* Tue Aug 15 2000 Trond Eivind Glomsr綬d <teg@redhat.com
443- make the pidfile 0644, not 0300 (#16256)
444
445* Tue Aug 08 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
446- added support for "-pidfile" option (#15531)
447
448* Fri Aug 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
449- added patch to ignore .rpmsave, .rpmorig, .rpmnew, ~
450  suffixed files (#15304)
451
452* Thu Aug 03 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
453- 2.1.8.9pre9, old patches are now integrated.
454
455* Wed Aug 02 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
456- fix converting of "wait" argument (#13884)
457- remove tcpd and /usr/sbin/tcpd from inetd.conf services
458  before converting - xinetd is linked against tcp_wrappers
459
460* Mon Jul 31 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
461- fix linuxconf restart problem (#14856)
462- fix conditional restart
463- mark /etc/xinetd.conf as a configuration file
464
465* Tue Jul 25 2000 Bill Nottingham <notting@redhat.com>
466- um, we *need* to prereq /etc/init.d
467
468* Mon Jul 24 2000 Bernhard Rosenkraenzer <bero@redhat.com>
469- Don't require /etc/init.d
470
471* Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
472- rebuild
473
474* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
475- fix the sections of the man pages (#14244)
476
477* Tue Jul 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
478- remove itox, as it wouldn't do the right thing with our
479  configuration
480- same with xconv.pl
481- some changes to the installation process
482
483* Mon Jul 17 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
484- move initscript back to /etc/rc.d/init.d
485
486* Fri Jul 14 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
487- change process name in init file
488
489* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
490- automatic rebuild
491
492* Fri Jul  7 2000 Nalin Dahyabhai <nalin@redhat.com>
493- start the daemon with the "-reuse" flag
494
495* Thu Jul 06 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
496- "Prereq:", not "Requires:" for /etc/init.d
497
498* Wed Jul 05 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
499- require /etc/init.d
500
501* Wed Jul  5 2000 Florian La Roche <Florian.LaRoche@redhat.com>
502- upper the number of instances to 60
503
504* Sun Jul  2 2000 Nalin Dahyabhai <nalin@redhat.com>
505- fix a memory-allocation bug
506
507* Wed Jun 28 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
508- 2.1.8.9pre8
509
510* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
511- moved to /etc/init.d
512
513* Wed Jun 21 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
514- changed specfile and initfile to implement conditional
515  restart
516
517* Sun Jun 18 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
518- 2.1.8.9pre7
519- now obsoletes inetd
520- use %%{_tmppath}
521
522* Sun Jun 04 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
523- 2.1.8.9pre6
524- added converter script which can convert specified or
525  remaing uncoverted services
526- use %%{_mandir}
527- removed +x on xinetd.conf
528
529* Wed May 24 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
530- 2.1.8.9pre4
531- authpriv patch no longer needed
532
533* Tue May 23 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
534- /etc/xinetd.d is now part of the filesystem package
535- more fixes to xinetd.init
536
537* Mon May 22 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
538- fixed some obvious bugs in xinetd.init
539- added a default xinetd.conf
540- patched xinetd to understand LOG_AUTHPRIV
541
542* Fri May 19 2000 Trond Eivind Glomsr綬d <teg@redhat.com>
543- updated version
544- removed a define %ver (we already have %version)
545- removed some extra CFLAGS declarations
546- added configuration directory, /etc/xinetd.d
547
548* Mon Feb 21 2000 Tim Powers <timp@redhat.com>
549- fixed broken postun sections, should have been *preun*
550- fixed broken gzip of manpages
551
552* Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
553- 2.1.8.8p8
554- Fix the init script (Bug #7277)
555- remove our patches (no longer required)
556
557* Tue Sep 21 1999 Bill Nottingham <notting@redhat.com>
558- add -lnsl
559
560* Tue Sep 7 1999 Tim Powers <timp@redhat.com>
561- modification top install routine
562
563* Mon Jul 26 1999 Tim Powers <timp@redhat.com>
564- updated source to 2.1.8.6b6
565- built for 6.1
566
567* Mon Apr 26 1999 Bill Nottingham <notting@redhat.com>
568- update to 2.1.8.6b5
569- build for PowerTools
570
571* Mon Jan 11 1999 Bill Nottingham <notting@redhat.com>
572- update to 2.1.8.5p2
573
574* Tue Dec  1 1998 Bill Nottingham <notting@redhat.com>
575- intial build
Note: See TracBrowser for help on using the repository browser.