source: projects/specs/trunk/w/wxGTK3/wxGTK3-vl.spec @ 12487

Revision 12487, 7.3 KB checked in by tomop, 3 months ago (diff)

updated 11 packages

chrony-3.5.1-2

dnsmasq-2.82-1

epiphany-3.36.4-2

filezilla-3.50.0-1

gnutls-3.6.15-1

libfilezilla-0.24.1-1

nettle-3.6-1

rdesktop-1.9.0-2

tigervnc-1.10.1-2

webkitgtk4-2.28.4-1

wxGTK3-3.0.5-1

Line 
1%global srcname wxWidgets
2%global wxgtkname wxGTK3
3%global wxbasename wxBase3
4
5%global gtkver 3
6
7Summary:        GTK port of the wxWidgets GUI library
8Name:           %{wxgtkname}
9Version:        3.0.5
10Release:        1%{?_dist_release}
11Group:          system
12Vendor:         Project Vine
13Distribution:   Vine Linux
14
15License:        wxWidgets
16URL:            http://www.wxwidgets.org/
17Source0:        https://github.com/wxWidgets/wxWidgets/releases/download/v%{version}/wxWidgets-%{version}.tar.bz2
18Source10:       wx-config
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  gtk%{gtkver}-devel
22#Note webkitgtk (GTK2) does not appear to be supported
23
24BuildRequires:  webkitgtk4-devel
25BuildRequires:  zlib-devel
26BuildRequires:  libpng-devel
27BuildRequires:  libjpeg-turbo-devel
28BuildRequires:  libtiff-devel
29BuildRequires:  expat-devel
30BuildRequires:  SDL2-devel
31BuildRequires:  libGLU-devel
32BuildRequires:  libSM-devel
33BuildRequires:  gstreamer1-plugins-base-devel
34BuildRequires:  GConf2-devel
35BuildRequires:  gettext
36BuildRequires:  cppunit-devel
37BuildRequires:  libmspack-devel
38
39Provides:       %{srcname} = %{version}-%{release}
40Requires:       %{wxbasename}%{?_isa} = %{version}-%{release}
41
42%description
43wxWidgets is the GTK port of the C++ cross-platform wxWidgets
44GUI library, offering classes for all common GUI controls as well as a
45comprehensive set of helper classes for most common application tasks,
46ranging from networking to HTML display and image manipulation.
47
48
49%package        devel
50Summary:        Development files for the wxGTK3 library
51Group:          programming
52Requires:       %{name}%{?_isa} = %{version}-%{release}
53Requires:       %{wxbasename} = %{version}-%{release}
54Requires:       gtk%{gtkver}-devel
55Requires:       libGLU-devel
56Provides:       %{srcname}-devel = %{version}-%{release}
57
58%description devel
59This package include files needed to link with the wxGTK3 library.
60wxWidgets is the GTK port of the C++ cross-platform wxWidgets
61GUI library, offering classes for all common GUI controls as well as a
62comprehensive set of helper classes for most common application tasks,
63ranging from networking to HTML display and image manipulation.
64
65
66%package -n     %{wxbasename}
67Summary:        Non-GUI support classes from the wxWidgets library
68Group:          system
69
70%description -n %{wxbasename}
71Every wxWidgets application must link against this library. It contains
72mandatory classes that any wxWidgets code depends on (like wxString) and
73portability classes that abstract differences between platforms. wxBase can
74be used to develop console mode applications -- it does not require any GUI
75libraries or the X Window System.
76
77
78#%package        docs
79#Group:          Development/Libraries
80#Summary:        Documentation for the wxGTK3 library
81#Requires:       %{name} = %{version}-%{release}
82#Provides:       %{srcname}-docs = %{version}-%{release}
83#BuildArch:      noarch
84
85#%description docs
86#This package provides documentation for the %{srcname} library.
87
88
89%debug_package
90
91
92%prep
93%setup -q -n %{srcname}-%{version}
94
95# in case of gtk3
96%if %{gtkver} == 3
97sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
98%endif
99
100# patch some installed files to avoid conflicts with 2.8.*
101sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
102sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
103sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
104
105# rename docs directory
106#mv %{srcname}-%{version} html
107
108sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
109
110# fix plugin dir for 64-bit
111sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
112
113
114%build
115# likely still dereferences type-punned pointers
116CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
117CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
118# fix unused-direct-shlib-dependency error:
119export LDFLAGS="-Wl,--as-needed"
120
121%configure \
122  --with-gtk=%{gtkver} \
123  --with-opengl \
124  --with-sdl \
125  --with-gnomeprint \
126  --with-libmspack \
127  --enable-intl \
128  --enable-no_deps \
129  --disable-rpath \
130  --enable-ipv6 \
131  --enable-utf8 \
132
133make %{?_smp_mflags}
134
135%install
136%makeinstall
137
138# install our multilib-aware wrapper
139rm %{buildroot}%{_bindir}/wx-config
140rm %{buildroot}%{_bindir}/wxrc
141install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
142
143# move bakefiles to avoid conflicts with 2.8.*
144mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
145mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
146
147%find_lang wxstd3
148%find_lang wxmsw3
149cat wxmsw3.lang >> wxstd3.lang
150
151%check
152pushd tests
153make %{?_smp_mflags} test
154popd
155
156%post -p /sbin/ldconfig
157%postun -p /sbin/ldconfig
158
159%post -n %{wxbasename} -p /sbin/ldconfig
160%postun -n %{wxbasename} -p /sbin/ldconfig
161
162%files -f wxstd3.lang
163%license docs/gpl.txt docs/lgpl.txt docs/licence.txt docs/licendoc.txt docs/preamble.txt
164%doc docs/changes.txt docs/readme.txt
165%{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
166%{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
167%{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
168%{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
169%{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
170%{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
171%{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
172%{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
173%{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
174%{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
175%{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
176%if %{gtkver} == 3
177%{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
178%endif
179%{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
180
181%files devel
182%{_bindir}/wx-config*
183%{_bindir}/wxrc-3.0
184%{_includedir}/wx-3.0
185%{_libdir}/libwx_*.so
186%{_libdir}/wx
187%{_datadir}/aclocal/wxwin3.m4
188%{_datadir}/bakefile/presets/wx3/
189
190%files -n %{wxbasename}
191%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
192%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
193%{_libdir}/libwx_baseu-*.so.*
194%{_libdir}/libwx_baseu_net-*.so.*
195%{_libdir}/libwx_baseu_xml-*.so.*
196
197#%files docs
198#%doc html
199
200%changelog
201* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.5-1
202- new upstream release.
203
204* Sun Oct 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.4-1
205- new upstream release.
206
207* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.2-2
208- rebuilt with new toolchain.
209
210* Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
211- new upstream release
212
213* Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
214- initial build for Vine Linux
215
216* Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
217- Bump to 3.0.1 RH#1076617
218
219* Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
220- Removed disable-catch_segvs, see RH#1076617
221
222* Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
223- Renable combat28 - without it causes bugs RH#1076617 and a few others
224
225* Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
226- Fixed GTK3 bug with wx-config
227- Fixed a unused-direct-shlib-dependency error
228
229* Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
230- Added patch to avoid build fail on gtk 3.10+
231- Reverted patching to make devel package compatible with wxGTK-devel
232- Added combatibility for RHEL 6+
233- Changed all mention of GTK3 and GTK2 to GTK for consistency
234
235* Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
236- Changed to build against gtk3
237- Add webkit to build requires
238- Removed patching to make devel package compatible with wxGTK-devel
239- Disable 2.8.* combatibility (redundant functionality)
240
241* Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
242- Initial build of wxwidgets version 3, mostly based on wxGTK spec
Note: See TracBrowser for help on using the repository browser.