source: projects/specs/trunk/w/wxGTK3/wxGTK3-vl.spec @ 12242

Revision 12242, 7.3 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

audacity-2.2.2-1

empathy-3.12.14-2

gthumb-3.8.1-1

liferea-1.12.7-1

libjpeg-turbo-2.0.3-2

libmspack-0.10.1-1

wxGTK3-3.0.4-1

Line 
1%global srcname wxWidgets
2%global wxgtkname wxGTK3
3%global wxbasename wxBase3
4
5%global gtkver 3
6
7Name:           %{wxgtkname}
8Version:        3.0.4
9Release:        1%{?_dist_release}
10Summary:        GTK port of the wxWidgets GUI library
11License:        wxWidgets
12Group:          System Environment/Libraries
13URL:            http://www.wxwidgets.org/
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17Source0:        https://github.com/wxWidgets/wxWidgets/releases/download/v%{version}/wxWidgets-%{version}.tar.bz2
18Source10:       wx-config
19
20BuildRoot: %{_tmppath}/%{name}-%{version}-root
21BuildRequires:  gtk%{gtkver}-devel
22#Note webkitgtk (GTK2) does not appear to be supported
23
24BuildRequires:  webkitgtk4-devel
25BuildRequires:  zlib-devel
26BuildRequires:  libpng-devel
27BuildRequires:  libjpeg-turbo-devel
28BuildRequires:  libtiff-devel
29BuildRequires:  expat-devel
30BuildRequires:  SDL-devel
31BuildRequires:  libgnomeprintui-devel
32BuildRequires:  libGLU-devel
33BuildRequires:  libSM-devel
34BuildRequires:  gstreamer-plugins-base-devel
35BuildRequires:  GConf2-devel
36BuildRequires:  gettext
37BuildRequires:  cppunit-devel
38BuildRequires:  libmspack-devel
39
40Provides:       %{srcname} = %{version}-%{release}
41Requires:       %{wxbasename}%{?_isa} = %{version}-%{release}
42
43%description
44wxWidgets is the GTK port of the C++ cross-platform wxWidgets
45GUI library, offering classes for all common GUI controls as well as a
46comprehensive set of helper classes for most common application tasks,
47ranging from networking to HTML display and image manipulation.
48
49
50%package        devel
51Group:          Development/Libraries
52Summary:        Development files for the wxGTK3 library
53Requires:       %{name}%{?_isa} = %{version}-%{release}
54Requires:       %{wxbasename} = %{version}-%{release}
55Requires:       gtk%{gtkver}-devel
56Requires:       libGLU-devel
57Provides:       %{srcname}-devel = %{version}-%{release}
58
59%description devel
60This package include files needed to link with the wxGTK3 library.
61wxWidgets is the GTK port of the C++ cross-platform wxWidgets
62GUI library, offering classes for all common GUI controls as well as a
63comprehensive set of helper classes for most common application tasks,
64ranging from networking to HTML display and image manipulation.
65
66
67%package -n     %{wxbasename}
68Summary:        Non-GUI support classes from the wxWidgets library
69Group:          System Environment/Libraries
70
71%description -n %{wxbasename}
72Every wxWidgets application must link against this library. It contains
73mandatory classes that any wxWidgets code depends on (like wxString) and
74portability classes that abstract differences between platforms. wxBase can
75be used to develop console mode applications -- it does not require any GUI
76libraries or the X Window System.
77
78
79#%package        docs
80#Group:          Development/Libraries
81#Summary:        Documentation for the wxGTK3 library
82#Requires:       %{name} = %{version}-%{release}
83#Provides:       %{srcname}-docs = %{version}-%{release}
84#BuildArch:      noarch
85
86#%description docs
87#This package provides documentation for the %{srcname} library.
88
89
90%prep
91%setup -q -n %{srcname}-%{version}
92
93# in case of gtk3
94%if %{gtkver} == 3
95sed -i -e 's|gtk2|gtk3|' %{SOURCE10}
96%endif
97
98# patch some installed files to avoid conflicts with 2.8.*
99sed -i -e 's|aclocal)|aclocal/wxwin3.m4)|' Makefile.in
100sed -i -e 's|wxstd.mo|wxstd3.mo|' Makefile.in
101sed -i -e 's|wxmsw.mo|wxmsw3.mo|' Makefile.in
102
103# rename docs directory
104#mv %{srcname}-%{version} html
105
106sed -i -e 's|/usr/lib\b|%{_libdir}|' wx-config.in configure
107
108# fix plugin dir for 64-bit
109sed -i -e 's|/lib|/%{_lib}|' src/unix/stdpaths.cpp
110
111
112%build
113# likely still dereferences type-punned pointers
114CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
115CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
116# fix unused-direct-shlib-dependency error:
117export LDFLAGS="-Wl,--as-needed"
118
119%configure \
120  --with-gtk=%{gtkver} \
121  --with-opengl \
122  --with-sdl \
123  --with-gnomeprint \
124  --with-libmspack \
125  --enable-intl \
126  --enable-no_deps \
127  --disable-rpath \
128  --enable-ipv6 \
129  --enable-utf8 \
130
131make %{?_smp_mflags}
132
133%install
134%makeinstall
135
136# install our multilib-aware wrapper
137rm %{buildroot}%{_bindir}/wx-config
138rm %{buildroot}%{_bindir}/wxrc
139install -p -m 755 %{SOURCE10} %{buildroot}%{_bindir}/wx-config-3.0
140
141# move bakefiles to avoid conflicts with 2.8.*
142mkdir %{buildroot}%{_datadir}/bakefile/presets/wx3
143mv %{buildroot}%{_datadir}/bakefile/presets/*.* %{buildroot}%{_datadir}/bakefile/presets/wx3
144
145%find_lang wxstd3
146%find_lang wxmsw3
147cat wxmsw3.lang >> wxstd3.lang
148
149%check
150pushd tests
151make %{?_smp_mflags} test
152popd
153
154%post -p /sbin/ldconfig
155%postun -p /sbin/ldconfig
156
157%post -n %{wxbasename} -p /sbin/ldconfig
158%postun -n %{wxbasename} -p /sbin/ldconfig
159
160%files -f wxstd3.lang
161%license docs/gpl.txt docs/lgpl.txt docs/licence.txt docs/licendoc.txt docs/preamble.txt
162%doc docs/changes.txt docs/readme.txt
163%{_libdir}/libwx_gtk%{gtkver}u_adv-*.so.*
164%{_libdir}/libwx_gtk%{gtkver}u_aui-*.so.*
165%{_libdir}/libwx_gtk%{gtkver}u_core-*.so.*
166%{_libdir}/libwx_gtk%{gtkver}u_html-*.so.*
167%{_libdir}/libwx_gtk%{gtkver}u_gl-*.so.*
168%{_libdir}/libwx_gtk%{gtkver}u_media-*.so.*
169%{_libdir}/libwx_gtk%{gtkver}u_propgrid-*.so.*
170%{_libdir}/libwx_gtk%{gtkver}u_qa-*.so.*
171%{_libdir}/libwx_gtk%{gtkver}u_ribbon-*.so.*
172%{_libdir}/libwx_gtk%{gtkver}u_richtext-*.so.*
173%{_libdir}/libwx_gtk%{gtkver}u_stc-*.so.*
174%if %{gtkver} == 3
175%{_libdir}/libwx_gtk%{gtkver}u_webview-*.so.*
176%endif
177%{_libdir}/libwx_gtk%{gtkver}u_xrc-*.so.*
178
179%files devel
180%{_bindir}/wx-config*
181%{_bindir}/wxrc-3.0
182%{_includedir}/wx-3.0
183%{_libdir}/libwx_*.so
184%{_libdir}/wx
185%{_datadir}/aclocal/wxwin3.m4
186%{_datadir}/bakefile/presets/wx3/
187
188%files -n %{wxbasename}
189%doc docs/changes.txt docs/gpl.txt docs/lgpl.txt docs/licence.txt
190%doc docs/licendoc.txt docs/preamble.txt docs/readme.txt
191%{_libdir}/libwx_baseu-*.so.*
192%{_libdir}/libwx_baseu_net-*.so.*
193%{_libdir}/libwx_baseu_xml-*.so.*
194
195#%files docs
196#%doc html
197
198%changelog
199* Sun Oct 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.4-1
200- new upstream release.
201
202* Fri Jul  1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.0.2-2
203- rebuilt with new toolchain.
204
205* Sat Nov 29 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 3.0.2-1
206- new upstream release
207
208* Fri Sep 05 2014 Toshiharu Kudoh <kudoh@vinelinux.org> - 3.0.1-1
209- initial build for Vine Linux
210
211* Sat Jul 5 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.1-1
212- Bump to 3.0.1 RH#1076617
213
214* Tue Mar 18 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-6
215- Removed disable-catch_segvs, see RH#1076617
216
217* Mon Mar 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-5
218- Renable combat28 - without it causes bugs RH#1076617 and a few others
219
220* Wed Feb 19 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-4
221- Fixed GTK3 bug with wx-config
222- Fixed a unused-direct-shlib-dependency error
223
224* Mon Feb 17 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-3
225- Added patch to avoid build fail on gtk 3.10+
226- Reverted patching to make devel package compatible with wxGTK-devel
227- Added combatibility for RHEL 6+
228- Changed all mention of GTK3 and GTK2 to GTK for consistency
229
230* Mon Feb 10 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-2
231- Changed to build against gtk3
232- Add webkit to build requires
233- Removed patching to make devel package compatible with wxGTK-devel
234- Disable 2.8.* combatibility (redundant functionality)
235
236* Sat Jan 4 2014 Jeremy Newton <alexjnewt@hotmail.com> - 3.0.0-1
237- Initial build of wxwidgets version 3, mostly based on wxGTK spec
Note: See TracBrowser for help on using the repository browser.