source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12508

Revision 12508, 10.7 KB checked in by tomop, 3 years ago (diff)

updated 14 packages

cups-2.3.3-1

firefox-78.5.0-1

golang-1.15.5-1

kernel-5.4.80-1

krb5-1.18.3-1

mariadb-10.5.8-1

nsd-4.3.4-1

php74-7.4.13-1

postfix-3.5.8-1

postgresql-13.1-1

thunderbird-78.5.1-1

tmux-3.1c-1

unbound-1.13.0-1

webkitgtk4-2.30.3-1

Line 
1%bcond_with systemd
2%bcond_with clang
3
4## NOTE: Lots of files in various subdirectories have the same name (such as
5## "LICENSE") so this short macro allows us to distinguish them by using their
6## directory names (from the source tree) as prefixes for the files.
7%global add_to_license_files() \
8        mkdir -p _license_files ; \
9        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
10
11Summary:        GTK+ Web content engine library
12Name:           webkitgtk4
13Version:        2.30.3
14Release:        1%{?_dist_release}%{?with_systemd:.systemd}
15Group:          system
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19License:        LGPLv2
20URL:            http://www.webkitgtk.org/
21Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23%if %{with clang}
24BuildRequires:  clang
25BuildRequires:  lld
26%endif
27BuildRequires:  at-spi2-core-devel
28BuildRequires:  bison
29BuildRequires:  bubblewrap
30BuildRequires:  cairo-devel
31BuildRequires:  cmake
32BuildRequires:  enchant2-devel
33BuildRequires:  flex
34BuildRequires:  fontconfig-devel
35BuildRequires:  freetype-devel
36BuildRequires:  geoclue2-devel
37BuildRequires:  gettext
38BuildRequires:  glib2-devel
39BuildRequires:  gobject-introspection-devel
40BuildRequires:  gperf
41BuildRequires:  gstreamer1-devel
42BuildRequires:  gstreamer1-plugins-base-devel
43BuildRequires:  gtk2-devel
44BuildRequires:  gtk3-devel
45BuildRequires:  harfbuzz-icu-devel
46BuildRequires:  libicu-devel
47BuildRequires:  libjpeg-turbo-devel
48BuildRequires:  libpng-devel
49BuildRequires:  libseccomp-devel
50BuildRequires:  libsecret-devel
51BuildRequires:  libsoup-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libxslt-devel
54BuildRequires:  libXt-devel
55BuildRequires:  ninja
56BuildRequires:  mesa-libGL-devel
57BuildRequires:  pcre-devel
58BuildRequires:  python3-devel
59BuildRequires:  ruby
60BuildRequires:  sqlite3-devel
61BuildRequires:  libnotify-devel
62BuildRequires:  hyphen-devel
63BuildRequires:  woff2-devel
64BuildRequires:  xdg-dbus-proxy
65%if %{with systemd}
66BuildRequires:  systemd-devel
67%endif
68
69Requires:       geoclue2
70
71# for sandbox
72Requires:       bubblewrap
73Requires:       xdg-dbus-proxy
74
75# Require the jsc subpackage
76Requires:       %{name}-jsc = %{version}-%{release}
77
78# Obsolete libwebkit2gtk from the webkitgtk3 package
79Obsoletes:      libwebkit2gtk < 2.4.5-3
80Provides:       libwebkit2gtk = %{version}-%{release}
81
82# Filter out provides for private libraries
83%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
84
85%description
86WebKitGTK+ is the port of the portable web rendering engine WebKit to the
87GTK+ platform.
88
89This package contains WebKitGTK+ for GTK+ 3.
90
91
92%package        devel
93Summary:        Development files for %{name}
94Group:                  programming
95Requires:       %{name} = %{version}-%{release}
96Requires:       %{name}-jsc-devel = %{version}-%{release}
97
98%description    devel
99The %{name}-devel package contains libraries, build data, and header
100files for developing applications that use %{name}.
101
102
103%package        jsc
104Summary:        JavaScript engine from %{name}
105Group:                  system
106
107%description    jsc
108This package contains JavaScript engine from %{name}.
109
110
111%package        jsc-devel
112Summary:        Development files for JavaScript engine from %{name}
113Group:                  programming
114Requires:       %{name}-jsc = %{version}-%{release}
115
116%description    jsc-devel
117The %{name}-jsc-devel package contains libraries, build data, and header
118files for developing applications that use JavaScript engine from %{name}.
119
120
121%debug_package
122
123
124%prep
125%setup -q -n webkitgtk-%{version}
126
127# Remove bundled libraries
128rm -rf Source/ThirdParty/leveldb/
129rm -rf Source/ThirdParty/gtest/
130rm -rf Source/ThirdParty/qunit/
131
132
133%build
134# binutils-2.23 doesn't support "reduce-memory-overheads"
135# Use linker flags to reduce memory consumption
136# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
137
138%if %{with clang}
139%ifnarch x86_64
140%define cflags_add --rtlib=compiler-rt
141%endif
142
143%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
144%else
145%global optflags  %{optflags} -DENABLE_YARR_JIT=0
146%endif
147
148mkdir -p %{_target_platform}
149pushd %{_target_platform}
150
151%if %{with clang}
152export CC=clang
153export CXX=clang++
154export LD=ld.lld
155%endif
156
157%cmake \
158  -GNinja \
159%if %{with clang}
160  -DCOMPILER_IS_CLANG=ON \
161  -DCMAKE_CXX_COMPILER=clang++ \
162%endif
163  -DPORT=GTK \
164  -DCMAKE_BUILD_TYPE=Release \
165  -DENABLE_JIT=OFF \
166  -DENABLE_LLINT_C_LOOP=ON \
167  -DUSE_GSTREAMER_GL=OFF \
168  -DUSE_OPENJPEG=OFF \
169  -DENABLE_GTKDOC=OFF \
170%if %{with systemd}
171  -DUSE_SYSTEMD=ON \
172%else
173  -DUSE_SYSTEMD=OFF \
174%endif
175  ..
176popd
177
178ninja -C %{_target_platform}
179
180
181%install
182DESTDIR=%{buildroot} ninja -C %{_target_platform} install
183
184%find_lang WebKit2GTK-4.0
185
186# Finally, copy over and rename various files for %%license inclusion
187%add_to_license_files Source/JavaScriptCore/COPYING.LIB
188%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
189%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
190%add_to_license_files Source/WebCore/LICENSE-APPLE
191%add_to_license_files Source/WebCore/LICENSE-LGPL-2
192%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
193%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
194%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
195%add_to_license_files Source/WTF/icu/LICENSE
196%add_to_license_files Source/WTF/wtf/dtoa/COPYING
197%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
198
199
200%post -p /sbin/ldconfig
201%postun -p /sbin/ldconfig
202%post jsc -p /sbin/ldconfig
203%postun jsc -p /sbin/ldconfig
204
205
206%files -f WebKit2GTK-4.0.lang
207%license _license_files/*
208%{_libdir}/libwebkit2gtk-4.0.so.*
209%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
210%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
211%{_libdir}/webkit2gtk-4.0/
212%{_libexecdir}/webkit2gtk-4.0/*
213%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
214%{_bindir}/WebKitWebDriver
215
216%files jsc
217%license _license_files/*JavaScriptCore*
218%dir %{_libexecdir}/webkit2gtk-4.0/
219%{_libexecdir}/webkit2gtk-4.0/jsc
220%{_libdir}/libjavascriptcoregtk-4.0.so.*
221%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
222
223%files devel
224%{_includedir}/webkitgtk-4.0/*
225%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
226%{_libdir}/libwebkit2gtk-4.0.so
227%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
228%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
229%{_datadir}/gir-1.0/WebKit2-4.0.gir
230%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
231
232%files jsc-devel
233%dir %{_includedir}/webkitgtk-4.0
234%{_includedir}/webkitgtk-4.0/JavaScriptCore/
235%{_libdir}/libjavascriptcoregtk-4.0.so
236%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
237%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
238
239
240%changelog
241* Tue Dec 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.3-1
242- new upstream release.
243- added systemd support (disabled as default).
244
245* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.4-1
246- new upstream release.
247
248* Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
249- new upstream release.
250
251* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
252- new upstream release.
253
254* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
255- new upstream release.
256- rebuilt with libicu67.
257
258* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
259- rebuilt with libicu66.
260
261* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
262- new upstream release.
263- dropped Patch1: fixed in upstream.
264
265* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
266- new upstream release.
267- built with icu-65.
268
269* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
270- new upstream release.
271- switched build-system to ninja.
272
273* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
274- new upstream release.
275
276* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
277- new upstream release.
278
279* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
280- new upstream release.
281- added subpackages webkitgtk4-jsc{,-devel}.
282
283* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
284- new upstream release.
285
286* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
287- rebuilt with new toolchain.
288
289* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
290- new upstream release
291  (including security fix for CVE-2016-1856,1857)
292
293* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
294- new upstream release
295- remove Patch0
296- add BuildRequires: libnotify-devel, hyphen-devel
297
298* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
299- rebuild with gnutls-3.4.7
300
301* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
302- rebuild with icu-56.1
303
304* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
305- new upstream release
306
307* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
308- new upstream release
309
310* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
311- new upstream release
312
313* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
314- new upstream release
315
316* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
317- new upstream release
318
319* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
320- new upstream release
321- update Patch0
322
323* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
324- new upstream release
325
326* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
327- add Group tag
328
329* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
330- new upstream release
331
332* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
333- new upstream release
334
335* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
336- initial build for Vine Linux
337
338
339* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
340- Add the wrongly removed CLoop patch and remove the one that was upstreamed
341
342* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
343- Update to 2.6.0
344
345* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
346- Update to 2.5.90
347
348* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
349- Obsolete libwebkit2gtk from the webkitgtk3 package
350
351* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
352- rebuild for ICU 53.1
353
354* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
355- Add support for secondary arches
356
357* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
358- Add webkitgtk-2.5.3-toggle-buttons.patch
359
360* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
361- More package review fixes (#1131284)
362- Correct the license tag to read LGPLv2
363- Filter out provides for private libraries
364
365* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
366- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
367
368* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
369- Update to 2.5.3
370
371* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
372- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.