source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12560

Revision 12560, 10.8 KB checked in by tomop, 3 years ago (diff)

updated 4 packages

ethtool-5.10-1

lcms2-2.12-1

squid-4.14-1

webkitgtk4-2.30.5-1

Line 
1%bcond_with systemd
2%bcond_with clang
3
4## NOTE: Lots of files in various subdirectories have the same name (such as
5## "LICENSE") so this short macro allows us to distinguish them by using their
6## directory names (from the source tree) as prefixes for the files.
7%global add_to_license_files() \
8        mkdir -p _license_files ; \
9        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
10
11Summary:        GTK+ Web content engine library
12Name:           webkitgtk4
13Version:        2.30.5
14Release:        1%{?_dist_release}%{?with_systemd:.systemd}
15Group:          system
16Vendor:         Project Vine
17Distribution:   Vine Linux
18
19License:        LGPLv2
20URL:            http://www.webkitgtk.org/
21Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
22
23%if %{with clang}
24BuildRequires:  clang
25BuildRequires:  lld
26%endif
27BuildRequires:  at-spi2-core-devel
28BuildRequires:  bison
29BuildRequires:  bubblewrap
30BuildRequires:  cairo-devel
31BuildRequires:  cmake
32BuildRequires:  enchant2-devel
33BuildRequires:  flex
34BuildRequires:  fontconfig-devel
35BuildRequires:  freetype-devel
36BuildRequires:  geoclue2-devel
37BuildRequires:  gettext
38BuildRequires:  glib2-devel
39BuildRequires:  gobject-introspection-devel
40BuildRequires:  gperf
41BuildRequires:  gstreamer1-devel
42BuildRequires:  gstreamer1-plugins-base-devel
43BuildRequires:  gtk2-devel
44BuildRequires:  gtk3-devel
45BuildRequires:  harfbuzz-icu-devel
46BuildRequires:  libicu-devel
47BuildRequires:  libjpeg-turbo-devel
48BuildRequires:  libpng-devel
49BuildRequires:  libseccomp-devel
50BuildRequires:  libsecret-devel
51BuildRequires:  libsoup-devel
52BuildRequires:  libwebp-devel
53BuildRequires:  libxslt-devel
54BuildRequires:  libXt-devel
55BuildRequires:  ninja
56BuildRequires:  mesa-libGL-devel
57BuildRequires:  pcre-devel
58BuildRequires:  python3-devel
59BuildRequires:  ruby
60BuildRequires:  sqlite3-devel
61BuildRequires:  libnotify-devel
62BuildRequires:  hyphen-devel
63BuildRequires:  woff2-devel
64BuildRequires:  xdg-dbus-proxy
65%if %{with systemd}
66BuildRequires:  systemd-devel
67%endif
68
69Requires:       geoclue2
70
71# for sandbox
72Requires:       bubblewrap
73Requires:       xdg-dbus-proxy
74
75# Require the jsc subpackage
76Requires:       %{name}-jsc = %{version}-%{release}
77
78# Obsolete libwebkit2gtk from the webkitgtk3 package
79Obsoletes:      libwebkit2gtk < 2.4.5-3
80Provides:       libwebkit2gtk = %{version}-%{release}
81
82# Filter out provides for private libraries
83%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
84
85%description
86WebKitGTK+ is the port of the portable web rendering engine WebKit to the
87GTK+ platform.
88
89This package contains WebKitGTK+ for GTK+ 3.
90
91
92%package        devel
93Summary:        Development files for %{name}
94Group:                  programming
95Requires:       %{name} = %{version}-%{release}
96Requires:       %{name}-jsc-devel = %{version}-%{release}
97
98%description    devel
99The %{name}-devel package contains libraries, build data, and header
100files for developing applications that use %{name}.
101
102
103%package        jsc
104Summary:        JavaScript engine from %{name}
105Group:                  system
106
107%description    jsc
108This package contains JavaScript engine from %{name}.
109
110
111%package        jsc-devel
112Summary:        Development files for JavaScript engine from %{name}
113Group:                  programming
114Requires:       %{name}-jsc = %{version}-%{release}
115
116%description    jsc-devel
117The %{name}-jsc-devel package contains libraries, build data, and header
118files for developing applications that use JavaScript engine from %{name}.
119
120
121%debug_package
122
123
124%prep
125%setup -q -n webkitgtk-%{version}
126
127# Remove bundled libraries
128rm -rf Source/ThirdParty/leveldb/
129rm -rf Source/ThirdParty/gtest/
130rm -rf Source/ThirdParty/qunit/
131
132
133%build
134# binutils-2.23 doesn't support "reduce-memory-overheads"
135# Use linker flags to reduce memory consumption
136# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
137
138%if %{with clang}
139%ifnarch x86_64
140%define cflags_add --rtlib=compiler-rt
141%endif
142
143%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
144%else
145%global optflags  %{optflags} -DENABLE_YARR_JIT=0
146%endif
147
148%if %{with clang}
149export CC=clang
150export CXX=clang++
151export LD=ld.lld
152%endif
153
154%cmake \
155  -GNinja \
156%if %{with clang}
157  -DCOMPILER_IS_CLANG=ON \
158  -DCMAKE_CXX_COMPILER=clang++ \
159%endif
160  -DPORT=GTK \
161  -DCMAKE_BUILD_TYPE=Release \
162  -DENABLE_JIT=OFF \
163  -DENABLE_LLINT_C_LOOP=ON \
164  -DUSE_GSTREAMER_GL=OFF \
165  -DUSE_OPENJPEG=OFF \
166  -DENABLE_GTKDOC=OFF \
167%if %{with systemd}
168  -DUSE_SYSTEMD=ON \
169%else
170  -DUSE_SYSTEMD=OFF \
171%endif
172  ..
173
174ninja -C %{_vpath_builddir}
175
176
177%install
178DESTDIR=%{buildroot} ninja -C %{_vpath_builddir} install
179
180%find_lang WebKit2GTK-4.0
181
182# Finally, copy over and rename various files for %%license inclusion
183%add_to_license_files Source/JavaScriptCore/COPYING.LIB
184%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
185%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
186%add_to_license_files Source/WebCore/LICENSE-APPLE
187%add_to_license_files Source/WebCore/LICENSE-LGPL-2
188%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
189%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
190%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
191%add_to_license_files Source/WTF/icu/LICENSE
192%add_to_license_files Source/WTF/wtf/dtoa/COPYING
193%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
194
195
196%post -p /sbin/ldconfig
197%postun -p /sbin/ldconfig
198%post jsc -p /sbin/ldconfig
199%postun jsc -p /sbin/ldconfig
200
201
202%files -f WebKit2GTK-4.0.lang
203%license _license_files/*
204%{_libdir}/libwebkit2gtk-4.0.so.*
205%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
206%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
207%{_libdir}/webkit2gtk-4.0/
208%{_libexecdir}/webkit2gtk-4.0/*
209%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
210%{_bindir}/WebKitWebDriver
211
212%files jsc
213%license _license_files/*JavaScriptCore*
214%dir %{_libexecdir}/webkit2gtk-4.0/
215%{_libexecdir}/webkit2gtk-4.0/jsc
216%{_libdir}/libjavascriptcoregtk-4.0.so.*
217%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
218
219%files devel
220%{_includedir}/webkitgtk-4.0/*
221%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
222%{_libdir}/libwebkit2gtk-4.0.so
223%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
224%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
225%{_datadir}/gir-1.0/WebKit2-4.0.gir
226%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
227
228%files jsc-devel
229%dir %{_includedir}/webkitgtk-4.0
230%{_includedir}/webkitgtk-4.0/JavaScriptCore/
231%{_libdir}/libjavascriptcoregtk-4.0.so
232%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
233%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
234
235
236%changelog
237* Tue Mar 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.5-1
238- new upstream release.
239
240* Tue Dec 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.3-1
241- new upstream release.
242- added systemd support (disabled as default).
243
244* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.4-1
245- new upstream release.
246
247* Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
248- new upstream release.
249
250* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
251- new upstream release.
252
253* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
254- new upstream release.
255- rebuilt with libicu67.
256
257* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
258- rebuilt with libicu66.
259
260* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
261- new upstream release.
262- dropped Patch1: fixed in upstream.
263
264* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
265- new upstream release.
266- built with icu-65.
267
268* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
269- new upstream release.
270- switched build-system to ninja.
271
272* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
273- new upstream release.
274
275* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
276- new upstream release.
277
278* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
279- new upstream release.
280- added subpackages webkitgtk4-jsc{,-devel}.
281
282* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
283- new upstream release.
284
285* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
286- rebuilt with new toolchain.
287
288* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
289- new upstream release
290  (including security fix for CVE-2016-1856,1857)
291
292* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
293- new upstream release
294- remove Patch0
295- add BuildRequires: libnotify-devel, hyphen-devel
296
297* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
298- rebuild with gnutls-3.4.7
299
300* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
301- rebuild with icu-56.1
302
303* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
304- new upstream release
305
306* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
307- new upstream release
308
309* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
310- new upstream release
311
312* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
313- new upstream release
314
315* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
316- new upstream release
317
318* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
319- new upstream release
320- update Patch0
321
322* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
323- new upstream release
324
325* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
326- add Group tag
327
328* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
329- new upstream release
330
331* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
332- new upstream release
333
334* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
335- initial build for Vine Linux
336
337
338* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
339- Add the wrongly removed CLoop patch and remove the one that was upstreamed
340
341* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
342- Update to 2.6.0
343
344* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
345- Update to 2.5.90
346
347* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
348- Obsolete libwebkit2gtk from the webkitgtk3 package
349
350* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
351- rebuild for ICU 53.1
352
353* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
354- Add support for secondary arches
355
356* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
357- Add webkitgtk-2.5.3-toggle-buttons.patch
358
359* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
360- More package review fixes (#1131284)
361- Correct the license tag to read LGPLv2
362- Filter out provides for private libraries
363
364* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
365- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
366
367* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
368- Update to 2.5.3
369
370* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
371- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.