source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12487

Revision 12487, 10.5 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

chrony-3.5.1-2

dnsmasq-2.82-1

epiphany-3.36.4-2

filezilla-3.50.0-1

gnutls-3.6.15-1

libfilezilla-0.24.1-1

nettle-3.6-1

rdesktop-1.9.0-2

tigervnc-1.10.1-2

webkitgtk4-2.28.4-1

wxGTK3-3.0.5-1

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Summary:        GTK+ Web content engine library
11Name:           webkitgtk4
12Version:        2.28.4
13Release:        1%{?_dist_release}
14Group:          system
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        LGPLv2
19URL:            http://www.webkitgtk.org/
20Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
21
22%if %{with clang}
23BuildRequires:  clang
24BuildRequires:  lld
25%endif
26BuildRequires:  at-spi2-core-devel
27BuildRequires:  bison
28BuildRequires:  bubblewrap
29BuildRequires:  cairo-devel
30BuildRequires:  cmake
31BuildRequires:  enchant2-devel
32BuildRequires:  flex
33BuildRequires:  fontconfig-devel
34BuildRequires:  freetype-devel
35BuildRequires:  geoclue2-devel
36BuildRequires:  gettext
37BuildRequires:  glib2-devel
38BuildRequires:  gobject-introspection-devel
39BuildRequires:  gperf
40BuildRequires:  gstreamer1-devel
41BuildRequires:  gstreamer1-plugins-base-devel
42BuildRequires:  gtk2-devel
43BuildRequires:  gtk3-devel
44BuildRequires:  harfbuzz-icu-devel
45BuildRequires:  libicu-devel
46BuildRequires:  libjpeg-turbo-devel
47BuildRequires:  libpng-devel
48BuildRequires:  libseccomp-devel
49BuildRequires:  libsecret-devel
50BuildRequires:  libsoup-devel
51BuildRequires:  libwebp-devel
52BuildRequires:  libxslt-devel
53BuildRequires:  libXt-devel
54BuildRequires:  ninja
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  pcre-devel
57BuildRequires:  python3-devel
58BuildRequires:  ruby
59BuildRequires:  sqlite3-devel
60BuildRequires:  libnotify-devel
61BuildRequires:  hyphen-devel
62BuildRequires:  woff2-devel
63BuildRequires:  xdg-dbus-proxy
64Requires:       geoclue2
65
66# for sandbox
67Requires:       bubblewrap
68Requires:       xdg-dbus-proxy
69
70# Require the jsc subpackage
71Requires:       %{name}-jsc = %{version}-%{release}
72
73# Obsolete libwebkit2gtk from the webkitgtk3 package
74Obsoletes:      libwebkit2gtk < 2.4.5-3
75Provides:       libwebkit2gtk = %{version}-%{release}
76
77# Filter out provides for private libraries
78%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
79
80%description
81WebKitGTK+ is the port of the portable web rendering engine WebKit to the
82GTK+ platform.
83
84This package contains WebKitGTK+ for GTK+ 3.
85
86
87%package        devel
88Summary:        Development files for %{name}
89Group:                  programming
90Requires:       %{name} = %{version}-%{release}
91Requires:       %{name}-jsc-devel = %{version}-%{release}
92
93%description    devel
94The %{name}-devel package contains libraries, build data, and header
95files for developing applications that use %{name}.
96
97
98%package        jsc
99Summary:        JavaScript engine from %{name}
100Group:                  system
101
102%description    jsc
103This package contains JavaScript engine from %{name}.
104
105
106%package        jsc-devel
107Summary:        Development files for JavaScript engine from %{name}
108Group:                  programming
109Requires:       %{name}-jsc = %{version}-%{release}
110
111%description    jsc-devel
112The %{name}-jsc-devel package contains libraries, build data, and header
113files for developing applications that use JavaScript engine from %{name}.
114
115
116%debug_package
117
118
119%prep
120%setup -q -n webkitgtk-%{version}
121
122# Remove bundled libraries
123rm -rf Source/ThirdParty/leveldb/
124rm -rf Source/ThirdParty/gtest/
125rm -rf Source/ThirdParty/qunit/
126
127
128%build
129# binutils-2.23 doesn't support "reduce-memory-overheads"
130# Use linker flags to reduce memory consumption
131# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
132
133%if %{with clang}
134%ifnarch x86_64
135%define cflags_add --rtlib=compiler-rt
136%endif
137
138%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
139%else
140%global optflags  %{optflags} -DENABLE_YARR_JIT=0
141%endif
142
143mkdir -p %{_target_platform}
144pushd %{_target_platform}
145
146%if %{with clang}
147export CC=clang
148export CXX=clang++
149export LD=ld.lld
150%endif
151
152%cmake \
153  -GNinja \
154%if %{with clang}
155  -DCOMPILER_IS_CLANG=ON \
156  -DCMAKE_CXX_COMPILER=clang++ \
157%endif
158  -DPORT=GTK \
159  -DCMAKE_BUILD_TYPE=Release \
160  -DENABLE_JIT=OFF \
161  -DENABLE_LLINT_C_LOOP=ON \
162  -DUSE_GSTREAMER_GL=OFF \
163  -DUSE_OPENJPEG=OFF \
164  -DENABLE_GTKDOC=OFF \
165  ..
166popd
167
168ninja -C %{_target_platform}
169
170
171%install
172DESTDIR=%{buildroot} ninja -C %{_target_platform} install
173
174%find_lang WebKit2GTK-4.0
175
176# Finally, copy over and rename various files for %%license inclusion
177%add_to_license_files Source/JavaScriptCore/COPYING.LIB
178%add_to_license_files Source/JavaScriptCore/icu/LICENSE
179%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
180%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
181%add_to_license_files Source/WebCore/icu/LICENSE
182%add_to_license_files Source/WebCore/LICENSE-APPLE
183%add_to_license_files Source/WebCore/LICENSE-LGPL-2
184%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
185%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
186%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
187%add_to_license_files Source/WTF/icu/LICENSE
188%add_to_license_files Source/WTF/wtf/dtoa/COPYING
189%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
190
191
192%post -p /sbin/ldconfig
193%postun -p /sbin/ldconfig
194%post jsc -p /sbin/ldconfig
195%postun jsc -p /sbin/ldconfig
196
197
198%files -f WebKit2GTK-4.0.lang
199%license _license_files/*
200%{_libdir}/libwebkit2gtk-4.0.so.*
201%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
202%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
203%{_libdir}/webkit2gtk-4.0/
204%{_libexecdir}/webkit2gtk-4.0/*
205%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
206%{_bindir}/WebKitWebDriver
207
208%files jsc
209%license _license_files/*JavaScriptCore*
210%dir %{_libexecdir}/webkit2gtk-4.0/
211%{_libexecdir}/webkit2gtk-4.0/jsc
212%{_libdir}/libjavascriptcoregtk-4.0.so.*
213%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
214
215%files devel
216%{_includedir}/webkitgtk-4.0/*
217%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
218%{_libdir}/libwebkit2gtk-4.0.so
219%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
220%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
221%{_datadir}/gir-1.0/WebKit2-4.0.gir
222%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
223
224%files jsc-devel
225%dir %{_includedir}/webkitgtk-4.0
226%{_includedir}/webkitgtk-4.0/JavaScriptCore/
227%{_libdir}/libjavascriptcoregtk-4.0.so
228%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
229%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
230
231
232%changelog
233* Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.4-1
234- new upstream release.
235
236* Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
237- new upstream release.
238
239* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
240- new upstream release.
241
242* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
243- new upstream release.
244- rebuilt with libicu67.
245
246* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
247- rebuilt with libicu66.
248
249* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
250- new upstream release.
251- dropped Patch1: fixed in upstream.
252
253* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
254- new upstream release.
255- built with icu-65.
256
257* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
258- new upstream release.
259- switched build-system to ninja.
260
261* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
262- new upstream release.
263
264* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
265- new upstream release.
266
267* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
268- new upstream release.
269- added subpackages webkitgtk4-jsc{,-devel}.
270
271* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
272- new upstream release.
273
274* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
275- rebuilt with new toolchain.
276
277* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
278- new upstream release
279  (including security fix for CVE-2016-1856,1857)
280
281* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
282- new upstream release
283- remove Patch0
284- add BuildRequires: libnotify-devel, hyphen-devel
285
286* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
287- rebuild with gnutls-3.4.7
288
289* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
290- rebuild with icu-56.1
291
292* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
293- new upstream release
294
295* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
296- new upstream release
297
298* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
299- new upstream release
300
301* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
302- new upstream release
303
304* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
305- new upstream release
306
307* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
308- new upstream release
309- update Patch0
310
311* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
312- new upstream release
313
314* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
315- add Group tag
316
317* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
318- new upstream release
319
320* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
321- new upstream release
322
323* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
324- initial build for Vine Linux
325
326
327* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
328- Add the wrongly removed CLoop patch and remove the one that was upstreamed
329
330* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
331- Update to 2.6.0
332
333* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
334- Update to 2.5.90
335
336* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
337- Obsolete libwebkit2gtk from the webkitgtk3 package
338
339* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
340- rebuild for ICU 53.1
341
342* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
343- Add support for secondary arches
344
345* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
346- Add webkitgtk-2.5.3-toggle-buttons.patch
347
348* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
349- More package review fixes (#1131284)
350- Correct the license tag to read LGPLv2
351- Filter out provides for private libraries
352
353* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
354- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
355
356* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
357- Update to 2.5.3
358
359* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
360- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.