source: projects/specs/trunk/w/webkitgtk4/webkitgtk4-vl.spec @ 12431

Revision 12431, 10.5 KB checked in by tomop, 4 years ago (diff)

updated 9 packages

control-center-3.30.3-2

docker-ce-19.03.9-1

docker-compose-1.26.2-1

golang-1.14.6-1

polkit-0.116-2

postfix-3.5.6-1

unbound-1.11.0-1

webkitgtk4-2.28.3-1

zabbix-5.0.2-1

Line 
1%bcond_with clang
2
3## NOTE: Lots of files in various subdirectories have the same name (such as
4## "LICENSE") so this short macro allows us to distinguish them by using their
5## directory names (from the source tree) as prefixes for the files.
6%global add_to_license_files() \
7        mkdir -p _license_files ; \
8        cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
9
10Name:           webkitgtk4
11Version:        2.28.3
12Release:        1%{?_dist_release}
13Summary:        GTK+ Web content engine library
14Group:          System Environment/Libraries
15Vendor:         Project Vine
16Distribution:   Vine Linux
17
18License:        LGPLv2
19URL:            http://www.webkitgtk.org/
20Source0:        https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
21
22%if %{with clang}
23BuildRequires:  clang
24BuildRequires:  lld
25%endif
26BuildRequires:  at-spi2-core-devel
27BuildRequires:  bison
28BuildRequires:  bubblewrap
29BuildRequires:  cairo-devel
30BuildRequires:  cmake
31BuildRequires:  enchant2-devel
32BuildRequires:  flex
33BuildRequires:  fontconfig-devel
34BuildRequires:  freetype-devel
35BuildRequires:  geoclue2-devel
36BuildRequires:  gettext
37BuildRequires:  glib2-devel
38BuildRequires:  gobject-introspection-devel
39BuildRequires:  gperf
40BuildRequires:  gstreamer1-devel
41BuildRequires:  gstreamer1-plugins-base-devel
42BuildRequires:  gtk2-devel
43BuildRequires:  gtk3-devel
44BuildRequires:  harfbuzz-icu-devel
45BuildRequires:  libicu-devel
46BuildRequires:  libjpeg-turbo-devel
47BuildRequires:  libpng-devel
48BuildRequires:  libseccomp-devel
49BuildRequires:  libsecret-devel
50BuildRequires:  libsoup-devel
51BuildRequires:  libwebp-devel
52BuildRequires:  libxslt-devel
53BuildRequires:  libXt-devel
54BuildRequires:  ninja
55BuildRequires:  mesa-libGL-devel
56BuildRequires:  pcre-devel
57BuildRequires:  python3-devel
58BuildRequires:  ruby
59BuildRequires:  sqlite3-devel
60BuildRequires:  libnotify-devel
61BuildRequires:  hyphen-devel
62BuildRequires:  woff2-devel
63BuildRequires:  xdg-dbus-proxy
64Requires:       geoclue2
65
66# for sandbox
67Requires:       bubblewrap
68Requires:       xdg-dbus-proxy
69
70# Require the jsc subpackage
71Requires:       %{name}-jsc = %{version}-%{release}
72
73# Obsolete libwebkit2gtk from the webkitgtk3 package
74Obsoletes:      libwebkit2gtk < 2.4.5-3
75Provides:       libwebkit2gtk = %{version}-%{release}
76
77# Filter out provides for private libraries
78%global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
79
80%description
81WebKitGTK+ is the port of the portable web rendering engine WebKit to the
82GTK+ platform.
83
84This package contains WebKitGTK+ for GTK+ 3.
85
86%package        devel
87Summary:        Development files for %{name}
88Group:                  Development/Libraries
89Requires:       %{name} = %{version}-%{release}
90Requires:       %{name}-jsc-devel = %{version}-%{release}
91
92%description    devel
93The %{name}-devel package contains libraries, build data, and header
94files for developing applications that use %{name}.
95
96%package        jsc
97Summary:        JavaScript engine from %{name}
98Group:                  System Environment/Libraries
99
100%description    jsc
101This package contains JavaScript engine from %{name}.
102
103%package        jsc-devel
104Summary:        Development files for JavaScript engine from %{name}
105Group:                  Development/Libraries
106Requires:       %{name}-jsc = %{version}-%{release}
107
108%description    jsc-devel
109The %{name}-jsc-devel package contains libraries, build data, and header
110files for developing applications that use JavaScript engine from %{name}.
111
112
113%debug_package
114
115
116%prep
117%setup -q -n webkitgtk-%{version}
118
119# Remove bundled libraries
120rm -rf Source/ThirdParty/leveldb/
121rm -rf Source/ThirdParty/gtest/
122rm -rf Source/ThirdParty/qunit/
123
124
125%build
126# binutils-2.23 doesn't support "reduce-memory-overheads"
127# Use linker flags to reduce memory consumption
128# global optflags %{optflags} -Wl,--no-keep-memory -Wl,--reduce-memory-overheads
129
130%if %{with clang}
131%ifnarch x86_64
132%define cflags_add --rtlib=compiler-rt
133%endif
134
135%global optflags  %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
136%else
137%global optflags  %{optflags} -DENABLE_YARR_JIT=0
138%endif
139
140mkdir -p %{_target_platform}
141pushd %{_target_platform}
142
143%if %{with clang}
144export CC=clang
145export CXX=clang++
146export LD=ld.lld
147%endif
148
149%cmake \
150  -GNinja \
151%if %{with clang}
152  -DCOMPILER_IS_CLANG=ON \
153  -DCMAKE_CXX_COMPILER=clang++ \
154%endif
155  -DPORT=GTK \
156  -DCMAKE_BUILD_TYPE=Release \
157  -DENABLE_JIT=OFF \
158  -DENABLE_LLINT_C_LOOP=ON \
159  -DUSE_GSTREAMER_GL=OFF \
160  -DUSE_OPENJPEG=OFF \
161  -DENABLE_GTKDOC=OFF \
162  ..
163popd
164
165ninja -C %{_target_platform}
166
167
168%install
169DESTDIR=%{buildroot} ninja -C %{_target_platform} install
170
171%find_lang WebKit2GTK-4.0
172
173# Finally, copy over and rename various files for %%license inclusion
174%add_to_license_files Source/JavaScriptCore/COPYING.LIB
175%add_to_license_files Source/JavaScriptCore/icu/LICENSE
176%add_to_license_files Source/ThirdParty/ANGLE/LICENSE
177%add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
178%add_to_license_files Source/WebCore/icu/LICENSE
179%add_to_license_files Source/WebCore/LICENSE-APPLE
180%add_to_license_files Source/WebCore/LICENSE-LGPL-2
181%add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
182%add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
183%add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
184%add_to_license_files Source/WTF/icu/LICENSE
185%add_to_license_files Source/WTF/wtf/dtoa/COPYING
186%add_to_license_files Source/WTF/wtf/dtoa/LICENSE
187
188
189%post -p /sbin/ldconfig
190%postun -p /sbin/ldconfig
191%post jsc -p /sbin/ldconfig
192%postun jsc -p /sbin/ldconfig
193
194
195%files -f WebKit2GTK-4.0.lang
196%license _license_files/*
197%{_libdir}/libwebkit2gtk-4.0.so.*
198%{_libdir}/girepository-1.0/WebKit2-4.0.typelib
199%{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
200%{_libdir}/webkit2gtk-4.0/
201%{_libexecdir}/webkit2gtk-4.0/*
202%exclude %{_libexecdir}/webkit2gtk-4.0/jsc
203%{_bindir}/WebKitWebDriver
204
205%files jsc
206%license _license_files/*JavaScriptCore*
207%dir %{_libexecdir}/webkit2gtk-4.0/
208%{_libexecdir}/webkit2gtk-4.0/jsc
209%{_libdir}/libjavascriptcoregtk-4.0.so.*
210%{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
211
212%files devel
213%{_includedir}/webkitgtk-4.0/*
214%exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
215%{_libdir}/libwebkit2gtk-4.0.so
216%{_libdir}/pkgconfig/webkit2gtk-4.0.pc
217%{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
218%{_datadir}/gir-1.0/WebKit2-4.0.gir
219%{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
220
221%files jsc-devel
222%dir %{_includedir}/webkitgtk-4.0
223%{_includedir}/webkitgtk-4.0/JavaScriptCore/
224%{_libdir}/libjavascriptcoregtk-4.0.so
225%{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
226%{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
227
228
229%changelog
230* Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
231- new upstream release.
232
233* Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
234- new upstream release.
235
236* Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
237- new upstream release.
238- rebuilt with libicu67.
239
240* Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
241- rebuilt with libicu66.
242
243* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
244- new upstream release.
245- dropped Patch1: fixed in upstream.
246
247* Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
248- new upstream release.
249- built with icu-65.
250
251* Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
252- new upstream release.
253- switched build-system to ninja.
254
255* Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
256- new upstream release.
257
258* Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
259- new upstream release.
260
261* Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
262- new upstream release.
263- added subpackages webkitgtk4-jsc{,-devel}.
264
265* Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
266- new upstream release.
267
268* Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
269- rebuilt with new toolchain.
270
271* Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
272- new upstream release
273  (including security fix for CVE-2016-1856,1857)
274
275* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
276- new upstream release
277- remove Patch0
278- add BuildRequires: libnotify-devel, hyphen-devel
279
280* Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
281- rebuild with gnutls-3.4.7
282
283* Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
284- rebuild with icu-56.1
285
286* Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
287- new upstream release
288
289* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
290- new upstream release
291
292* Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
293- new upstream release
294
295* Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
296- new upstream release
297
298* Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
299- new upstream release
300
301* Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
302- new upstream release
303- update Patch0
304
305* Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
306- new upstream release
307
308* Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
309- add Group tag
310
311* Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
312- new upstream release
313
314* Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
315- new upstream release
316
317* Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
318- initial build for Vine Linux
319
320
321* Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
322- Add the wrongly removed CLoop patch and remove the one that was upstreamed
323
324* Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
325- Update to 2.6.0
326
327* Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
328- Update to 2.5.90
329
330* Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
331- Obsolete libwebkit2gtk from the webkitgtk3 package
332
333* Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
334- rebuild for ICU 53.1
335
336* Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
337- Add support for secondary arches
338
339* Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
340- Add webkitgtk-2.5.3-toggle-buttons.patch
341
342* Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
343- More package review fixes (#1131284)
344- Correct the license tag to read LGPLv2
345- Filter out provides for private libraries
346
347* Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
348- Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
349
350* Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
351- Update to 2.5.3
352
353* Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
354- Initial Fedora packaging, based on the webkitgtk3 package
Note: See TracBrowser for help on using the repository browser.