source: projects/specs/trunk/w/w3m/w3m-vl.spec @ 1908

Revision 1908, 12.1 KB checked in by shaolin, 14 years ago (diff)
  • w3m: add ambiguous width patch (see <BTS:wishes:218>)
Line 
1%define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
2
3%define _docdir %{_defaultdocdir}
4
5%define cvsdate 20060815
6
7Summary: A Pager with WWW capability
8Summary(ja): World Wide Web に対応したページャ
9Name: w3m
10Version: 0.5.2
11Release: 6%{?_dist_release}
12Group: Applications/Internet
13License: BSD
14URL: http://w3m.sourceforge.net/
15Source0: %{name}-%{version}.tar.gz
16Source1: w3m.sh
17Source2: w3m.csh
18Source10: w3m-term
19Source11: filter-requires-w3m.sh
20
21Patch10: w3m-0.5.2-ambwidth.patch
22Patch11: w3m-0.5.2-bugfix.patch
23
24Requires: perl, openssl >= 0.9, gc >= 6.2
25Requires(post,preun): alternatives
26Provides: webclient, pager
27Obsoletes: w3m-m17n
28
29BuildRequires: openssl-devel >= 0.9
30BuildRequires: ncurses-devel
31BuildRequires: gc-devel >= 6.2
32BuildRequires: sed
33BuildRequires: gtk2-devel
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35
36Vendor: Project Vine
37Distribution: Vine Linux
38Packager: shaolin
39
40# work around for [VineSeed-x86_64:00178]
41%define __find_requires %{SOURCE11}
42
43%description
44w3m is a pager with WWW capability. It IS a pager, but it can be
45used as a text-mode WWW browser. The features of w3m are as follows:
46- When reading HTML document, you can follow links and view images
47  (using external image viewer).
48- It has 'internet message mode', which determines the type of document
49  from header. If the Content-Type: field of the document is text/html,
50  that document is displayed as HTML document.
51- You can change URL description like 'http://hogege.net' in plain text
52  into link to that URL.
53
54%description -l ja
55w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
56です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
57
58・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
59  り,画像を見ることができる.
60・Internet message 表示のためのモードがある.この時,Content-Type: が
61  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
62 MIME header のデコードをする.
63・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
64  をたどることができる.
65
66%package img
67Summary: inline image extension support utilities for w3m
68Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
69Group: Applications/Internet
70Requires: %{name} = %{version}-%{release}
71
72%description img
73w3m-img provides some utilities to support inline
74images for w3m
75on terminal emulator in X Window System environments.
76
77%description -l ja img
78w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
79表示するためのユーティリティです。
80
81%prep
82%setup -q
83%patch10 -p1
84%patch11 -p1
85find Bonus -type f | \
86    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
87
88%build
89%configure \
90        --enable-japanese=E \
91        --with-termlib=ncurses \
92        --enable-image=x11 \
93        --with-imagelib=gtk2 \
94        --with-browser=gnome-open \
95        --with-mailer=gnome-open \
96        --with-editor=%{_sysbindir}/vi
97sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
98sed -i -e 's|\-lgpm||g' Makefile
99make %{?_smp_mflags}
100
101
102%install
103rm -rf %{buildroot}
104make install DESTDIR=%{buildroot}
105
106mkdir -p %{buildroot}/etc/profile.d
107cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
108cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
109
110mkdir -p %{buildroot}%{_bindir}
111cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
112chmod +x %{buildroot}%{_bindir}/w3m-term
113
114mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
115install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
116install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
117# dont include duplicated man pages and CVS directory in doc
118rm -f doc-jp/w3m.1 doc/w3m.1
119find . -type d -name "CVS" | xargs rm -rf
120
121# prepare system-wide preference file
122mkdir -p %{buildroot}%{_sysconfdir}/w3m
123
124# prepare applnk
125%define applnkdir /etc/X11/applnk/Internet
126mkdir -p %{buildroot}/%{applnkdir}
127cat > %{buildroot}/%{applnkdir}/%{name}.desktop <<EOF
128[Desktop Entry]
129Name=%{name}
130Type=Application
131Comment=A Pager with WWW capability
132Comment[ja]=WWW対応ページャ
133Exec=w3m-term
134Terminal=false
135EOF
136
137# eliminate executable bit in %doc
138find Bonus/ -type f -perm +111 | xargs -r chmod -x
139
140
141%clean
142rm -rf %{buildroot}
143
144%post
145%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
146
147%preun
148if [ "$1" = "0" ]; then
149  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
150fi
151
152
153%files
154%defattr(-,root,root)
155%doc Bonus ChangeLog NEWS README doc doc-jp
156%attr(755,root,root) %config /etc/profile.d/*
157%config(missingok) %{applnkdir}/%{name}.desktop
158%dir %{_sysconfdir}/w3m
159%{_bindir}/w3m*
160%exclude %{_libexecdir}/w3m/w3mimgdisplay
161%{_libexecdir}/w3m/
162%{_datadir}/w3m/
163%{_datadir}/locale/*/LC_MESSAGES/*
164%{_mandir}/ja/man1/w3m.1*
165%{_mandir}/man1/w3m*
166
167%files img
168%{_libexecdir}/w3m/w3mimgdisplay
169
170%changelog
171* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
172- add Patch10 to fix display utf8 ambiguous width characters
173  (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
174- add Patch11 to fix sudden crash
175  (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
176
177* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
178- rebuilt with gcc-4.4.3-3 on ppc
179
180* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
181- rebuilt with new toolchain
182
183* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
184- spec in utf-8
185- remove Requires: indexhtml
186- set HTTP_HOME to http://vinelinux.org/
187- update w3m-term
188
189* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
190- new upstream release
191- dropped Patch100 (merged into upstream)
192
193* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
194- rebuilt with new toolchain and environment
195
196* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
197- add Provides: pager
198- add Requires(post,preun): alternatives
199
200* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
201- add update-alternatives: pager in %post and %preun scriptlet
202
203* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
204- 0.5.1.20060815-0vl2
205- rebuilt for VineSeed
206
207* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
208- 0.5.1.20060815-0vl1.1
209- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
210
211* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
212- update to cvs snapshot
213- use gtk2 for w3m-img instead of gdk-pixbuf
214
215* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
216- use filter-requires-w3m.sh as find-requires (rpm's bug?)
217
218* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
219- use %%{_docdir}/Vine/index.html as default homepage
220
221* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
222- change default editor to %%{_sysbindir}/vi
223- use ncurses explicitly as termlib
224
225* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
226- fix typo
227- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
228
229* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
230- rebuild without gpm
231
232* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
233- new upstream release
234- Obsoletes: w3m-m17n
235
236* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
237- add message catalogs to %%files
238
239* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
240- new upstream release
241- fix w3mimgdisplay path in w3m-term
242
243* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
244- new upstream release
245- split w3mimgdisplay to w3m-img subpackage.
246- Requires: gc >= 6.2
247
248* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
249- new upstream release
250
251* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
252- new upstream release
253
254* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
255- new upstream release.
256  w3m 0.3.2.2 - 2002-12-06
257  * security fix: html_quote for img alt attributes
258
259* Fri Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
260- change default page path to /usr/doc/HTML.
261  this should be changed to /usr/share/doc in next release.
262  ( TODO: indexhtml package )
263
264* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
265- new upstream release
266  w3m 0.3.2.1 - 2002-11-27
267  * security fix: html_quote for frame contents
268  * backport from w3m 0.3.2+cvs
269    - fix segmentation fault by large complex table.
270      [w3m-dev 03371][w3m-dev 03438]
271
272* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
273- new upstream release
274  w3m 0.3.2 - 2002-11-05
275  * ~/.netrc: password for ftp
276  * rc: display_lineinfo: display current line number
277  * rc: passwd_file: passwd file for HTTP auth
278  * func: MARK_WORD
279  * rc: imgsize: obsoleted
280  * w3m-img for framebuffer merged
281
282* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
283- replace gc with an old version on alpha (Source20)
284
285* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
286- upstream release
287- coped new configure options
288
289* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
290- fixed configure option ([VineSeed:06372])
291- added openssl-devel version in {Build,}Requires
292
293* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
294- updated in sync with upstream 0.3 release
295  (now w3m-img patch is included in the upstream version)
296
297* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
298- w3m-0.2.5 with 0.2.5+cvs-1.302
299
300* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
301- eliminate executable bit in %doc
302- spec cleanup
303
304* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
305- updated to current stable release
306
307* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
308- updated to new upstream release
309- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
310
311* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
312- 0.2.1-0vl9
313- added sparc patch
314
315* Thu Aug 23 2001 <shom@vinelinux.org>
316- 0.2.1-0vl8: add w3m-term script
317
318* Mon Aug 06 2001 <sagami@vinelinux.org>
319- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
320- update img patch to version 1.10 from 1.9
321
322* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
323- added img patch
324
325* Mon Jul 16 2001 <sagami@vinelinux.org>
326- 0.2.1-0vl5: spec file clean up
327- openssl-devel for BuildPrereq, not openssl
328- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
329
330* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
331- 0.2.1-0vl4
332- rebuilt with openssl-0.9.6b
333
334* Sun Jun 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
335- 0.2.1-0vl3
336- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
337
338* Sat Jun 09 2001 <sagami@vinelinux.org>
339- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
340- actually rebuilt with ncurses5 (i386)
341
342* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
343- 0.2.1-0vl1
344
345* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
346- 0.1.10-0vl6
347- use better macros
348- rebuilt with ncurses5
349
350* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
351- w3m-0.1.10-0vl5
352- use applnk instead of wmconfig
353- use openssl
354
355* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
356- w3m-0.1.10-0vl4
357- fix typo in w3m.csh and w3m.wmconfig
358
359* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
360- w3m-0.1.10-0vl3
361- provide default HTTP_HOME in /etc/profile.d
362
363* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
364- Provides: webclient, Requires: indexhtml (capability of lynx)
365- added w3m.wmconfig
366- give them(who?) RPM_OPT_FLAGS(what?)
367- dont include duplicated man pages and CVS directory in doc
368
369* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
370- 0.1.10-0vl1
371
372* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
373- fix spec file
374
375* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
376- updated from 0.1.4 to 0.1.6
377
378* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
379- updated from 991203 to 0.1.4
380
381* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
382- updated from 991028 to 991203
383
384* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
385- updated from 990820 to 991028
386
387* Tue Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
388- updated from 990716 to 990820
389
390* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
391- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.