source: projects/specs/trunk/w/w3m/w3m-vl.spec @ 12152

Revision 12152, 13.2 KB checked in by ara_t, 5 years ago (diff)

w3m: rebuild with ncurses-6.1

Line 
1#define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
2#define __find_requires /bin/true
3
4%define _docdir %{_defaultdocdir}
5
6#%define cvsdate 20060815
7
8Summary: A Pager with WWW capability
9Summary(ja): World Wide Web に対応したページャ
10Name: w3m
11Version: 0.5.3
12Release: 6%{?_dist_release}
13
14License: BSD
15Group: Applications/Internet
16URL: http://w3m.sourceforge.net/
17
18Source0: %{name}-%{version}.tar.gz
19Source1: w3m.sh
20Source2: w3m.csh
21Source10: w3m-term
22Source11: filter-requires-w3m.sh
23
24Patch200: w3m-fh-def.patch
25Patch201: w3m-gc7.patch
26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: gc-devel >= 7.0
29BuildRequires: gtk2-devel
30BuildRequires: ncurses-devel
31BuildRequires: openssl-devel >= 0.9
32BuildRequires: sed
33Requires: perl
34Requires: openssl >= 0.9
35Requires(post): alternatives
36Requires(preun): alternatives
37
38Provides: webclient, pager
39Obsoletes: w3m-m17n
40
41
42Vendor: Project Vine
43Distribution: Vine Linux
44Packager: shaolin
45
46# work around for [VineSeed-x86_64:00178]
47%define __perl_requires %{SOURCE11}
48
49%description
50w3m is a pager with WWW capability. It IS a pager, but it can be
51used as a text-mode WWW browser. The features of w3m are as follows:
52- When reading HTML document, you can follow links and view images
53  (using external image viewer).
54- It has 'internet message mode', which determines the type of document
55  from header. If the Content-Type: field of the document is text/html,
56  that document is displayed as HTML document.
57- You can change URL description like 'http://hogege.net' in plain text
58  into link to that URL.
59
60%description -l ja
61w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
62です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
63
64・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
65  り,画像を見ることができる.
66・Internet message 表示のためのモードがある.この時,Content-Type: が
67  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
68 MIME header のデコードをする.
69・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
70  をたどることができる.
71
72%package img
73Summary: inline image extension support utilities for w3m
74Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
75Group: Applications/Internet
76Requires: %{name} = %{version}-%{release}
77
78%description img
79w3m-img provides some utilities to support inline
80images for w3m
81on terminal emulator in X Window System environments.
82
83%description -l ja img
84w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
85表示するためのユーティリティです。
86
87%prep
88%setup -q
89%patch200 -p0 -b .fh
90%patch201 -p1 -b .gc7
91
92find Bonus -type f | \
93    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
94
95# http://www.linuxfromscratch.org/blfs/view/svn/basicnet/w3m.html
96# Allows building against openssl-1.1
97sed -i '/USE_EGD/s/define/undef/' config.h.in
98
99%build
100%configure \
101  --enable-japanese=E \
102  --with-termlib=ncurses \
103  --enable-image=x11 \
104  --with-imagelib=gtk2 \
105  --with-browser=gnome-open \
106  --with-mailer=gnome-open \
107  --with-editor=%{_sysbindir}/vi
108sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
109sed -i -e 's|\-lgpm||g' Makefile
110sed -i -e 's|\-ldl|\-ldl \-lX11|g' Makefile
111make %{?_smp_mflags}
112
113%install
114rm -rf %{buildroot}
115make install DESTDIR=%{buildroot}
116
117mkdir -p %{buildroot}/etc/profile.d
118cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
119cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
120
121mkdir -p %{buildroot}%{_bindir}
122cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
123chmod +x %{buildroot}%{_bindir}/w3m-term
124
125mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
126install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
127install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
128# dont include duplicated man pages and CVS directory in doc
129rm -f doc-jp/w3m.1 doc/w3m.1
130find . -type d -name "CVS" | xargs rm -rf
131
132# prepare system-wide preference file
133mkdir -p %{buildroot}%{_sysconfdir}/w3m
134
135mkdir -p %{buildroot}%{_datadir}/applications
136cat > %{buildroot}%{_datadir}/applications/%{name}.desktop <<EOF
137[Desktop Entry]
138Name=%{name}
139Type=Application
140Comment=A Pager with WWW capability
141Comment[ja]=WWW対応ページャ
142Exec=w3m-term
143Terminal=false
144Categories=Network;
145EOF
146
147# eliminate executable bit in %doc
148find Bonus/ -type f -perm +111 | xargs -r chmod -x
149
150
151%clean
152rm -rf %{buildroot}
153
154%post
155%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
156
157%preun
158if [ "$1" = "0" ]; then
159  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
160fi
161
162
163%files
164%defattr(-,root,root)
165%doc Bonus ChangeLog NEWS README doc doc-jp
166%attr(755,root,root) %config /etc/profile.d/*
167%dir %{_sysconfdir}/w3m
168%{_bindir}/w3m*
169%exclude %{_libexecdir}/w3m/w3mimgdisplay
170%{_libexecdir}/w3m/
171%{_datadir}/applications/%{name}.desktop
172%{_datadir}/w3m/
173%{_datadir}/locale/*/LC_MESSAGES/*
174%{_mandir}/ja/man1/w3m.1*
175%{_mandir}/man1/w3m*
176
177%files img
178%{_libexecdir}/w3m/w3mimgdisplay
179
180%changelog
181* Sun Sep 01 2019 Toshiaki Ara <ara_t@384.jp> 0.5.3-6
182- rebuild with ncurses-6.1
183
184* Mon Nov 05 2018 Toshiaki Ara <ara_t@384.jp> 0.5.3-5
185- rebuild with openssl-1.1.1
186- Allows building against openssl-1.1
187
188* Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-4
189- rebuild with openssl-1.0.2
190
191* Tue Nov 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.3-3
192- change localtion of desktop file
193
194* Mon Sep 15 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.5.3-2
195- updated Source11 to call /usr/lib/rpm/perl.req
196- added Patch200 and 201 for building current environment
197- rebuilt for removing libpng12 dependency
198
199* Thu Apr 21 2011 IWAI, Masaharu <iwai@alib.jp> 0.5.3-1
200- new upstream release
201- drop unnecessary patches: upstream fixed
202 - ambwidth patch (Patch10)
203 - sudden crash patch (Patch11)
204 - x86_64 patch (Patch100)
205
206* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
207- rebuild with openssl-1.0.0c
208- add Patch100 (w3m-0.5.2-x86_64-vine.patch)
209
210* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
211- add Patch10 to fix display utf8 ambiguous width characters
212  (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
213- add Patch11 to fix sudden crash
214  (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
215
216* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
217- rebuilt with gcc-4.4.3-3 on ppc
218
219* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
220- rebuilt with new toolchain
221
222* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
223- spec in utf-8
224- remove Requires: indexhtml
225- set HTTP_HOME to http://vinelinux.org/
226- update w3m-term
227
228* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
229- new upstream release
230- dropped Patch100 (merged into upstream)
231
232* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
233- rebuilt with new toolchain and environment
234
235* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
236- add Provides: pager
237- add Requires(post,preun): alternatives
238
239* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
240- add update-alternatives: pager in %post and %preun scriptlet
241
242* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
243- 0.5.1.20060815-0vl2
244- rebuilt for VineSeed
245
246* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
247- 0.5.1.20060815-0vl1.1
248- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
249
250* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
251- update to cvs snapshot
252- use gtk2 for w3m-img instead of gdk-pixbuf
253
254* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
255- use filter-requires-w3m.sh as find-requires (rpm's bug?)
256
257* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
258- use %%{_docdir}/Vine/index.html as default homepage
259
260* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
261- change default editor to %%{_sysbindir}/vi
262- use ncurses explicitly as termlib
263
264* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
265- fix typo
266- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
267
268* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
269- rebuild without gpm
270
271* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
272- new upstream release
273- Obsoletes: w3m-m17n
274
275* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
276- add message catalogs to %%files
277
278* Fri Mar 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
279- new upstream release
280- fix w3mimgdisplay path in w3m-term
281
282* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
283- new upstream release
284- split w3mimgdisplay to w3m-img subpackage.
285- Requires: gc >= 6.2
286
287* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
288- new upstream release
289
290* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
291- new upstream release
292
293* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
294- new upstream release.
295  w3m 0.3.2.2 - 2002-12-06
296  * security fix: html_quote for img alt attributes
297
298* Fri Nov 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
299- change default page path to /usr/doc/HTML.
300  this should be changed to /usr/share/doc in next release.
301  ( TODO: indexhtml package )
302
303* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
304- new upstream release
305  w3m 0.3.2.1 - 2002-11-27
306  * security fix: html_quote for frame contents
307  * backport from w3m 0.3.2+cvs
308    - fix segmentation fault by large complex table.
309      [w3m-dev 03371][w3m-dev 03438]
310
311* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
312- new upstream release
313  w3m 0.3.2 - 2002-11-05
314  * ~/.netrc: password for ftp
315  * rc: display_lineinfo: display current line number
316  * rc: passwd_file: passwd file for HTTP auth
317  * func: MARK_WORD
318  * rc: imgsize: obsoleted
319  * w3m-img for framebuffer merged
320
321* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
322- replace gc with an old version on alpha (Source20)
323
324* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
325- upstream release
326- coped new configure options
327
328* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
329- fixed configure option ([VineSeed:06372])
330- added openssl-devel version in {Build,}Requires
331
332* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
333- updated in sync with upstream 0.3 release
334  (now w3m-img patch is included in the upstream version)
335
336* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
337- w3m-0.2.5 with 0.2.5+cvs-1.302
338
339* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
340- eliminate executable bit in %doc
341- spec cleanup
342
343* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
344- updated to current stable release
345
346* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
347- updated to new upstream release
348- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
349
350* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
351- 0.2.1-0vl9
352- added sparc patch
353
354* Thu Aug 23 2001 <shom@vinelinux.org>
355- 0.2.1-0vl8: add w3m-term script
356
357* Mon Aug 06 2001 <sagami@vinelinux.org>
358- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
359- update img patch to version 1.10 from 1.9
360
361* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
362- added img patch
363
364* Mon Jul 16 2001 <sagami@vinelinux.org>
365- 0.2.1-0vl5: spec file clean up
366- openssl-devel for BuildPrereq, not openssl
367- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
368
369* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
370- 0.2.1-0vl4
371- rebuilt with openssl-0.9.6b
372
373* Sun Jun 24 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
374- 0.2.1-0vl3
375- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
376
377* Sat Jun 09 2001 <sagami@vinelinux.org>
378- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
379- actually rebuilt with ncurses5 (i386)
380
381* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
382- 0.2.1-0vl1
383
384* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
385- 0.1.10-0vl6
386- use better macros
387- rebuilt with ncurses5
388
389* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
390- w3m-0.1.10-0vl5
391- use applnk instead of wmconfig
392- use openssl
393
394* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
395- w3m-0.1.10-0vl4
396- fix typo in w3m.csh and w3m.wmconfig
397
398* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
399- w3m-0.1.10-0vl3
400- provide default HTTP_HOME in /etc/profile.d
401
402* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
403- Provides: webclient, Requires: indexhtml (capability of lynx)
404- added w3m.wmconfig
405- give them(who?) RPM_OPT_FLAGS(what?)
406- dont include duplicated man pages and CVS directory in doc
407
408* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
409- 0.1.10-0vl1
410
411* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
412- fix spec file
413
414* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
415- updated from 0.1.4 to 0.1.6
416
417* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
418- updated from 991203 to 0.1.4
419
420* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
421- updated from 991028 to 991203
422
423* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
424- updated from 990820 to 991028
425
426* Thu Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
427- updated from 990716 to 990820
428
429* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
430- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.