source: projects/specs/trunk/w/w3m/w3m-vl.spec @ 2490

Revision 2490, 12.3 KB checked in by Takemikaduchi, 13 years ago (diff)

rebuild with openssl-1.0.0c

Line 
1%define __perl_requires %{_rpmconfigdir}/perl.req | grep -v w3mhelp
2
3%define _docdir %{_defaultdocdir}
4
5%define cvsdate 20060815
6
7Summary: A Pager with WWW capability
8Summary(ja): World Wide Web に対応したページャ
9Name: w3m
10Version: 0.5.2
11Release: 7%{?_dist_release}
12Group: Applications/Internet
13License: BSD
14URL: http://w3m.sourceforge.net/
15Source0: %{name}-%{version}.tar.gz
16Source1: w3m.sh
17Source2: w3m.csh
18Source10: w3m-term
19Source11: filter-requires-w3m.sh
20
21Patch10: w3m-0.5.2-ambwidth.patch
22Patch11: w3m-0.5.2-bugfix.patch
23
24# patch for Vine Linux
25Patch100: w3m-0.5.2-x86_64-vine.patch
26
27Requires: perl, openssl >= 0.9, gc >= 6.2
28Requires(post,preun): alternatives
29Provides: webclient, pager
30Obsoletes: w3m-m17n
31
32BuildRequires: openssl-devel >= 0.9
33BuildRequires: ncurses-devel
34BuildRequires: gc-devel >= 6.2
35BuildRequires: sed
36BuildRequires: gtk2-devel
37BuildRoot: %{_tmppath}/%{name}-%{version}-root
38
39Vendor: Project Vine
40Distribution: Vine Linux
41Packager: shaolin
42
43# work around for [VineSeed-x86_64:00178]
44%define __find_requires %{SOURCE11}
45
46%description
47w3m is a pager with WWW capability. It IS a pager, but it can be
48used as a text-mode WWW browser. The features of w3m are as follows:
49- When reading HTML document, you can follow links and view images
50  (using external image viewer).
51- It has 'internet message mode', which determines the type of document
52  from header. If the Content-Type: field of the document is text/html,
53  that document is displayed as HTML document.
54- You can change URL description like 'http://hogege.net' in plain text
55  into link to that URL.
56
57%description -l ja
58w3m は,ページャfmをベースに開発された World Wide Web に対応したページャ
59です.fm の機能に加えて、w3m の特徴には,次のようなものがあります.
60
61・WWW 対応なので,HTML の文書を読んでいる時には,その中のリンクを辿った
62  り,画像を見ることができる.
63・Internet message 表示のためのモードがある.この時,Content-Type: が
64  text/html の場合は,自動的に HTML の文書として表示する.また,自力で
65 MIME header のデコードをする.
66・見ている plain text 文書中に URL 表記があった場合,その部分からリンク
67  をたどることができる.
68
69%package img
70Summary: inline image extension support utilities for w3m
71Summary(ja): w3m 用インライン画像拡張サポートユーティリティ
72Group: Applications/Internet
73Requires: %{name} = %{version}-%{release}
74
75%description img
76w3m-img provides some utilities to support inline
77images for w3m
78on terminal emulator in X Window System environments.
79
80%description -l ja img
81w3m-img は X 環境のターミナルエミュレータ上の w3m でインライン画像を
82表示するためのユーティリティです。
83
84%prep
85%setup -q
86%patch10 -p1
87%patch11 -p1
88%patch100 -p1
89find Bonus -type f | \
90    xargs sed -i -e "s|/usr/local/bin/ruby|/usr/bin/ruby|g;"
91
92%build
93%configure \
94        --enable-japanese=E \
95        --with-termlib=ncurses \
96        --enable-image=x11 \
97        --with-imagelib=gtk2 \
98        --with-browser=gnome-open \
99        --with-mailer=gnome-open \
100        --with-editor=%{_sysbindir}/vi
101sed -i -e 's|#define USE_GPM 1|/* #undef USE_GPM */|' config.h
102sed -i -e 's|\-lgpm||g' Makefile
103make %{?_smp_mflags}
104
105
106%install
107rm -rf %{buildroot}
108make install DESTDIR=%{buildroot}
109
110mkdir -p %{buildroot}/etc/profile.d
111cp %{SOURCE1} %{buildroot}/etc/profile.d/w3m.sh
112cp %{SOURCE2} %{buildroot}/etc/profile.d/w3m.csh
113
114mkdir -p %{buildroot}%{_bindir}
115cp %{SOURCE10} %{buildroot}%{_bindir}/w3m-term
116chmod +x %{buildroot}%{_bindir}/w3m-term
117
118mkdir -p %{buildroot}%{_mandir}/{man1,ja/man1}
119install -p -m 644 doc-jp/w3m.1 %{buildroot}%{_mandir}/ja/man1
120install -p -m 644 doc/w3m.1 %{buildroot}%{_mandir}/man1
121# dont include duplicated man pages and CVS directory in doc
122rm -f doc-jp/w3m.1 doc/w3m.1
123find . -type d -name "CVS" | xargs rm -rf
124
125# prepare system-wide preference file
126mkdir -p %{buildroot}%{_sysconfdir}/w3m
127
128# prepare applnk
129%define applnkdir /etc/X11/applnk/Internet
130mkdir -p %{buildroot}/%{applnkdir}
131cat > %{buildroot}/%{applnkdir}/%{name}.desktop <<EOF
132[Desktop Entry]
133Name=%{name}
134Type=Application
135Comment=A Pager with WWW capability
136Comment[ja]=WWW対応ページャ
137Exec=w3m-term
138Terminal=false
139EOF
140
141# eliminate executable bit in %doc
142find Bonus/ -type f -perm +111 | xargs -r chmod -x
143
144
145%clean
146rm -rf %{buildroot}
147
148%post
149%{_syssbindir}/update-alternatives --install /usr/bin/pager pager /usr/bin/w3m 30
150
151%preun
152if [ "$1" = "0" ]; then
153  %{_syssbindir}/update-alternatives --remove pager /usr/bin/w3m
154fi
155
156
157%files
158%defattr(-,root,root)
159%doc Bonus ChangeLog NEWS README doc doc-jp
160%attr(755,root,root) %config /etc/profile.d/*
161%config(missingok) %{applnkdir}/%{name}.desktop
162%dir %{_sysconfdir}/w3m
163%{_bindir}/w3m*
164%exclude %{_libexecdir}/w3m/w3mimgdisplay
165%{_libexecdir}/w3m/
166%{_datadir}/w3m/
167%{_datadir}/locale/*/LC_MESSAGES/*
168%{_mandir}/ja/man1/w3m.1*
169%{_mandir}/man1/w3m*
170
171%files img
172%{_libexecdir}/w3m/w3mimgdisplay
173
174%changelog
175* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.5.2-7
176- rebuild with openssl-1.0.0c
177- add Patch100 (w3m-0.5.2-x86_64-vine.patch)
178
179* Sun Sep 26 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-6
180- add Patch10 to fix display utf8 ambiguous width characters
181  (from: http://www.j10n.org/files/w3m-cvs-1.914-ambwidth.patch)
182- add Patch11 to fix sudden crash
183  (from: http://www.sic.med.tohoku.ac.jp/~satodai/w3m-dev/200708.month/4286.html)
184
185* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-5
186- rebuilt with gcc-4.4.3-3 on ppc
187
188* Tue Feb  2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.2-4
189- rebuilt with new toolchain
190
191* Tue Apr 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-2
192- spec in utf-8
193- remove Requires: indexhtml
194- set HTTP_HOME to http://vinelinux.org/
195- update w3m-term
196
197* Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.2-1
198- new upstream release
199- dropped Patch100 (merged into upstream)
200
201* Sun Jun  3 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1.20060815-0vl6
202- rebuilt with new toolchain and environment
203
204* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl5
205- add Provides: pager
206- add Requires(post,preun): alternatives
207
208* Tue Apr 10 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 0.5.1.20060815-0vl3
209- add update-alternatives: pager in %post and %preun scriptlet
210
211* Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
212- 0.5.1.20060815-0vl2
213- rebuilt for VineSeed
214
215* Sat Dec 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
216- 0.5.1.20060815-0vl1.1
217- add patch100 for fix "inputAnswer()" SSL Certificate Handling Vulnerabilit
218
219* Tue Aug 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp>
220- update to cvs snapshot
221- use gtk2 for w3m-img instead of gdk-pixbuf
222
223* Sun Jul 23 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.5.1-0vl6
224- use filter-requires-w3m.sh as find-requires (rpm's bug?)
225
226* Sat Sep 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl5
227- use %%{_docdir}/Vine/index.html as default homepage
228
229* Sun Jul 25 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl4
230- change default editor to %%{_sysbindir}/vi
231- use ncurses explicitly as termlib
232
233* Sun Jul 11 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.5.1-0vl3
234- fix typo
235- add BuildPrereq: gtk+-devel, gdk-pixbuf-devel
236
237* Wed Jul 07 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl2
238- rebuild without gpm
239
240* Wed May  5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.1-0vl1
241- new upstream release
242- Obsoletes: w3m-m17n
243
244* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl2
245- add message catalogs to %%files
246
247* Fri Mar 27 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5-0vl1
248- new upstream release
249- fix w3mimgdisplay path in w3m-term
250
251* Sun Dec 14 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.2-0vl1
252- new upstream release
253- split w3mimgdisplay to w3m-img subpackage.
254- Requires: gc >= 6.2
255
256* Sat May 31 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 0.4.1-0vl1
257- new upstream release
258
259* Tue Feb 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4-0vl1
260- new upstream release
261
262* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.2-0vl1
263- new upstream release.
264  w3m 0.3.2.2 - 2002-12-06
265  * security fix: html_quote for img alt attributes
266
267* Fri Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl2
268- change default page path to /usr/doc/HTML.
269  this should be changed to /usr/share/doc in next release.
270  ( TODO: indexhtml package )
271
272* Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2.1-0vl1
273- new upstream release
274  w3m 0.3.2.1 - 2002-11-27
275  * security fix: html_quote for frame contents
276  * backport from w3m 0.3.2+cvs
277    - fix segmentation fault by large complex table.
278      [w3m-dev 03371][w3m-dev 03438]
279
280* Wed Nov  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.2-0vl1
281- new upstream release
282  w3m 0.3.2 - 2002-11-05
283  * ~/.netrc: password for ftp
284  * rc: display_lineinfo: display current line number
285  * rc: passwd_file: passwd file for HTTP auth
286  * func: MARK_WORD
287  * rc: imgsize: obsoleted
288  * w3m-img for framebuffer merged
289
290* Mon Sep 30 2002 Tomoya TAKA <taka@vinelinux.org> 0.3.1-0vl2
291- replace gc with an old version on alpha (Source20)
292
293* Wed Jul 17 2002 IWAI Masaharu <iwai@alib.jp> 0.3.1-0vl1
294- upstream release
295- coped new configure options
296
297* Sun Apr 21 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.3-0vl2
298- fixed configure option ([VineSeed:06372])
299- added openssl-devel version in {Build,}Requires
300
301* Mon Mar 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.3-0vl1
302- updated in sync with upstream 0.3 release
303  (now w3m-img patch is included in the upstream version)
304
305* Tue Feb 05 2002 Toru Sagami <sagami@vinelinux.org> 0.2.5-0vl1
306- w3m-0.2.5 with 0.2.5+cvs-1.302
307
308* Tue Jan 29 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl2
309- eliminate executable bit in %doc
310- spec cleanup
311
312* Wed Jan 16 2002 Toru Sagami <sagami@vinelinux.org> 0.2.4-0vl1
313- updated to current stable release
314
315* Thu Jan 03 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.3.2-0vl1
316- updated to new upstream release
317- FIXME: system-wide /etc/w3m/w3mconfig should be prepared. Anyone? :)
318
319* Fri Sep 28 2001 <masato@nets.ce.hiroshima-cu.ac.jp>
320- 0.2.1-0vl9
321- added sparc patch
322
323* Thu Aug 23 2001 <shom@vinelinux.org>
324- 0.2.1-0vl8: add w3m-term script
325
326* Mon Aug 06 2001 <sagami@vinelinux.org>
327- 0.2.1-0vl7: added imlib-devel ncurses-devel for BuildPreReq
328- update img patch to version 1.10 from 1.9
329
330* Mon Aug  6 2001 Jun Nishii <jun@vinelinux.org> 0.2.1-0vl6
331- added img patch
332
333* Mon Jul 16 2001 <sagami@vinelinux.org>
334- 0.2.1-0vl5: spec file clean up
335- openssl-devel for BuildPrereq, not openssl
336- install more sophisticated w3m.sh w3m.csh with any %%{_docdir} definition
337
338* Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
339- 0.2.1-0vl4
340- rebuilt with openssl-0.9.6b
341
342* Sun Jun 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
343- 0.2.1-0vl3
344- security fixes (http://www.lac.co.jp/security/snsadv/32.html)
345
346* Sat Jun 09 2001 <sagami@vinelinux.org>
347- 0.2.1-0vl2: minor spec fixes(URL, License and etc.)
348- actually rebuilt with ncurses5 (i386)
349
350* Sat Mar 24 2001 Yoichi Imai <yoichi@silver-forest.com>
351- 0.2.1-0vl1
352
353* Wed Dec 20 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
354- 0.1.10-0vl6
355- use better macros
356- rebuilt with ncurses5
357
358* Thu Sep 21 2000 Jun Nishii <jun@vinelinux.org>
359- w3m-0.1.10-0vl5
360- use applnk instead of wmconfig
361- use openssl
362
363* Thu Jul 27 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
364- w3m-0.1.10-0vl4
365- fix typo in w3m.csh and w3m.wmconfig
366
367* Sun Jul 09 2000 Toru Sagami <czs14350@nifty.ne.jp>
368- w3m-0.1.10-0vl3
369- provide default HTTP_HOME in /etc/profile.d
370
371* Fri Jul 07 2000 Toru Sagami <czs14350@nifty.ne.jp>
372- Provides: webclient, Requires: indexhtml (capability of lynx)
373- added w3m.wmconfig
374- give them(who?) RPM_OPT_FLAGS(what?)
375- dont include duplicated man pages and CVS directory in doc
376
377* Wed Jun 21 2000 Jun Nishii <jun@vinelinux.org>
378- 0.1.10-0vl1
379
380* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
381- fix spec file
382
383* Sat Jan 22 2000 Yoichi Imai <yoichi@silver-forest.com>
384- updated from 0.1.4 to 0.1.6
385
386* Thu Jan 13 2000 Yoichi Imai <yoichi@silver-forest.com>
387- updated from 991203 to 0.1.4
388
389* Fri Dec 03 1999 Yoichi Imai <yoichi@silver-forest.com>
390- updated from 991028 to 991203
391
392* Sat Oct 30 1999 Yoichi Imai <bonaim@mutt.freemail.ne.jp>
393- updated from 990820 to 991028
394
395* Tue Aug 26 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
396- updated from 990716 to 990820
397
398* Wed Aug 11 1999 Ryo Hattori <ryoh@vs01.vaio.ne.jp>
399- initial Release to VinePlus
Note: See TracBrowser for help on using the repository browser.