source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 9933

Revision 9933, 9.3 KB checked in by tomop, 8 years ago (diff)

unixODBC-2.3.4-1

Line 
1Name: unixODBC
2Version: 2.3.4
3Release: 1%{?_dist_release}
4Summary: A complete ODBC Driver Manager for Linux
5Summary(ja): Linux 用 ODBC ドライバマネージャー
6
7Group: System Environment/Libraries
8# Programs are GPL, libraries are LGPL, except News Server library is GPL.
9License: GPLv2+ and LGPLv2+
10URL: http://www.unixODBC.org/
11
12Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
13Source1: odbcinst.ini
14Source4: conffile.h
15Source5: README.dist
16
17Patch6: export-symbols.patch
18Patch8: so-version-bump.patch
19Patch9: keep-typedefs.patch
20
21Conflicts: iodbc
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
25BuildRequires: readline-devel
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Install unixODBC if you want to access databases through ODBC.
32You will also need the mysql-connector-odbc package if you want to access
33a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
34
35%package devel
36Summary: Development files for programs which will use the unixODBC library.
37Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42The unixODBC package can be used to access databases through ODBC
43drivers. If you want to develop programs that will access data through
44ODBC, you need to install this package.
45
46%prep
47%setup -q
48%patch6 -p1
49%patch8 -p1
50%patch9 -p1
51
52chmod 0644 Drivers/MiniSQL/*.c
53chmod 0644 Drivers/nn/*.c
54chmod 0644 Drivers/template/*.c
55chmod 0644 doc/ProgrammerManual/Tutorial/*.html
56chmod 0644 doc/lst/*
57chmod 0644 include/odbcinst.h
58
59# Blow away the embedded libtool and replace with build system's libtool.
60# (We will use the installed libtool anyway, but this makes sure they match.)
61rm -rf config.guess config.sub install-sh ltmain.sh libltdl
62# this hack is so we can build with either libtool 2.2 or 1.5
63libtoolize --install || libtoolize
64
65%build
66aclocal
67automake --add-missing
68autoconf
69
70# unixODBC 2.2.14 is not aliasing-safe
71CFLAGS="%{optflags} -fno-strict-aliasing"
72CXXFLAGS="$CFLAGS"
73export CFLAGS CXXFLAGS
74
75%configure --with-gnu-ld=yes --enable-threads=yes \
76        --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
77
78# Get rid of the rpaths
79sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
80sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
81
82make all
83
84%install
85rm -rf $RPM_BUILD_ROOT
86make DESTDIR=$RPM_BUILD_ROOT install
87install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
88
89# multilib header hacks
90# we only apply this to known Red Hat multilib arches, per bug #181335
91case `uname -i` in
92  i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
93    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
94    rm -f unixodbc_conf.h
95    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
96    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
97    ;;
98  *)
99    ;;
100esac
101
102# add some explanatory documentation
103cp %{SOURCE5} README.dist
104
105# remove obsolete Postgres drivers from the package (but not the setup code)
106rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
107
108# copy text driver documentation into main doc directory
109# currently disabled because upstream no longer includes text driver
110# mkdir -p doc/Drivers/txt
111# cp -pr Drivers/txt/doc/* doc/Drivers/txt
112
113# don't want to install doc Makefiles as docs
114find doc -name 'Makefile*' | xargs rm
115
116# we do not want to ship static libraries
117rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
118
119# remove unpackaged files from the buildroot
120rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
121rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
122rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
123
124# initialize lists of .so files
125find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
126find $RPM_BUILD_ROOT%{_libdir} -name "*.so"   | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
127
128# move these to main package, they're often dlopened...
129for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
130do
131    echo "%{_libdir}/$lib" >> base-so-list
132    grep -v "/$lib$" devel-so-list > devel-so-list.x
133    mv -f devel-so-list.x devel-so-list
134done
135
136%clean
137rm -rf $RPM_BUILD_ROOT
138
139%post -p /sbin/ldconfig
140
141%postun -p /sbin/ldconfig
142
143%files -f base-so-list
144%doc README COPYING AUTHORS ChangeLog NEWS doc
145%doc README.dist
146%config(noreplace) %{_sysconfdir}/odbc*
147%{_bindir}/odbcinst
148%{_bindir}/isql
149%{_bindir}/dltest
150%{_bindir}/iusql
151%{_bindir}/odbc_config
152%{_bindir}/slencheck
153%{_mandir}/man*/*
154
155%files devel -f devel-so-list
156%{_includedir}/*
157
158%changelog
159* Tue Jan  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
160- new upstream release.
161
162* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
163- rebuilt with readline 6.3
164- removed kde-subpackage-related BuildRequires
165- added Japanese summary
166
167* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
168- new upstream release.
169- gui was discontinued in upstream.
170
171* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
172- rebuild with VineSeed environment
173
174* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
175- add --with-qt-includes option for configure
176
177* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
178- updated to 2.2.14
179
180* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
181- applied new versioning policy
182- removed *.la files from devel package
183
184* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
185- updated to 2.2.12
186- rebuilt with new toolchain
187
188* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
189- use installed libltdl
190- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
191
192* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
193- rebuilt with readline 5.1
194
195* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
196- updated to 2.2.11
197- not libtoolize
198
199* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
200- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
201
202* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
203- source upgrade
204- remove patch (no need)
205- run libtoolize etc for VineSeed
206
207* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
208- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
209
210* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
211- source upgrade
212- change spec to build both VineSeed and Vine2.5/2.6
213- add patch from rawhide 2.2.3-6
214
215* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
216- Requires: libjpeg (not libjpeg-6b)
217
218* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
219- source upgrade
220- add BuildPrereq: autoconf253 automake15
221- add PreReq: ldconfig
222- fix %files section and clean up spec
223- for unixODBC-kde package
224  - add Requires: unixODBC = %{version}
225  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
226  - delete .desktop files
227
228* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
229- rebuild with KDE3
230
231* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
232- updated unixODBC-2.2.0
233- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
234
235* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
236- remove -kde package on alpha
237
238* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
239- Rebuild for Vine.
240
241* Sun Jun 24 2001 Than Ngo <than@redhat.com>
242- rebuild against qt-2.3.1, kde-2.1.x
243
244* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
245- Better default odbcinst.ini
246- Minor cleanups
247
248* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
249- 2.0.7
250
251* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
252- Fix for isql segfault on EOF/ctrl-d exit
253
254* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
255- 2.0.6
256- add patch for 64 bit archs (dword shouldn't be "long int")
257
258* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
259- rebuild
260
261* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
262- 1.8.13
263
264* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
265- enable GUI now that we have KDE compiled with the standard
266  compiler
267- move the applnk entries to the KDE package
268
269* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
270- add the missing shared libs to the non-devel package
271
272* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
273- 1.8.12 fixes problems with the postgresql driver
274
275* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
276- disable KDE subpackage to avoid the mess that is C++ binary
277  compatibility
278
279* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
280- automatic rebuild
281
282* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
283- improved QTDIR detection
284
285* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
286- 1.8.10
287- use %%{_tmppath}
288- update URL
289- including two missing libraries
290
291* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
292- 1.8.9
293
294* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
295- adopted for Winston, changed to Red Hat packaging standards
296
297* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
298- added a unixODBC-devel RPM to the group, added KDE links and icons to system
299- all of which came from recommendations from Fredrick Meunier
300- <Fredrick.Meunier@computershare.com.au>
301
302* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
303- unixODBC-1.8.7
304- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
305
306
Note: See TracBrowser for help on using the repository browser.