source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 11440

Revision 11440, 9.0 KB checked in by tomop, 6 years ago (diff)

unixODBC-2.3.5-1

Line 
1Name: unixODBC
2Version: 2.3.5
3Release: 1%{?_dist_release}
4Summary: A complete ODBC Driver Manager for Linux
5Summary(ja): Linux 用 ODBC ドライバマネージャー
6
7Group: System Environment/Libraries
8# Programs are GPL, libraries are LGPL, except News Server library is GPL.
9License: GPLv2+ and LGPLv2+
10URL: http://www.unixODBC.org/
11
12Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
13Source1: odbcinst.ini
14Source4: conffile.h
15Source5: README.dist
16
17Patch6: export-symbols.patch
18Patch8: so-version-bump.patch
19Patch9: keep-typedefs.patch
20
21Conflicts: iodbc
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-root
24BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
25BuildRequires: readline-devel
26
27Vendor: Project Vine
28Distribution: Vine Linux
29
30%description
31Install unixODBC if you want to access databases through ODBC.
32You will also need the mysql-connector-odbc package if you want to access
33a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
34
35%package devel
36Summary: Development files for programs which will use the unixODBC library.
37Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
38Group: Development/Libraries
39Requires: %{name} = %{version}-%{release}
40
41%description devel
42The unixODBC package can be used to access databases through ODBC
43drivers. If you want to develop programs that will access data through
44ODBC, you need to install this package.
45
46%prep
47%setup -q
48%patch6 -p1
49%patch8 -p1
50%patch9 -p1
51
52chmod 0644 Drivers/MiniSQL/*.c
53chmod 0644 Drivers/nn/*.c
54chmod 0644 Drivers/template/*.c
55chmod 0644 doc/ProgrammerManual/Tutorial/*.html
56chmod 0644 doc/lst/*
57chmod 0644 include/odbcinst.h
58
59%build
60autoreconf -ivf
61
62# unixODBC 2.2.14 is not aliasing-safe
63CFLAGS="%{optflags} -fno-strict-aliasing"
64CXXFLAGS="$CFLAGS"
65export CFLAGS CXXFLAGS
66
67%configure --with-gnu-ld=yes --enable-threads=yes \
68        --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
69
70# Get rid of the rpaths
71sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
72sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
73
74make all
75
76%install
77rm -rf $RPM_BUILD_ROOT
78make DESTDIR=$RPM_BUILD_ROOT install
79install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
80
81# multilib header hacks
82# we only apply this to known Red Hat multilib arches, per bug #181335
83case `uname -i` in
84  i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
85    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
86    rm -f unixodbc_conf.h
87    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
88    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
89    ;;
90  *)
91    ;;
92esac
93
94# add some explanatory documentation
95cp %{SOURCE5} README.dist
96
97# remove obsolete Postgres drivers from the package (but not the setup code)
98rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
99
100# copy text driver documentation into main doc directory
101# currently disabled because upstream no longer includes text driver
102# mkdir -p doc/Drivers/txt
103# cp -pr Drivers/txt/doc/* doc/Drivers/txt
104
105# don't want to install doc Makefiles as docs
106find doc -name 'Makefile*' | xargs rm
107
108# we do not want to ship static libraries
109rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
110
111# remove unpackaged files from the buildroot
112rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
113rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
114rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
115
116# initialize lists of .so files
117find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
118find $RPM_BUILD_ROOT%{_libdir} -name "*.so"   | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
119
120# move these to main package, they're often dlopened...
121for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
122do
123    echo "%{_libdir}/$lib" >> base-so-list
124    grep -v "/$lib$" devel-so-list > devel-so-list.x
125    mv -f devel-so-list.x devel-so-list
126done
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%post -p /sbin/ldconfig
132
133%postun -p /sbin/ldconfig
134
135%files -f base-so-list
136%doc README COPYING AUTHORS ChangeLog NEWS doc
137%doc README.dist
138%config(noreplace) %{_sysconfdir}/odbc*
139%{_bindir}/odbcinst
140%{_bindir}/isql
141%{_bindir}/dltest
142%{_bindir}/iusql
143%{_bindir}/odbc_config
144%{_bindir}/slencheck
145%{_mandir}/man*/*
146
147%files devel -f devel-so-list
148%{_includedir}/*
149
150%changelog
151* Sat Jan 20 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.5-1
152- new upstream release.
153
154* Tue Jan  5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.4-1
155- new upstream release.
156
157* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
158- rebuilt with readline 6.3
159- removed kde-subpackage-related BuildRequires
160- added Japanese summary
161
162* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
163- new upstream release.
164- gui was discontinued in upstream.
165
166* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
167- rebuild with VineSeed environment
168
169* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
170- add --with-qt-includes option for configure
171
172* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
173- updated to 2.2.14
174
175* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
176- applied new versioning policy
177- removed *.la files from devel package
178
179* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
180- updated to 2.2.12
181- rebuilt with new toolchain
182
183* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
184- use installed libltdl
185- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
186
187* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
188- rebuilt with readline 5.1
189
190* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
191- updated to 2.2.11
192- not libtoolize
193
194* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
195- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
196
197* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
198- source upgrade
199- remove patch (no need)
200- run libtoolize etc for VineSeed
201
202* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
203- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
204
205* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
206- source upgrade
207- change spec to build both VineSeed and Vine2.5/2.6
208- add patch from rawhide 2.2.3-6
209
210* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
211- Requires: libjpeg (not libjpeg-6b)
212
213* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
214- source upgrade
215- add BuildPrereq: autoconf253 automake15
216- add PreReq: ldconfig
217- fix %files section and clean up spec
218- for unixODBC-kde package
219  - add Requires: unixODBC = %{version}
220  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
221  - delete .desktop files
222
223* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
224- rebuild with KDE3
225
226* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
227- updated unixODBC-2.2.0
228- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
229
230* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
231- remove -kde package on alpha
232
233* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
234- Rebuild for Vine.
235
236* Sun Jun 24 2001 Than Ngo <than@redhat.com>
237- rebuild against qt-2.3.1, kde-2.1.x
238
239* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
240- Better default odbcinst.ini
241- Minor cleanups
242
243* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
244- 2.0.7
245
246* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
247- Fix for isql segfault on EOF/ctrl-d exit
248
249* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
250- 2.0.6
251- add patch for 64 bit archs (dword shouldn't be "long int")
252
253* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
254- rebuild
255
256* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
257- 1.8.13
258
259* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
260- enable GUI now that we have KDE compiled with the standard
261  compiler
262- move the applnk entries to the KDE package
263
264* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
265- add the missing shared libs to the non-devel package
266
267* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
268- 1.8.12 fixes problems with the postgresql driver
269
270* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
271- disable KDE subpackage to avoid the mess that is C++ binary
272  compatibility
273
274* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
275- automatic rebuild
276
277* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
278- improved QTDIR detection
279
280* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
281- 1.8.10
282- use %%{_tmppath}
283- update URL
284- including two missing libraries
285
286* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
287- 1.8.9
288
289* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
290- adopted for Winston, changed to Red Hat packaging standards
291
292* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
293- added a unixODBC-devel RPM to the group, added KDE links and icons to system
294- all of which came from recommendations from Fredrick Meunier
295- <Fredrick.Meunier@computershare.com.au>
296
297* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
298- unixODBC-1.8.7
299- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
300
301
Note: See TracBrowser for help on using the repository browser.