source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 9467

Revision 9467, 9.5 KB checked in by inagaki, 9 years ago (diff)

2015-03-24 Ryoichi INAGAKI <ryo1@…>

  • bind, guild, js, unixODBC: rebuilt
  • ed: updated


Line 
1Name: unixODBC
2Version: 2.3.2
3Release: 2%{?_dist_release}
4Summary: A complete ODBC Driver Manager for Linux
5Summary(ja): Linux 用 ODBC ドライバマネージャー
6
7Group: System Environment/Libraries
8# Programs are GPL, libraries are LGPL, except News Server library is GPL.
9License: GPLv2+ and LGPLv2+
10URL: http://www.unixODBC.org/
11
12Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
13Source1: odbcinst.ini
14Source4: conffile.h
15Source5: README.dist
16Source6: iusql.1
17Source7: dltest.1
18Source8: odbc_config.1
19Source9: unixODBC.7
20
21Patch1: depcomp.patch
22Patch6: export-symbols.patch
23Patch8: so-version-bump.patch
24Patch9: keep-typedefs.patch
25Patch10: unixODBC-isql.1.patch
26
27Conflicts: iodbc
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
31BuildRequires: readline-devel
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37Install unixODBC if you want to access databases through ODBC.
38You will also need the mysql-connector-odbc package if you want to access
39a MySQL database, and/or the postgresql-odbc package for PostgreSQL.
40
41%package devel
42Summary: Development files for programs which will use the unixODBC library.
43Summary(ja): unixODBC ライブラリを用いるプログラムのための開発用ファイル
44Group: Development/Libraries
45Requires: %{name} = %{version}-%{release}
46
47%description devel
48The unixODBC package can be used to access databases through ODBC
49drivers. If you want to develop programs that will access data through
50ODBC, you need to install this package.
51
52%prep
53%setup -q
54%patch1 -p1
55%patch6 -p1
56%patch8 -p1
57%patch9 -p1
58%patch10 -p1
59
60chmod 0644 Drivers/MiniSQL/*.c
61chmod 0644 Drivers/nn/*.c
62chmod 0644 Drivers/template/*.c
63chmod 0644 doc/ProgrammerManual/Tutorial/*.html
64chmod 0644 doc/lst/*
65chmod 0644 include/odbcinst.h
66
67# Blow away the embedded libtool and replace with build system's libtool.
68# (We will use the installed libtool anyway, but this makes sure they match.)
69rm -rf config.guess config.sub install-sh ltmain.sh libltdl
70# this hack is so we can build with either libtool 2.2 or 1.5
71libtoolize --install || libtoolize
72
73%build
74aclocal
75automake --add-missing
76autoconf
77
78# unixODBC 2.2.14 is not aliasing-safe
79CFLAGS="%{optflags} -fno-strict-aliasing"
80CXXFLAGS="$CFLAGS"
81export CFLAGS CXXFLAGS
82
83%configure --with-gnu-ld=yes --enable-threads=yes \
84        --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
85make all
86
87%install
88rm -rf $RPM_BUILD_ROOT
89make DESTDIR=$RPM_BUILD_ROOT install
90install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
91
92# multilib header hacks
93# we only apply this to known Red Hat multilib arches, per bug #181335
94case `uname -i` in
95  i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
96    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
97    rm -f unixodbc_conf.h
98    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
99    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
100    ;;
101  *)
102    ;;
103esac
104
105# add some explanatory documentation
106cp %{SOURCE5} README.dist
107
108# remove obsolete Postgres drivers from the package (but not the setup code)
109rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
110
111# copy text driver documentation into main doc directory
112# currently disabled because upstream no longer includes text driver
113# mkdir -p doc/Drivers/txt
114# cp -pr Drivers/txt/doc/* doc/Drivers/txt
115
116# don't want to install doc Makefiles as docs
117find doc -name 'Makefile*' | xargs rm
118
119# we do not want to ship static libraries
120rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
121
122# remove unpackaged files from the buildroot
123rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
124rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
125rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
126
127# initialize lists of .so files
128find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
129find $RPM_BUILD_ROOT%{_libdir} -name "*.so"   | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
130
131# move these to main package, they're often dlopened...
132for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
133do
134    echo "%{_libdir}/$lib" >> base-so-list
135    grep -v "/$lib$" devel-so-list > devel-so-list.x
136    mv -f devel-so-list.x devel-so-list
137done
138
139# install man pages that are not part of the upstream yet
140install -Dm644 %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/man1/iusql.1
141install -Dm644 %{SOURCE7} $RPM_BUILD_ROOT%{_mandir}/man1/dltest.1
142install -Dm644 %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/man1/odbc_config.1
143install -Dm644 %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/man7/unixODBC.7
144
145%clean
146rm -rf $RPM_BUILD_ROOT
147
148%post -p /sbin/ldconfig
149
150%postun -p /sbin/ldconfig
151
152%files -f base-so-list
153%doc README COPYING AUTHORS ChangeLog NEWS doc
154%doc README.dist
155%config(noreplace) %{_sysconfdir}/odbc*
156%{_bindir}/odbcinst
157%{_bindir}/isql
158%{_bindir}/dltest
159%{_bindir}/iusql
160%{_bindir}/odbc_config
161%{_bindir}/slencheck
162%{_mandir}/man*/*
163
164%files devel -f devel-so-list
165%{_includedir}/*
166
167%changelog
168* Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.3.2-2
169- rebuilt with readline 6.3
170- removed kde-subpackage-related BuildRequires
171- added Japanese summary
172
173* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
174- new upstream release.
175- gui was discontinued in upstream.
176
177* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
178- rebuild with VineSeed environment
179
180* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
181- add --with-qt-includes option for configure
182
183* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
184- updated to 2.2.14
185
186* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
187- applied new versioning policy
188- removed *.la files from devel package
189
190* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
191- updated to 2.2.12
192- rebuilt with new toolchain
193
194* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
195- use installed libltdl
196- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
197
198* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
199- rebuilt with readline 5.1
200
201* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
202- updated to 2.2.11
203- not libtoolize
204
205* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
206- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
207
208* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
209- source upgrade
210- remove patch (no need)
211- run libtoolize etc for VineSeed
212
213* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
214- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
215
216* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
217- source upgrade
218- change spec to build both VineSeed and Vine2.5/2.6
219- add patch from rawhide 2.2.3-6
220
221* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
222- Requires: libjpeg (not libjpeg-6b)
223
224* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
225- source upgrade
226- add BuildPrereq: autoconf253 automake15
227- add PreReq: ldconfig
228- fix %files section and clean up spec
229- for unixODBC-kde package
230  - add Requires: unixODBC = %{version}
231  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
232  - delete .desktop files
233
234* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
235- rebuild with KDE3
236
237* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
238- updated unixODBC-2.2.0
239- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
240
241* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
242- remove -kde package on alpha
243
244* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
245- Rebuild for Vine.
246
247* Sun Jun 24 2001 Than Ngo <than@redhat.com>
248- rebuild against qt-2.3.1, kde-2.1.x
249
250* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
251- Better default odbcinst.ini
252- Minor cleanups
253
254* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
255- 2.0.7
256
257* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
258- Fix for isql segfault on EOF/ctrl-d exit
259
260* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
261- 2.0.6
262- add patch for 64 bit archs (dword shouldn't be "long int")
263
264* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
265- rebuild
266
267* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
268- 1.8.13
269
270* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
271- enable GUI now that we have KDE compiled with the standard
272  compiler
273- move the applnk entries to the KDE package
274
275* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
276- add the missing shared libs to the non-devel package
277
278* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
279- 1.8.12 fixes problems with the postgresql driver
280
281* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
282- disable KDE subpackage to avoid the mess that is C++ binary
283  compatibility
284
285* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
286- automatic rebuild
287
288* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
289- improved QTDIR detection
290
291* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
292- 1.8.10
293- use %%{_tmppath}
294- update URL
295- including two missing libraries
296
297* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
298- 1.8.9
299
300* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
301- adopted for Winston, changed to Red Hat packaging standards
302
303* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
304- added a unixODBC-devel RPM to the group, added KDE links and icons to system
305- all of which came from recommendations from Fredrick Meunier
306- <Fredrick.Meunier@computershare.com.au>
307
308* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
309- unixODBC-1.8.7
310- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
311
312
Note: See TracBrowser for help on using the repository browser.