source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 8757

Revision 8757, 10.0 KB checked in by tomop, 10 years ago (diff)

unixODBC-2.3.2-1

RevLine 
[521]1%define __libtoolize true
2
[8067]3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.5)
[3408]4%define _qt4_bindir %(pkg-config --variable bindir --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{_qt4_version}/bin)
[521]5
[3408]6Name: unixODBC
[521]7Summary: A complete ODBC Driver Manager for Linux
[8757]8Version: 2.3.2
9Release: 1%{?_dist_release}
[3408]10
[521]11Group: System Environment/Libraries
[3408]12# Programs are GPL, libraries are LGPL, except News Server library is GPL.
13License: GPLv2+ and LGPLv2+
14URL: http://www.unixODBC.org/
15
[521]16Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
17Source1: odbcinst.ini
[3408]18Source4: conffile.h
[8757]19Source5: README.dist
20Source6: iusql.1
21Source7: dltest.1
22Source8: odbc_config.1
23Source9: unixODBC.7
[521]24
[3408]25Patch1: depcomp.patch
26Patch6: export-symbols.patch
27Patch8: so-version-bump.patch
28Patch9: keep-typedefs.patch
[8757]29Patch10: unixODBC-isql.1.patch
30
[521]31Conflicts: iodbc
32
33BuildRoot: %{_tmppath}/%{name}-%{version}-root
[3408]34BuildRequires: libX11-devel libXt-devel libXext-devel
35BuildRequires: qt4-devel qt-assistant-adp-devel readline-devel
36BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
37BuildRequires: desktop-file-utils
[521]38
[8067]39Vendor: Project Vine
40Distribution: Vine Linux
41
[521]42%description
43The unixODBC Project goals are to develop and promote unixODBC to
44be the definitive standard for ODBC on the Linux platform. This is to
45include GUI support for KDE.
46
47Install unixODBC if you'd like to access databases through ODBC. This
48package include drivers for PostgreSQL and local files.
49
50If you want to develop programs that will access data through ODBC,
51you'll also need to have the unixODBC package installed.
52
53%package devel
54Summary: Development files for programs which will use the unixODBC library.
55Group: Development/Libraries
[3408]56Requires: %{name} = %{version}-%{release}
[521]57
58%description devel
59Install unixODBC if you'd like to access databases through ODBC drivers.
60
61If you want to develop programs that will access data through ODBC,
62you'll also need to install the unixODBC-devel (this) package.
63
64%package kde
65Summary: KDE DriverManager components for ODBC
66Group: System Environment/Libraries
[3408]67Requires: %{name} = %{version}-%{release}
[521]68
69%description kde
70Components for the ODBCConfig and DataManager (KDE) Components of unixODBC.
71
72%prep
73%setup -q
74%patch1 -p1
[3408]75%patch6 -p1
76%patch8 -p1
77%patch9 -p1
78%patch10 -p1
[521]79
[3408]80chmod 0644 Drivers/MiniSQL/*.c
81chmod 0644 Drivers/nn/*.c
82chmod 0644 Drivers/template/*.c
83chmod 0644 doc/ProgrammerManual/Tutorial/*.html
84chmod 0644 doc/lst/*
85chmod 0644 include/odbcinst.h
[521]86
[3408]87# Blow away the embedded libtool and replace with build system's libtool.
88# (We will use the installed libtool anyway, but this makes sure they match.)
89rm -rf config.guess config.sub install-sh ltmain.sh libltdl
90# this hack is so we can build with either libtool 2.2 or 1.5
91libtoolize --install || libtoolize
[521]92
93%build
94aclocal
95automake --add-missing
96autoconf
97
[3408]98# unixODBC 2.2.14 is not aliasing-safe
99CFLAGS="%{optflags} -fno-strict-aliasing"
100CXXFLAGS="$CFLAGS"
101export CFLAGS CXXFLAGS
102
[8757]103%configure --with-gnu-ld=yes --enable-threads=yes \
104        --enable-drivers=yes --enable-driverc=yes --enable-ltdllib
[521]105make all
106
107%install
[3408]108make DESTDIR=$RPM_BUILD_ROOT install
[8757]109install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
[521]110
[3408]111# multilib header hacks
112# we only apply this to known Red Hat multilib arches, per bug #181335
113case `uname -i` in
[8757]114  i386 | x86_64 | ia64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
[3408]115    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
116    rm -f unixodbc_conf.h
117    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
118    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
119    ;;
120  *)
121    ;;
122esac
123
[8757]124# add some explanatory documentation
125cp %{SOURCE5} README.dist
126
[3408]127# remove obsolete Postgres drivers from the package (but not the setup code)
128rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
129
130# copy text driver documentation into main doc directory
131# currently disabled because upstream no longer includes text driver
132# mkdir -p doc/Drivers/txt
133# cp -pr Drivers/txt/doc/* doc/Drivers/txt
134
135# don't want to install doc Makefiles as docs
[8757]136find doc -name 'Makefile*' | xargs rm
[3408]137
138# we do not want to ship static libraries
139rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
140
141# remove unpackaged files from the buildroot
142rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
143rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
144rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
145
[8757]146# initialize lists of .so files
147find $RPM_BUILD_ROOT%{_libdir} -name "*.so.*" | sed "s|^$RPM_BUILD_ROOT||" > base-so-list
148find $RPM_BUILD_ROOT%{_libdir} -name "*.so"   | sed "s|^$RPM_BUILD_ROOT||" > devel-so-list
149
150# move these to main package, they're often dlopened...
151for lib in libodbc.so libodbcinst.so libodbcpsqlS.so libodbcmyS.so
152do
153    echo "%{_libdir}/$lib" >> base-so-list
154    grep -v "/$lib$" devel-so-list > devel-so-list.x
155    mv -f devel-so-list.x devel-so-list
156done
157
158# install man pages that are not part of the upstream yet
159install -Dm644 %{SOURCE6} $RPM_BUILD_ROOT%{_mandir}/man1/iusql.1
160install -Dm644 %{SOURCE7} $RPM_BUILD_ROOT%{_mandir}/man1/dltest.1
161install -Dm644 %{SOURCE8} $RPM_BUILD_ROOT%{_mandir}/man1/odbc_config.1
162install -Dm644 %{SOURCE9} $RPM_BUILD_ROOT%{_mandir}/man7/unixODBC.7
163
[521]164%clean
165rm -rf $RPM_BUILD_ROOT
166
167%post -p /sbin/ldconfig
168
169%postun -p /sbin/ldconfig
170
171%post kde -p /sbin/ldconfig
172
173%postun kde -p /sbin/ldconfig
174
[8757]175%files -f base-so-list
176%doc README COPYING AUTHORS ChangeLog NEWS doc
177%doc README.dist
[521]178%config(noreplace) %{_sysconfdir}/odbc*
[8757]179%{_bindir}/odbcinst
[521]180%{_bindir}/isql
[8757]181%{_bindir}/dltest
[521]182%{_bindir}/iusql
183%{_bindir}/odbc_config
[8757]184%{_bindir}/slencheck
185%{_mandir}/man*/*
186
187%files devel -f devel-so-list
[521]188%{_includedir}/*
189
190%changelog
[8757]191* Tue Jul  8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.2-1
192- new upstream release.
193- gui was discontinued in upstream.
194
[8067]195* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
196- rebuild with VineSeed environment
197
[3409]198* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
199- add --with-qt-includes option for configure
200
[3408]201* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
202- updated to 2.2.14
203
[521]204* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
205- applied new versioning policy
206- removed *.la files from devel package
207
208* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
209- updated to 2.2.12
210- rebuilt with new toolchain
211
212* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
213- use installed libltdl
214- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
215
216* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
217- rebuilt with readline 5.1
218
219* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
220- updated to 2.2.11
221- not libtoolize
222
223* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
224- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
225
226* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
227- source upgrade
228- remove patch (no need)
229- run libtoolize etc for VineSeed
230
231* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
232- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
233
234* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
235- source upgrade
236- change spec to build both VineSeed and Vine2.5/2.6
237- add patch from rawhide 2.2.3-6
238
239* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
240- Requires: libjpeg (not libjpeg-6b)
241
242* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
243- source upgrade
244- add BuildPrereq: autoconf253 automake15
245- add PreReq: ldconfig
246- fix %files section and clean up spec
247- for unixODBC-kde package
248  - add Requires: unixODBC = %{version}
249  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
250  - delete .desktop files
251
252* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
253- rebuild with KDE3
254
255* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
256- updated unixODBC-2.2.0
257- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
258
259* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
260- remove -kde package on alpha
261
262* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
263- Rebuild for Vine.
264
265* Sun Jun 24 2001 Than Ngo <than@redhat.com>
266- rebuild against qt-2.3.1, kde-2.1.x
267
268* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
269- Better default odbcinst.ini
270- Minor cleanups
271
272* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
273- 2.0.7
274
275* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
276- Fix for isql segfault on EOF/ctrl-d exit
277
278* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
279- 2.0.6
280- add patch for 64 bit archs (dword shouldn't be "long int")
281
282* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
283- rebuild
284
285* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
286- 1.8.13
287
288* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
289- enable GUI now that we have KDE compiled with the standard
290  compiler
291- move the applnk entries to the KDE package
292
293* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
294- add the missing shared libs to the non-devel package
295
296* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
297- 1.8.12 fixes problems with the postgresql driver
298
299* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
300- disable KDE subpackage to avoid the mess that is C++ binary
301  compatibility
302
303* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
304- automatic rebuild
305
306* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
307- improved QTDIR detection
308
[8067]309* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
[521]310- 1.8.10
311- use %%{_tmppath}
312- update URL
313- including two missing libraries
314
315* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
316- 1.8.9
317
318* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
319- adopted for Winston, changed to Red Hat packaging standards
320
321* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
322- added a unixODBC-devel RPM to the group, added KDE links and icons to system
323- all of which came from recommendations from Fredrick Meunier
324- <Fredrick.Meunier@computershare.com.au>
325
326* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
327- unixODBC-1.8.7
328- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
329
330
Note: See TracBrowser for help on using the repository browser.