source: projects/specs/trunk/u/unixODBC/unixODBC-vl.spec @ 8067

Revision 8067, 11.2 KB checked in by Takemikaduchi, 10 years ago (diff)

new upstream release or rebuild

Line 
1%define __libtoolize true
2
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.8.5)
4%define _qt4_bindir %(pkg-config --variable bindir --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{_qt4_version}/bin)
5
6Name: unixODBC
7Summary: A complete ODBC Driver Manager for Linux
8Version: 2.2.14
9Release: 3%{?_dist_release}
10
11Group: System Environment/Libraries
12# Programs are GPL, libraries are LGPL, except News Server library is GPL.
13License: GPLv2+ and LGPLv2+
14URL: http://www.unixODBC.org/
15
16Source: http://www.unixODBC.org/%{name}-%{version}.tar.gz
17Source1: odbcinst.ini
18Source2: ODBCConfig.desktop
19Source3: DataManager.desktop
20Source4: conffile.h
21
22Patch1: depcomp.patch
23Patch2: multilib-config.patch
24Patch3: warning-cleanup.patch
25Patch6: export-symbols.patch
26Patch7: libtool-config.patch
27Patch8: so-version-bump.patch
28Patch9: keep-typedefs.patch
29Patch10: odbcint64-config.patch
30Patch11: enable-items.patch
31Patch12: isql-fixes.patch
32Conflicts: iodbc
33
34BuildRoot: %{_tmppath}/%{name}-%{version}-root
35BuildRequires: libX11-devel libXt-devel libXext-devel
36BuildRequires: qt4-devel qt-assistant-adp-devel readline-devel
37BuildRequires: automake autoconf libtool libtool-ltdl-devel bison flex
38BuildRequires: desktop-file-utils
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%description
44The unixODBC Project goals are to develop and promote unixODBC to
45be the definitive standard for ODBC on the Linux platform. This is to
46include GUI support for KDE.
47
48Install unixODBC if you'd like to access databases through ODBC. This
49package include drivers for PostgreSQL and local files.
50
51If you want to develop programs that will access data through ODBC,
52you'll also need to have the unixODBC package installed.
53
54%package devel
55Summary: Development files for programs which will use the unixODBC library.
56Group: Development/Libraries
57Requires: %{name} = %{version}-%{release}
58
59%description devel
60Install unixODBC if you'd like to access databases through ODBC drivers.
61
62If you want to develop programs that will access data through ODBC,
63you'll also need to install the unixODBC-devel (this) package.
64
65%package kde
66Summary: KDE DriverManager components for ODBC
67Group: System Environment/Libraries
68Requires: %{name} = %{version}-%{release}
69
70%description kde
71Components for the ODBCConfig and DataManager (KDE) Components of unixODBC.
72
73%prep
74%setup -q
75%patch1 -p1
76%patch2 -p1
77%patch3 -p1
78%patch6 -p1
79%patch7 -p1
80%patch8 -p1
81%patch9 -p1
82%patch10 -p1
83%patch11 -p1
84%patch12 -p1
85
86chmod 0644 Drivers/MiniSQL/*.c
87chmod 0644 Drivers/nn/*.c
88chmod 0644 Drivers/template/*.c
89chmod 0644 doc/ProgrammerManual/Tutorial/*.html
90chmod 0644 doc/lst/*
91chmod 0644 include/odbcinst.h
92
93# Blow away the embedded libtool and replace with build system's libtool.
94# (We will use the installed libtool anyway, but this makes sure they match.)
95rm -rf config.guess config.sub install-sh ltmain.sh libltdl
96# this hack is so we can build with either libtool 2.2 or 1.5
97libtoolize --install || libtoolize
98
99%build
100# pick up qt path
101export PATH="%{_qt4_bindir}:$PATH"
102# clean up old moc files
103(cd odbcinstQ4 && rm -f mC*.cpp)
104
105aclocal
106automake --add-missing
107autoconf
108
109# unixODBC 2.2.14 is not aliasing-safe
110CFLAGS="%{optflags} -fno-strict-aliasing"
111CXXFLAGS="$CFLAGS"
112export CFLAGS CXXFLAGS
113
114%configure --with-gnu-ld=yes --enable-threads=yes --enable-gui=yes --enable-drivers --enable-ltdllib --with-qt-programs="%{_qt4_bindir}" --with-qt-libraries="%{_qt4_libdir}" --with-qt-includes="%{_qt4_headerdir}"
115make all
116
117%install
118# pick up qt path
119export PATH="%{_qt4_bindir}:$PATH"
120
121rm -rf $RPM_BUILD_ROOT
122mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
123mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
124
125make DESTDIR=$RPM_BUILD_ROOT install
126cp %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
127
128# install *.desktop files
129desktop-file-install --dir=$RPM_BUILD_ROOT%{_datadir}/applications %{SOURCE2}
130
131# package doesn't supply an icon for ODBCConfig, so use the one for DataManager
132cp DataManager/LinuxODBC.xpm $RPM_BUILD_ROOT%{_datadir}/pixmaps
133
134# multilib header hacks
135# we only apply this to known Red Hat multilib arches, per bug #181335
136case `uname -i` in
137  i386 | x86_64 | ppc | ppc64 | s390 | s390x | sparc | sparc64 )
138    mv $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}/unixodbc_conf_`uname -i`.h
139    rm -f unixodbc_conf.h
140    sed s/CONFFILE/unixodbc_conf/ %{SOURCE4} >unixodbc_conf.h
141    install -m 644 unixodbc_conf.h $RPM_BUILD_ROOT%{_includedir}
142    ;;
143  *)
144    ;;
145esac
146
147# remove obsolete Postgres drivers from the package (but not the setup code)
148rm -f $RPM_BUILD_ROOT%{_libdir}/libodbcpsql.so*
149
150# copy text driver documentation into main doc directory
151# currently disabled because upstream no longer includes text driver
152# mkdir -p doc/Drivers/txt
153# cp -pr Drivers/txt/doc/* doc/Drivers/txt
154
155# don't want to install doc Makefiles as docs
156#find doc -name 'Makefile*' | xargs rm
157
158# we do not want to ship static libraries
159rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
160
161# remove unpackaged files from the buildroot
162rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
163rm -f $RPM_BUILD_ROOT%{_libdir}/libltdl.*
164rm -rf $RPM_BUILD_ROOT%{_datadir}/libtool
165
166%clean
167rm -rf $RPM_BUILD_ROOT
168
169%post -p /sbin/ldconfig
170
171%postun -p /sbin/ldconfig
172
173%post kde -p /sbin/ldconfig
174
175%postun kde -p /sbin/ldconfig
176
177%files
178%defattr(-,root,root)
179%doc README COPYING AUTHORS ChangeLog NEWS INSTALL doc
180%config(noreplace) %{_sysconfdir}/odbc*
181%{_bindir}/dltest
182%{_bindir}/isql
183%{_bindir}/iusql
184%{_bindir}/odbcinst
185%{_libdir}/libboundparam.so.*
186%{_libdir}/libesoobS.so.*
187%{_libdir}/libgtrtst.so.*
188%{_libdir}/libmimerS.so.*
189%{_libdir}/libnn.so.*
190%{_libdir}/libodbc.so.*
191%{_libdir}/libodbccr.so.*
192%{_libdir}/libodbcdrvcfg1S.so.*
193%{_libdir}/libodbcdrvcfg2S.so.*
194#%{_libdir}/libodbcextras.so.*
195%{_libdir}/libodbcinst.so.*
196%{_libdir}/libodbcminiS.so.*
197%{_libdir}/libodbcmyS.so.*
198%{_libdir}/libodbcnnS.so.*
199#%{_libdir}/libodbcpsql.so.*
200%{_libdir}/libodbcpsqlS.so.*
201#%{_libdir}/libodbctxt.so.*
202%{_libdir}/libodbctxtS.so.*
203%{_libdir}/liboplodbcS.so.*
204%{_libdir}/liboraodbcS.so.*
205%{_libdir}/libsapdbS.so.*
206%{_libdir}/libtdsS.so.*
207%{_libdir}/libtemplate.so.*
208
209%files devel
210%defattr(-,root,root)
211%{_bindir}/odbc_config
212%{_includedir}/*
213%{_libdir}/libboundparam.so
214%{_libdir}/libesoobS.so
215%{_libdir}/libgtrtst.so
216%{_libdir}/libmimerS.so
217%{_libdir}/libnn.so
218%{_libdir}/libodbc.so
219%{_libdir}/libodbccr.so
220%{_libdir}/libodbcdrvcfg1S.so
221%{_libdir}/libodbcdrvcfg2S.so
222#%{_libdir}/libodbcextras.so
223%{_libdir}/libodbcinst.so
224%{_libdir}/libodbcminiS.so
225%{_libdir}/libodbcmyS.so
226%{_libdir}/libodbcnnS.so
227#%{_libdir}/libodbcpsql.so
228%{_libdir}/libodbcpsqlS.so
229#%{_libdir}/libodbctxt.so
230%{_libdir}/libodbctxtS.so
231%{_libdir}/liboplodbcS.so
232%{_libdir}/liboraodbcS.so
233%{_libdir}/libsapdbS.so
234%{_libdir}/libtdsS.so
235%{_libdir}/libtemplate.so
236#{_libdir}/*.a
237#{_libdir}/*.la
238
239%files kde
240%defattr(-,root,root)
241%{_bindir}/ODBCConfig
242%{_datadir}/applications/ODBCConfig.desktop
243%{_datadir}/pixmaps/LinuxODBC.xpm
244%{_libdir}/libodbcinstQ*so
245%{_libdir}/libodbcinstQ*so.*
246
247%changelog
248* Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2.14-3
249- rebuild with VineSeed environment
250
251* Tue Apr 12 2011 IWAI, Masaharu <iwai@alib.jp> 2.2.14-2
252- add --with-qt-includes option for configure
253
254* Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.14-1
255- updated to 2.2.14
256
257* Sat Sep 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-1
258- applied new versioning policy
259- removed *.la files from devel package
260
261* Sun Sep 02 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.12-0vl1
262- updated to 2.2.12
263- rebuilt with new toolchain
264
265* Thu Sep 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.11-0vl3
266- use installed libltdl
267- added unixODBC-2.2.11-symbols.patch and nortldglobal.patch
268
269* Sat Apr 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl2
270- rebuilt with readline 5.1
271
272* Wed Aug 24 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.11-0vl1
273- updated to 2.2.11
274- not libtoolize
275
276* Sat Sep 27 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.5-0vl2
277- added Patch100 to fix typo in doc/Makefile.am from failure on compiling
278
279* Fri Jun  6 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.5-0vl1
280- source upgrade
281- remove patch (no need)
282- run libtoolize etc for VineSeed
283
284* Wed Feb 12 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.4-0vl2
285- enable -kde subpackage on alpha, but still disable for Vine2.5/2.6
286
287* Sun Feb  9 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.4-0vl1
288- source upgrade
289- change spec to build both VineSeed and Vine2.5/2.6
290- add patch from rawhide 2.2.3-6
291
292* Sun Oct 13 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl2
293- Requires: libjpeg (not libjpeg-6b)
294
295* Sun Oct  6 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.2.3-0vl1
296- source upgrade
297- add BuildPrereq: autoconf253 automake15
298- add PreReq: ldconfig
299- fix %files section and clean up spec
300- for unixODBC-kde package
301  - add Requires: unixODBC = %{version}
302  - add Requires: XFree86-libs qt freetype2 libjpeg-6b libmng libpng zlib
303  - delete .desktop files
304
305* Thu Apr  4 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.0-0vl2
306- rebuild with KDE3
307
308* Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 2.2.0-0vl1
309- updated unixODBC-2.2.0
310- fixed LinuxODBC.xpm and smallLinuxODBC.xpm dir
311
312* Wed Jan 30 2002 Tomoya TAKA <taka@vinelinux.org> 2.0.7-3vl2
313- remove -kde package on alpha
314
315* Fri Jan  4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 2.0.7-3vl1
316- Rebuild for Vine.
317
318* Sun Jun 24 2001 Than Ngo <than@redhat.com>
319- rebuild against qt-2.3.1, kde-2.1.x
320
321* Fri Jun 15 2001 Trond Eivind Glomsrød <teg@redhat.com>
322- Better default odbcinst.ini
323- Minor cleanups
324
325* Wed Jun  6 2001 Trond Eivind Glomsrød <teg@redhat.com>
326- 2.0.7
327
328* Wed Apr 25 2001 Trond Eivind Glomsrød <teg@redhat.com>
329- Fix for isql segfault on EOF/ctrl-d exit
330
331* Fri Apr 20 2001 Trond Eivind Glomsrød <teg@redhat.com>
332- 2.0.6
333- add patch for 64 bit archs (dword shouldn't be "long int")
334
335* Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
336- rebuild
337
338* Tue Nov 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
339- 1.8.13
340
341* Tue Oct 10 2000 Trond Eivind Glomsrød <teg@redhat.com>
342- enable GUI now that we have KDE compiled with the standard
343  compiler
344- move the applnk entries to the KDE package
345
346* Thu Aug 24 2000 Nalin Dahyabhai <nalin@redhat.com>
347- add the missing shared libs to the non-devel package
348
349* Wed Aug 23 2000 Preston Brown <pbrown@redhat.com>
350- 1.8.12 fixes problems with the postgresql driver
351
352* Mon Jul 31 2000 Trond Eivind Glomsrød <teg@redhat.com>
353- disable KDE subpackage to avoid the mess that is C++ binary
354  compatibility
355
356* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
357- automatic rebuild
358
359* Fri Jun 30 2000 Florian La Roche <laroche@redhat.com>
360- improved QTDIR detection
361
362* Wed Jun 28 2000 Trond Eivind Glomsrød <teg@redhat.com>
363- 1.8.10
364- use %%{_tmppath}
365- update URL
366- including two missing libraries
367
368* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
369- 1.8.9
370
371* Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
372- adopted for Winston, changed to Red Hat packaging standards
373
374* Tue Apr 18 2000 Murray Todd Williams <murray@codingapes.com>
375- added a unixODBC-devel RPM to the group, added KDE links and icons to system
376- all of which came from recommendations from Fredrick Meunier
377- <Fredrick.Meunier@computershare.com.au>
378
379* Mon Apr 17 2000 Murray Todd Williams <murray@codingapes.com>
380- unixODBC-1.8.7
381- moved install to $RPM_BUILD_ROOT so it didn't overrun existing files.
382
383
Note: See TracBrowser for help on using the repository browser.