source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 7769

Revision 7769, 24.2 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2013

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4# * texmf/web2c/texmf.cnf
5# use BUILD
6# * texmf/xdvi
7# use BUILD
8
9# * depend libX*
10# inimf
11# mf
12# pdfclose
13# pdfopen
14# pxdvi-motif
15# xdvi-motif
16
17%global _use_internal_dependency_generator 0
18%global __find_provides %{SOURCE99}
19%global __find_requires %{nil}
20
21%global texlivesrcver   20130823
22
23Summary: The TeX text formatting system
24Summary(ja): TeX 文書整形システム
25Name: texlive
26Version: 2013
27Release: 1%{?_dist_release}
28License: distributable
29Group: Applications/Publishing
30URL: http://www.tug.org/texlive/
31
32## original TeX Live source
33#Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
34## snapshot
35# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
36# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
37Source: %{name}-source-%{texlivesrcver}.tar.xz
38
39## tlptexlive: pmetapost
40Source1: http://www.preining.info/software/build-tlptexlive-20130815.zip
41Source2: http://www.tug.org/texlive/updmap-kanji.html
42
43## our updmap{,-hdr}.cfg from collection-basic 20130823
44# NOTE:
45# * texmf.cnf: we use the conf file texmf.cnf generated from Source0
46Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
47Source7: updmap.cfg.texlive-%{texlivesrcver}
48
49## desktop files
50# Source10: pxdvi.desktop
51Source11: texdoctk.desktop
52
53# ## pxdvi from tlptexlive 2012
54# Source50: texlive-source-xdvik-20130106.tar.xz
55# Source51: http://www.preining.info/software/build-tlptexlive-20130106.zip
56
57## find library sonames for libkpathsea and libptexenc
58Source99: find-provides-texlive.sh
59
60## etc...
61#Source100: texlive.cron
62
63
64######
65# TeX patches
66######
67
68## vine
69Patch0:         reautoconf-parallel.diff
70Patch1:         texlive-%{texlivesrcver}-vine.patch
71Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
72Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
73#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
74
75## security
76
77Requires:    coreutils
78Requires:    ed mktemp
79Requires:    tmpwatch
80Requires:    zlib
81Requires:    libpng
82Requires:    gd
83Requires:    ncurses
84Requires:    libjpeg
85Requires:    t1lib
86Requires:    freetype2
87Requires:    openMotif
88Requires:    poppler >= 0.20
89Requires:    openssl
90Requires:    libpaper
91Requires:    fontconfig
92Requires:    perl-Tk perl-Tk-TableMatrix
93Requires:    nkf
94Requires:    ghostscript >= 8.71
95Requires:    libkpathsea = %{version}-%{release}
96Requires:    libptexenc = %{version}-%{release}
97Requires:    fontconfig >= 2.6.0-2
98Requires(post,postun): fontconfig >= 2.6.0-2
99Requires(post): ed mktemp
100Requires(post): vutils >= 7.1
101%{!?with_firstbuild:Requires: texlive-common = %{version}}
102BuildRequires: xz
103BuildRequires: unzip
104BuildRequires: bison flex
105BuildRequires: bzip2-devel
106BuildRequires: zlib-devel
107BuildRequires: libpng-devel
108BuildRequires: gd-devel
109BuildRequires: ncurses-devel
110BuildRequires: libjpeg-devel
111BuildRequires: t1lib-devel
112BuildRequires: XOrg-devel
113BuildRequires: freetype2-devel >= 2.1.10
114BuildRequires: autoconf >= 2.68
115BuildRequires: openMotif-devel
116BuildRequires: poppler-devel >= 0.20
117BuildRequires: openssl-devel
118BuildRequires: libpaper-devel
119BuildRequires: fontconfig-devel
120BuildRequires: nkf
121
122BuildRequires: texlive-vtlpkg = %{version}
123
124Buildroot:    %{_tmppath}/%{name}-%{version}-root
125
126Vendor:       Project Vine
127Distribution: Vine Linux
128Packager:     munepi
129
130
131%description
132The TeX Live software distribution offers a complete TeX system for a
133variety of Unix, Macintosh, Windows and other platforms. It
134encompasses programs for editing, typesetting, previewing and printing
135of TeX documents in many different languages, and a large collection
136of TeX macros and font libraries.
137
138The distribution includes extensive general documentation about TeX,
139as well as the documentation for the included software packages.
140
141
142%description -l ja
143TeX Live ソフトウェアディストリビューションは、
144さまざまな Unix, Macintosh, Windows、および
145他のプラットホームに対して完全な TeX システムを提供します。
146多くの異なった言語を含む TeX ドキュメントの
147編集、組版、閲覧、印刷するためのプログラム、
148そして、TeX マクロやフォントライブラリの大きなコレクションを
149同梱しています。
150
151このディストリビューションは
152同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
153TeX に関するたくさんの一般的なドキュメントを含んでいます。
154
155
156%package doc
157Summary: TeX Live: Documentation files of %{name}
158Group: Applications/Publishing
159Requires: %{name} = %{version}-%{release}
160BuildArch: noarch
161
162%description doc
163This package contains documentation files of %{name}.
164
165%package -n libkpathsea
166Summary: path search library for the TeX Live
167Summary(ja): TeX Live 用パス検索ライブラリ
168Group: System Environment/Libraries
169
170%description -n libkpathsea
171This package includes runtime part of the Kpathsea library.
172
173
174%package -n libkpathsea-devel
175Summary: path search libary and header files for the TeX Live
176Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
177Group: Development/Libraries
178Requires: libkpathsea = %{version}-%{release}
179
180%description -n libkpathsea-devel
181This package includes static library and header files of the Kpathsea library.
182
183
184%package -n libptexenc
185Summary: Kanji code convert library for Japanese pTeX
186Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
187Group: System Environment/Libraries
188Requires: libkpathsea = %{version}-%{release}
189
190%description -n libptexenc
191This package includes runtime part of the ptexenc library.
192
193
194%package -n libptexenc-devel
195Summary: Kanji code convert library and header files for Japanese pTeX
196Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
197Group: Development/Libraries
198Requires: libptexenc = %{version}-%{release}
199
200%description -n libptexenc-devel
201This package includes header files of the ptexenc library.
202
203
204%prep
205[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
206
207#%setup -q -n %{name}-%{texlivesrcver}-source
208%setup -q -n %{name}-source-%{texlivesrcver} -a 1
209
210%patch0 -p0 -b .parallel
211%patch1 -p1 -b .vine
212%patch2 -p1 -b .vine
213%patch3 -p1 -b .vine
214
215## Applying tlptexlive that provides pxdvi(k) and pmpost
216echo "applying patches"
217cat "$(pwd)/build-tlptexlive-20130815/patches/series" | while read p r ; do
218    echo $p | grep '^#' >/dev/null  || \
219    patch -p1 $r < "$(pwd)/build-tlptexlive-20130815/patches/$p" || exit 1
220done
221
222# ## pxdvi from tlptexlive 2012
223# echo "creating pxdvi folder"
224# [ -d texk/pxdvik ] && exit 1
225# %__cp -pR texlive-source-20130106/texk/xdvik texk/pxdvik
226# echo "applying patches"
227# cat "$(pwd)/build-tlptexlive-20130106/patches/series" | \
228#     grep -v -e freetype-modules -e pmpost -e reautoconf | while read p r ; do
229#         echo $p | grep '^#' >/dev/null || \
230#       patch -p1 $r < "$(pwd)/build-tlptexlive-20130106/patches/$p" || exit 1
231# done
232#
233# # customize pxdvik for Vine Linux
234# %patch10 -p1 -b .vine
235
236
237## Avoid pollution from internal libraries.
238%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
239# ./reautoconf || exit 1
240
241
242%build
243set -x
244unset TEXINPUTS || :
245unset HOME || :
246
247export CFLAGS="$RPM_OPT_FLAGS" \
248       CXXFLAGS="$RPM_OPT_FLAGS" \
249       LANG=C
250
251PREFIX=$(pwd)/work
252
253TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
254TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
255
256TL_CONFIGURE_ARGS=" \
257    --disable-multiplatform \
258    --disable-native-texlive-build \
259    --with-banner-add=\"/Vine Linux\" \
260    --enable-shared --disable-static \
261    --enable-compiler-warnings=max \
262    --without-cxx-runtime-hack \
263    \
264    --enable-web2c \
265    --enable-web-progs --enable-dvipdfmx --enable-mendexk \
266    --enable-makejvf --enable-pxdvik --enable-dvipsk \
267    --enable-tetex --enable-texlive \
268    \
269    --with-system-xpdf \
270    --with-system-gd \
271    --with-system-t1lib \
272    --with-system-libpng \
273    --with-system-zlib \
274    --with-system-freetype2 \
275    --with-system-pixman \
276    --with-system-poppler \
277    --with-system-cairo \
278    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
279    --with-pic \
280    \
281    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
282    --disable-dvi2tty \
283    --disable-t1utils --disable-psutils --disable-detex \
284    --disable-dvipng --disable-lcdf-typetools \
285"
286
287export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
288TL_MAKE=%__make ./Build || exit 1
289
290
291%install
292## prepare %%install session
293[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
294
295## copy inst directory to /usr
296%__mkdir_p %{buildroot}
297%__cp -a inst %{buildroot}%{_prefix} || exit 1
298%ifarch x86_64
299%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
300%endif
301
302## make some fundamental texmf trees
303%__mkdir_p %{buildroot}%{_tl_texmfvine}
304%__mkdir_p %{buildroot}%{_tl_texmfdist}
305%__mkdir_p %{buildroot}%{_tl_texmflocal}
306%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
307%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
308%__mkdir_p %{buildroot}%{_tl_vartexfonts}
309%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
310%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
311
312cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
313The directory %{_tl_texmfdist} is the TeX Live distribution wide TEXMF.
314You should not do any changes in this directory.
315EOF
316
317cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
318The directory %{_tl_texmfdist} is the distribution wide TEXMF.
319You should not use this directory to manage any other packages because
320we Project Vine use this directory to manage non-CTAN packages and
321enhancement packages.
322EOF
323
324cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
325The directory %{_tl_texmflocal} is the system wide TEXMF.
326If you are a privileged user of this system,
327you can use this directory to manage your local packages.
328EOF
329
330## our texmf-dist/web2c/updmap{,-hdr}.cfg
331%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
332%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
333%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
334
335## our map files for dvipdfmx
336%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
337%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
338for x in ptex uptex otf otf-up; do
339    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
340done
341for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
342    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
343done
344
345## desktop things
346%__mkdir_p %{buildroot}%{_datadir}/applications
347# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
348%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
349
350# for created fonts
351%__mkdir_p %{buildroot}%{_tl_vartexfonts}
352# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
353# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
354
355## set executable bit for the library
356%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
357%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
358
359# configure ConTeXt
360for x in context ctxtools luatools texexec texmfstart; do
361  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
362done
363
364# touch ghosts
365touch %{buildroot}%{_tl_texmfvine}/ls-R
366touch %{buildroot}%{_tl_texmfdist}/ls-R
367touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
368touch %{buildroot}%{_tl_texmfsysvar}/ls-R
369
370%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
371%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
372%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
373%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
374touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
375touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
376touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
377touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
378touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
379touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
380touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
381touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
382touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
383touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
384touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
385
386
387## remove unpackaging files
388find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
389find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
390%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
391find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
392find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
393%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
394%__rm -f %{buildroot}%{_infodir}/*
395
396## use external packages
397%__rm %{buildroot}/usr/bin/latexmk || exit 1
398
399
400### Files list
401find %{buildroot} -type f -or -type l | \
402    %__sed -e "s|%{buildroot}||g" | \
403    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
404    %__grep -v "%{_includedir}" | \
405    %__grep -v "%{_libdir}" | \
406    %__grep -v "%{_infodir}" | \
407    %__sed -e "s|.*ls-R$|%ghost &|" \
408           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
409           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
410           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
411           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
412           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
413           -e "s|.*\.cnf$|%config(noreplace) &|" \
414           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
415           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
416           -e "s|^.*/updmap/$|%config &|" \
417           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
418           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
419           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
420           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
421           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
422           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
423           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
424           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
425           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
426           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
427           -e "s|%{_mandir}/.*|&*|" \
428        > %{_builddir}/filelist.full
429
430find %{buildroot}%{_tl_texmfvine}* -type d | \
431    %__sed -e "s|^%{buildroot}|%dir |" \
432           -e "s|$|/|" >> %{_builddir}/filelist.full
433
434## subpackages
435%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
436cat %{_builddir}/filelist.doc \
437    %{_builddir}/filelist.full | \
438    sort | uniq -u > %{_builddir}/filelist.tmp
439%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
440
441
442%clean
443%__rm -rf %{buildroot}
444
445
446%pretrans
447rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012
448[ $? -eq 1 ] && exit 0
449_trans_time=$(date +%Y%m%d)
450echo "Running some transitional processes on your TeX system ... "
451x=(
452    #/var/lib/texmf
453    #/etc/texmf
454    /usr/share/texmf-local
455    /usr/share/texmf-var
456    /usr/share/texmf-config
457)
458for dir in ${x[@]}; do
459    _trans_dir=${dir}.${_trans_time}.rpmorig
460    [ -d ${_trans_dir}.old ] && \
461        echo -n "  " && \
462        echo "Found ${_trans_dir}.old: " && \
463        echo -n "    " && \
464        %__rm -rvf ${_trans_dir}.old
465    [ -d ${_trans_dir} ] && \
466        echo -n "  " && \
467        echo "Found ${_trans_dir}: " && \
468        echo -n "    " && \
469        %__mv -v ${_trans_dir} ${_trans_dir}.old
470    [ -d ${dir} ] && \
471        echo -n "  " && \
472        echo "Found ${dir}: " && \
473        echo -n "    " && \
474        %__mv -v ${dir} ${_trans_dir}
475done
476echo "done."
477
478%postun
479if [ "$1" = 0 ]; then
480    %__rm -rf %{_tl_vartexfonts}
481fi
482exit 0
483
484%post
485%_tl_touch_run texhash
486%_tl_touch_run updmap
487%_tl_touch_run mtxrun
488%_tl_touch_run fmtutil
489exit 0
490
491%posttrans
492%__mkdir_p %{_tl_vartexfonts}
493%__chmod 1777 %{_tl_vartexfonts}
494
495## create our map files {ptex,uptex,otf,otf-up}-vine.map
496( %{_tl_exec_upddeffont} ) ||:
497
498%{_tl_exec_texhash}
499%{_tl_exec_mtxrun}
500%{_tl_exec_updmap}
501%{_tl_exec_fmtutil}
502exit 0
503
504%post -n libkpathsea
505/sbin/ldconfig
506# for x in kpathsea tds web2c; do
507#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
508# done
509
510# %preun -n libkpathsea
511# if [ "$1" = 0 ]; then
512#     for x in kpathsea tds web2c; do
513#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
514#     done
515# fi
516
517%postun -n libkpathsea
518/sbin/ldconfig
519
520%post -n libptexenc
521/sbin/ldconfig
522
523%postun -n libptexenc
524/sbin/ldconfig
525
526%triggerin -- ghostscript
527%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
528if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
529    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
530elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
531    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
532fi
533%_tl_touch_run texhash
534exit 0
535
536
537%files -f %{_builddir}/filelist.full
538%defattr(-,root,root)
539%dir %{_tl_aliasttfdir}
540%attr(1777,root,root) %dir %{_tl_vartexfonts}
541# %config %{_sysconfdir}/cron.daily/texlive.cron
542
543%files doc -f %{_builddir}/filelist.doc
544%defattr(-,root,root)
545
546%files -n libkpathsea
547%defattr(-,root,root)
548%{_libdir}/libkpathsea.so.*
549# %{_infodir}/kpathsea.info*
550
551%files -n libkpathsea-devel
552%defattr(-,root,root)
553%{_libdir}/libkpathsea.so
554%dir %{_includedir}/kpathsea
555%{_includedir}/kpathsea/*
556
557%files -n libptexenc
558%defattr(-,root,root)
559%{_libdir}/libptexenc.so.*
560
561%files -n libptexenc-devel
562%defattr(-,root,root)
563%{_libdir}/libptexenc.so
564%dir %{_includedir}/ptexenc
565%{_includedir}/ptexenc/*
566
567
568%changelog
569* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
570- upgrade to TeX Live 2013
571  - texlive-source-20130823 2014/dev + tlptexlive 20130815
572- dropped Requires: jvf
573
574* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
575- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
576- fixed duplicated lw35 for updmap.pl
577- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
578
579* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
580- touch the map files generated by updmap-sys
581
582* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
583- fixed Source7: updmap.cfg.texlive-20120701
584  (upto /etc/texmf/web2c/updmap.cfg)
585- fixex %%triggerin -- ghostscript
586  - replaced %%exec_texhash with %%touch_run texhash
587
588* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
589- TeX Live 2012 + tlptexlive 20121107
590
591* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
592- drop BR: poppler-devel temporaly
593  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
594
595* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
596- build with poppler-0.18.4
597- remove tlmgr
598
599* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
600- updated to tl11supp-120120
601- run %%{exec_fmtutil} at %%post when upgrading
602
603* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
604- updated to tl11supp-111214
605
606* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
607- added BuildRequires: texlive-common
608  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
609  - check japanese.ldf
610- updated tl11supp-111120-vine.patch
611  - added the following options to $$TL_CONFIGURE_ARGS:
612    --disable-detex
613    --disable-dvipng
614    --disable-lcdf-typetools
615- remove some files of asymptote
616- remove a man file of latexmk
617- remove man files of lcdf-typetools
618- remove man files of dvipng
619- remove a man file of detex
620
621* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
622- added find-provides-texlive.sh and set it to %%__find_provides
623  - use to find library sonames for libkpathsea and libptexenc
624- added cmex.enc (%%{SOURCE110})
625  - do not install cmex.enc in our TDS, yet
626- removed some unused directories in texmf/fonts/map
627- removed man files of lcdf-typetools
628- moved texdoc{,tk} and its related files to texlive-doc
629
630* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
631- TeX Live 2011 + tl11supp-111120
632
633* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
634- make the directory VARTEXFONTS (%%posttrans)
635  - dropped %%triggerpostun -- texlive < 2009-17vl6
636
637* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
638- fixed ptexlive-20100711-dvipdfmx-vine.patch
639  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
640
641* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
642- added %%pre to avoid conflictions of texmf-{config,var}
643
644* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
645- dropped Requires: texlive-common
646- added perl-Tk-TableMatrix
647  - supported texdoctk
648- removed broken symbolic links in /usr/bin
649  - for each these symbolic links, the package of its real file/path
650    should be its owner.
651
652* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
653- added %%triggerpostun -- texlive < 2009-17vl6
654  - make the directory VARTEXFONTS
655
656* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
657- fixed %%dir VARTEXFONTS around in %%files
658- dropped BuildRequires: t1utils
659
660* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
661- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
662  - changed VARTEXFONTS to /var/lib/texmf/fonts
663
664* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
665- fixed updmap.cfg
666
667* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
668- dropped Requires: texlive-macros
669
670* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
671- updated ptexlive-20100711-pxdvik-vine.patch
672  and added texlive-20091107-xdvik-vine.patch
673  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
674
675* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
676- supported Vine Linux 5
677  - for vl5, changed a requirement of Japanese VF package
678    - added Requires: texlive-jvf = 2009 (vl5)
679- dropped dependencies of Provides:/Obsoletes: tags
680  - merged these dependencies in texlive-common-vl.spec
681
682* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
683- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
684
685* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
686- applied some security patches from Debian
687  - texlive-2009-CVE-2010-0827.patch
688  - texlive-2009-CVE-2010-1440.patch
689- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
690- applied texlive-2009-luatexdir-libpoppler-0.12.patch
691  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
692- fixed some dependencies
693
694* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
695- added BuildArch: noarch in %%package doc
696- removed some comment-out sentences
697
698* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
699- separeted texmf-dist to texlive-common package
700
701* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
702- unpacked texlive-20091107-source.tar.xz
703- babel is available now
704- applied eptex-100420 and some patches:
705  - eptex-100420-vine.patch
706  - eptex-100420-patch1.diff
707
708* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
709- updated ptexlive-20100711
710
711* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
712- customized updmap.cfg to correspond installed fonts
713
714* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
715- fixed insttexfont()
716
717* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
718- added jvf of MORISAWA basic 5 fonts
719- added cm-super, mathdesign in fntlst
720
721* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
722- define insttexfont() in %%install
723  - copy almost compatible tetex-3.0
724
725* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
726- ptexlive-20090322 + TeXLive 2009
727- added BuildRequires: openssl-devel
728
729* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
730- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.