source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 7810

Revision 7810, 24.4 KB checked in by munepi, 11 years ago (diff)

update all of TeX Live 2013 packages to texlive-source-20130919 2014/dev + TLNET 20130919

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4# * depend libX*
5# inimf
6# mf
7# pdfclose
8# pdfopen
9# pxdvi-motif
10# xdvi-motif
11
12%global _use_internal_dependency_generator 0
13%global __find_provides %{SOURCE99}
14%global __find_requires %{nil}
15
16%global texlivesrcver   20130919
17
18Summary: The TeX text formatting system
19Summary(ja): TeX 文書整形システム
20Name: texlive
21Version: 2013
22Release: 2%{?_dist_release}
23License: distributable
24Group: Applications/Publishing
25URL: http://www.tug.org/texlive/
26
27## original TeX Live source
28#Source: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
29## snapshot
30# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
31# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
32Source: %{name}-source-%{texlivesrcver}.tar.xz
33
34## tlptexlive: pmetapost
35Source1: http://www.preining.info/software/build-tlptexlive-20130815.zip
36Source2: http://www.tug.org/texlive/updmap-kanji.html
37
38## our updmap{,-hdr}.cfg from collection-basic 20130823
39# NOTE:
40# * texmf.cnf: we use the conf file texmf.cnf generated from Source0
41Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
42Source7: updmap.cfg.texlive-%{texlivesrcver}
43
44## desktop files
45# Source10: pxdvi.desktop
46Source11: texdoctk.desktop
47
48# ## pxdvi from tlptexlive 2012
49# Source50: texlive-source-xdvik-20130106.tar.xz
50# Source51: http://www.preining.info/software/build-tlptexlive-20130106.zip
51
52## find library sonames for libkpathsea and libptexenc
53Source99: find-provides-texlive.sh
54
55## etc...
56#Source100: texlive.cron
57
58
59######
60# TeX patches
61######
62
63## vine
64Patch0:         reautoconf-parallel.diff
65Patch1:         texlive-%{texlivesrcver}-vine.patch
66Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
67Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
68#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
69
70## security
71
72Requires:    coreutils
73Requires:    ed mktemp
74Requires:    tmpwatch
75Requires:    zlib
76Requires:    libpng
77Requires:    gd
78Requires:    ncurses
79Requires:    libjpeg
80Requires:    t1lib
81Requires:    freetype2
82Requires:    openMotif
83Requires:    poppler >= 0.20
84Requires:    openssl
85Requires:    libpaper
86Requires:    fontconfig
87Requires:    perl-Tk perl-Tk-TableMatrix
88Requires:    nkf
89Requires:    ghostscript >= 8.71
90Requires:    libkpathsea = %{version}-%{release}
91Requires:    libptexenc = %{version}-%{release}
92Requires:    fontconfig >= 2.6.0-2
93Requires(post,postun): fontconfig >= 2.6.0-2
94Requires(post): ed mktemp
95Requires(post): vutils >= 7.1
96%{!?with_firstbuild:Requires: texlive-common = %{version}}
97BuildRequires: xz
98BuildRequires: unzip
99BuildRequires: bison flex
100BuildRequires: bzip2-devel
101BuildRequires: zlib-devel
102BuildRequires: libpng-devel
103BuildRequires: gd-devel
104BuildRequires: ncurses-devel
105BuildRequires: libjpeg-devel
106BuildRequires: t1lib-devel
107BuildRequires: XOrg-devel
108BuildRequires: freetype2-devel >= 2.1.10
109BuildRequires: autoconf >= 2.68
110BuildRequires: openMotif-devel
111BuildRequires: poppler-devel >= 0.20
112BuildRequires: openssl-devel
113BuildRequires: libpaper-devel
114BuildRequires: fontconfig-devel
115BuildRequires: nkf
116
117BuildRequires: texlive-vtlpkg = %{version}
118
119Buildroot:    %{_tmppath}/%{name}-%{version}-root
120
121Vendor:       Project Vine
122Distribution: Vine Linux
123Packager:     munepi
124
125
126%description
127The TeX Live software distribution offers a complete TeX system for a
128variety of Unix, Macintosh, Windows and other platforms. It
129encompasses programs for editing, typesetting, previewing and printing
130of TeX documents in many different languages, and a large collection
131of TeX macros and font libraries.
132
133The distribution includes extensive general documentation about TeX,
134as well as the documentation for the included software packages.
135
136
137%description -l ja
138TeX Live ソフトウェアディストリビューションは、
139さまざまな Unix, Macintosh, Windows、および
140他のプラットホームに対して完全な TeX システムを提供します。
141多くの異なった言語を含む TeX ドキュメントの
142編集、組版、閲覧、印刷するためのプログラム、
143そして、TeX マクロやフォントライブラリの大きなコレクションを
144同梱しています。
145
146このディストリビューションは
147同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
148TeX に関するたくさんの一般的なドキュメントを含んでいます。
149
150
151%package doc
152Summary: TeX Live: Documentation files of %{name}
153Group: Applications/Publishing
154Requires: %{name} = %{version}-%{release}
155BuildArch: noarch
156
157%description doc
158This package contains documentation files of %{name}.
159
160%package -n libkpathsea
161Summary: path search library for the TeX Live
162Summary(ja): TeX Live 用パス検索ライブラリ
163Group: System Environment/Libraries
164
165%description -n libkpathsea
166This package includes runtime part of the Kpathsea library.
167
168
169%package -n libkpathsea-devel
170Summary: path search libary and header files for the TeX Live
171Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
172Group: Development/Libraries
173Requires: libkpathsea = %{version}-%{release}
174
175%description -n libkpathsea-devel
176This package includes static library and header files of the Kpathsea library.
177
178
179%package -n libptexenc
180Summary: Kanji code convert library for Japanese pTeX
181Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
182Group: System Environment/Libraries
183Requires: libkpathsea = %{version}-%{release}
184
185%description -n libptexenc
186This package includes runtime part of the ptexenc library.
187
188
189%package -n libptexenc-devel
190Summary: Kanji code convert library and header files for Japanese pTeX
191Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
192Group: Development/Libraries
193Requires: libptexenc = %{version}-%{release}
194
195%description -n libptexenc-devel
196This package includes header files of the ptexenc library.
197
198
199%prep
200[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
201
202#%setup -q -n %{name}-%{texlivesrcver}-source
203%setup -q -n %{name}-source-%{texlivesrcver} -a 1
204
205%patch0 -p0 -b .parallel
206%patch1 -p1 -b .vine
207%patch2 -p1 -b .vine
208%patch3 -p1 -b .vine
209
210## Applying tlptexlive that provides pxdvi(k) and pmpost
211echo "applying patches"
212cat "$(pwd)/build-tlptexlive-20130815/patches/series" | while read p r ; do
213    echo $p | grep '^#' >/dev/null  || \
214    patch -p1 $r < "$(pwd)/build-tlptexlive-20130815/patches/$p" || exit 1
215done
216
217# ## pxdvi from tlptexlive 2012
218# echo "creating pxdvi folder"
219# [ -d texk/pxdvik ] && exit 1
220# %__cp -pR texlive-source-20130106/texk/xdvik texk/pxdvik
221# echo "applying patches"
222# cat "$(pwd)/build-tlptexlive-20130106/patches/series" | \
223#     grep -v -e freetype-modules -e pmpost -e reautoconf | while read p r ; do
224#         echo $p | grep '^#' >/dev/null || \
225#       patch -p1 $r < "$(pwd)/build-tlptexlive-20130106/patches/$p" || exit 1
226# done
227#
228# # customize pxdvik for Vine Linux
229# %patch10 -p1 -b .vine
230
231
232## Avoid pollution from internal libraries.
233%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,poppler,t1lib,unzip,xpdf,zlib} || exit 1
234# ./reautoconf || exit 1
235
236
237%build
238set -x
239unset TEXINPUTS || :
240unset HOME || :
241
242export CFLAGS="$RPM_OPT_FLAGS" \
243       CXXFLAGS="$RPM_OPT_FLAGS" \
244       LANG=C
245
246PREFIX=$(pwd)/work
247
248TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
249TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
250
251TL_CONFIGURE_ARGS=" \
252    --disable-multiplatform \
253    --disable-native-texlive-build \
254    --with-banner-add=\"/Vine Linux\" \
255    --enable-shared --disable-static \
256    --enable-compiler-warnings=max \
257    --without-cxx-runtime-hack \
258    \
259    --enable-web2c \
260    --enable-web-progs --enable-dvipdfmx --enable-mendexk \
261    --enable-makejvf --enable-pxdvik --enable-dvipsk \
262    --enable-tetex --enable-texlive \
263    \
264    --with-system-xpdf \
265    --with-system-gd \
266    --with-system-t1lib \
267    --with-system-libpng \
268    --with-system-zlib \
269    --with-system-freetype2 \
270    --with-system-pixman \
271    --with-system-poppler \
272    --with-system-cairo \
273    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
274    --with-pic \
275    \
276    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
277    --disable-dvi2tty \
278    --disable-t1utils --disable-psutils --disable-detex \
279    --disable-dvipng --disable-lcdf-typetools \
280"
281
282export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
283TL_MAKE=%__make ./Build || exit 1
284
285
286%install
287## prepare %%install session
288[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
289
290## copy inst directory to /usr
291%__mkdir_p %{buildroot}
292%__cp -a inst %{buildroot}%{_prefix} || exit 1
293%ifarch x86_64
294%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
295%endif
296
297## make some fundamental texmf trees
298%__mkdir_p %{buildroot}%{_tl_texmfvine}
299%__mkdir_p %{buildroot}%{_tl_texmfdist}
300%__mkdir_p %{buildroot}%{_tl_texmflocal}
301%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
302%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
303%__mkdir_p %{buildroot}%{_tl_vartexfonts}
304%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
305%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
306
307cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
308The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
309distribution wide.
310You must not do any changes in this directory.
311EOF
312
313cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
314The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
315You should not use this directory to manage any other packages because
316we Project Vine use this directory to manage non-CTAN packages, some
317enhancement packages and so on.
318EOF
319
320cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
321The directory %{_tl_texmflocal} is the texmf tree of the system wide.
322If you are a privileged user of this system,
323you can use this directory to manage your local packages.
324EOF
325
326## our texmf-dist/web2c/updmap{,-hdr}.cfg
327%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
328%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
329%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
330
331## our map files for dvipdfmx
332%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
333%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
334for x in ptex uptex otf otf-up; do
335    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
336done
337for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
338    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
339done
340
341## desktop things
342%__mkdir_p %{buildroot}%{_datadir}/applications
343# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
344%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
345
346# for created fonts
347%__mkdir_p %{buildroot}%{_tl_vartexfonts}
348# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
349# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
350
351## set executable bit for the library
352%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
353%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
354
355# configure ConTeXt
356for x in context ctxtools luatools texexec texmfstart; do
357  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
358done
359
360# touch ghosts
361touch %{buildroot}%{_tl_texmfvine}/ls-R
362touch %{buildroot}%{_tl_texmfdist}/ls-R
363touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
364touch %{buildroot}%{_tl_texmfsysvar}/ls-R
365
366%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
367%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
368%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
369%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
370touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
371touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
372touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
373touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
374touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
375touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
376touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
377touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
378touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
379touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
380touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
381
382
383## remove unpackaging files
384find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
385find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
386%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
387find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
388find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
389%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
390%__rm -f %{buildroot}%{_infodir}/*
391
392## use external packages
393%__rm %{buildroot}/usr/bin/latexmk || exit 1
394
395
396### Files list
397find %{buildroot} -type f -or -type l | \
398    %__sed -e "s|%{buildroot}||g" | \
399    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
400    %__grep -v "%{_includedir}" | \
401    %__grep -v "%{_libdir}" | \
402    %__grep -v "%{_infodir}" | \
403    %__sed -e "s|.*ls-R$|%ghost &|" \
404           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
405           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
406           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
407           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
408           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
409           -e "s|.*\.cnf$|%config(noreplace) &|" \
410           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
411           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
412           -e "s|^.*/updmap/$|%config &|" \
413           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
414           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
415           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
416           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
417           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
418           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
419           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
420           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
421           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
422           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
423           -e "s|%{_mandir}/.*|&*|" \
424        > %{_builddir}/filelist.full
425
426find %{buildroot}%{_tl_texmfvine}* -type d | \
427    %__sed -e "s|^%{buildroot}|%dir |" \
428           -e "s|$|/|" >> %{_builddir}/filelist.full
429
430## subpackages
431%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
432cat %{_builddir}/filelist.doc \
433    %{_builddir}/filelist.full | \
434    sort | uniq -u > %{_builddir}/filelist.tmp
435%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
436
437
438%clean
439%__rm -rf %{buildroot}
440
441
442%pretrans
443rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012
444[ $? -eq 1 ] && exit 0
445_trans_time=$(date +%Y%m%d)
446echo "Running some transitional processes on your TeX system ... "
447x=(
448    #/var/lib/texmf
449    #/etc/texmf
450    /usr/share/texmf-local
451    /usr/share/texmf-var
452    /usr/share/texmf-config
453)
454for dir in ${x[@]}; do
455    _trans_dir=${dir}.${_trans_time}.rpmorig
456    [ -d ${_trans_dir}.old ] && \
457        echo -n "  " && \
458        echo "Found ${_trans_dir}.old: " && \
459        echo -n "    " && \
460        %__rm -rvf ${_trans_dir}.old
461    [ -d ${_trans_dir} ] && \
462        echo -n "  " && \
463        echo "Found ${_trans_dir}: " && \
464        echo -n "    " && \
465        %__mv -v ${_trans_dir} ${_trans_dir}.old
466    [ -d ${dir} ] && \
467        echo -n "  " && \
468        echo "Found ${dir}: " && \
469        echo -n "    " && \
470        %__mv -v ${dir} ${_trans_dir}
471done
472echo "done."
473
474%postun
475if [ "$1" = 0 ]; then
476    %__rm -rf %{_tl_vartexfonts}
477fi
478exit 0
479
480%post
481%_tl_touch_run texhash
482%_tl_touch_run updmap
483%_tl_touch_run mtxrun
484%_tl_touch_run fmtutil
485exit 0
486
487%posttrans
488%__mkdir_p %{_tl_vartexfonts}
489%__chmod 1777 %{_tl_vartexfonts}
490
491## create our map files {ptex,uptex,otf,otf-up}-vine.map
492( %{_tl_exec_upddeffont} ) ||:
493
494%{_tl_exec_texhash}
495%{_tl_exec_mtxrun}
496%{_tl_exec_updmap}
497%{_tl_exec_fmtutil}
498exit 0
499
500%post -n libkpathsea
501/sbin/ldconfig
502# for x in kpathsea tds web2c; do
503#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
504# done
505
506# %preun -n libkpathsea
507# if [ "$1" = 0 ]; then
508#     for x in kpathsea tds web2c; do
509#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
510#     done
511# fi
512
513%postun -n libkpathsea
514/sbin/ldconfig
515
516%post -n libptexenc
517/sbin/ldconfig
518
519%postun -n libptexenc
520/sbin/ldconfig
521
522%triggerin -- ghostscript
523%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
524if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
525    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
526elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
527    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
528fi
529%_tl_touch_run texhash
530exit 0
531
532
533%files -f %{_builddir}/filelist.full
534%defattr(-,root,root)
535%dir %{_tl_aliasttfdir}
536%attr(1777,root,root) %dir %{_tl_vartexfonts}
537# %config %{_sysconfdir}/cron.daily/texlive.cron
538
539%files doc -f %{_builddir}/filelist.doc
540%defattr(-,root,root)
541
542%files -n libkpathsea
543%defattr(-,root,root)
544%{_libdir}/libkpathsea.so.*
545# %{_infodir}/kpathsea.info*
546
547%files -n libkpathsea-devel
548%defattr(-,root,root)
549%{_libdir}/libkpathsea.so
550%dir %{_includedir}/kpathsea
551%{_includedir}/kpathsea/*
552
553%files -n libptexenc
554%defattr(-,root,root)
555%{_libdir}/libptexenc.so.*
556
557%files -n libptexenc-devel
558%defattr(-,root,root)
559%{_libdir}/libptexenc.so
560%dir %{_includedir}/ptexenc
561%{_includedir}/ptexenc/*
562
563
564%changelog
565* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
566- texlive-source-20130919 2014/dev + tlptexlive 20130815
567- correct some scripts of README.vine for each texmf trees
568
569* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
570- upgrade to TeX Live 2013
571  - texlive-source-20130823 2014/dev + tlptexlive 20130815
572- dropped Requires: jvf
573
574* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
575- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
576- fixed duplicated lw35 for updmap.pl
577- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
578
579* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
580- touch the map files generated by updmap-sys
581
582* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
583- fixed Source7: updmap.cfg.texlive-20120701
584  (upto /etc/texmf/web2c/updmap.cfg)
585- fixex %%triggerin -- ghostscript
586  - replaced %%exec_texhash with %%touch_run texhash
587
588* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
589- TeX Live 2012 + tlptexlive 20121107
590
591* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
592- drop BR: poppler-devel temporaly
593  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
594
595* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
596- build with poppler-0.18.4
597- remove tlmgr
598
599* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
600- updated to tl11supp-120120
601- run %%{exec_fmtutil} at %%post when upgrading
602
603* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
604- updated to tl11supp-111214
605
606* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
607- added BuildRequires: texlive-common
608  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
609  - check japanese.ldf
610- updated tl11supp-111120-vine.patch
611  - added the following options to $$TL_CONFIGURE_ARGS:
612    --disable-detex
613    --disable-dvipng
614    --disable-lcdf-typetools
615- remove some files of asymptote
616- remove a man file of latexmk
617- remove man files of lcdf-typetools
618- remove man files of dvipng
619- remove a man file of detex
620
621* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
622- added find-provides-texlive.sh and set it to %%__find_provides
623  - use to find library sonames for libkpathsea and libptexenc
624- added cmex.enc (%%{SOURCE110})
625  - do not install cmex.enc in our TDS, yet
626- removed some unused directories in texmf/fonts/map
627- removed man files of lcdf-typetools
628- moved texdoc{,tk} and its related files to texlive-doc
629
630* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
631- TeX Live 2011 + tl11supp-111120
632
633* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
634- make the directory VARTEXFONTS (%%posttrans)
635  - dropped %%triggerpostun -- texlive < 2009-17vl6
636
637* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
638- fixed ptexlive-20100711-dvipdfmx-vine.patch
639  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
640
641* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
642- added %%pre to avoid conflictions of texmf-{config,var}
643
644* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
645- dropped Requires: texlive-common
646- added perl-Tk-TableMatrix
647  - supported texdoctk
648- removed broken symbolic links in /usr/bin
649  - for each these symbolic links, the package of its real file/path
650    should be its owner.
651
652* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
653- added %%triggerpostun -- texlive < 2009-17vl6
654  - make the directory VARTEXFONTS
655
656* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
657- fixed %%dir VARTEXFONTS around in %%files
658- dropped BuildRequires: t1utils
659
660* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
661- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
662  - changed VARTEXFONTS to /var/lib/texmf/fonts
663
664* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
665- fixed updmap.cfg
666
667* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
668- dropped Requires: texlive-macros
669
670* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
671- updated ptexlive-20100711-pxdvik-vine.patch
672  and added texlive-20091107-xdvik-vine.patch
673  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
674
675* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
676- supported Vine Linux 5
677  - for vl5, changed a requirement of Japanese VF package
678    - added Requires: texlive-jvf = 2009 (vl5)
679- dropped dependencies of Provides:/Obsoletes: tags
680  - merged these dependencies in texlive-common-vl.spec
681
682* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
683- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
684
685* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
686- applied some security patches from Debian
687  - texlive-2009-CVE-2010-0827.patch
688  - texlive-2009-CVE-2010-1440.patch
689- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
690- applied texlive-2009-luatexdir-libpoppler-0.12.patch
691  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
692- fixed some dependencies
693
694* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
695- added BuildArch: noarch in %%package doc
696- removed some comment-out sentences
697
698* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
699- separeted texmf-dist to texlive-common package
700
701* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
702- unpacked texlive-20091107-source.tar.xz
703- babel is available now
704- applied eptex-100420 and some patches:
705  - eptex-100420-vine.patch
706  - eptex-100420-patch1.diff
707
708* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
709- updated ptexlive-20100711
710
711* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
712- customized updmap.cfg to correspond installed fonts
713
714* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
715- fixed insttexfont()
716
717* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
718- added jvf of MORISAWA basic 5 fonts
719- added cm-super, mathdesign in fntlst
720
721* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
722- define insttexfont() in %%install
723  - copy almost compatible tetex-3.0
724
725* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
726- ptexlive-20090322 + TeXLive 2009
727- added BuildRequires: openssl-devel
728
729* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
730- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.