source: projects/specs/trunk/t/texlive/texlive-vl.spec @ 11118

Revision 11118, 27.4 KB checked in by munepi, 7 years ago (diff)

TeX Live 2017

Line 
1# -*- coding: utf-8-unix -*-
2%bcond_with firstbuild
3
4%global _use_internal_dependency_generator 0
5%global __find_provides %{SOURCE99}
6%global __find_requires %{SOURCE98}
7
8%global texlivesrcver   20170520
9
10Summary: The TeX text formatting system
11Summary(ja): TeX 文書整形システム
12Name: texlive
13Version: 2017
14Release: 2%{?_dist_release}
15License: distributable
16Group: Applications/Publishing
17URL: http://www.tug.org/texlive/
18
19## original TeX Live source
20#Source: http://ftp.tug.org/texlive/Images/test/%{name}-%{texlivesrcver}-source.tar.xz
21Source0: ftp://tug.org/historic/systems/texlive/%{version}/%{name}-%{texlivesrcver}-source.tar.xz
22## snapshot
23# $ rsync -a --delete --exclude=.svn tug.org::tldevsrc/Build/source/ texlive-source-YYYYMMDD
24# $ tar -cf - texlive-source-YYYYMMDD | pxz -9 > texlive-source-YYYYMMDD.tar.xz
25#Source0: %{name}-source-%{texlivesrcver}.tar.xz
26
27## our updmap{,-hdr}.cfg from collection-basic 20140524
28## NOTE: fmtutil.cnf, texmf.cnf: use the conf files generated from Source0
29Source6: updmap-hdr.cfg.texlive-%{texlivesrcver}
30Source7: updmap.cfg.texlive-%{texlivesrcver}
31
32## desktop files
33Source11: texdoctk.desktop
34
35Source98: find-requires-texlive.sh
36## find library sonames for libkpathsea, libptexenc, and libsynctex
37Source99:  find-provides-texlive.sh
38
39######
40# TeX patches
41######
42
43## vine
44Patch0:         reautoconf-parallel.diff
45#Patch1:                texlive-%{texlivesrcver}-vine.patch
46Patch2:         texlive-%{texlivesrcver}-texmfcnf-vine.patch
47Patch3:         texlive-%{texlivesrcver}-set-selfautoparent-vine.patch
48#Patch4:                texlive-%{texlivesrcver}-fmtutilcnf-vine.patch
49#Patch10:       texlive-%{texlivesrcver}-pxdvik-vine.patch
50
51## security
52
53Requires:    perl-Tk perl-Tk-TableMatrix
54Requires:    ghostscript >= 8.71
55Requires:    nkf
56Requires(post,postun): fontconfig
57Requires(post): ed mktemp
58Requires(post): vutils >= 7.1
59%{!?with_firstbuild:Requires: texlive-common = %{version}}
60BuildRequires: autoconf >= 2.68
61BuildRequires: bison flex
62BuildRequires: bzip2-devel
63BuildRequires: cairo-devel >= 1.12
64BuildRequires: fontconfig-devel
65BuildRequires: freetype2-devel >= 2.1.10
66BuildRequires: gd-devel
67BuildRequires: libjpeg-devel
68BuildRequires: libpng-devel >= 1.6
69BuildRequires: ncurses-devel
70BuildRequires: nkf
71BuildRequires: openssl-devel
72BuildRequires: pixman-devel >= 0.18
73#BuildRequires: poppler-devel >= 0.26
74BuildRequires: xorg-x11-devel
75BuildRequires: zlib-devel
76## use distro's libpaper
77#BuildRequires: libpaper-devel >= 1.1.24-2
78## do not xdvi(k)
79#BuildRequires: XOrg-devel
80#BuildRequires: openMotif-devel
81## needs to build pxdvi
82#BuildRequires: t1lib-devel
83
84BuildRequires: texlive-vtlpkg = %{version}
85
86Buildroot:    %{_tmppath}/%{name}-%{version}-root
87
88Vendor:       Project Vine
89Distribution: Vine Linux
90Packager:     munepi
91
92
93%description
94The TeX Live software distribution offers a complete TeX system for a
95variety of Unix, Macintosh, Windows and other platforms. It
96encompasses programs for editing, typesetting, previewing and printing
97of TeX documents in many different languages, and a large collection
98of TeX macros and font libraries.
99
100The distribution includes extensive general documentation about TeX,
101as well as the documentation for the included software packages.
102
103
104%description -l ja
105TeX Live ソフトウェアディストリビューションは、
106さまざまな Unix, Macintosh, Windows、および
107他のプラットホームに対して完全な TeX システムを提供します。
108多くの異なった言語を含む TeX ドキュメントの
109編集、組版、閲覧、印刷するためのプログラム、
110そして、TeX マクロやフォントライブラリの大きなコレクションを
111同梱しています。
112
113このディストリビューションは
114同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
115TeX に関するたくさんの一般的なドキュメントを含んでいます。
116
117
118%package doc
119Summary: TeX Live: Documentation files of %{name}
120Group: Applications/Publishing
121Requires: %{name} = %{version}-%{release}
122BuildArch: noarch
123
124%description doc
125This package contains documentation files of %{name}.
126
127%package -n libkpathsea
128Summary: path search library for the TeX Live
129Summary(ja): TeX Live 用パス検索ライブラリ
130Group: System Environment/Libraries
131
132%description -n libkpathsea
133This package includes runtime part of the Kpathsea library.
134
135
136%package -n libkpathsea-devel
137Summary: path search libary and header files for the TeX Live
138Summary(ja): TeX Live 用パス検索ライブラリとヘッダファイル
139Group: Development/Libraries
140Requires: libkpathsea = %{version}-%{release}
141
142%description -n libkpathsea-devel
143This package includes static library and header files of the Kpathsea library.
144
145
146%package -n libptexenc
147Summary: Kanji code convert library for Japanese pTeX
148Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリ
149Group: System Environment/Libraries
150Requires: libkpathsea = %{version}-%{release}
151
152%description -n libptexenc
153This package includes runtime part of the ptexenc library.
154
155
156%package -n libptexenc-devel
157Summary: Kanji code convert library and header files for Japanese pTeX
158Summary(ja): 日本語 pTeX 用漢字コード変換ライブラリとヘッダファイル
159Group: Development/Libraries
160Requires: libptexenc = %{version}-%{release}
161
162%description -n libptexenc-devel
163This package includes header files of the ptexenc library.
164
165
166%package -n libsynctex
167Summary: SyncTeX library
168Group: System Environment/Libraries
169
170%description -n libsynctex
171This package includes the runtime part of SyncTeX library.
172
173%package -n libsynctex-devel
174Summary: SyncTeX header files
175Group: Development/Libraries
176Requires: libsynctex = %{version}-%{release}
177
178%description -n libsynctex-devel
179This package includes the header files of SyncTeX library.
180
181
182%prep
183[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
184
185%setup -q -n %{name}-%{texlivesrcver}-source
186#% setup -q -n %{name}-source-%{texlivesrcver}
187
188%patch0 -p0 -b .parallel
189# %patch1 -p1 -b .vine
190%patch2 -p1 -b .vine
191%patch3 -p1 -b .vine
192# %patch4 -p1 -b .vine
193
194# ## Applying tlptexlive that provides pxdvi(k) and pmpost
195# echo "applying patches"
196# cat "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/series" | while read p r ; do
197#     echo $p | grep '^#' >/dev/null  || \
198#     patch -p1 $r < "$(pwd)/build-tlptexlive-%{tlptexlivesrcver}/patches/$p" || exit 1
199# done
200
201## Avoid pollution from internal libraries.
202#,paper,poppler,xpdf
203%__rm -rf ./libs/{cairo,expat,freetype,freetype2,gd,jpeg,libpng,libttf,ncurses,pixman,t1lib,unzip,zlib} || exit 1
204./reautoconf || exit 1
205
206
207%build
208set -x
209unset TEXINPUTS || :
210unset HOME || :
211
212export CFLAGS="$RPM_OPT_FLAGS" \
213       CXXFLAGS="$RPM_OPT_FLAGS" \
214       LANG=C
215
216PREFIX=$(pwd)/work
217
218TL_CONF_XDVI_TOOLKIT=--with-xdvi-x-toolkit=motif
219TL_MAKE_FLAGS=-j$(/usr/bin/getconf _NPROCESSORS_ONLN)
220
221TL_CONFIGURE_ARGS=" \
222    --disable-multiplatform \
223    --disable-native-texlive-build \
224    --with-banner-add=\"/Vine Linux\" \
225    --enable-shared --disable-static \
226    --enable-compiler-warnings=max \
227    --without-cxx-runtime-hack \
228    \
229    --with-system-xpdf=no --with-system-poppler=no \
230    --with-system-gd \
231    --with-system-t1lib \
232    --with-system-libpng \
233    --with-system-zlib \
234    --with-system-freetype2 \
235    --with-system-pixman \
236    --with-system-cairo \
237    --with-freetype2-include=$(freetype-config --cflags | %__sed -e 's/-I//' -e 's/ .*//') \
238    --with-pic \
239    \
240    --disable-xindy --disable-xindy-docs --disable-xindy-make-rules \
241    --disable-xdvik \
242    --disable-dvi2tty \
243    --disable-t1utils --disable-psutils --disable-detex \
244    --disable-dvipng --disable-lcdf-typetools \
245"
246
247export TL_CONF_XDVI_TOOLKIT TL_MAKE_FLAGS TL_CONFIGURE_ARGS
248TL_MAKE=%__make ./Build || exit 1
249
250
251%install
252## prepare %%install session
253[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
254
255## copy inst directory to /usr
256%__mkdir_p %{buildroot}
257%__cp -a inst %{buildroot}%{_prefix} || exit 1
258%ifarch x86_64
259%__mv %{buildroot}%{_prefix}/lib %{buildroot}%{_libdir} || exit 1
260%endif
261
262if [ -f %{buildroot}%{_libdir}/kpathsea/c-auto.h ]; then
263   %__mv %{buildroot}%{_libdir}/kpathsea/c-auto.h \
264         %{buildroot}%{_includedir}/kpathsea/c-auto.h || exit 1
265   %__rm -r %{buildroot}%{_libdir}/kpathsea || exit 1
266fi
267
268## make some fundamental texmf trees
269%__mkdir_p %{buildroot}%{_tl_texmfvine}
270%__mkdir_p %{buildroot}%{_tl_texmfdist}
271%__mkdir_p %{buildroot}%{_tl_texmflocal}
272%__mkdir_p %{buildroot}%{_tl_texmfsysconfig}
273%__mkdir_p %{buildroot}%{_tl_texmfsysvar}
274%__mkdir_p %{buildroot}%{_tl_vartexfonts}
275%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/{truetype,opentype}
276%__mkdir_p %{buildroot}%{_tl_texmfvine}/fonts/cmap
277
278cat<<EOF>%{buildroot}%{_tl_texmfdist}/README.vine || exit 1
279The directory %{_tl_texmfdist} is the texmf tree of the TeX Live
280distribution wide.
281You must not do any changes in this directory.
282EOF
283
284cat<<EOF>%{buildroot}%{_tl_texmfvine}/README.vine || exit 1
285The directory %{_tl_texmfvine} is the texmf tree of our distribution wide.
286You should not use this directory to manage any other packages because
287we Project Vine use this directory to manage non-CTAN packages, some
288enhancement packages and so on.
289EOF
290
291cat<<EOF>%{buildroot}%{_tl_texmflocal}/README.vine || exit 1
292The directory %{_tl_texmflocal} is the texmf tree of the system wide.
293If you are a privileged user of this system,
294you can use this directory to manage your local packages.
295EOF
296
297## our texmf-dist/web2c/updmap{,-hdr}.cfg
298%__mkdir_p %{buildroot}%{_tl_texmfdist}/web2c
299%__cp -a %{SOURCE6} %{buildroot}%{_tl_texmfdist}/web2c/updmap-hdr.cfg || exit 1
300%__cp -a %{SOURCE7} %{buildroot}%{_tl_texmfdist}/web2c/updmap.cfg || exit 1
301
302## our map files for dvipdfmx
303%__mkdir_p %{buildroot}%{_tl_aliasttfdir}
304%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine
305for x in ptex uptex otf otf-up; do
306    touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/${x}-vine.map
307done
308for x in FutoGo-Bold FutoMin-Bold Gothic-Medium MaruGo-Medium Mincho-Medium; do
309    touch %{buildroot}%{_tl_aliasttfdir}/${x}.ttf
310done
311
312## desktop things
313%__mkdir_p %{buildroot}%{_datadir}/applications
314# %__install -m0644 -c %{SOURCE10} %{buildroot}%{_datadir}/applications/
315%__install -m0644 -c %{SOURCE11} %{buildroot}%{_datadir}/applications/
316
317# for created fonts
318%__mkdir_p %{buildroot}%{_tl_vartexfonts}
319# %__mkdir_p %{buildroot}%{_sysconfdir}/cron.daily
320# %__install -m 755 %{SOURCE100} %{buildroot}%{_sysconfdir}/cron.daily/
321
322## set executable bit for the library
323%__chmod a+x %{buildroot}%{_libdir}/libkpathsea.so.*.*
324%__chmod a+x %{buildroot}%{_libdir}/libptexenc.so.*.*
325
326# configure ConTeXt
327for x in context luatools texexec texmfstart; do
328  %__sed -i -e 's|mtxrun|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; mtxrun|' %{buildroot}%{_bindir}/${x} || exit 1
329done
330for x in contextjit; do
331  %__sed -i -e 's|luajittex --luaonly|export TEXMF=%{_tl_texmfconfig}:%{_tl_texmfvar}:%{_tl_texmfhome}:%{_tl_texmfsysconfig}:%{_tl_texmfsysvar}:%{_tl_texmflocal}:%{_tl_texmfvine}:%{_tl_texmfdist} TEXMFCNF=%{_tl_texmfsysvar}/web2c:%{_tl_texmflocal}/web2c:%{_tl_texmfvine}/web2c:%{_tl_texmfdist}/web2c TEXMFCACHE=%{_tl_texmfsysvar}:%{_tl_texmfvar}; luajittex --luaonly|' %{buildroot}%{_bindir}/${x} || exit 1
332done
333
334# touch ghosts
335touch %{buildroot}%{_tl_texmfvine}/ls-R
336touch %{buildroot}%{_tl_texmfdist}/ls-R
337touch %{buildroot}%{_tl_texmfsysconfig}/ls-R
338touch %{buildroot}%{_tl_texmfsysvar}/ls-R
339
340%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/
341%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/
342%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/
343%__mkdir_p %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/
344touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/builtin35.map
345touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_t1.map
346touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts_pk.map
347touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/download35.map
348touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/ps2pk.map
349touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvips/updmap/psfonts.map
350touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/dvipdfmx/updmap/kanjix.map
351#touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pxdvi/updmap/xdvi-ptex.map
352touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_dl14.map
353touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex.map
354touch %{buildroot}%{_tl_texmfsysvar}/fonts/map/pdftex/updmap/pdftex_ndl14.map
355
356
357## remove unpackaging files
358find %{buildroot} | %__grep -e "\\.\(la\|a\)$" | xargs %__rm -f || exit 1
359find %{buildroot} | %__grep -e "\\.\(diff\|patch\)$" | xargs %__rm -f || exit 1
360%__rm -f %{buildroot}%{_bindir}/tlmgr || exit 1
361find %{buildroot}%{_tl_texmfvine}/fonts/map -type d | %__grep "updmap" | xargs %__rm -rf || exit 1
362find %{buildroot} -type d | grep asymptote | xargs %__rm -rf || exit 1
363%__rm -f %{buildroot}%{_tl_texmfvine}/dvipdfm/config/config-win32 || exit 1
364%__rm -f %{buildroot}%{_infodir}/*
365
366## use external packages
367%__rm %{buildroot}/usr/bin/latexmk || exit 1
368
369
370### Files list
371find %{buildroot} -type f -or -type l | \
372    %__sed -e "s|%{buildroot}||g" | \
373    %__grep -v -e ".patch$" -e "\.diff$" -e "\.orig$" | \
374    %__grep -v "%{_includedir}" | \
375    %__grep -v "%{_libdir}" | \
376    %__grep -v "%{_infodir}" | \
377    %__sed -e "s|.*ls-R$|%ghost &|" \
378           -e "s|%{_tl_texmfsysvar}/fonts/map/dvipdfmx/vine/.*\.map$|%ghost &|" \
379           -e "s|%{_tl_aliasttfdir}/.*\.ttf$|%ghost &|" \
380           -e "s|.*/updmap.*\.cfg$|%config(noreplace) &|" \
381           -e "s|.*/dvipdfmx\.cfg$|%config(noreplace) &|" \
382           -e "s|.*xdvi\.cfg$|%config(noreplace) &|" \
383           -e "s|.*\.cnf$|%config(noreplace) &|" \
384           -e "s|%{_tl_texmfvine}*/xdvi/XDvi|%config(noreplace) &|" \
385           -e "s|%{_tl_texmfvine}*/web2c/texmfcnf\.lua$|%config(noreplace) &|" \
386           -e "s|^.*/updmap/$|%config &|" \
387           -e "s|%{_tl_texmfvine}*/texconfig/tcfmgr.map$|%config &|" \
388           -e "s|%{_tl_texmfvine}*/dvips/config/.*$|%config &|" \
389           -e "s|%{_tl_texmfvine}*/dvips/tetex/config.*$|%config &|" \
390           -e "s|%{_tl_texmfvine}*/dvipdfm/config/config$|%config &|" \
391           -e "s|%{_tl_texmfvine}*/fonts/map/dvips/tetex/.*.map$|%config &|" \
392           -e "s|%{_tl_texmfvine}*/fonts/map/dvipdfmx/.*.map$|%config &|" \
393           -e "s|%{_tl_texmfvine}*/tex/generic/config/.*|%config &|" \
394           -e "s|%{_tl_texmfvine}*/ttf2pk/ttf2pk\.cfg$|%config &|" \
395           -e "s|%{_tl_texmfvine}*/hbf2gf/.*\.cfg$|%config &|" \
396           -e "s|%{_tl_texmfvine}*/chktex/chktexrc$|%config &|" \
397           -e "s|%{_mandir}/.*|&*|" \
398        > %{_builddir}/filelist.full
399
400find %{buildroot}%{_tl_texmfvine}* -type d | \
401    %__sed -e "s|^%{buildroot}|%dir |" \
402           -e "s|$|/|" >> %{_builddir}/filelist.full
403
404## subpackages
405%__grep -e "/texmf/doc/" -e "/texmf-dist/doc/" -e "/texdoc" %{_builddir}/filelist.full > %{_builddir}/filelist.doc
406cat %{_builddir}/filelist.doc \
407    %{_builddir}/filelist.full | \
408    sort | uniq -u > %{_builddir}/filelist.tmp
409%__mv -f %{_builddir}/filelist.tmp %{_builddir}/filelist.full
410
411
412%clean
413%__rm -rf %{buildroot}
414
415
416%pretrans
417rpm -q texlive | grep -q -e 2009 -e 2011 -e 2012 -e 2013 -e 2014
418[ $? -eq 1 ] && exit 0
419_trans_time=$(date +%Y%m%d)
420echo "Running some transitional processes on your TeX system ... "
421x=(
422    /usr/share/texmf-local
423    /usr/share/texmf-var
424    /usr/share/texmf-config
425)
426for dir in ${x[@]}; do
427    _trans_dir=${dir}.${_trans_time}.rpmorig
428    [ -d ${_trans_dir}.old ] && \
429        echo -n "  " && \
430        echo "Found ${_trans_dir}.old: " && \
431        echo -n "    " && \
432        %__rm -rvf ${_trans_dir}.old
433    [ -d ${_trans_dir} ] && \
434        echo -n "  " && \
435        echo "Found ${_trans_dir}: " && \
436        echo -n "    " && \
437        %__mv -v ${_trans_dir} ${_trans_dir}.old
438    [ -d ${dir} ] && \
439        echo -n "  " && \
440        echo "Found ${dir}: " && \
441        echo -n "    " && \
442        %__mv -v ${dir} ${_trans_dir}
443done
444echo "done."
445
446%postun
447if [ "$1" = 0 ]; then
448    %__rm -rf %{_tl_vartexfonts}
449fi
450exit 0
451
452%post
453%_tl_touch_run texhash
454%_tl_touch_run updmap
455%_tl_touch_run mtxrun
456%_tl_touch_run fmtutil
457exit 0
458
459%posttrans
460%__mkdir_p %{_tl_vartexfonts}
461%__chmod 1777 %{_tl_vartexfonts}
462
463## create our map files {ptex,uptex,otf,otf-up}-vine.map
464( %{_tl_exec_upddeffont} ) ||:
465
466%{_tl_exec_texhash}
467%{_tl_exec_mtxrun}
468%{_tl_exec_updmap}
469%{_tl_exec_fmtutil}
470exit 0
471
472%post -n libkpathsea
473/sbin/ldconfig
474# for x in kpathsea tds web2c; do
475#     /sbin/install-info %{_infodir}/${x}.info.* %{_infodir}/dir
476# done
477
478# %preun -n libkpathsea
479# if [ "$1" = 0 ]; then
480#     for x in kpathsea tds web2c; do
481#         /sbin/install-info --delete %{_infodir}/${x}.info.* %{_infodir}/dir
482#     done
483# fi
484
485%postun -n libkpathsea
486/sbin/ldconfig
487
488%post -n libptexenc
489/sbin/ldconfig
490
491%postun -n libptexenc
492/sbin/ldconfig
493
494%triggerin -- ghostscript
495%__rm -f %{_tl_texmfvine}/fonts/cmap/ghostscript
496if [ -d "%{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap" ] ; then
497    %__ln_s %{_datadir}/ghostscript/$(gs --version| cut -d . -f 1-2)/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
498elif [ -d "%{_datadir}/ghostscript/Resource/CMap" ] ; then
499    %__ln_s %{_datadir}/ghostscript/Resource/CMap %{_tl_texmfvine}/fonts/cmap/ghostscript
500fi
501%_tl_touch_run texhash
502exit 0
503
504
505%files -f %{_builddir}/filelist.full
506%defattr(-,root,root)
507%{_libdir}/libtexlua52.so.*
508%{_libdir}/libtexluajit.so.*
509%dir %{_tl_aliasttfdir}
510%attr(1777,root,root) %dir %{_tl_vartexfonts}
511# %config %{_sysconfdir}/cron.daily/texlive.cron
512
513%exclude %{_includedir}/texlua52/*.h
514%exclude %{_includedir}/texlua52/*.hpp
515%exclude %{_includedir}/texluajit/*.h
516%exclude %{_includedir}/texluajit/*.hpp
517%exclude %{_libdir}/libtexlua52.so
518%exclude %{_libdir}/libtexluajit.so
519%exclude %{_libdir}/pkgconfig/texlua52.pc
520%exclude %{_libdir}/pkgconfig/texluajit.pc
521
522%files doc -f %{_builddir}/filelist.doc
523%defattr(-,root,root)
524
525%files -n libkpathsea
526%defattr(-,root,root)
527%{_libdir}/libkpathsea.so.*
528# %{_infodir}/kpathsea.info*
529
530%files -n libkpathsea-devel
531%defattr(-,root,root)
532%{_libdir}/libkpathsea.so
533%dir %{_includedir}/kpathsea
534%{_includedir}/kpathsea/*.h
535%{_libdir}/pkgconfig/kpathsea.pc
536
537%files -n libptexenc
538%defattr(-,root,root)
539%{_libdir}/libptexenc.so.*
540
541%files -n libptexenc-devel
542%defattr(-,root,root)
543%{_libdir}/libptexenc.so
544%dir %{_includedir}/ptexenc
545%{_includedir}/ptexenc/*.h
546%{_libdir}/pkgconfig/ptexenc.pc
547
548%files -n libsynctex
549%defattr(-,root,root)
550%{_libdir}/libsynctex.so.*
551
552%files -n libsynctex-devel
553%defattr(-,root,root)
554%{_libdir}/libsynctex.so
555%dir %{_includedir}/synctex
556%{_includedir}/synctex/*.h
557%{_libdir}/pkgconfig/synctex.pc
558
559
560%changelog
561* Thu Jun  8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 2017-2
562- rebuilt
563
564* Wed Jun  7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 2017-1
565- upgraded to TeX Live 2017
566- texlive-20170520-source
567
568* Tue Jul  5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-5
569- updated to texlive-source-20160702
570
571* Wed Jun 29 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-4
572- rebuilt with new toolchain
573
574* Mon Jun  6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-3
575- texlive-20160523-source (TeX Live 2016)
576
577* Tue May 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-2
578- texlive-20160510-source (TeX Live 2016/pretest)
579
580* Thu Apr 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2016-1
581- texlive-20160427-source (TeX Live 2016/pretest)
582
583* Thu Jan 21 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-5
584- fixed some development files
585
586* Tue Jan 12 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-4
587- reverted to texlive-20150521-source (TeX Live 2015)
588
589* Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 2015-3
590- texlive-source-20160110 (TeX Live 2016/dev)
591
592* Sun May 24 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-2
593- texlive-source-20150523 (TeX Live 2015/pretest)
594- configure ConTeXt/LuaTeX+LuaJIT
595
596* Sun Apr 26 2015 Munehiro Yamamoto <munepi@vinelinux.org> 2015-1
597- texlive-source-20150426 (TeX Live 2015/pretest)
598
599* Tue Dec 30 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-3
600- texlive-source-20141230 (TeX Live 2015/dev)
601
602* Thu Jul  3 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
603- texlive-source-20140525 + tlptexlive 20140507
604- dropped texlive-20140524-vine.patch: built with libpng >= 1.6
605
606* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
607- upgrade to TeX Live 2014
608  - texlive-source-20140524 + tlptexlive 20140507
609
610* Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2013-7
611- rebuild with poppler-0.24.5
612
613* Mon Jan 13 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2013-6
614- rebuilt
615
616* Fri Nov  1 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-5
617- texlive-source-20131101 2014/dev + tlptexlive 20130815
618- added BuildRequires: libpaper-devel >= 1.1.24-2 :-(
619
620* Mon Oct  7 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-4
621- updated texlive-20131002-texmfcnf-vine.patch:
622  texmf.cnf (shell_escape_commands): added some programs
623
624* Wed Oct  2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-3
625- texlive-source-20131002 2014/dev + tlptexlive 20130815
626- defined %%global __find_requires find-requires-texlive.sh
627  - dropped unused dependencies of Requires
628
629* Thu Sep 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-2
630- texlive-source-20130919 2014/dev + tlptexlive 20130815
631- correct some scripts of README.vine for each texmf trees
632
633* Fri Aug 23 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2013-1
634- upgrade to TeX Live 2013
635  - texlive-source-20130823 2014/dev + tlptexlive 20130815
636- dropped Requires: jvf
637
638* Thu May 16 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-4
639- update enhancement binaries TeX Live 2013/dev 20130106 snapshot (tlptexlive-20130106)
640- fixed duplicated lw35 for updmap.pl
641- updated updmap.cfg.texlive-20120701: use ipaex as kanjiEmbed
642
643* Sat Mar  9 2013 Munehiro Yamamoto <munepi@vinelinux.org> 2012-3
644- touch the map files generated by updmap-sys
645
646* Mon Nov 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-2
647- fixed Source7: updmap.cfg.texlive-20120701
648  (upto /etc/texmf/web2c/updmap.cfg)
649- fixex %%triggerin -- ghostscript
650  - replaced %%exec_texhash with %%touch_run texhash
651
652* Wed Nov 21 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
653- TeX Live 2012 + tlptexlive 20121107
654
655* Tue Oct 30 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-7
656- drop BR: poppler-devel temporaly
657  - modify tl11supp-120120-vine.patch, texlive-20110705-vine.patch to do that
658
659* Mon May 28 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-6
660- build with poppler-0.18.4
661- remove tlmgr
662
663* Thu Jan 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2011-5
664- updated to tl11supp-120120
665- run %%{exec_fmtutil} at %%post when upgrading
666
667* Sat Dec 17 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-4
668- updated to tl11supp-111214
669
670* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-3
671- added BuildRequires: texlive-common
672  - Babel needs docstrip.tex, which is contained in texlive-collection-latex
673  - check japanese.ldf
674- updated tl11supp-111120-vine.patch
675  - added the following options to $$TL_CONFIGURE_ARGS:
676    --disable-detex
677    --disable-dvipng
678    --disable-lcdf-typetools
679- remove some files of asymptote
680- remove a man file of latexmk
681- remove man files of lcdf-typetools
682- remove man files of dvipng
683- remove a man file of detex
684
685* Mon Nov 28 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
686- added find-provides-texlive.sh and set it to %%__find_provides
687  - use to find library sonames for libkpathsea and libptexenc
688- added cmex.enc (%%{SOURCE110})
689  - do not install cmex.enc in our TDS, yet
690- removed some unused directories in texmf/fonts/map
691- removed man files of lcdf-typetools
692- moved texdoc{,tk} and its related files to texlive-doc
693
694* Wed Nov 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
695- TeX Live 2011 + tl11supp-111120
696
697* Thu Oct 13 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-22
698- make the directory VARTEXFONTS (%%posttrans)
699  - dropped %%triggerpostun -- texlive < 2009-17vl6
700
701* Tue Jul 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-21
702- fixed ptexlive-20100711-dvipdfmx-vine.patch
703  - for dvipdfmx.cfg, given some ps2pdf's parameters mistaked
704
705* Thu Jun 16 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-20
706- added %%pre to avoid conflictions of texmf-{config,var}
707
708* Sun May 22 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-19
709- dropped Requires: texlive-common
710- added perl-Tk-TableMatrix
711  - supported texdoctk
712- removed broken symbolic links in /usr/bin
713  - for each these symbolic links, the package of its real file/path
714    should be its owner.
715
716* Thu May 19 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-18
717- added %%triggerpostun -- texlive < 2009-17vl6
718  - make the directory VARTEXFONTS
719
720* Tue May 10 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-17
721- fixed %%dir VARTEXFONTS around in %%files
722- dropped BuildRequires: t1utils
723
724* Tue Apr 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-16
725- updated texlive-20091107-texmfcnf-vine.patch, texlive.cron
726  - changed VARTEXFONTS to /var/lib/texmf/fonts
727
728* Mon Apr 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-15
729- fixed updmap.cfg
730
731* Sun Mar 27 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-14
732- dropped Requires: texlive-macros
733
734* Sat Jan 15 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-13
735- updated ptexlive-20100711-pxdvik-vine.patch
736  and added texlive-20091107-xdvik-vine.patch
737  - fixed to adjust X resources in texmf/xdvi/XDvi for (p)xdvi
738
739* Sat Jan 08 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-12
740- supported Vine Linux 5
741  - for vl5, changed a requirement of Japanese VF package
742    - added Requires: texlive-jvf = 2009 (vl5)
743- dropped dependencies of Provides:/Obsoletes: tags
744  - merged these dependencies in texlive-common-vl.spec
745
746* Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 2009-11
747- rebuilt with poppler-0.14.2 (libpoppler has been up to so.7)
748
749* Fri Sep 24 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-10
750- applied some security patches from Debian
751  - texlive-2009-CVE-2010-0827.patch
752  - texlive-2009-CVE-2010-1440.patch
753- applied texlive-2009-pdftexdir-libpoppler-0.12.patch from Debian
754- applied texlive-2009-luatexdir-libpoppler-0.12.patch
755  based on texlive-2009-pdftexdir-libpoppler-0.12.patch
756- fixed some dependencies
757
758* Mon Aug 09 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-9
759- added BuildArch: noarch in %%package doc
760- removed some comment-out sentences
761
762* Tue Jul 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-8
763- separeted texmf-dist to texlive-common package
764
765* Mon Jul 19 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-7
766- unpacked texlive-20091107-source.tar.xz
767- babel is available now
768- applied eptex-100420 and some patches:
769  - eptex-100420-vine.patch
770  - eptex-100420-patch1.diff
771
772* Tue Jul 13 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-6
773- updated ptexlive-20100711
774
775* Sat Jun 12 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-5
776- customized updmap.cfg to correspond installed fonts
777
778* Mon May 31 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
779- fixed insttexfont()
780
781* Mon May 17 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
782- added jvf of MORISAWA basic 5 fonts
783- added cm-super, mathdesign in fntlst
784
785* Sun May 16 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
786- define insttexfont() in %%install
787  - copy almost compatible tetex-3.0
788
789* Sat May 08 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
790- ptexlive-20090322 + TeXLive 2009
791- added BuildRequires: openssl-devel
792
793* Sun Dec 06 2009 Munehiro Yamamoto <munepi@vinelinux.org> 2008-0.20091206
794- ptexlive-20091009 + TeXLive 2008
Note: See TracBrowser for help on using the repository browser.