source: projects/specs/trunk/t/tclx/tclx-vl.spec @ 1262

Revision 1262, 7.1 KB checked in by owa, 14 years ago (diff)

updated tcl/tk

Line 
1%define tcl_major       8.4
2%define tk_major        8.4
3%define thread_major    2.6
4%define tclx_major      8.4
5%define tclxvers        %{tclx_major}
6Summary: A Tcl/Tk development environment: tclX
7Summary(ja): Tcl/Tk 開発環境: tclX
8Name: tclx
9Version: %{tclxvers}
10Release: 2%{?_dist_release}
11Group: Development/Languages
12License: BSD
13Source0:   ftp://ftp.tcl.tk/pub/tcl/nightly-cvs/tclx-20070227.tar.gz
14BuildRequires: tcl >= %{tcl_major}
15BuildRequires: tk >= %{tk_major}
16BuildRequires: thread >= %{thread_major}
17Requires: tcl >= %{tcl_major}
18Requires: tk >= %{tk_major}
19Requires: thread >= %{thread_major}
20Buildroot: %{_tmppath}/%{name}-root
21
22Distribution: Vine Linux
23Vendor: Project Vine
24
25%description -n tclx
26TclX is a set of extensions which make it easier to use the Tcl
27scripting language for common UNIX/Linux programming tasks.  TclX
28enhances Tcl support for files, network access, debugging, math, lists,
29and message catalogs.  TclX can be used with both Tcl and Tcl/Tk
30applications.
31
32Install TclX if you are developing applications with Tcl/Tk.  You'll
33also need to install the tcl and tk packages.
34
35%description -n tclx -l ja
36TclX は一般的な UNIX/Linux プログラミング作業のおいて、Tcl スクリプト言語
37をより簡単に使用するための拡張キットです。TclX は、ファイルや、ネットワーク
38アクセス、デバッグ、数値計算、リスト、メッセージカタログの Tcl サポートを拡
39張します。TclX は Tcl と Tcl/Tk アプリケーションの両方で使うことができます。
40
41Tcl/Tk のアプリケーションを開発するときには、TclXもインストールしてください。
42tcl と tk のパッケージも必要です。
43
44
45%prep
46%setup -q -n %{name}
47
48
49%build
50# make the libraries reentrant
51RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
52
53# tclX
54%configure \
55--with-tcl=%{_libdir} --with-tk=%{_libdir} \
56--enable-shared --enable-tk --enable-threads --enable-64bit
57make
58
59
60%install
61rm -rf ${RPM_BUILD_ROOT}
62mkdir -p ${RPM_BUILD_ROOT}
63rm -f *.files
64
65# TclX
66%makeinstall
67
68if [ "%_mandir" = "%{_prefix}/share/man" ]; then
69   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; tar cf - ./man[13n] ) |
70   ( cd ${RPM_BUILD_ROOT}%{_mandir}; tar xf - )
71   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; rm -rf ./man[13n] )
72fi
73
74echo "%%defattr(-,root,root)" > tclx.files
75(find ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_includedir} \
76        ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
77 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
78        | sort | uniq -u >> tclx.files
79
80set +x +H
81for n in `cat tclx.files`; do
82        test -f $n || continue
83        head -1 $n | grep -q ^#! || continue
84        chmod u+w $n
85        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
86done
87set -x -H
88
89# post process the *.files list, removing build sys references and mark
90# which are directories
91set +x
92for n in *.files; do
93        mv $n $n.in
94        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
95            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
96                echo -n '%dir '
97            fi
98            echo $file
99        done > $n
100        rm -f $n.in
101done
102set -x
103
104# Man pages can be compressed
105perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
106
107%post -p /sbin/ldconfig -n tclx
108%postun -p /sbin/ldconfig -n tclx
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files -f tclx.files -n tclx
113
114%changelog
115* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
116- rebuilt with tcl/tk-8.4.19-2
117
118* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
119- applied new versioning policy
120
121* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
122- updated tclx to tclx-20070227.tar.gz
123- rebuild with tcl/tk-8.4.18
124
125* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
126- rebuild with tcl/tk-8.4.16
127
128* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
129- update based on BitWalk's tcltk-8.4.2-83bw
130
131* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
132- split source package.
133
134* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
135- expand some macros.. (FIXME)
136
137* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
138- use %configure macros
139- add Patch 47,50
140
141* Thu May 31 2001 <sagami@vinelinux.org>
142- 8.0.5_jp-10
143- unexpand old %%{configure}, new one causes build failure
144- fixed missing libtkx.so libtclx.so symlink in /usr/lib
145- install manpages into %%{_mandir} and mode 644
146
147* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
148- 8.0.5_jp-9
149- modified %install section to handle compressed man pages
150- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
151
152* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
153- changed default fonts
154
155* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
156- added defattr
157
158* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
159- added some symlinks, such as libtcl8.0.so.
160- obsoletes version number using _jp, now 8.0.5-31vl1
161
162* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
163- Apply Tcl/Tk 8.0 Japanese Patch 1.7
164
165* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
166- fix tclX symlinks.
167- compile on systems where SIGPWR == SIGLOST.
168
169* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
170- update tcl/tk to 8.0.5.
171- avoid "containing" in Tix (#2332).
172
173* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
174- use /usr/bin/write in kibitz (#1320).
175- use cirrus.sprl.umich.edu in weather (#1926).
176
177* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
178- auto rebuild in the new build environment (release 28)
179
180* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
181- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
182
183* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
184- expect does unaligned access on alpha (#989)
185- upgrade tcl/tk/tclX to 8.0.4
186- upgrade expect to 5.28.
187- add itcl 3.0.1
188
189* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
190- call libtoolize to allow building on the arm
191- build for glibc 2.1
192- strip binaries
193
194* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
195- update tcl/tk/tclX to 8.0.3, expect is updated also.
196
197* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
198- expect: mkpasswd needs delay before sending password (problem #576)
199
200* Thu May 07 1998 Prospector System <bugs@redhat.com>
201- translations modified for de, fr, tr
202
203* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
204- fixed expect binaries exec permissions
205
206* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
207- updated to Tix 4.1.0.006
208- updated version numbers of tcl/tk to relflect includsion of p2
209
210* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
211- updated tcl/tk to patch level 2
212- updated tclX to 8.0.2
213
214* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
215- fixed filelist for tix... replacing path to the expect binary in scripts
216  was leaving junk files around.
217
218* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
219- added patch to remove libieee test in configure.in for tcl and tk.
220  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
221  solution for all systems
222- fixed src urls
223
224* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
225- removed version numbers from descriptions
226
227* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
228- updated to tcl/tk 8.0 and related versions of packages
229
230* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
231- built against glibc
232- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.