source: projects/specs/trunk/t/tclx/tclx-vl.spec @ 521

Revision 521, 7.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define tcl_major       8.4
2%define tk_major        8.4
3%define thread_major    2.6
4%define tclx_major      8.4
5%define tclxvers        %{tclx_major}
6Summary: A Tcl/Tk development environment: tclX
7Summary(ja): Tcl/Tk 開発環境: tclX
8Name: tclx
9Version: %{tclxvers}
10Release: 1%{?_dist_release}
11Group: Development/Languages
12License: BSD
13Source0:   ftp://ftp.tcl.tk/pub/tcl/nightly-cvs/tclx-20070227.tar.gz
14BuildRequires: tcl >= %{tcl_major}
15BuildRequires: tk >= %{tk_major}
16BuildRequires: thread >= %{thread_major}
17Requires: tcl >= %{tcl_major}
18Requires: tk >= %{tk_major}
19Requires: thread >= %{thread_major}
20Buildroot: %{_tmppath}/%{name}-root
21
22Distribution: Vine Linux
23Vendor: Project Vine
24
25%description -n tclx
26TclX is a set of extensions which make it easier to use the Tcl
27scripting language for common UNIX/Linux programming tasks.  TclX
28enhances Tcl support for files, network access, debugging, math, lists,
29and message catalogs.  TclX can be used with both Tcl and Tcl/Tk
30applications.
31
32Install TclX if you are developing applications with Tcl/Tk.  You'll
33also need to install the tcl and tk packages.
34
35%description -n tclx -l ja
36TclX は一般的な UNIX/Linux プログラミング作業のおいて、Tcl スクリプト言語
37をより簡単に使用するための拡張キットです。TclX は、ファイルや、ネットワーク
38アクセス、デバッグ、数値計算、リスト、メッセージカタログの Tcl サポートを拡
39張します。TclX は Tcl と Tcl/Tk アプリケーションの両方で使うことができます。
40
41Tcl/Tk のアプリケーションを開発するときには、TclXもインストールしてください。
42tcl と tk のパッケージも必要です。
43
44
45%prep
46%setup -q -n %{name}
47
48
49%build
50# make the libraries reentrant
51RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
52
53# tclX
54%configure \
55--with-tcl=%{_libdir} --with-tk=%{_libdir} \
56--enable-shared --enable-tk --enable-threads --enable-64bit
57make
58
59
60%install
61rm -rf ${RPM_BUILD_ROOT}
62mkdir -p ${RPM_BUILD_ROOT}
63rm -f *.files
64
65# TclX
66%makeinstall
67
68if [ "%_mandir" = "%{_prefix}/share/man" ]; then
69   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; tar cf - ./man[13n] ) |
70   ( cd ${RPM_BUILD_ROOT}%{_mandir}; tar xf - )
71   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; rm -rf ./man[13n] )
72fi
73
74echo "%%defattr(-,root,root)" > tclx.files
75(find ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_includedir} \
76        ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
77 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
78        | sort | uniq -u >> tclx.files
79
80set +x +H
81for n in `cat tclx.files`; do
82        test -f $n || continue
83        head -1 $n | grep -q ^#! || continue
84        chmod u+w $n
85        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
86done
87set -x -H
88
89# post process the *.files list, removing build sys references and mark
90# which are directories
91set +x
92for n in *.files; do
93        mv $n $n.in
94        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
95            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
96                echo -n '%dir '
97            fi
98            echo $file
99        done > $n
100        rm -f $n.in
101done
102set -x
103
104# Man pages can be compressed
105perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
106
107%post -p /sbin/ldconfig -n tclx
108%postun -p /sbin/ldconfig -n tclx
109%clean
110rm -rf $RPM_BUILD_ROOT
111
112%files -f tclx.files -n tclx
113
114%changelog
115* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
116- applied new versioning policy
117
118* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
119- updated tclx to tclx-20070227.tar.gz
120- rebuild with tcl/tk-8.4.18
121
122* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
123- rebuild with tcl/tk-8.4.16
124
125* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
126- update based on BitWalk's tcltk-8.4.2-83bw
127
128* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
129- split source package.
130
131* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
132- expand some macros.. (FIXME)
133
134* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
135- use %configure macros
136- add Patch 47,50
137
138* Thu May 31 2001 <sagami@vinelinux.org>
139- 8.0.5_jp-10
140- unexpand old %%{configure}, new one causes build failure
141- fixed missing libtkx.so libtclx.so symlink in /usr/lib
142- install manpages into %%{_mandir} and mode 644
143
144* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
145- 8.0.5_jp-9
146- modified %install section to handle compressed man pages
147- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
148
149* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
150- changed default fonts
151
152* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
153- added defattr
154
155* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
156- added some symlinks, such as libtcl8.0.so.
157- obsoletes version number using _jp, now 8.0.5-31vl1
158
159* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
160- Apply Tcl/Tk 8.0 Japanese Patch 1.7
161
162* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
163- fix tclX symlinks.
164- compile on systems where SIGPWR == SIGLOST.
165
166* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
167- update tcl/tk to 8.0.5.
168- avoid "containing" in Tix (#2332).
169
170* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
171- use /usr/bin/write in kibitz (#1320).
172- use cirrus.sprl.umich.edu in weather (#1926).
173
174* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
175- auto rebuild in the new build environment (release 28)
176
177* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
178- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
179
180* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
181- expect does unaligned access on alpha (#989)
182- upgrade tcl/tk/tclX to 8.0.4
183- upgrade expect to 5.28.
184- add itcl 3.0.1
185
186* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
187- call libtoolize to allow building on the arm
188- build for glibc 2.1
189- strip binaries
190
191* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
192- update tcl/tk/tclX to 8.0.3, expect is updated also.
193
194* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
195- expect: mkpasswd needs delay before sending password (problem #576)
196
197* Thu May 07 1998 Prospector System <bugs@redhat.com>
198- translations modified for de, fr, tr
199
200* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
201- fixed expect binaries exec permissions
202
203* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
204- updated to Tix 4.1.0.006
205- updated version numbers of tcl/tk to relflect includsion of p2
206
207* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
208- updated tcl/tk to patch level 2
209- updated tclX to 8.0.2
210
211* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
212- fixed filelist for tix... replacing path to the expect binary in scripts
213  was leaving junk files around.
214
215* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
216- added patch to remove libieee test in configure.in for tcl and tk.
217  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
218  solution for all systems
219- fixed src urls
220
221* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
222- removed version numbers from descriptions
223
224* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
225- updated to tcl/tk 8.0 and related versions of packages
226
227* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
228- built against glibc
229- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.