source: projects/specs/trunk/t/tclx/tclx-vl.spec @ 9210

Revision 9210, 7.4 KB checked in by inagaki, 9 years ago (diff)

2015-01-01 Ryoichi INAGAKI <ryo1@…>

  • cjs, gjs: changed Group
  • expect, tclx, thread: updated
  • pclock, tix: rebuilt


Line 
1%define tcl_major       8.5
2%define tk_major        8.5
3%define thread_major    2.7
4%define tclx_major      8.4
5%define tclxvers        %{tclx_major}
6Summary: A Tcl/Tk development environment: tclX
7Summary(ja): Tcl/Tk 開発環境: tclX
8Name: tclx
9Version: %{tclxvers}.1
10Release: 1%{?_dist_release}
11Group: Development/Languages
12License: BSD
13Source0: http://downloads.sourceforge.net/project/tclx/TclX/8.4.1/%{name}%{version}.tar.bz2
14
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16BuildRequires: tcl >= %{tcl_major}
17BuildRequires: tk >= %{tk_major}
18BuildRequires: thread >= %{thread_major}
19Requires: tcl >= %{tcl_major}
20Requires: tk >= %{tk_major}
21Requires: thread >= %{thread_major}
22
23Distribution: Vine Linux
24Vendor: Project Vine
25
26%description -n tclx
27TclX is a set of extensions which make it easier to use the Tcl
28scripting language for common UNIX/Linux programming tasks.  TclX
29enhances Tcl support for files, network access, debugging, math, lists,
30and message catalogs.  TclX can be used with both Tcl and Tcl/Tk
31applications.
32
33Install TclX if you are developing applications with Tcl/Tk.  You'll
34also need to install the tcl and tk packages.
35
36%description -n tclx -l ja
37TclX は一般的な UNIX/Linux プログラミング作業のおいて、Tcl スクリプト言語
38をより簡単に使用するための拡張キットです。TclX は、ファイルや、ネットワーク
39アクセス、デバッグ、数値計算、リスト、メッセージカタログの Tcl サポートを拡
40張します。TclX は Tcl と Tcl/Tk アプリケーションの両方で使うことができます。
41
42Tcl/Tk のアプリケーションを開発するときには、TclXもインストールしてください。
43tcl と tk のパッケージも必要です。
44
45
46%prep
47%setup -q -n %{name}%{tclxvers}
48
49
50%build
51# make the libraries reentrant
52RPM_OPT_FLAGS="$RPM_OPT_FLAGS -D_REENTRANT"
53
54# tclX
55%configure \
56--with-tcl=%{_libdir} --with-tk=%{_libdir} \
57--enable-shared --enable-tk --enable-threads --enable-64bit
58make
59
60
61%install
62rm -rf ${RPM_BUILD_ROOT}
63mkdir -p ${RPM_BUILD_ROOT}
64rm -f *.files
65
66# TclX
67%makeinstall
68
69#if [ "%_mandir" = "%{_prefix}/share/man" ]; then
70#   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; tar cf - ./man[13n] ) |
71#   ( cd ${RPM_BUILD_ROOT}%{_mandir}; tar xf - )
72#   ( cd ${RPM_BUILD_ROOT}%{_prefix}/man; rm -rf ./man[13n] )
73#fi
74
75echo "%%defattr(-,root,root)" > tclx.files
76(find ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_includedir} \
77        ${RPM_BUILD_ROOT}%{_mandir} -type f -o -type l;
78 find ${RPM_BUILD_ROOT}%{_libdir}/*) | cat - *.files \
79        | sort | uniq -u >> tclx.files
80
81set +x +H
82for n in `cat tclx.files`; do
83        test -f $n || continue
84        head -1 $n | grep -q ^#! || continue
85        chmod u+w $n
86        perl -pi -e "s|${RPM_BUILD_ROOT}||" $n
87done
88set -x -H
89
90# post process the *.files list, removing build sys references and mark
91# which are directories
92set +x
93for n in *.files; do
94        mv $n $n.in
95        sed "s|.*%{_prefix}\\>|%{_prefix}|" < $n.in | while read file; do
96            if [ -d ${RPM_BUILD_ROOT}/$file ]; then
97                echo -n '%dir '
98            fi
99            echo $file
100        done > $n
101        rm -f $n.in
102done
103set -x
104
105# Man pages can be compressed
106perl -pi -e 's|(^%{_mandir}/man.*$)|\1\*|' *.files
107
108%post -p /sbin/ldconfig -n tclx
109%postun -p /sbin/ldconfig -n tclx
110%clean
111rm -rf $RPM_BUILD_ROOT
112
113%files -f tclx.files -n tclx
114%doc ChangeLog README
115
116%changelog
117* Wed Dec 31 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.4.1-1
118- updated to 8.4.1
119- rebuilt with tcl/tk 8.5.15 and thread 2.7.1
120
121* Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> 8.4-3
122- rebuilt with rpm-4.8.1-3
123
124* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.2-2
125- rebuilt with tcl/tk-8.4.19-2
126
127* Sat Jul 26 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-1vl5
128- applied new versioning policy
129
130* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl3
131- updated tclx to tclx-20070227.tar.gz
132- rebuild with tcl/tk-8.4.18
133
134* Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.2-0vl2
135- rebuild with tcl/tk-8.4.16
136
137* Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
138- update based on BitWalk's tcltk-8.4.2-83bw
139
140* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
141- split source package.
142
143* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
144- expand some macros.. (FIXME)
145
146* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
147- use %configure macros
148- add Patch 47,50
149
150* Thu May 31 2001 <sagami@vinelinux.org>
151- 8.0.5_jp-10
152- unexpand old %%{configure}, new one causes build failure
153- fixed missing libtkx.so libtclx.so symlink in /usr/lib
154- install manpages into %%{_mandir} and mode 644
155
156* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
157- 8.0.5_jp-9
158- modified %install section to handle compressed man pages
159- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
160
161* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
162- changed default fonts
163
164* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
165- added defattr
166
167* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
168- added some symlinks, such as libtcl8.0.so.
169- obsoletes version number using _jp, now 8.0.5-31vl1
170
171* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
172- Apply Tcl/Tk 8.0 Japanese Patch 1.7
173
174* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
175- fix tclX symlinks.
176- compile on systems where SIGPWR == SIGLOST.
177
178* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
179- update tcl/tk to 8.0.5.
180- avoid "containing" in Tix (#2332).
181
182* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
183- use /usr/bin/write in kibitz (#1320).
184- use cirrus.sprl.umich.edu in weather (#1926).
185
186* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
187- auto rebuild in the new build environment (release 28)
188
189* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
190- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
191
192* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
193- expect does unaligned access on alpha (#989)
194- upgrade tcl/tk/tclX to 8.0.4
195- upgrade expect to 5.28.
196- add itcl 3.0.1
197
198* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
199- call libtoolize to allow building on the arm
200- build for glibc 2.1
201- strip binaries
202
203* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
204- update tcl/tk/tclX to 8.0.3, expect is updated also.
205
206* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
207- expect: mkpasswd needs delay before sending password (problem #576)
208
209* Thu May 07 1998 Prospector System <bugs@redhat.com>
210- translations modified for de, fr, tr
211
212* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
213- fixed expect binaries exec permissions
214
215* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
216- updated to Tix 4.1.0.006
217- updated version numbers of tcl/tk to relflect includsion of p2
218
219* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
220- updated tcl/tk to patch level 2
221- updated tclX to 8.0.2
222
223* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
224- fixed filelist for tix... replacing path to the expect binary in scripts
225  was leaving junk files around.
226
227* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
228- added patch to remove libieee test in configure.in for tcl and tk.
229  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
230  solution for all systems
231- fixed src urls
232
233* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
234- removed version numbers from descriptions
235
236* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
237- updated to tcl/tk 8.0 and related versions of packages
238
239* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
240- built against glibc
241- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.