source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 9294

Revision 9294, 10.9 KB checked in by inagaki, 9 years ago (diff)

2015-01-26 Ryoichi INAGAKI <ryo1@…>

  • hdf: updated
  • tcl, tk: split development files into devel subpackage


Line 
1%define majorver 8.5
2%define minorver 15
3%define version %{majorver}.%{minorver}
4%define htmlver %{majorver}.15
5
6%{!?sdt:%define sdt 0}
7
8Summary: A Tcl/Tk development environment: tcl
9Summary(ja): Tcl/Tk 開発環境: tcl
10Name: tcl
11Version: %{version}
12Release: 3%{?_dist_release}
13Group: Development/Languages
14License: TCL
15URL:     http://tcl.sourceforge.net/
16
17Source0: http://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
18Source1: http://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
19# patches from Red Hat Enterprise Linux tcl-8.5.7-6.el6
20Patch100: tcl-8.5.1-autopath.patch
21Patch101: tcl-8.5.15-conf.patch
22Patch102: tcl-8.5.0-hidden.patch
23
24Buildroot: %{_tmppath}/%{name}-%{version}-root
25Buildrequires: autoconf
26BuildRequires: zlib-devel
27%if %sdt
28BuildRequires: systemtap-sdt-devel
29%endif
30
31Vendor: Project Vine
32Distribution: Vine Linux
33
34%description
35Tcl is a simple scripting language designed to be embedded into
36other applications.  Tcl is designed to be used with Tk, a widget
37set, which is provided in the tk package.  This package also includes
38tclsh, a simple example of a Tcl application.
39
40%description -l ja
41Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
42ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
43デザインしています。このパッケージにはTclの簡単な例として、tclsh
44も含んでいます。
45
46%package devel
47Summary: Tcl scripting language development environment
48Summary(ja): Tcl スクリプト言語の開発環境
49Group: Development/Libraries
50Requires: %{name} = %{version}-%{release}
51
52%description devel
53Tcl is a simple scripting language designed to be embedded into
54other applications.  Tcl is designed to be used with Tk, a widget
55set, which is provided in the tk package.  This package also includes
56tclsh, a simple example of a Tcl application.
57
58The package contains the development files and man pages for tcl.
59
60
61%prep
62%setup -n %{name}%{version} -q -a 1
63mv tcl%{htmlver}/html .
64
65%patch100 -p1 -b .autopath
66%patch101 -p1 -b .conf
67%patch102 -p1 -b .hidden
68
69%build
70pushd unix
71autoconf
72%configure \
73%if %sdt
74--enable-dtrace \
75%endif
76--disable-threads \
77--enable-symbols \
78--enable-shared
79
80make %{?_smp_mflags} TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
81
82
83%install
84rm -rf $RPM_BUILD_ROOT
85make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
86
87ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
88
89# for linking with -lib%{name}
90ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
91
92mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
93
94# postgresql and maybe other packages too need tclConfig.sh
95# paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
96ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
97
98mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
99find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
100( cd $RPM_BUILD_ROOT/%{_includedir}
101        for i in *.h ; do
102                [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
103        done
104)
105
106# remove buildroot traces
107sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
108rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
109rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%post -p /sbin/ldconfig
115
116%postun -p /sbin/ldconfig
117
118%files
119%defattr(-,root,root,-)
120%doc README changes
121%doc license.terms
122%doc html/*
123%{_bindir}/tclsh*
124%{_libdir}/libtcl%{majorver}.so
125%dir %{_libdir}/tcl%{majorver}
126%{_datadir}/%{name}8
127%{_datadir}/tcl%{majorver}
128%{_mandir}/man1/*
129%{_mandir}/mann/*
130
131%files devel
132%defattr(-,root,root,-)
133%{_includedir}/*
134%{_libdir}/libtcl.so
135%{_libdir}/libtclstub%{majorver}.a
136%{_libdir}/tclConfig.sh
137%{_libdir}/tcl%{majorver}/tclConfig.sh
138%{_mandir}/man3/*
139
140%changelog
141* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-3
142- split development files into devel subpackage
143
144* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
145- rebuilt with the current environment
146
147* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
148- update to 8.5.15
149- update Patch101 (tcl-8.5.15-conf.patch)
150- remove Patch103 (tcl-8.5.7-sigabrt.patch)
151
152* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
153- update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
154- update License: TCL
155- drop obsolete patches
156 - tclm4-soname patch (Patch1)
157 - lib-perm patch (Patch2)
158 - configure patch (Patch3)
159 - no rpath patch (Patch4)
160 - init lib64 patch (Patch10)
161- add some patches from RHEL tcl-8.5.7-6.el6
162 - autopath patch (Patch100)
163 - conf patch (Patch101)
164 - hidden patch (Patch102)
165 - sigabrt patch (Patch103)
166- update build and install section: sync RHEL tcl-8.5.7-6.el6
167- add BR: systemtap-sdt-devel: default disable
168
169* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
170- added imake to BR:.
171
172* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
173- rebuilt with rpm-4.8.1-3
174
175* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
176- rebuilt with new environment
177- updated Patch3: tcl8.4.16-configure.patch
178
179* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
180- new upstream release
181
182* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
183- spec in UTF-8
184- configure with disabled threads. See:
185  https://bugzilla.redhat.com/show_bug.cgi?id=443246
186  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
187
188* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
189- rebuild with new environment
190
191* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
192- updated tcl to 8.4.18
193- updated tcl-html to 8.4.18
194
195* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
196- updated tcl to 8.4.16
197- updated tcl-html to 8.4.16
198- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
199- added Patch3: tcl8.4.16-configure.patch
200
201* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
202- updated tcl to 8.4.15
203- updated tcl-html to 8.4.15
204- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
205- added Patch10: tcl-8.4.15-init.lib64.patch
206- rebuilt with new toolchain
207
208* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
209- updated tcl to 8.4.13
210- updated tcl-html to 8.4.13
211
212* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
213- updated tcl to 8.4.12
214- updated patch4
215
216* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
217- updated tcl to 8.4.11
218- updated Patch4
219
220* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
221- updated tcl to 8.4.6
222
223* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
224- merged with fedora
225  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
226  - removed rpath (patch 4)
227
228  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
229  - put private header files under generic and unix subdirs
230  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
231  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
232
233  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
234  - new package split out from tcltk
235  - update to tcl 8.4.5 (#88429)
236    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
237      and tcl8.3.5-koi8-u.enc-88806.patch
238  - include private include headers under %{_includedir}/tcl-private
239  - filtered changelog for tcl
240  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
241
242* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
243- update based on BitWalk's tcltk-8.4.2-83bw
244
245* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
246- split source package.
247
248* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
249- expand some macros.. (FIXME)
250
251* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
252- use %configure macros
253- add Patch 47,50
254
255* Thu May 31 2001 <sagami@vinelinux.org>
256- 8.0.5_jp-10
257- unexpand old %%{configure}, new one causes build failure
258- fixed missing libtkx.so libtclx.so symlink in /usr/lib
259- install manpages into %%{_mandir} and mode 644
260
261* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
262- 8.0.5_jp-9
263- modified %install section to handle compressed man pages
264- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
265
266* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
267- changed default fonts
268
269* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
270- added defattr
271
272* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
273- added some symlinks, such as libtcl8.0.so.
274- obsoletes version number using _jp, now 8.0.5-31vl1
275
276* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
277- Apply Tcl/Tk 8.0 Japanese Patch 1.7
278
279* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
280- fix tclX symlinks.
281- compile on systems where SIGPWR == SIGLOST.
282
283* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
284- update tcl/tk to 8.0.5.
285- avoid "containing" in Tix (#2332).
286
287* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
288- use /usr/bin/write in kibitz (#1320).
289- use cirrus.sprl.umich.edu in weather (#1926).
290
291* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
292- auto rebuild in the new build environment (release 28)
293
294* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
295- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
296
297* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
298- expect does unaligned access on alpha (#989)
299- upgrade tcl/tk/tclX to 8.0.4
300- upgrade expect to 5.28.
301- add itcl 3.0.1
302
303* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
304- call libtoolize to allow building on the arm
305- build for glibc 2.1
306- strip binaries
307
308* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
309- update tcl/tk/tclX to 8.0.3, expect is updated also.
310
311* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
312- expect: mkpasswd needs delay before sending password (problem #576)
313
314* Thu May 07 1998 Prospector System <bugs@redhat.com>
315- translations modified for de, fr, tr
316
317* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
318- fixed expect binaries exec permissions
319
320* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
321- updated to Tix 4.1.0.006
322- updated version numbers of tcl/tk to relflect includsion of p2
323
324* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
325- updated tcl/tk to patch level 2
326- updated tclX to 8.0.2
327
328* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
329- fixed filelist for tix... replacing path to the expect binary in scripts
330  was leaving junk files around.
331
332* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
333- added patch to remove libieee test in configure.in for tcl and tk.
334  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
335  solution for all systems
336- fixed src urls
337
338* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
339- removed version numbers from descriptions
340
341* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
342- updated to tcl/tk 8.0 and related versions of packages
343
344* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
345- built against glibc
346- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.