source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 12236

Revision 12236, 14.9 KB checked in by tomop, 5 years ago (diff)

updated 8 packages

expect-5.45.4-1

postgresql-12.0-1

python-2.7.16-4

python3-3.5.7-3

rp-pppoe-3.13-3

tcl-8.6.9-1

tix-8.4.3-4

tk-8.6.9-1

Line 
1%define majorver 8.6
2%define minorver 9
3%define version %{majorver}.%{minorver}
4%define htmlver %{majorver}.%{minorver}
5
6%global itcl_version 4.1.2
7%global tdbc_version 1.1.0
8%global thread_version 2.8.4
9
10%{!?sdt:%define sdt 0}
11
12Summary: A Tcl/Tk development environment: tcl
13Summary(ja): Tcl/Tk 開発環境: tcl
14Name: tcl
15Version: %{version}
16Release: 1%{?_dist_release}
17Group: Development/Languages
18License: TCL
19URL:     http://tcl.sourceforge.net/
20
21Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
22Source1: https://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
23# patches from Red Hat Enterprise Linux tcl-8.5.7-6.el6
24Patch100: tcl-8.5.1-autopath.patch
25Patch102: tcl-8.5.0-hidden.patch
26# Upstream ticket:
27# https://core.tcl.tk/tcl/tktview/7d0db7c388f52de81faf12da332bc97a24f7b9e5
28Patch103: tcl-8.6.5-parallel-make-fix.patch
29
30Buildroot: %{_tmppath}/%{name}-%{version}-root
31Buildrequires: autoconf
32BuildRequires: zlib-devel
33%if %sdt
34BuildRequires: systemtap-sdt-devel
35%endif
36
37Vendor: Project Vine
38Distribution: Vine Linux
39
40%description
41Tcl is a simple scripting language designed to be embedded into
42other applications.  Tcl is designed to be used with Tk, a widget
43set, which is provided in the tk package.  This package also includes
44tclsh, a simple example of a Tcl application.
45
46%description -l ja
47Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
48ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
49デザインしています。このパッケージにはTclの簡単な例として、tclsh
50も含んでいます。
51
52%package devel
53Summary: Tcl scripting language development environment
54Summary(ja): Tcl スクリプト言語の開発環境
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57
58%description devel
59Tcl is a simple scripting language designed to be embedded into
60other applications.  Tcl is designed to be used with Tk, a widget
61set, which is provided in the tk package.  This package also includes
62tclsh, a simple example of a Tcl application.
63
64The package contains the development files and man pages for tcl.
65
66
67%package itcl
68Summary: Object oriented extensions to Tcl and Tk
69Summary(ja): Tcl/Tk のオブジェクト指向拡張
70Group: Development/Libraries
71Requires: %{name} = %{version}-%{release}
72Provides: itcl = %{itcl_version}
73Obsoletes: itcl < 4.0.0
74
75%description itcl
76[incr Tcl] is Tcl extension that provides object-oriented features that are
77missing from the Tcl language.
78
79
80%package itcl-devel
81Summary: Development headers and libraries for linking against tcl-itcl
82Summary(ja): tcl-itclとリンクするためのヘッダ・ライブラリ
83Group: Development/Libraries
84Requires: %{name}-itcl = %{version}-%{release}
85Provides: itcl-devel = %{itcl_version}
86Obsoletes: itcl-devel < 4.0.0
87
88%description itcl-devel
89Development headers and libraries for linking against itcl.
90
91
92%package tdbc
93Summary: database extensions to Tcl and Tk
94Summary(ja): Tcl/Tk のデータベース拡張
95Group: Development/Libraries
96Requires: %{name} = %{version}-%{release}
97Provides: tdbc = %{tdbc_version}
98
99%description tdbc
100tdbc is Tcl extension that provides database features to tcl/tk.
101
102
103%package tdbc-devel
104Summary: Development headers and libraries for linking against tcl-tdbc
105Summary(ja): tcl-tdbcとリンクするためのヘッダ・ライブラリ
106Group: Development/Libraries
107Requires: %{name}-tdbc = %{version}-%{release}
108Requires: sqlite3-tcl
109Provides: tdbc-devel = %{tdbc_version}
110
111%description tdbc-devel
112Development headers and libraries for linking against tdbc.
113
114
115%package thread
116Summary: thread extensions to Tcl and Tk
117Summary(ja): Tcl/Tk のスレッド拡張
118Group: Development/Libraries
119Requires: %{name} = %{version}-%{release}
120Provides: thread = %{thread_version}
121Obsoletes: thread < 2.8.0
122
123%description thread
124 You can use this extension to gain script-level access to Tcl threading
125capabilities.
126
127
128%prep
129%setup -n %{name}%{version} -q -a 1
130mv tcl%{htmlver}/html .
131
132%patch100 -p1 -b .autopath
133%patch102 -p1 -b .hidden
134%patch103 -p1 -b .parallel-make-fix
135
136pushd unix
137sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtcl%{majorver}.so/' Makefile.in
138popd
139
140%build
141pushd unix
142autoconf
143%configure \
144--disable-rpath \
145%if %sdt
146--enable-dtrace \
147%endif
148--disable-threads \
149--enable-symbols \
150--enable-shared
151
152make %{?_smp_mflags} CFLAGS="%{optflags} -fPIC" TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
153
154
155%install
156rm -rf $RPM_BUILD_ROOT
157make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
158
159ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
160
161# for linking with -lib%{name}
162ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
163
164mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
165
166# postgresql and maybe other packages too need tclConfig.sh
167# paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
168ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
169
170mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
171find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
172pushd $RPM_BUILD_ROOT/%{_includedir}
173        for i in *.h ; do
174                [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
175        done
176popd
177
178# remove buildroot traces
179sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
180rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
181rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
182
183
184# sqlite3 extension is provided by sqlite3-tcl
185rm -rf %{buildroot}%{_libdir}/sqlite3*
186rm -f %{buildroot}%{_mandir}/mann/sqlite3*
187
188%clean
189rm -rf $RPM_BUILD_ROOT
190
191%post -p /sbin/ldconfig
192
193%postun -p /sbin/ldconfig
194
195%files
196%defattr(-,root,root,-)
197%license license.terms
198%doc README changes
199%doc html/*
200%{_bindir}/tclsh*
201%{_libdir}/libtcl%{majorver}.so
202%dir %{_libdir}/tcl%{majorver}
203%{_datadir}/%{name}8
204%{_datadir}/tcl%{majorver}
205%{_mandir}/man1/*
206%{_mandir}/mann/*
207# itcl
208%exclude %{_mandir}/mann/body.n*
209%exclude %{_mandir}/mann/class.n*
210%exclude %{_mandir}/mann/code.n*
211%exclude %{_mandir}/mann/configbody.n*
212%exclude %{_mandir}/mann/delete.n*
213%exclude %{_mandir}/mann/ensemble.n*
214%exclude %{_mandir}/mann/find.n*
215%exclude %{_mandir}/mann/is.n*
216%exclude %{_mandir}/mann/itcl*.n*
217%exclude %{_mandir}/mann/local.n*
218%exclude %{_mandir}/mann/scope.n*
219# tdbc
220%exclude %{_mandir}/mann/tdbc*
221# thread
222%exclude %{_mandir}/mann/thread.n*
223%exclude %{_mandir}/mann/tpool.n*
224%exclude %{_mandir}/mann/tsv.n*
225%exclude %{_mandir}/mann/ttrace.n*
226
227
228%files devel
229%defattr(-,root,root,-)
230%{_includedir}/*
231%{_libdir}/pkgconfig/tcl.pc
232%{_libdir}/libtcl.so
233%{_libdir}/libtclstub%{majorver}.a
234%{_libdir}/tclConfig.sh
235%{_libdir}/tclooConfig.sh
236%{_libdir}/tcl%{majorver}/tclConfig.sh
237%{_mandir}/man3/*
238
239%files itcl
240%{_libdir}/itcl*
241%exclude %{_libdir}/itcl*/itclConfig.sh
242%exclude %{_libdir}/itcl*/libitclstub*.a
243%{_mandir}/mann/body.n*
244%{_mandir}/mann/class.n*
245%{_mandir}/mann/code.n*
246%{_mandir}/mann/configbody.n*
247%{_mandir}/mann/delete.n*
248%{_mandir}/mann/ensemble.n*
249%{_mandir}/mann/find.n*
250%{_mandir}/mann/is.n*
251%{_mandir}/mann/itcl*.n*
252%{_mandir}/mann/local.n*
253%{_mandir}/mann/scope.n*
254
255%files itcl-devel
256%{_libdir}/itcl*/itclConfig.sh
257%{_libdir}/itcl*/libitclstub*.a
258%{_includedir}/itcl*.h
259
260%files tdbc
261%{_libdir}/tdbc*
262%exclude %{_libdir}/tdbc*/libtdbcstub*.a
263%exclude %{_libdir}/tdbc*/tdbcConfig.sh
264%{_bindir}/sqlite3_analyzer
265%{_libdir}/tcl8/%{majorver}/tdbc/sqlite3-*.tm
266%{_mandir}/mann/tdbc*
267
268%files tdbc-devel
269%{_libdir}/tdbc*/libtdbcstub*.a
270%{_libdir}/tdbc*/tdbcConfig.sh
271%{_includedir}/tdbc*.h
272
273%files thread
274%{_libdir}/thread*
275%{_mandir}/mann/thread.n*
276%{_mandir}/mann/tpool.n*
277%{_mandir}/mann/tsv.n*
278%{_mandir}/mann/ttrace.n*
279
280
281%changelog
282* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
283- new upstream release.
284- dropped Patch101: get same effects by sed and configure options.
285- imported Patch103.
286- added subpackages: itcl{,-devel}, tdbc{,-devel} and thread.
287
288* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-3
289- split development files into devel subpackage
290
291* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
292- rebuilt with the current environment
293
294* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
295- update to 8.5.15
296- update Patch101 (tcl-8.5.15-conf.patch)
297- remove Patch103 (tcl-8.5.7-sigabrt.patch)
298
299* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
300- update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
301- update License: TCL
302- drop obsolete patches
303 - tclm4-soname patch (Patch1)
304 - lib-perm patch (Patch2)
305 - configure patch (Patch3)
306 - no rpath patch (Patch4)
307 - init lib64 patch (Patch10)
308- add some patches from RHEL tcl-8.5.7-6.el6
309 - autopath patch (Patch100)
310 - conf patch (Patch101)
311 - hidden patch (Patch102)
312 - sigabrt patch (Patch103)
313- update build and install section: sync RHEL tcl-8.5.7-6.el6
314- add BR: systemtap-sdt-devel: default disable
315
316* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
317- added imake to BR:.
318
319* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
320- rebuilt with rpm-4.8.1-3
321
322* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
323- rebuilt with new environment
324- updated Patch3: tcl8.4.16-configure.patch
325
326* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
327- new upstream release
328
329* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
330- spec in UTF-8
331- configure with disabled threads. See:
332  https://bugzilla.redhat.com/show_bug.cgi?id=443246
333  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
334
335* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
336- rebuild with new environment
337
338* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
339- updated tcl to 8.4.18
340- updated tcl-html to 8.4.18
341
342* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
343- updated tcl to 8.4.16
344- updated tcl-html to 8.4.16
345- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
346- added Patch3: tcl8.4.16-configure.patch
347
348* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
349- updated tcl to 8.4.15
350- updated tcl-html to 8.4.15
351- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
352- added Patch10: tcl-8.4.15-init.lib64.patch
353- rebuilt with new toolchain
354
355* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
356- updated tcl to 8.4.13
357- updated tcl-html to 8.4.13
358
359* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
360- updated tcl to 8.4.12
361- updated patch4
362
363* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
364- updated tcl to 8.4.11
365- updated Patch4
366
367* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
368- updated tcl to 8.4.6
369
370* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
371- merged with fedora
372  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
373  - removed rpath (patch 4)
374
375  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
376  - put private header files under generic and unix subdirs
377  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
378  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
379
380  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
381  - new package split out from tcltk
382  - update to tcl 8.4.5 (#88429)
383    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
384      and tcl8.3.5-koi8-u.enc-88806.patch
385  - include private include headers under %{_includedir}/tcl-private
386  - filtered changelog for tcl
387  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
388
389* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
390- update based on BitWalk's tcltk-8.4.2-83bw
391
392* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
393- split source package.
394
395* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
396- expand some macros.. (FIXME)
397
398* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
399- use %configure macros
400- add Patch 47,50
401
402* Thu May 31 2001 <sagami@vinelinux.org>
403- 8.0.5_jp-10
404- unexpand old %%{configure}, new one causes build failure
405- fixed missing libtkx.so libtclx.so symlink in /usr/lib
406- install manpages into %%{_mandir} and mode 644
407
408* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
409- 8.0.5_jp-9
410- modified %install section to handle compressed man pages
411- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
412
413* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
414- changed default fonts
415
416* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
417- added defattr
418
419* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
420- added some symlinks, such as libtcl8.0.so.
421- obsoletes version number using _jp, now 8.0.5-31vl1
422
423* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
424- Apply Tcl/Tk 8.0 Japanese Patch 1.7
425
426* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
427- fix tclX symlinks.
428- compile on systems where SIGPWR == SIGLOST.
429
430* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
431- update tcl/tk to 8.0.5.
432- avoid "containing" in Tix (#2332).
433
434* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
435- use /usr/bin/write in kibitz (#1320).
436- use cirrus.sprl.umich.edu in weather (#1926).
437
438* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
439- auto rebuild in the new build environment (release 28)
440
441* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
442- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
443
444* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
445- expect does unaligned access on alpha (#989)
446- upgrade tcl/tk/tclX to 8.0.4
447- upgrade expect to 5.28.
448- add itcl 3.0.1
449
450* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
451- call libtoolize to allow building on the arm
452- build for glibc 2.1
453- strip binaries
454
455* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
456- update tcl/tk/tclX to 8.0.3, expect is updated also.
457
458* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
459- expect: mkpasswd needs delay before sending password (problem #576)
460
461* Thu May 07 1998 Prospector System <bugs@redhat.com>
462- translations modified for de, fr, tr
463
464* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
465- fixed expect binaries exec permissions
466
467* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
468- updated to Tix 4.1.0.006
469- updated version numbers of tcl/tk to relflect includsion of p2
470
471* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
472- updated tcl/tk to patch level 2
473- updated tclX to 8.0.2
474
475* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
476- fixed filelist for tix... replacing path to the expect binary in scripts
477  was leaving junk files around.
478
479* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
480- added patch to remove libieee test in configure.in for tcl and tk.
481  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
482  solution for all systems
483- fixed src urls
484
485* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
486- removed version numbers from descriptions
487
488* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
489- updated to tcl/tk 8.0 and related versions of packages
490
491* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
492- built against glibc
493- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.