source: projects/specs/trunk/t/tcl/tcl-vl.spec @ 12419

Revision 12419, 14.9 KB checked in by tomop, 4 years ago (diff)

updated 2 packages

tcl-8.6.10-1

tk-8.6.10-1

Line 
1%global itcl_version 4.2.0
2%global tdbc_version 1.1.1
3%global thread_version 2.8.5
4
5%{!?sdt:%define sdt 0}
6
7Summary: A Tcl/Tk development environment: tcl
8Summary(ja): Tcl/Tk 開発環境: tcl
9Name: tcl
10Version: 8.6.10
11%global majorver %(echo %{version} | sed -e 's/\.[0-9]*$//')
12%global minorver %(echo %{version} | sed -e 's/^.*\.//')
13%global htmlver %{version}
14Release: 1%{?_dist_release}
15Group: Development/Languages
16Vendor: Project Vine
17Distribution: Vine Linux
18
19License: TCL
20URL:     http://tcl.sourceforge.net/
21Source0: https://prdownloads.sourceforge.net/tcl/%{name}%{version}-src.tar.gz
22Source1: https://prdownloads.sourceforge.net/tcl/%{name}%{htmlver}-html.tar.gz
23Patch0: tcl-8.6.10-autopath.patch
24Patch1: tcl-8.6.10-conf.patch
25Patch2: tcl-8.6.10-hidden.patch
26Patch3: tcl-8.6.10-tcltests-path-fix.patch
27
28Buildroot: %{_tmppath}/%{name}-%{version}-root
29Buildrequires: autoconf
30BuildRequires: zlib-devel
31%if %sdt
32BuildRequires: systemtap-sdt-devel
33%endif
34
35%description
36Tcl is a simple scripting language designed to be embedded into
37other applications.  Tcl is designed to be used with Tk, a widget
38set, which is provided in the tk package.  This package also includes
39tclsh, a simple example of a Tcl application.
40
41%description -l ja
42Tcl は様々なアプリケーションの実行を行うための、簡単なスクリプ
43ト言語です。Tclはウィジッド・セットであるTkとともに用いるように
44デザインしています。このパッケージにはTclの簡単な例として、tclsh
45も含んでいます。
46
47%package devel
48Summary: Tcl scripting language development environment
49Summary(ja): Tcl スクリプト言語の開発環境
50Group: Development/Libraries
51Requires: %{name} = %{version}-%{release}
52
53%description devel
54Tcl is a simple scripting language designed to be embedded into
55other applications.  Tcl is designed to be used with Tk, a widget
56set, which is provided in the tk package.  This package also includes
57tclsh, a simple example of a Tcl application.
58
59The package contains the development files and man pages for tcl.
60
61
62%package itcl
63Summary: Object oriented extensions to Tcl and Tk
64Summary(ja): Tcl/Tk のオブジェクト指向拡張
65Group: Development/Libraries
66Requires: %{name} = %{version}-%{release}
67Provides: itcl = %{itcl_version}
68Obsoletes: itcl < 4.0.0
69
70%description itcl
71[incr Tcl] is Tcl extension that provides object-oriented features that are
72missing from the Tcl language.
73
74
75%package itcl-devel
76Summary: Development headers and libraries for linking against tcl-itcl
77Summary(ja): tcl-itclとリンクするためのヘッダ・ライブラリ
78Group: Development/Libraries
79Requires: %{name}-itcl = %{version}-%{release}
80Provides: itcl-devel = %{itcl_version}
81Obsoletes: itcl-devel < 4.0.0
82
83%description itcl-devel
84Development headers and libraries for linking against itcl.
85
86
87%package tdbc
88Summary: database extensions to Tcl and Tk
89Summary(ja): Tcl/Tk のデータベース拡張
90Group: Development/Libraries
91Requires: %{name} = %{version}-%{release}
92Provides: tdbc = %{tdbc_version}
93
94%description tdbc
95tdbc is Tcl extension that provides database features to tcl/tk.
96
97
98%package tdbc-devel
99Summary: Development headers and libraries for linking against tcl-tdbc
100Summary(ja): tcl-tdbcとリンクするためのヘッダ・ライブラリ
101Group: Development/Libraries
102Requires: %{name}-tdbc = %{version}-%{release}
103Requires: sqlite3-tcl
104Provides: tdbc-devel = %{tdbc_version}
105
106%description tdbc-devel
107Development headers and libraries for linking against tdbc.
108
109
110%package thread
111Summary: thread extensions to Tcl and Tk
112Summary(ja): Tcl/Tk のスレッド拡張
113Group: Development/Libraries
114Requires: %{name} = %{version}-%{release}
115Provides: thread = %{thread_version}
116Obsoletes: thread < 2.8.0
117
118%description thread
119 You can use this extension to gain script-level access to Tcl threading
120capabilities.
121
122
123%prep
124%setup -n %{name}%{version} -q -a 1
125mv tcl%{htmlver}/html .
126
127%patch0 -p1 -b .autopath
128%patch1 -p1 -b .conf
129%patch2 -p1 -b .hidden
130%patch3 -p1 -b .tcltests-path-fix
131
132pushd unix
133sed -i -e 's/@SHLIB_LD@/@SHLIB_LD@ -fPIC -Wl,-soname,libtcl%{majorver}.so/' Makefile.in
134popd
135
136%build
137pushd unix
138autoconf
139%configure \
140%if %sdt
141--enable-dtrace \
142%endif
143--disable-threads \
144--enable-symbols \
145--enable-shared
146
147make %{?_smp_mflags} CFLAGS="%{optflags} -fPIC" TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
148
149
150%install
151rm -rf $RPM_BUILD_ROOT
152make install -C unix INSTALL_ROOT=$RPM_BUILD_ROOT TCL_LIBRARY=%{_datadir}/%{name}%{majorver}
153
154ln -s tclsh%{majorver} $RPM_BUILD_ROOT%{_bindir}/tclsh
155
156# for linking with -lib%{name}
157ln -s lib%{name}%{majorver}.so $RPM_BUILD_ROOT%{_libdir}/lib%{name}.so
158
159mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}
160
161# postgresql and maybe other packages too need tclConfig.sh
162# paths don't look at /usr/lib for efficiency, so we symlink into tcl8.5 for now
163ln -s %{_libdir}/%{name}Config.sh $RPM_BUILD_ROOT/%{_libdir}/%{name}%{majorver}/%{name}Config.sh
164
165mkdir -p $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/{generic,unix}
166find generic unix -name "*.h" -exec cp -p '{}' $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/'{}' ';'
167pushd $RPM_BUILD_ROOT/%{_includedir}
168        for i in *.h ; do
169                [ -f $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic/$i ] && ln -sf ../../$i $RPM_BUILD_ROOT/%{_includedir}/%{name}-private/generic ;
170        done
171popd
172
173# remove buildroot traces
174sed -i -e "s|$PWD/unix|%{_libdir}|; s|$PWD|%{_includedir}/%{name}-private|" $RPM_BUILD_ROOT/%{_libdir}/%{name}Config.sh
175rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/tclAppInit.c
176rm -rf $RPM_BUILD_ROOT/%{_datadir}/%{name}%{majorver}/ldAix
177
178
179# sqlite3 extension is provided by sqlite3-tcl
180rm -rf %{buildroot}%{_libdir}/sqlite3*
181rm -f %{buildroot}%{_mandir}/mann/sqlite3*
182
183%clean
184rm -rf $RPM_BUILD_ROOT
185
186%post -p /sbin/ldconfig
187
188%postun -p /sbin/ldconfig
189
190%files
191%defattr(-,root,root,-)
192%license license.terms
193%doc README changes
194%doc html/*
195%{_bindir}/tclsh*
196%{_libdir}/libtcl%{majorver}.so
197%dir %{_libdir}/tcl%{majorver}
198%{_datadir}/%{name}8
199%{_datadir}/tcl%{majorver}
200%{_mandir}/man1/*
201%{_mandir}/mann/*
202# itcl
203%exclude %{_mandir}/mann/body.n*
204%exclude %{_mandir}/mann/class.n*
205%exclude %{_mandir}/mann/code.n*
206%exclude %{_mandir}/mann/configbody.n*
207%exclude %{_mandir}/mann/delete.n*
208%exclude %{_mandir}/mann/ensemble.n*
209%exclude %{_mandir}/mann/find.n*
210%exclude %{_mandir}/mann/is.n*
211%exclude %{_mandir}/mann/itcl*.n*
212%exclude %{_mandir}/mann/local.n*
213%exclude %{_mandir}/mann/scope.n*
214# tdbc
215%exclude %{_mandir}/mann/tdbc*
216# thread
217%exclude %{_mandir}/mann/thread.n*
218%exclude %{_mandir}/mann/tpool.n*
219%exclude %{_mandir}/mann/tsv.n*
220%exclude %{_mandir}/mann/ttrace.n*
221
222
223%files devel
224%defattr(-,root,root,-)
225%{_includedir}/*
226%{_libdir}/pkgconfig/tcl.pc
227%{_libdir}/libtcl.so
228%{_libdir}/libtclstub%{majorver}.a
229%{_libdir}/tclConfig.sh
230%{_libdir}/tclooConfig.sh
231%{_libdir}/tcl%{majorver}/tclConfig.sh
232%{_mandir}/man3/*
233
234%files itcl
235%{_libdir}/itcl*
236%exclude %{_libdir}/itcl*/itclConfig.sh
237%exclude %{_libdir}/itcl*/libitclstub*.a
238%{_mandir}/mann/body.n*
239%{_mandir}/mann/class.n*
240%{_mandir}/mann/code.n*
241%{_mandir}/mann/configbody.n*
242%{_mandir}/mann/delete.n*
243%{_mandir}/mann/ensemble.n*
244%{_mandir}/mann/find.n*
245%{_mandir}/mann/is.n*
246%{_mandir}/mann/itcl*.n*
247%{_mandir}/mann/local.n*
248%{_mandir}/mann/scope.n*
249
250%files itcl-devel
251%{_libdir}/itcl*/itclConfig.sh
252%{_libdir}/itcl*/libitclstub*.a
253%{_includedir}/itcl*.h
254
255%files tdbc
256%{_libdir}/tdbc*
257%exclude %{_libdir}/tdbc*/libtdbcstub*.a
258%exclude %{_libdir}/tdbc*/tdbcConfig.sh
259%{_bindir}/sqlite3_analyzer
260%{_libdir}/tcl8/%{majorver}/tdbc/sqlite3-*.tm
261%{_mandir}/mann/tdbc*
262
263%files tdbc-devel
264%{_libdir}/tdbc*/libtdbcstub*.a
265%{_libdir}/tdbc*/tdbcConfig.sh
266%{_includedir}/tdbc*.h
267
268%files thread
269%{_libdir}/thread*
270%{_mandir}/mann/thread.n*
271%{_mandir}/mann/tpool.n*
272%{_mandir}/mann/tsv.n*
273%{_mandir}/mann/ttrace.n*
274
275
276%changelog
277* Wed Jul 01 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.10-1
278- new upstream release.
279- replaced all patches to the newest rawhide's.
280
281* Fri Oct 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.6.9-1
282- new upstream release.
283- dropped Patch101: get same effects by sed and configure options.
284- imported Patch103.
285- added subpackages: itcl{,-devel}, tdbc{,-devel} and thread.
286
287* Mon Jan 26 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 8.5.15-3
288- split development files into devel subpackage
289
290* Wed Jan 15 2014 NAKAMURA Kenta <kenta@vinelinux.org> 8.5.15-2
291- rebuilt with the current environment
292
293* Tue Oct 01 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.5.15-1
294- update to 8.5.15
295- update Patch101 (tcl-8.5.15-conf.patch)
296- remove Patch103 (tcl-8.5.7-sigabrt.patch)
297
298* Fri Jan  4 2013 IWAI, Masaharu <iwai@alib.jp> 8.5.7-1
299- update to 8.5.7: sync Red Hat Enterprise Linux 6 tcl-8.5.7-6.el6
300- update License: TCL
301- drop obsolete patches
302 - tclm4-soname patch (Patch1)
303 - lib-perm patch (Patch2)
304 - configure patch (Patch3)
305 - no rpath patch (Patch4)
306 - init lib64 patch (Patch10)
307- add some patches from RHEL tcl-8.5.7-6.el6
308 - autopath patch (Patch100)
309 - conf patch (Patch101)
310 - hidden patch (Patch102)
311 - sigabrt patch (Patch103)
312- update build and install section: sync RHEL tcl-8.5.7-6.el6
313- add BR: systemtap-sdt-devel: default disable
314
315* Thu Apr 21 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.4.19-4
316- added imake to BR:.
317
318* Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 8.4.19-3
319- rebuilt with rpm-4.8.1-3
320
321* Tue Jun 29 2010 Shu KONNO <owa@bg.wakwak.com> 8.4.19-2
322- rebuilt with new environment
323- updated Patch3: tcl8.4.16-configure.patch
324
325* Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.19-1
326- new upstream release
327
328* Tue Sep 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 8.4.18-2
329- spec in UTF-8
330- configure with disabled threads. See:
331  https://bugzilla.redhat.com/show_bug.cgi?id=443246
332  http://groups.google.com/group/comp.lang.tcl/msg/ce6a1324bada8db0
333
334* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 8.4.18-1
335- rebuild with new environment
336
337* Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 8.4.18-0vl1
338- updated tcl to 8.4.18
339- updated tcl-html to 8.4.18
340
341* Mon Oct 08 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.16-0vl1
342- updated tcl to 8.4.16
343- updated tcl-html to 8.4.16
344- dropt Patch3: tcl8.3.5-tclConfig-package-path-90160.patch
345- added Patch3: tcl8.4.16-configure.patch
346
347* Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 8.4.15-0vl1
348- updated tcl to 8.4.15
349- updated tcl-html to 8.4.15
350- dropt Patch1: tcl-8.3.5-tclm4-soname.patch
351- added Patch10: tcl-8.4.15-init.lib64.patch
352- rebuilt with new toolchain
353
354* Wed May 10 2006 IWAI, Masaharu <iwai@alib.jp> 8.4.13-0vl1
355- updated tcl to 8.4.13
356- updated tcl-html to 8.4.13
357
358* Sat Jan 28 2006 Shu KONNO <owa@bg.wakwak.com> 8.4.12-0vl1
359- updated tcl to 8.4.12
360- updated patch4
361
362* Sat Aug 13 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 8.4.11-0vl1
363- updated tcl to 8.4.11
364- updated Patch4
365
366* Thu Jun 24 2004 Shu KONNO <owa@bg.wakwak.com> 8.4.6-0vl1
367- updated tcl to 8.4.6
368
369* Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.5-3vl2
370- merged with fedora
371  * Mon Dec  1 2003 Thomas Woerner <twoerner@redhat.com> 8.4.5-3
372  - removed rpath (patch 4)
373
374  * Fri Nov 28 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-2
375  - put private header files under generic and unix subdirs
376  - include real generic/tclPort.h not just a symlink to tclUnixPort.h
377  - add tclMath.h to %{_includedir}/tcl-private/generic for building tk
378
379  * Thu Nov 27 2003 Jens Petersen <petersen@redhat.com> - 8.4.5-1
380  - new package split out from tcltk
381  - update to tcl 8.4.5 (#88429)
382    - drop tcl-8.3.3-heiierarchy.patch, tcl-8.3.3-dlopen.patch
383      and tcl8.3.5-koi8-u.enc-88806.patch
384  - include private include headers under %{_includedir}/tcl-private
385  - filtered changelog for tcl
386  - buildrequire autoconf213 (#110583) [mvd@mylinux.com.ua]
387
388* Sat Mar 29 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
389- update based on BitWalk's tcltk-8.4.2-83bw
390
391* Thu Nov 15 2001 Kazuhisa TAKEI <takei@linux.or.jp>
392- split source package.
393
394* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
395- expand some macros.. (FIXME)
396
397* Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
398- use %configure macros
399- add Patch 47,50
400
401* Thu May 31 2001 <sagami@vinelinux.org>
402- 8.0.5_jp-10
403- unexpand old %%{configure}, new one causes build failure
404- fixed missing libtkx.so libtclx.so symlink in /usr/lib
405- install manpages into %%{_mandir} and mode 644
406
407* Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
408- 8.0.5_jp-9
409- modified %install section to handle compressed man pages
410- fixed /usr/lib/tk8.0jp/demos.jp/images symlink
411
412* Sun Jul  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
413- changed default fonts
414
415* Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
416- added defattr
417
418* Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
419- added some symlinks, such as libtcl8.0.so.
420- obsoletes version number using _jp, now 8.0.5-31vl1
421
422* Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
423- Apply Tcl/Tk 8.0 Japanese Patch 1.7
424
425* Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
426- fix tclX symlinks.
427- compile on systems where SIGPWR == SIGLOST.
428
429* Sat May  1 1999 Jeff Johnson <jbj@redhat.com>
430- update tcl/tk to 8.0.5.
431- avoid "containing" in Tix (#2332).
432
433* Thu Apr  8 1999 Jeff Johnson <jbj@redhat.com>
434- use /usr/bin/write in kibitz (#1320).
435- use cirrus.sprl.umich.edu in weather (#1926).
436
437* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
438- auto rebuild in the new build environment (release 28)
439
440* Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
441- whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
442
443* Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
444- expect does unaligned access on alpha (#989)
445- upgrade tcl/tk/tclX to 8.0.4
446- upgrade expect to 5.28.
447- add itcl 3.0.1
448
449* Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
450- call libtoolize to allow building on the arm
451- build for glibc 2.1
452- strip binaries
453
454* Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
455- update tcl/tk/tclX to 8.0.3, expect is updated also.
456
457* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
458- expect: mkpasswd needs delay before sending password (problem #576)
459
460* Thu May 07 1998 Prospector System <bugs@redhat.com>
461- translations modified for de, fr, tr
462
463* Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
464- fixed expect binaries exec permissions
465
466* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
467- updated to Tix 4.1.0.006
468- updated version numbers of tcl/tk to relflect includsion of p2
469
470* Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
471- updated tcl/tk to patch level 2
472- updated tclX to 8.0.2
473
474* Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
475- fixed filelist for tix... replacing path to the expect binary in scripts
476  was leaving junk files around.
477
478* Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
479- added patch to remove libieee test in configure.in for tcl and tk.
480  Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
481  solution for all systems
482- fixed src urls
483
484* Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
485- removed version numbers from descriptions
486
487* Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
488- updated to tcl/tk 8.0 and related versions of packages
489
490* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
491- built against glibc
492- fixed dangling tclx/tkx symlinks
Note: See TracBrowser for help on using the repository browser.