source: projects/specs/trunk/s/system-config-printer/system-config-printer-vl.spec @ 3251

Revision 3251, 31.5 KB checked in by daisuke, 13 years ago (diff)

system-config-printer:

  • new upstream release
    • system-config-printer-1.3.2
    • pycups-1.9.55
    • pysmbc-1.0.10
  • drop old patches (1,2,10)
  • add Patch2,3 from fedora
    • Patch2: Improvements for check-device-ids from upstream.
    • Patch3: Fixed traceback in newprinter.py (bug #680683).
  • update ja.po
  • Patch21: add more ppd translation dictionary
  • add BR: epydoc


Line 
1%define pycups_version 1.9.55
2%define pysmbc_version 1.0.10
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.3.2
11Release: 1%{?_dist_release}
12License: GPLv2+
13URL: http://cyberelk.net/tim/software/system-config-printer/
14Group: System Environment/Base
15
16Source0: http://cyberelk.net/tim/data/system-config-printer/1.3/system-config-printer-%{version}.tar.xz
17Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
18Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
19
20Source10: %{name}-1.3.2-ja.po
21
22#Patch1: system-config-printer-no-applet-in-gnome.patch
23Patch2: system-config-printer-check-device-ids.patch
24Patch3: system-config-printer-self.printers.patch
25
26Patch20: %{name}-1.3.2-gettext.patch
27Patch21: %{name}-1.3.2-ppd-translation.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31BuildRequires: cups-devel >= 1.2
32BuildRequires: python-devel >= 2.5
33BuildRequires: libsmbclient-devel >= 3.2
34BuildRequires: desktop-file-utils >= 0.2.92
35BuildRequires: gettext
36BuildRequires: intltool
37BuildRequires: xmlto
38BuildRequires: python-tools
39BuildRequires: libusb-devel, libudev-devel
40BuildRequires: epydoc
41
42Requires: pygtk2
43Requires: pygobject
44Requires: desktop-file-utils
45Requires: dbus-x11
46Requires: system-config-printer-libs = %{version}-%{release}
47Requires: gnome-icon-theme
48Requires: gnome-python
49Requires: gnome-python-gnomekeyring
50Requires: notification-daemon
51Requires: notify-python
52Requires: libxml2-python
53
54Obsoletes: system-config-printer-gui <= 0.6.152
55Provides: system-config-printer-gui = 0.6.152
56
57Obsoletes: desktop-printing <= 0.20-7.fc7
58Provides: desktop-printing = 0.20-7.fc7
59
60%description
61system-config-printer is a graphical user interface that allows
62the user to configure a CUPS print server.
63
64%package libs
65Summary: Libraries and shared code for printer administration tool
66Summary(ja): Libraries and shared code for printer administration tool
67Group: System Environment/Base
68Requires: python
69Requires: foomatic
70Provides: pycups = %{pycups_version}
71Provides: pysmbc = %{pysmbc_version}
72
73%description libs
74The common code used by both the graphical and non-graphical parts of
75the configuration tool.
76
77%package udev
78Summary: Rules for udev for automatic configuration of USB printers
79Group: System Environment/Base
80Requires: system-config-printer-libs = %{version}-%{release}
81Obsoletes: hal-cups-utils <= 0.6.20
82Provides: hal-cups-utils = 0.6.20
83
84%description udev
85The udev rules and helper programs for automatically configuring USB
86printers.
87
88%prep
89%setup -q -a 1 -a 2
90
91# Don't start the applet in GNOME.
92#%patch1 -p1 -b .no-applet-in-gnome
93
94# Improvements for check-device-ids from upstream.
95%patch2 -p1 -b .check-device-ids
96
97# Fixed traceback in newprinter.py (bug #680683).
98%patch3 -p1 -b .self.printers
99
100%patch20 -p1 -b .gettext
101%patch21 -p1 -b .ppd-translation
102
103cp -f %{SOURCE10} po/ja.po
104
105%build
106%configure --with-udev-rules
107
108pushd pycups-%{pycups_version}
109make
110make doc
111popd
112
113pushd pysmbc-%{pysmbc_version}
114make
115make doc
116popd
117
118%install
119rm -rf %buildroot
120make DESTDIR=%buildroot install \
121     udevrulesdir=/lib/udev/rules.d \
122     udevhelperdir=/lib/udev
123
124pushd pycups-%{pycups_version}
125make DESTDIR=%buildroot install
126popd
127
128pushd pysmbc-%{pysmbc_version}
129make DESTDIR=%buildroot install
130popd
131
132%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
133touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
134
135%find_lang system-config-printer
136
137%clean
138rm -rf %buildroot
139
140%post
141/bin/rm -f /var/cache/foomatic/foomatic.pickle
142exit 0
143
144%files libs -f system-config-printer.lang
145%defattr(-,root,root,-)
146%doc --parents pycups-%{pycups_version}/{ChangeLog,README,NEWS,TODO,examples,html}
147%doc --parents pysmbc-%{pysmbc_version}/{ChangeLog,README,NEWS,TODO,test.py,html}
148%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
149%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
150%dir %{_sysconfdir}/cupshelpers
151%config(noreplace) %{_sysconfdir}/cupshelpers/preferreddrivers.xml
152%{python_sitearch}/cups.so
153%{python_sitearch}/smbc.so
154%{python_sitearch}/*.egg-info
155%dir %{python_sitelib}/cupshelpers
156%{python_sitelib}/cupshelpers/*.py*
157%{python_sitelib}/*.egg-info
158%{_rpmconfigdir}/fileattrs/psdriver.attr
159%{_rpmconfigdir}/postscriptdriver.prov
160
161%files udev
162%defattr(-,root,root,-)
163/lib/udev/rules.d/*.rules
164/lib/udev/udev-*-printer
165%dir %{_localstatedir}/run/udev-configure-printer
166%verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
167
168%files
169%defattr(-,root,root,-)
170%doc ChangeLog README
171%{_bindir}/%{name}
172%{_bindir}/%{name}-applet
173%{_bindir}/scp-dbus-service
174%{_datadir}/dbus-1/interfaces/*.xml
175%{_datadir}/dbus-1/services/*.service
176%dir %{_datadir}/%{name}
177%{_datadir}/%{name}/*.py*
178%{_datadir}/%{name}/troubleshoot
179%{_datadir}/%{name}/icons
180%dir %{_datadir}/%{name}/xml
181%{_datadir}/%{name}/xml/*.rng
182%{_datadir}/%{name}/xml/*.py*
183%dir %{_datadir}/%{name}/ui
184%{_datadir}/%{name}/ui/*.glade
185%{_datadir}/applications/system-config-printer.desktop
186%{_sysconfdir}/xdg/autostart/print-applet.desktop
187%{_mandir}/man1/*
188
189%changelog
190* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-1
191- new upstream release
192  - system-config-printer-1.3.2
193  - pycups-1.9.55
194  - pysmbc-1.0.10
195- drop old patches (1,2,10)
196- add Patch2,3 from fedora
197  - Patch2: Improvements for check-device-ids from upstream.
198  - Patch3: Fixed traceback in newprinter.py (bug #680683).
199- update ja.po
200- Patch21: add more ppd translation dictionary
201- add BR: epydoc
202
203* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
204- new development release (pre1.2)
205  - system-config-printer-1.1.92
206  - pycups-1.9.48
207- add Patch1,2 from fedora
208  - Patch1: build without epydoc, remove BR: epydoc
209  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
210    to work around bug #566217.
211- add BR: python-tools, libudev-devel, libusb-devel
212- add R: libxml2-python
213
214* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
215- rebuilt with python-2.6.4
216
217* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
218- new upstream release
219  - Updated translations.
220  - Don't abort if the jobviewer couldn't show a notification.
221  - Don't use setlocale() for locale-independent case conversion.
222  - Don't assume the notification daemon can show action buttons.
223  - Use case-insensitive matching for model names.
224  - HPLIP compatibility fixes.
225  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
226  - Added support for https device URIs (bug #478677).
227  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
228- add Patch10: fix infinite loop on adding printer
229- add Patch11: do not probe hplip
230
231* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
232- new upstream release
233  - system-config-printer 1.1.6
234  - pycups 1.9.45
235
236* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
237- initial build for Vine Linux
238
239* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
240- Updated to 1.0.9 for translations.
241- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
242
243* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
244- Added patch for pysmbc changes in git to prevent getdents crashing
245  (bug #465975).
246
247* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
248- Updated patch for 1.0.x changes:
249  - Fixed SMB authentication dialog's cancel button (bug #467127).
250  - Work around samba bug #5805 by sending debug output to stderr
251    instead of stdout.
252
253* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
254- Updated patch for 1.0.x changes:
255  - Fixed SMB authentication (bug #464003).
256
257* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
258- Updated patch for 1.0.x changes:
259  - Removed unneeded debugging output.
260  - Don't show the applet in KDE (bug #466945).
261  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
262
263* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
264- Added patch for 1.0.x changes since 1.0.8:
265  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
266  - Don't use a separator for the server settings dialog (bug
267    #465407).
268  - Don't set non-zero page size for SpinButtons.
269  - Don't show an error dialog if an IPP operation's authentication
270    dialog is cancelled by the user, but show an error dialog if the
271    password was incorrect (bug #465407).
272  - Set Server Settings... menu entry sensitive depending on whether
273    we are connected to a server (Ubuntu #280736).
274  - Lots of translations updated.
275
276* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
277- Removed patch (no longer needed).
278
279* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
280- 1.0.8:
281  - Use modelName from custom PPD to suggest name for new printer
282    (trac #97).
283  - Avoid display problem with installable options.
284  - Better matching for Lexmark printers.
285  - Catch exceptions from advanced server settings dialog (Ubuntu
286    #267557).
287  - Added some missing OpenPrinting query fields.
288  - Jockey support added.
289  - Lots of translations updated.
290
291* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
292- Handle IPP_FORBIDDEN (bug #460670).
293
294* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
295- 1.0.7:
296  - Efficiency improvements.
297  - Small UI improvements for the New Printer dialog.
298  - Other small fixes.
299
300* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
301- Updated pysmbc to 1.0.5.
302- Updated pycups to 1.9.42.
303
304* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
305- Requires gnome-python2-gnome (bug #460021).
306- 1.0.6:
307  - More delete-event fixes.
308  - Fixed temporary file leak.
309  - Fixed dialog leaks.
310  - Small UI improvements for the New Printer dialog.
311  - Other small fixes.
312
313* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
314- Include other fixes from upstream including:
315  - OpenPrinting API change (trac #74).
316  - libnotify API change for 'closed' signal.
317  - Notification for job authentication (trac #91).
318  - Glade delete-event fixes (trac #88).
319  - Pre-fill username in job authentication dialog (trac #87).
320
321* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
322- Handle HTTP_FORBIDDEN.
323
324* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
325- 1.0.5.
326- Updated pycups to 1.9.41.
327
328* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
329- 1.0.4.
330- Applied upstream patch for pycups to fix getPrinterAttributes when
331  requested_attributes is specified.
332
333* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
334- Better debugging for pysmbc.
335
336* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
337- Updated pycups to 1.9.40.
338- 1.0.3.
339
340* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
341- Updated pysmbc to 1.0.4.
342
343* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
344- 1.0.2.
345
346* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
347- Updated pysmbc to 1.0.3.
348- 1.0.1 (bug #450119).
349
350* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
351- Requires notify-python (bug #450139).
352
353* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
354- Applied patches from upstream (bug #450120).
355
356* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
357- Applied patches from upstream (bug #449753).
358
359* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
360- Updated pycups to 1.9.39.
361- Updated libs summary.
362
363* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
364- 1.0.0.
365
366* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
367- Fixed small UI problem in SMB browser.
368
369* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
370- 0.9.93.
371
372* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
373- 0.9.92.
374
375* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
376- Sync to trunk.
377- Updated pysmbc to 1.0.2.
378
379* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
380- Fixed icon search path.
381
382* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
383- No longer requires system-install-packages (bug #444645).
384- Added pysmbc.  Build requires libsmbclient-devel.
385- Don't install consolehelper bits any more as they are no longer needed.
386- 0.9.91:
387  - User interface overhaul, part 2.
388
389* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
390- Updated pycups to 1.9.38.
391- 0.9.90:
392  - User interface overhaul, part 1.
393
394* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
395- 0.7.82.2:
396  - Various bug fixes.
397  - Translation updates.
398
399* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
400- Updated pycups to 1.9.37.
401- More fixes from upstream.
402
403* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
404- Updated pycups to 1.9.36.
405- Some fixes from upstream.
406
407* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
408- Requires /usr/bin/system-install-packages not pirut (bug #435622).
409- 0.7.82.1:
410  - More trouble-shooting improvements.
411  - applet: notify user about failed jobs (bug #168370).
412
413* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
414- Updated to pycups-1.9.35.
415- 0.7.82:
416  - More trouble-shooting improvements.
417
418* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
419- 0.7.81:
420  - Trouble-shooting improvements and other minor fixes.
421
422* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
423- Rebuild for GCC 4.3.
424
425* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
426- Updated to pycups-1.9.34.
427- 0.7.80:
428  - Trouble-shooting support.
429
430* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
431- 0.7.79.
432
433* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
434- Updated to pycups-1.9.33.
435
436* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
437- Use config-util from new usermode (bug #428406).
438
439* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
440- Requires notification-daemon (Ubuntu #176929).
441- Requires gnome-python2 for theme support (Ubuntu #176929).
442- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
443
444* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
445- Install Python egg-info file.
446- Updated pycups to 1.9.32.
447
448* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
449- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
450- Sync to SVN 1748.
451
452* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
453- pycups: Fix job-sheets-default attribute.
454- Updated pycups to 1.9.31.
455- 0.7.78.
456
457* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
458- Applied patch to pycups to avoid reading uninitialised
459  memory (bug #390431).
460
461* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
462- Updated pycups to 1.9.30.
463
464* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
465- 0.7.77:
466  - Tooltips for the button bar buttons (bug #335601).
467
468* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
469- 0.7.76.
470
471* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
472- 0.7.75.
473
474* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
475- No need to run update-desktop-database because there are no MimeKey
476  lines in the desktop files.
477- Consistent macro style.
478
479* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
480- Changed PreReq to Requires.
481- Mark console.apps file as a config file.
482- Mark pam file as a config file (not replaceable).
483- No need to ship empty NEWS file.
484- Give cupsd.py executable permissions to satisfy rpmlint.
485- Provides system-config-printer-gui.
486- Mark D-Bus configuration file as a config file.
487- Fixed libs summary.
488- Better buildroot tag.
489- Better defattr.
490- Preserve timestamps on explicitly install files.
491- Make example pycups program non-executable.
492- 0.7.74.4:
493  - Updated translations.
494  - Several small bugs fixed.
495
496* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
497- 0.7.74.3:
498  - Updated translations.
499  - Other small bug fixes.
500
501* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
502- Pull in SVN patch from stable branch for foomatic recommended
503  drivers (bug #292021).
504
505* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
506- Pull in SVN patch from stable branch for 'Allow printing from
507  the Internet' check-box (bug #221003).
508
509* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
510- Updated pycups to 1.9.27.
511- 0.7.74.2:
512  - When a class is removed on the server, remove it from the UI.
513  - When deleting a printer, select the default printer again.
514  - Select newly-copied printer.
515  - Updated translation (fi).
516  - Better --help message.
517  - Use strcoll to sort manufacturer names.
518  - Avoid duplicate 'recommended' marks.
519  - Remove duplicate device URIs.
520  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
521
522* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
523- Updated pycups to 1.9.26.
524- Build requires epydoc.  Ship HTML documentation.
525
526* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
527- 0.7.74.1:
528  - Updated Polish translation (bug #263001).
529  - Don't select the default printer after changes to another printer have
530    been made.
531  - Always construct URI from input fields when changing device (bug #281551).
532  - Avoid busy-cursor traceback when window is not yet displayed.
533
534* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
535- Updated pycups to 1.9.25.
536- 0.7.74:
537  - Fixed New Class dialog.
538  - UI fixes.
539
540* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
541- More specific license tag.
542
543* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
544- 0.7.73.
545
546* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
547- Ship the applet's desktop file.
548
549* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
550- 0.7.72:
551  - Fixed my-default-printer traceback.
552  - Improvements to New Printer wizard (Till Kamppeter).
553
554* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
555- 0.7.71:
556  - Don't discard make/model-matched devices when there are ID-matched
557    devices (Till Kamppeter).
558  - Fixed fallback if no text-only driver is available (Till Kamppeter).
559  - Initialise the make/model list when an ID match failed (Till Kamppeter).
560  - Better error-handling in default-print application (Ubuntu #129901).
561  - UI tweak in admin tool (Ubuntu #128263).
562  - Handle socket: URIs (Ubuntu #127074).
563
564* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
565- Obsoletes/provides desktop-printing.
566
567* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
568- Requires pirut for system-install-packages.
569- 0.7.70:
570  - Increased GetReady->NewPrinter timeout.
571  - More binary names mapped to package named.
572  - Run system-install-packages to install missing drivers (bug #246726).
573  - Less debug output.
574  - Desktop file fixes for KDE (bug #247299).
575
576* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
577- No longer requires PyXML (bug #233146).
578- Moved applet to main package.
579- 0.7.69:
580  - Use HardwareSettings category for my-default-printer desktop
581    file (bug #244935).
582  - Removed unused code.
583  - Filter PPDs by natural language (bug #244173).
584
585* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
586- The applet requires dbus-x11 (Ubuntu #119570).
587
588* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
589- 0.7.68:
590  - Fixed the notification bubbles.
591  - Ship my-default-printer utility.
592
593* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
594- Don't put TrayIcon or SystemSetup categories in the desktop file.
595- Updated pycups to 1.9.24.
596- 0.7.67:
597  - Fixed desktop files to have capital letters at the start of each
598    word in the Name field (bug #242859).
599  - Fixed crash when saving unapplied changes.
600  - Fixed Device ID parser to always split the CMD field at commas.
601  - New PPDs class means we no longer parse the foomatic XML database.
602
603* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
604- 0.7.66:
605  - Allow job-hold-until to be set (bug #239776).
606  - Implement new printer notifications.
607
608* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
609- Build requires xmlto.
610- Updated to pycups-1.9.22.
611- 0.7.65:
612  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
613  - Added kn translation.
614  - Better permissions on non-scripts.
615  - Added man pages.
616  - Applet: status feedback.
617  - Applet: fixed relative time descriptions.
618  - Applet: limit refresh frequency.
619
620* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
621- 0.7.63.1:
622  - Small applet fixes.
623
624* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
625- 0.7.63:
626  - Translation updates.
627  - Checked in missing file.
628
629* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
630- Updated to pycups-1.9.20 for printer-state-reasons fix.
631
632* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
633- 0.7.62:
634  - Use standard icon for admin tool desktop file.
635  - Fixed env path in Python scripts.
636  - Applet: stop running when the session ends.
637  - Prevent a traceback in the SMB browser (bug #225351).
638  - 'Manage print jobs' desktop file.
639
640* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
641- 0.7.61:
642  - Fixed retrieval of SMB authentication details (bug #203539).
643
644* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
645- Updated to pycups-1.9.19.
646- Avoid %%makeinstall.
647- 0.7.60:
648  - Handle reconnection failure.
649  - New applet name.
650
651* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
652- 0.7.59:
653  - Fixed a translatable string.
654  - Set a window icon (bug #233899).
655  - Handle failure to start the D-Bus service.
656  - Ellipsize the document and printer named (bug #233899).
657  - Removed the status bar (bug #233899).
658  - Added an icon pop-up menu for 'Hide' (bug #233899).
659
660* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
661- Added URL tag.
662- 0.7.57:
663  - Prevent traceback when removing temporary file (Ubuntu #92914).
664  - Added print applet.
665
666* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
667- Updated to pycups-1.9.18.
668
669* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
670- 0.7.56:
671  - Parse Boolean strings correctly in job options.
672  - Small command-set list/string fix (bug #230665).
673  - Handle hostname look-up failures.
674  - Updated filter-to-driver map.
675  - Don't parse printers.conf (bug #231826).
676
677* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
678- 0.7.55:
679  - Use converted value for job option widgets.
680
681* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
682- 0.7.54:
683  - Removed debugging code.
684
685* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
686- No longer requires rhpl (since 0.7.53).
687- 0.7.53:
688  - Use gettext instead of rhpl.translate.
689  - Better layout for PPD options.
690  - Added scrollbars to main printer list (bug #229453).
691  - Set maximum width of default printer label (bug #229453).
692  - Handle applying changes correctly when switching to another
693    printer (bug #229378).
694  - Don't crash when failing to fetch the PPD (bug #229406).
695  - Make the text entry boxes sensitive but not editable for remote
696    printers (bug #229381).
697  - Better job options screen layout (bug #222272).
698
699* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
700- 0.7.52:
701  - Sort models using cups.modelSort before scanning for a close
702    match (bug #228505).
703  - Fixed matching logic (bug #228505).
704
705* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
706- 0.7.51:
707  - Prevent display glitch in job options list when clicking on a printer
708    repeatedly.
709  - List conflicting PPD options, and embolden the relevant tab
710    labels (bug #226368).
711  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
712  - Handle interactive search a little better (bug #227935).
713
714* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
715- 0.7.50:
716  - Fixed hex digits list (bug #223770).
717  - Added bs translation.
718  - Don't put the ellipsis in the real device URI (bug #227643).
719  - Don't check for existing drivers for complex command lines (bug #225104).
720  - Allow floating point job options (bug #224651).
721  - Prevent shared/published confusion (bug #225081).
722  - Fixed PPD page size setting.
723  - Avoid os.remove exception (bug #226703).
724  - Handle unknown job options (bug #225538).
725
726* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
727- 0.7.49:
728  - Fixed a traceback in the driver check code.
729  - Fixed a typo in the conflicts message.
730  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
731
732* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
733- 0.7.48:
734  - Updated translations.
735
736* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
737- 0.7.47:
738  - Fixed minor text bugs (bug #177433).
739  - Handle shell builtins in the driver check (bug #222413).
740
741* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
742- 0.7.46:
743  - Fixed page size problem (bug #221702).
744  - Added 'ro' to ALL_LINGUAS.
745
746* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
747- Updated to pycups-1.9.17.
748- 0.7.45:
749  - Fixed traceback in driver check.
750
751* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
752- 0.7.44:
753  - Fixed traceback in error display (bug #220136).
754  - Preserve case in model string when dumping debug output.
755
756* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
757- 0.7.43:
758  - Don't check against IEEE 1284 DES field at all.
759  - Merged device matching code (bug #219518).
760  - Catch non-fatal errors when auto-matching device.
761  - Fixed driver checking bug involving pipelines (bug #220347).
762  - Show PPD errors (bug #220136).
763
764* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
765- 0.7.42:
766  - Fixed typo in command set matching code.
767  - Case-insensitive matching when Device ID not known to database.
768
769* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
770- build against python 2.5
771
772* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
773- Updated pycups to 1.9.16.
774- 0.7.41:
775  - Reconnect smoothly after uploading new configuration.
776  - Update lpoptions when setting default printer if it conflicts with
777    the new setting (bug #217395).
778  - Fixed typo in show_HTTP_Error (bug #217537).
779  - Don't pre-select make and model when not discoverable for chosen
780    device (bug #217518).
781  - Set Forward button sensitive on Device screen in new-printer
782    dialog (bug #217515).
783  - Keep Server Settings selected after applying changes if it was selected
784    before.
785  - Set Connecting dialog transient for main window.
786  - Center Connecting dialog on parent.
787  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
788  - Describe devices that have no optional parameters.
789
790* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
791- Provide pycups feature.
792
793* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
794- 0.7.40:
795  - Removed username:password from hint string because we add that in
796    afterwards.
797  - Don't set button widths in create-printer dialog (bug #217025).
798
799* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
800- 0.7.39:
801  - Busy cursor while loading foomatic and PPD list (bug #215527).
802  - Make PPD NickName selectable.
803  - Added SMB hint label on device screen (bug #212759).
804
805* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
806- Updated pycups to 1.9.15.
807- 0.7.38:
808  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
809
810* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
811- 0.7.37:
812  - Allow cancellation of test pages (bug #215054).
813
814* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
815- 0.7.36:
816  - Match against commandset (bug #214181).
817  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
818  - Don't remove foomatic PPDs from the list (bug #197331).
819
820* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
821- 0.7.35.
822
823* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
824- Updated to pycups-1.9.14 (bug #213136).
825
826* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
827- Update desktop database (bug #213249).
828
829* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
830- Build requires Python 2.4.
831
832* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
833- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
834- 0.7.32:
835  - Handle HTTP errors during connection (bug #208824).
836  - Updated translations (bug #208873).
837
838* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
839- 0.7.31:
840  - Select recommended driver automatically (bug #208606).
841  - Better visibility of driver list (bug #203907).
842
843* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
844- 0.7.30:
845  - Translations fixed properly (bug #206622).
846  - Button widths corrected (bug #208556).
847
848* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
849- 0.7.28.  Translations fixed (bug #206622).
850
851* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
852- Build requires intltool.
853- 0.7.27.
854
855* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
856- 0.7.26.  Fixes bug # 203149.
857
858* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
859- 0.7.25. (bug #202060)
860
861* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
862- Fixed description (bug #202189).
863
864* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
865- 0.7.24.
866
867* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
868- 0.7.23.  Fixes bug #197866.
869
870* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
871- rebuild
872
873* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
874- 0.7.22.
875
876* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
877- Updated to pycups-1.9.12.
878- 0.7.21.
879
880* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
881- 0.7.20.
882
883* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
884- 0.7.19.
885- Remove foomatic pickle file post-install.
886
887* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
888- 0.7.18.
889- Ship translations with libs subpackage.
890
891* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
892- 0.7.17.
893
894* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
895- 0.7.16, now with SMB browser.
896
897* Wed Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
898- 0.7.15.
899- Build requires gettext-devel.
900- Ship translations.
901
902* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
903- 0.7.14.
904
905* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
906- 0.7.13.
907
908* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
909- 0.7.12.
910
911* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
912- Fix libs dependency.
913
914* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
915- Moved the gtk_html2pango module to the libs package (needed by
916  foomatic.py).
917
918* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
919- Split out system-config-printer-libs.
920- Updated to system-config-printer-0.7.11.
921
922* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
923- Requires gobject2 (bug #192764).
924
925* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
926- Require foomatic (bug #192764).
927- Updated to system-config-printer-0.7.10.
928
929* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
930- Updated to pycups-1.9.11.
931- Updated to system-config-printer-0.7.9.
932
933* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
934- Updated to pycups-1.9.10.
935- Updated to system-config-printer-0.7.8.
936
937* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
938- Fix pycups segfault.
939
940* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
941- Ship PAM and userhelper files.
942- Requires usermode.
943- Added missing options.py file.
944- Fix getClasses() in pycups.
945
946* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
947- Updated to system-config-printer-0.7.7.
948- Updated to pycups-1.9.9.
949- Desktop file.
950- Requires PyXML.
951
952* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
953- Make it actually run.
954
955* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
956- Build requires CUPS 1.2.
957
958* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
959- Updated to pycups-1.9.8.  No longer need threads patch.
960- Updated to system-config-printer-0.7.5.
961
962* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
963- Updated to pycups-1.9.7.
964
965* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
966- Obsoletes: system-config-printer-gui <= 0.6.152
967
968* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
969- Updated to system-config-printer-0.7.4.
970
971* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
972- Added threads patch from pycups CVS.
973- Updated to system-config-printer-0.7.3.
974
975* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
976- Updated to pycups-1.9.6.
977
978* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
979- Updated to pycups-1.9.5.
980
981* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
982- Package the actual system-config-printer command.
983
984* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
985- Include s-c-printer tarball.
986- Updated to pycups-1.9.4.
987
988* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
989- Initial spec file.
Note: See TracBrowser for help on using the repository browser.