source: projects/specs/trunk/s/system-config-printer/system-config-printer-vl.spec @ 3330

Revision 3330, 31.6 KB checked in by Takemikaduchi, 13 years ago (diff)

fix: failed to build package

Line 
1%define pycups_version 1.9.55
2%define pysmbc_version 1.0.10
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.3.2
11Release: 2%{?_dist_release}
12License: GPLv2+
13URL: http://cyberelk.net/tim/software/system-config-printer/
14Group: System Environment/Base
15
16Source0: http://cyberelk.net/tim/data/system-config-printer/1.3/system-config-printer-%{version}.tar.xz
17Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
18Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
19
20Source10: %{name}-1.3.2-ja.po
21
22#Patch1: system-config-printer-no-applet-in-gnome.patch
23Patch2: system-config-printer-check-device-ids.patch
24Patch3: system-config-printer-self.printers.patch
25
26Patch20: %{name}-1.3.2-gettext.patch
27Patch21: %{name}-1.3.2-ppd-translation.patch
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
30
31BuildRequires: cups-devel >= 1.2
32BuildRequires: glib2-devel
33BuildRequires: python-devel >= 2.5
34BuildRequires: libsmbclient-devel >= 3.2
35BuildRequires: desktop-file-utils >= 0.2.92
36BuildRequires: gettext
37BuildRequires: intltool
38BuildRequires: xmlto
39BuildRequires: python-tools
40BuildRequires: libusb-devel, libudev-devel
41BuildRequires: epydoc
42
43Requires: pygtk2
44Requires: pygobject
45Requires: desktop-file-utils
46Requires: dbus-x11
47Requires: system-config-printer-libs = %{version}-%{release}
48Requires: gnome-icon-theme
49Requires: gnome-python
50Requires: gnome-python-gnomekeyring
51Requires: notification-daemon
52Requires: notify-python
53Requires: libxml2-python
54
55Obsoletes: system-config-printer-gui <= 0.6.152
56Provides: system-config-printer-gui = 0.6.152
57
58Obsoletes: desktop-printing <= 0.20-7.fc7
59Provides: desktop-printing = 0.20-7.fc7
60
61%description
62system-config-printer is a graphical user interface that allows
63the user to configure a CUPS print server.
64
65%package libs
66Summary: Libraries and shared code for printer administration tool
67Summary(ja): Libraries and shared code for printer administration tool
68Group: System Environment/Base
69Requires: python
70Requires: foomatic
71Provides: pycups = %{pycups_version}
72Provides: pysmbc = %{pysmbc_version}
73
74%description libs
75The common code used by both the graphical and non-graphical parts of
76the configuration tool.
77
78%package udev
79Summary: Rules for udev for automatic configuration of USB printers
80Group: System Environment/Base
81Requires: system-config-printer-libs = %{version}-%{release}
82Obsoletes: hal-cups-utils <= 0.6.20
83Provides: hal-cups-utils = 0.6.20
84
85%description udev
86The udev rules and helper programs for automatically configuring USB
87printers.
88
89%prep
90%setup -q -a 1 -a 2
91
92# Don't start the applet in GNOME.
93#%patch1 -p1 -b .no-applet-in-gnome
94
95# Improvements for check-device-ids from upstream.
96%patch2 -p1 -b .check-device-ids
97
98# Fixed traceback in newprinter.py (bug #680683).
99%patch3 -p1 -b .self.printers
100
101%patch20 -p1 -b .gettext
102%patch21 -p1 -b .ppd-translation
103
104cp -f %{SOURCE10} po/ja.po
105
106%build
107%configure --with-udev-rules
108
109pushd pycups-%{pycups_version}
110make
111make doc
112popd
113
114pushd pysmbc-%{pysmbc_version}
115make
116make doc
117popd
118
119%install
120rm -rf %buildroot
121make DESTDIR=%buildroot install \
122     udevrulesdir=/lib/udev/rules.d \
123     udevhelperdir=/lib/udev
124
125pushd pycups-%{pycups_version}
126make DESTDIR=%buildroot install
127popd
128
129pushd pysmbc-%{pysmbc_version}
130make DESTDIR=%buildroot install
131popd
132
133%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
134touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
135
136%find_lang system-config-printer
137
138%clean
139rm -rf %buildroot
140
141%post
142/bin/rm -f /var/cache/foomatic/foomatic.pickle
143exit 0
144
145%files libs -f system-config-printer.lang
146%defattr(-,root,root,-)
147%doc --parents pycups-%{pycups_version}/{ChangeLog,README,NEWS,TODO,examples,html}
148%doc --parents pysmbc-%{pysmbc_version}/{ChangeLog,README,NEWS,TODO,test.py,html}
149%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
150%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
151%dir %{_sysconfdir}/cupshelpers
152%config(noreplace) %{_sysconfdir}/cupshelpers/preferreddrivers.xml
153%{python_sitearch}/cups.so
154%{python_sitearch}/smbc.so
155%{python_sitearch}/*.egg-info
156%dir %{python_sitelib}/cupshelpers
157%{python_sitelib}/cupshelpers/*.py*
158%{python_sitelib}/*.egg-info
159%{_rpmconfigdir}/fileattrs/psdriver.attr
160%{_rpmconfigdir}/postscriptdriver.prov
161
162%files udev
163%defattr(-,root,root,-)
164/lib/udev/rules.d/*.rules
165/lib/udev/udev-*-printer
166%dir %{_localstatedir}/run/udev-configure-printer
167%verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
168
169%files
170%defattr(-,root,root,-)
171%doc ChangeLog README
172%{_bindir}/%{name}
173%{_bindir}/%{name}-applet
174%{_bindir}/scp-dbus-service
175%{_datadir}/dbus-1/interfaces/*.xml
176%{_datadir}/dbus-1/services/*.service
177%dir %{_datadir}/%{name}
178%{_datadir}/%{name}/*.py*
179%{_datadir}/%{name}/troubleshoot
180%{_datadir}/%{name}/icons
181%dir %{_datadir}/%{name}/xml
182%{_datadir}/%{name}/xml/*.rng
183%{_datadir}/%{name}/xml/*.py*
184%dir %{_datadir}/%{name}/ui
185%{_datadir}/%{name}/ui/*.glade
186%{_datadir}/applications/system-config-printer.desktop
187%{_sysconfdir}/xdg/autostart/print-applet.desktop
188%{_mandir}/man1/*
189
190%changelog
191* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-2
192- add BuildRequires: glib2-devel
193
194* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-1
195- new upstream release
196  - system-config-printer-1.3.2
197  - pycups-1.9.55
198  - pysmbc-1.0.10
199- drop old patches (1,2,10)
200- add Patch2,3 from fedora
201  - Patch2: Improvements for check-device-ids from upstream.
202  - Patch3: Fixed traceback in newprinter.py (bug #680683).
203- update ja.po
204- Patch21: add more ppd translation dictionary
205- add BR: epydoc
206
207* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
208- new development release (pre1.2)
209  - system-config-printer-1.1.92
210  - pycups-1.9.48
211- add Patch1,2 from fedora
212  - Patch1: build without epydoc, remove BR: epydoc
213  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
214    to work around bug #566217.
215- add BR: python-tools, libudev-devel, libusb-devel
216- add R: libxml2-python
217
218* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
219- rebuilt with python-2.6.4
220
221* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
222- new upstream release
223  - Updated translations.
224  - Don't abort if the jobviewer couldn't show a notification.
225  - Don't use setlocale() for locale-independent case conversion.
226  - Don't assume the notification daemon can show action buttons.
227  - Use case-insensitive matching for model names.
228  - HPLIP compatibility fixes.
229  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
230  - Added support for https device URIs (bug #478677).
231  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
232- add Patch10: fix infinite loop on adding printer
233- add Patch11: do not probe hplip
234
235* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
236- new upstream release
237  - system-config-printer 1.1.6
238  - pycups 1.9.45
239
240* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
241- initial build for Vine Linux
242
243* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
244- Updated to 1.0.9 for translations.
245- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
246
247* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
248- Added patch for pysmbc changes in git to prevent getdents crashing
249  (bug #465975).
250
251* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
252- Updated patch for 1.0.x changes:
253  - Fixed SMB authentication dialog's cancel button (bug #467127).
254  - Work around samba bug #5805 by sending debug output to stderr
255    instead of stdout.
256
257* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
258- Updated patch for 1.0.x changes:
259  - Fixed SMB authentication (bug #464003).
260
261* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
262- Updated patch for 1.0.x changes:
263  - Removed unneeded debugging output.
264  - Don't show the applet in KDE (bug #466945).
265  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
266
267* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
268- Added patch for 1.0.x changes since 1.0.8:
269  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
270  - Don't use a separator for the server settings dialog (bug
271    #465407).
272  - Don't set non-zero page size for SpinButtons.
273  - Don't show an error dialog if an IPP operation's authentication
274    dialog is cancelled by the user, but show an error dialog if the
275    password was incorrect (bug #465407).
276  - Set Server Settings... menu entry sensitive depending on whether
277    we are connected to a server (Ubuntu #280736).
278  - Lots of translations updated.
279
280* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
281- Removed patch (no longer needed).
282
283* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
284- 1.0.8:
285  - Use modelName from custom PPD to suggest name for new printer
286    (trac #97).
287  - Avoid display problem with installable options.
288  - Better matching for Lexmark printers.
289  - Catch exceptions from advanced server settings dialog (Ubuntu
290    #267557).
291  - Added some missing OpenPrinting query fields.
292  - Jockey support added.
293  - Lots of translations updated.
294
295* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
296- Handle IPP_FORBIDDEN (bug #460670).
297
298* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
299- 1.0.7:
300  - Efficiency improvements.
301  - Small UI improvements for the New Printer dialog.
302  - Other small fixes.
303
304* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
305- Updated pysmbc to 1.0.5.
306- Updated pycups to 1.9.42.
307
308* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
309- Requires gnome-python2-gnome (bug #460021).
310- 1.0.6:
311  - More delete-event fixes.
312  - Fixed temporary file leak.
313  - Fixed dialog leaks.
314  - Small UI improvements for the New Printer dialog.
315  - Other small fixes.
316
317* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
318- Include other fixes from upstream including:
319  - OpenPrinting API change (trac #74).
320  - libnotify API change for 'closed' signal.
321  - Notification for job authentication (trac #91).
322  - Glade delete-event fixes (trac #88).
323  - Pre-fill username in job authentication dialog (trac #87).
324
325* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
326- Handle HTTP_FORBIDDEN.
327
328* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
329- 1.0.5.
330- Updated pycups to 1.9.41.
331
332* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
333- 1.0.4.
334- Applied upstream patch for pycups to fix getPrinterAttributes when
335  requested_attributes is specified.
336
337* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
338- Better debugging for pysmbc.
339
340* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
341- Updated pycups to 1.9.40.
342- 1.0.3.
343
344* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
345- Updated pysmbc to 1.0.4.
346
347* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
348- 1.0.2.
349
350* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
351- Updated pysmbc to 1.0.3.
352- 1.0.1 (bug #450119).
353
354* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
355- Requires notify-python (bug #450139).
356
357* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
358- Applied patches from upstream (bug #450120).
359
360* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
361- Applied patches from upstream (bug #449753).
362
363* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
364- Updated pycups to 1.9.39.
365- Updated libs summary.
366
367* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
368- 1.0.0.
369
370* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
371- Fixed small UI problem in SMB browser.
372
373* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
374- 0.9.93.
375
376* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
377- 0.9.92.
378
379* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
380- Sync to trunk.
381- Updated pysmbc to 1.0.2.
382
383* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
384- Fixed icon search path.
385
386* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
387- No longer requires system-install-packages (bug #444645).
388- Added pysmbc.  Build requires libsmbclient-devel.
389- Don't install consolehelper bits any more as they are no longer needed.
390- 0.9.91:
391  - User interface overhaul, part 2.
392
393* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
394- Updated pycups to 1.9.38.
395- 0.9.90:
396  - User interface overhaul, part 1.
397
398* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
399- 0.7.82.2:
400  - Various bug fixes.
401  - Translation updates.
402
403* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
404- Updated pycups to 1.9.37.
405- More fixes from upstream.
406
407* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
408- Updated pycups to 1.9.36.
409- Some fixes from upstream.
410
411* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
412- Requires /usr/bin/system-install-packages not pirut (bug #435622).
413- 0.7.82.1:
414  - More trouble-shooting improvements.
415  - applet: notify user about failed jobs (bug #168370).
416
417* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
418- Updated to pycups-1.9.35.
419- 0.7.82:
420  - More trouble-shooting improvements.
421
422* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
423- 0.7.81:
424  - Trouble-shooting improvements and other minor fixes.
425
426* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
427- Rebuild for GCC 4.3.
428
429* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
430- Updated to pycups-1.9.34.
431- 0.7.80:
432  - Trouble-shooting support.
433
434* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
435- 0.7.79.
436
437* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
438- Updated to pycups-1.9.33.
439
440* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
441- Use config-util from new usermode (bug #428406).
442
443* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
444- Requires notification-daemon (Ubuntu #176929).
445- Requires gnome-python2 for theme support (Ubuntu #176929).
446- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
447
448* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
449- Install Python egg-info file.
450- Updated pycups to 1.9.32.
451
452* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
453- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
454- Sync to SVN 1748.
455
456* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
457- pycups: Fix job-sheets-default attribute.
458- Updated pycups to 1.9.31.
459- 0.7.78.
460
461* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
462- Applied patch to pycups to avoid reading uninitialised
463  memory (bug #390431).
464
465* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
466- Updated pycups to 1.9.30.
467
468* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
469- 0.7.77:
470  - Tooltips for the button bar buttons (bug #335601).
471
472* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
473- 0.7.76.
474
475* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
476- 0.7.75.
477
478* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
479- No need to run update-desktop-database because there are no MimeKey
480  lines in the desktop files.
481- Consistent macro style.
482
483* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
484- Changed PreReq to Requires.
485- Mark console.apps file as a config file.
486- Mark pam file as a config file (not replaceable).
487- No need to ship empty NEWS file.
488- Give cupsd.py executable permissions to satisfy rpmlint.
489- Provides system-config-printer-gui.
490- Mark D-Bus configuration file as a config file.
491- Fixed libs summary.
492- Better buildroot tag.
493- Better defattr.
494- Preserve timestamps on explicitly install files.
495- Make example pycups program non-executable.
496- 0.7.74.4:
497  - Updated translations.
498  - Several small bugs fixed.
499
500* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
501- 0.7.74.3:
502  - Updated translations.
503  - Other small bug fixes.
504
505* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
506- Pull in SVN patch from stable branch for foomatic recommended
507  drivers (bug #292021).
508
509* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
510- Pull in SVN patch from stable branch for 'Allow printing from
511  the Internet' check-box (bug #221003).
512
513* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
514- Updated pycups to 1.9.27.
515- 0.7.74.2:
516  - When a class is removed on the server, remove it from the UI.
517  - When deleting a printer, select the default printer again.
518  - Select newly-copied printer.
519  - Updated translation (fi).
520  - Better --help message.
521  - Use strcoll to sort manufacturer names.
522  - Avoid duplicate 'recommended' marks.
523  - Remove duplicate device URIs.
524  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
525
526* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
527- Updated pycups to 1.9.26.
528- Build requires epydoc.  Ship HTML documentation.
529
530* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
531- 0.7.74.1:
532  - Updated Polish translation (bug #263001).
533  - Don't select the default printer after changes to another printer have
534    been made.
535  - Always construct URI from input fields when changing device (bug #281551).
536  - Avoid busy-cursor traceback when window is not yet displayed.
537
538* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
539- Updated pycups to 1.9.25.
540- 0.7.74:
541  - Fixed New Class dialog.
542  - UI fixes.
543
544* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
545- More specific license tag.
546
547* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
548- 0.7.73.
549
550* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
551- Ship the applet's desktop file.
552
553* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
554- 0.7.72:
555  - Fixed my-default-printer traceback.
556  - Improvements to New Printer wizard (Till Kamppeter).
557
558* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
559- 0.7.71:
560  - Don't discard make/model-matched devices when there are ID-matched
561    devices (Till Kamppeter).
562  - Fixed fallback if no text-only driver is available (Till Kamppeter).
563  - Initialise the make/model list when an ID match failed (Till Kamppeter).
564  - Better error-handling in default-print application (Ubuntu #129901).
565  - UI tweak in admin tool (Ubuntu #128263).
566  - Handle socket: URIs (Ubuntu #127074).
567
568* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
569- Obsoletes/provides desktop-printing.
570
571* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
572- Requires pirut for system-install-packages.
573- 0.7.70:
574  - Increased GetReady->NewPrinter timeout.
575  - More binary names mapped to package named.
576  - Run system-install-packages to install missing drivers (bug #246726).
577  - Less debug output.
578  - Desktop file fixes for KDE (bug #247299).
579
580* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
581- No longer requires PyXML (bug #233146).
582- Moved applet to main package.
583- 0.7.69:
584  - Use HardwareSettings category for my-default-printer desktop
585    file (bug #244935).
586  - Removed unused code.
587  - Filter PPDs by natural language (bug #244173).
588
589* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
590- The applet requires dbus-x11 (Ubuntu #119570).
591
592* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
593- 0.7.68:
594  - Fixed the notification bubbles.
595  - Ship my-default-printer utility.
596
597* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
598- Don't put TrayIcon or SystemSetup categories in the desktop file.
599- Updated pycups to 1.9.24.
600- 0.7.67:
601  - Fixed desktop files to have capital letters at the start of each
602    word in the Name field (bug #242859).
603  - Fixed crash when saving unapplied changes.
604  - Fixed Device ID parser to always split the CMD field at commas.
605  - New PPDs class means we no longer parse the foomatic XML database.
606
607* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
608- 0.7.66:
609  - Allow job-hold-until to be set (bug #239776).
610  - Implement new printer notifications.
611
612* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
613- Build requires xmlto.
614- Updated to pycups-1.9.22.
615- 0.7.65:
616  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
617  - Added kn translation.
618  - Better permissions on non-scripts.
619  - Added man pages.
620  - Applet: status feedback.
621  - Applet: fixed relative time descriptions.
622  - Applet: limit refresh frequency.
623
624* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
625- 0.7.63.1:
626  - Small applet fixes.
627
628* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
629- 0.7.63:
630  - Translation updates.
631  - Checked in missing file.
632
633* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
634- Updated to pycups-1.9.20 for printer-state-reasons fix.
635
636* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
637- 0.7.62:
638  - Use standard icon for admin tool desktop file.
639  - Fixed env path in Python scripts.
640  - Applet: stop running when the session ends.
641  - Prevent a traceback in the SMB browser (bug #225351).
642  - 'Manage print jobs' desktop file.
643
644* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
645- 0.7.61:
646  - Fixed retrieval of SMB authentication details (bug #203539).
647
648* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
649- Updated to pycups-1.9.19.
650- Avoid %%makeinstall.
651- 0.7.60:
652  - Handle reconnection failure.
653  - New applet name.
654
655* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
656- 0.7.59:
657  - Fixed a translatable string.
658  - Set a window icon (bug #233899).
659  - Handle failure to start the D-Bus service.
660  - Ellipsize the document and printer named (bug #233899).
661  - Removed the status bar (bug #233899).
662  - Added an icon pop-up menu for 'Hide' (bug #233899).
663
664* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
665- Added URL tag.
666- 0.7.57:
667  - Prevent traceback when removing temporary file (Ubuntu #92914).
668  - Added print applet.
669
670* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
671- Updated to pycups-1.9.18.
672
673* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
674- 0.7.56:
675  - Parse Boolean strings correctly in job options.
676  - Small command-set list/string fix (bug #230665).
677  - Handle hostname look-up failures.
678  - Updated filter-to-driver map.
679  - Don't parse printers.conf (bug #231826).
680
681* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
682- 0.7.55:
683  - Use converted value for job option widgets.
684
685* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
686- 0.7.54:
687  - Removed debugging code.
688
689* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
690- No longer requires rhpl (since 0.7.53).
691- 0.7.53:
692  - Use gettext instead of rhpl.translate.
693  - Better layout for PPD options.
694  - Added scrollbars to main printer list (bug #229453).
695  - Set maximum width of default printer label (bug #229453).
696  - Handle applying changes correctly when switching to another
697    printer (bug #229378).
698  - Don't crash when failing to fetch the PPD (bug #229406).
699  - Make the text entry boxes sensitive but not editable for remote
700    printers (bug #229381).
701  - Better job options screen layout (bug #222272).
702
703* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
704- 0.7.52:
705  - Sort models using cups.modelSort before scanning for a close
706    match (bug #228505).
707  - Fixed matching logic (bug #228505).
708
709* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
710- 0.7.51:
711  - Prevent display glitch in job options list when clicking on a printer
712    repeatedly.
713  - List conflicting PPD options, and embolden the relevant tab
714    labels (bug #226368).
715  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
716  - Handle interactive search a little better (bug #227935).
717
718* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
719- 0.7.50:
720  - Fixed hex digits list (bug #223770).
721  - Added bs translation.
722  - Don't put the ellipsis in the real device URI (bug #227643).
723  - Don't check for existing drivers for complex command lines (bug #225104).
724  - Allow floating point job options (bug #224651).
725  - Prevent shared/published confusion (bug #225081).
726  - Fixed PPD page size setting.
727  - Avoid os.remove exception (bug #226703).
728  - Handle unknown job options (bug #225538).
729
730* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
731- 0.7.49:
732  - Fixed a traceback in the driver check code.
733  - Fixed a typo in the conflicts message.
734  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
735
736* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
737- 0.7.48:
738  - Updated translations.
739
740* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
741- 0.7.47:
742  - Fixed minor text bugs (bug #177433).
743  - Handle shell builtins in the driver check (bug #222413).
744
745* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
746- 0.7.46:
747  - Fixed page size problem (bug #221702).
748  - Added 'ro' to ALL_LINGUAS.
749
750* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
751- Updated to pycups-1.9.17.
752- 0.7.45:
753  - Fixed traceback in driver check.
754
755* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
756- 0.7.44:
757  - Fixed traceback in error display (bug #220136).
758  - Preserve case in model string when dumping debug output.
759
760* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
761- 0.7.43:
762  - Don't check against IEEE 1284 DES field at all.
763  - Merged device matching code (bug #219518).
764  - Catch non-fatal errors when auto-matching device.
765  - Fixed driver checking bug involving pipelines (bug #220347).
766  - Show PPD errors (bug #220136).
767
768* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
769- 0.7.42:
770  - Fixed typo in command set matching code.
771  - Case-insensitive matching when Device ID not known to database.
772
773* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
774- build against python 2.5
775
776* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
777- Updated pycups to 1.9.16.
778- 0.7.41:
779  - Reconnect smoothly after uploading new configuration.
780  - Update lpoptions when setting default printer if it conflicts with
781    the new setting (bug #217395).
782  - Fixed typo in show_HTTP_Error (bug #217537).
783  - Don't pre-select make and model when not discoverable for chosen
784    device (bug #217518).
785  - Set Forward button sensitive on Device screen in new-printer
786    dialog (bug #217515).
787  - Keep Server Settings selected after applying changes if it was selected
788    before.
789  - Set Connecting dialog transient for main window.
790  - Center Connecting dialog on parent.
791  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
792  - Describe devices that have no optional parameters.
793
794* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
795- Provide pycups feature.
796
797* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
798- 0.7.40:
799  - Removed username:password from hint string because we add that in
800    afterwards.
801  - Don't set button widths in create-printer dialog (bug #217025).
802
803* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
804- 0.7.39:
805  - Busy cursor while loading foomatic and PPD list (bug #215527).
806  - Make PPD NickName selectable.
807  - Added SMB hint label on device screen (bug #212759).
808
809* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
810- Updated pycups to 1.9.15.
811- 0.7.38:
812  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
813
814* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
815- 0.7.37:
816  - Allow cancellation of test pages (bug #215054).
817
818* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
819- 0.7.36:
820  - Match against commandset (bug #214181).
821  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
822  - Don't remove foomatic PPDs from the list (bug #197331).
823
824* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
825- 0.7.35.
826
827* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
828- Updated to pycups-1.9.14 (bug #213136).
829
830* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
831- Update desktop database (bug #213249).
832
833* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
834- Build requires Python 2.4.
835
836* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
837- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
838- 0.7.32:
839  - Handle HTTP errors during connection (bug #208824).
840  - Updated translations (bug #208873).
841
842* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
843- 0.7.31:
844  - Select recommended driver automatically (bug #208606).
845  - Better visibility of driver list (bug #203907).
846
847* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
848- 0.7.30:
849  - Translations fixed properly (bug #206622).
850  - Button widths corrected (bug #208556).
851
852* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
853- 0.7.28.  Translations fixed (bug #206622).
854
855* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
856- Build requires intltool.
857- 0.7.27.
858
859* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
860- 0.7.26.  Fixes bug # 203149.
861
862* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
863- 0.7.25. (bug #202060)
864
865* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
866- Fixed description (bug #202189).
867
868* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
869- 0.7.24.
870
871* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
872- 0.7.23.  Fixes bug #197866.
873
874* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
875- rebuild
876
877* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
878- 0.7.22.
879
880* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
881- Updated to pycups-1.9.12.
882- 0.7.21.
883
884* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
885- 0.7.20.
886
887* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
888- 0.7.19.
889- Remove foomatic pickle file post-install.
890
891* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
892- 0.7.18.
893- Ship translations with libs subpackage.
894
895* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
896- 0.7.17.
897
898* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
899- 0.7.16, now with SMB browser.
900
901* Wed Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
902- 0.7.15.
903- Build requires gettext-devel.
904- Ship translations.
905
906* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
907- 0.7.14.
908
909* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
910- 0.7.13.
911
912* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
913- 0.7.12.
914
915* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
916- Fix libs dependency.
917
918* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
919- Moved the gtk_html2pango module to the libs package (needed by
920  foomatic.py).
921
922* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
923- Split out system-config-printer-libs.
924- Updated to system-config-printer-0.7.11.
925
926* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
927- Requires gobject2 (bug #192764).
928
929* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
930- Require foomatic (bug #192764).
931- Updated to system-config-printer-0.7.10.
932
933* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
934- Updated to pycups-1.9.11.
935- Updated to system-config-printer-0.7.9.
936
937* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
938- Updated to pycups-1.9.10.
939- Updated to system-config-printer-0.7.8.
940
941* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
942- Fix pycups segfault.
943
944* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
945- Ship PAM and userhelper files.
946- Requires usermode.
947- Added missing options.py file.
948- Fix getClasses() in pycups.
949
950* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
951- Updated to system-config-printer-0.7.7.
952- Updated to pycups-1.9.9.
953- Desktop file.
954- Requires PyXML.
955
956* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
957- Make it actually run.
958
959* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
960- Build requires CUPS 1.2.
961
962* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
963- Updated to pycups-1.9.8.  No longer need threads patch.
964- Updated to system-config-printer-0.7.5.
965
966* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
967- Updated to pycups-1.9.7.
968
969* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
970- Obsoletes: system-config-printer-gui <= 0.6.152
971
972* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
973- Updated to system-config-printer-0.7.4.
974
975* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
976- Added threads patch from pycups CVS.
977- Updated to system-config-printer-0.7.3.
978
979* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
980- Updated to pycups-1.9.6.
981
982* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
983- Updated to pycups-1.9.5.
984
985* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
986- Package the actual system-config-printer command.
987
988* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
989- Include s-c-printer tarball.
990- Updated to pycups-1.9.4.
991
992* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
993- Initial spec file.
Note: See TracBrowser for help on using the repository browser.