source: projects/specs/trunk/s/system-config-printer/system-config-printer-vl.spec @ 12469

Revision 12469, 32.1 KB checked in by tomop, 4 years ago (diff)

python-3.8.5 and related packages.

Line 
1%define pycups_version 1.9.66
2%define pysmbc_version 1.0.14.1
3%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
4%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
5%{!?pyver: %define pyver %(%{__python} -c "import sys ; print sys.version[:3]")}
6
7Summary: A printer administration tool
8Summary(ja): プリンタ管理ツール
9Name: system-config-printer
10Version: 1.5.12
11Release: 1%{?_dist_release}
12Group: admin-tools
13Vendor: Project Vine
14Distribution: Vine Linux
15
16License: GPLv2+
17URL: https://github.com/OpenPrinting/system-config-printer
18Source0: https://github.com/OpenPrinting/system-config-printer/releases/download/%{version}/system-config-printer-%{version}.tar.xz
19
20# all upstream patches, remove with new release
21Patch01: 0001-udev-configure-printer-Add-checks-for-NULL.patch
22Patch02: system-config-printer-getchildren-removed.patch
23
24BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25
26BuildRequires: cups-devel >= 1.2
27BuildRequires: desktop-file-utils >= 0.2.92
28BuildRequires: gettext-devel
29BuildRequires: intltool
30BuildRequires: libusb1-devel
31BuildRequires: pkgconfig(glib-2.0)
32BuildRequires: xmlto
33BuildRequires: python3-devel
34BuildRequires: python3-rpm-macros
35BuildRequires: eudev-libudev-devel
36
37Requires: python3-pygobject
38Requires: gtk3
39Requires: desktop-file-utils >= 0.2.92
40Requires: dbus-x11
41Requires: dbus-python3
42Requires: system-config-printer-libs = %{version}-%{release}
43Requires: notification-daemon
44Requires: libnotify
45Requires: python3-pycairo
46#Requires: python3-firewall
47Requires: libcanberra-gtk3
48
49Obsoletes: system-config-printer-gui <= 0.6.152
50Provides: system-config-printer-gui = 0.6.152
51
52Obsoletes: desktop-printing <= 0.20-7.fc7
53Provides: desktop-printing = 0.20-7.fc7
54
55%description
56system-config-printer is a graphical user interface that allows
57the user to configure a CUPS print server.
58
59
60%package libs
61Summary: Libraries and shared code for printer administration tool
62Summary(ja): Libraries and shared code for printer administration tool
63Group: system
64BuildArch: noarch
65Requires: python3-cups >= 1.9.60
66Requires: python3-pycurl
67Requires: gobject-introspection
68Requires: python3-pygobject
69Requires: gtk3
70Requires: dbus-python3
71Requires: python3-requests
72Suggests: python3-smbc
73Obsoletes: %{name}-libs < 1.3.12-10
74
75%description libs
76The common code used by both the graphical and non-graphical parts of
77the configuration tool.
78
79
80%package udev
81Summary: Rules for udev for automatic configuration of USB printers
82Group: system
83Requires: system-config-printer-libs = %{version}-%{release}
84Obsoletes: hal-cups-utils <= 0.6.20
85Provides: hal-cups-utils = 0.6.20
86
87%description udev
88The udev rules and helper programs for automatically configuring USB
89printers.
90
91
92%prep
93%setup -q
94# all backported from upstream
95%patch01 -p1 -b .udev-configure-segfault
96%patch02 -p1 -b .getchildren-removed
97
98
99%build
100%configure --with-udev-rules
101make %{?_smp_mflags}
102
103%install
104rm -rf %buildroot
105make DESTDIR=%buildroot install \
106     udevrulesdir=/lib/udev/rules.d \
107     udevhelperdir=/lib/udev
108
109%{__mkdir_p} %buildroot%{_localstatedir}/run/udev-configure-printer
110touch %buildroot%{_localstatedir}/run/udev-configure-printer/usb-uris
111
112%find_lang system-config-printer
113
114%clean
115rm -rf %buildroot
116
117
118%files libs -f system-config-printer.lang
119%defattr(-,root,root,-)
120%license COPYING
121%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.NewPrinterNotification.conf
122%config(noreplace) %{_sysconfdir}/dbus-1/system.d/com.redhat.PrinterDriversInstaller.conf
123%dir %{_sysconfdir}/cupshelpers
124%config(noreplace) %{_sysconfdir}/cupshelpers/preferreddrivers.xml
125%{python3_sitelib}/cupshelpers
126%{python3_sitelib}/cupshelpers-*.egg-info
127
128%files udev
129%defattr(-,root,root,-)
130/lib/udev/rules.d/*.rules
131/lib/udev/udev-*-printer
132%dir %{_localstatedir}/run/udev-configure-printer
133%ghost %verify(not md5 size mtime) %config(noreplace,missingok) %attr(0644,root,root) %{_localstatedir}/run/udev-configure-printer/usb-uris
134
135%files
136%defattr(-,root,root,-)
137%license COPYING
138%doc ChangeLog NEWS ABOUT-NLS AUTHORS ChangeLog-OLD
139%{_bindir}/%{name}
140%{_bindir}/%{name}-applet
141%{_bindir}/install-printerdriver
142%{_bindir}/scp-dbus-service
143%{_datadir}/dbus-1/interfaces/*.xml
144%{_datadir}/dbus-1/services/*.service
145%dir %{_datadir}/%{name}
146%{_datadir}/%{name}/*.py*
147%{_datadir}/%{name}/troubleshoot
148%{_datadir}/%{name}/icons
149%dir %{_datadir}/%{name}/xml
150%{_datadir}/%{name}/xml/*.rng
151%{_datadir}/%{name}/xml/*.py*
152%dir %{_datadir}/%{name}/ui
153%{_datadir}/%{name}/ui/*.ui
154%{_datadir}/metainfo/system-config-printer.appdata.xml
155%{_datadir}/applications/system-config-printer.desktop
156%{_sysconfdir}/xdg/autostart/print-applet.desktop
157%{_mandir}/man1/*
158
159%changelog
160* Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.12-1
161- new upstream release.
162
163* Thu Apr 04 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.11-1
164- new upstream release.
165- made to run with python3.
166
167* Sun Nov  1 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-2
168- removed R:foomatic.
169
170* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.8-1
171- update to 1.4.8
172- add BuildRequires: gnutls-devel
173- remove Requires: gnome-python, gnome-python-gnomekeyrin
174- add Patch0 (pycups-1.9.66-cups-server-remote-printers.patch)
175
176* Fri Jun 27 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-2
177- add Requires: python-pycurl
178
179* Sun Jun 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.4-1
180- new upstream release
181  - system-config-printer-1.4.4
182  - pycups-1.9.66
183  - pysmbc-1.0.14.1
184- change BuildRequires: eudev-libudev-devel instead of libudev-devel
185- change BuildRequires: libusb1-devel instead of libusb-devel
186- remove Patch2 (system-config-printer-check-device-ids.patch)
187- remove Patch3 (system-config-printer-self.printers.patch)
188- remove Patch20 (system-config-printer-1.3.2-gettext.patch)
189
190* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-4
191- rebuild with python-2.7.2
192
193* Fri Apr 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
194- update patch21 and ja.po
195
196* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2-2
197- add BuildRequires: glib2-devel
198
199* Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-1
200- new upstream release
201  - system-config-printer-1.3.2
202  - pycups-1.9.55
203  - pysmbc-1.0.10
204- drop old patches (1,2,10)
205- add Patch2,3 from fedora
206  - Patch2: Improvements for check-device-ids from upstream.
207  - Patch3: Fixed traceback in newprinter.py (bug #680683).
208- update ja.po
209- Patch21: add more ppd translation dictionary
210- add BR: epydoc
211
212* Mon Feb 22 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.92-1
213- new development release (pre1.2)
214  - system-config-printer-1.1.92
215  - pycups-1.9.48
216- add Patch1,2 from fedora
217  - Patch1: build without epydoc, remove BR: epydoc
218  - Patch2: Convert MFG and MDL to lowercase before D-Bus call
219    to work around bug #566217.
220- add BR: python-tools, libudev-devel, libusb-devel
221- add R: libxml2-python
222
223* Wed Feb 03 2010 Shu KONNO <owa@bg.wakwak.com> 1.1.7-2
224- rebuilt with python-2.6.4
225
226* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.7-1
227- new upstream release
228  - Updated translations.
229  - Don't abort if the jobviewer couldn't show a notification.
230  - Don't use setlocale() for locale-independent case conversion.
231  - Don't assume the notification daemon can show action buttons.
232  - Use case-insensitive matching for model names.
233  - HPLIP compatibility fixes.
234  - Fixed typo in jobviewer keyring support (Ubuntu #343156).
235  - Added support for https device URIs (bug #478677).
236  - Prevent traceback in monitor when connection failed (Ubuntu #343387).
237- add Patch10: fix infinite loop on adding printer
238- add Patch11: do not probe hplip
239
240* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.6-1
241- new upstream release
242  - system-config-printer 1.1.6
243  - pycups 1.9.45
244
245* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.9-1
246- initial build for Vine Linux
247
248* Tue Oct 21 2008 Tim Waugh <twaugh@redhat.com> 1.0.9-1
249- Updated to 1.0.9 for translations.
250- Updated pysmbc to 1.0.6.  No longer need pysmbc-git patch.
251
252* Fri Oct 17 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-7
253- Added patch for pysmbc changes in git to prevent getdents crashing
254  (bug #465975).
255
256* Thu Oct 16 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-6
257- Updated patch for 1.0.x changes:
258  - Fixed SMB authentication dialog's cancel button (bug #467127).
259  - Work around samba bug #5805 by sending debug output to stderr
260    instead of stdout.
261
262* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-5
263- Updated patch for 1.0.x changes:
264  - Fixed SMB authentication (bug #464003).
265
266* Wed Oct 15 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-4
267- Updated patch for 1.0.x changes:
268  - Removed unneeded debugging output.
269  - Don't show the applet in KDE (bug #466945).
270  - Auth/error dialog improvements for SMB as for IPP (bug #465407).
271
272* Mon Oct 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-3
273- Added patch for 1.0.x changes since 1.0.8:
274  - Don't use a LinkButton for the 'Problems?' button (bug #465407).
275  - Don't use a separator for the server settings dialog (bug
276    #465407).
277  - Don't set non-zero page size for SpinButtons.
278  - Don't show an error dialog if an IPP operation's authentication
279    dialog is cancelled by the user, but show an error dialog if the
280    password was incorrect (bug #465407).
281  - Set Server Settings... menu entry sensitive depending on whether
282    we are connected to a server (Ubuntu #280736).
283  - Lots of translations updated.
284
285* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-2
286- Removed patch (no longer needed).
287
288* Mon Sep 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.8-1
289- 1.0.8:
290  - Use modelName from custom PPD to suggest name for new printer
291    (trac #97).
292  - Avoid display problem with installable options.
293  - Better matching for Lexmark printers.
294  - Catch exceptions from advanced server settings dialog (Ubuntu
295    #267557).
296  - Added some missing OpenPrinting query fields.
297  - Jockey support added.
298  - Lots of translations updated.
299
300* Sat Aug 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-2
301- Handle IPP_FORBIDDEN (bug #460670).
302
303* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com> 1.0.7-1
304- 1.0.7:
305  - Efficiency improvements.
306  - Small UI improvements for the New Printer dialog.
307  - Other small fixes.
308
309* Fri Aug 29 2008 Tim Waugh <twaugh@redhat.com>
310- Updated pysmbc to 1.0.5.
311- Updated pycups to 1.9.42.
312
313* Tue Aug 26 2008 Tim Waugh <twaugh@redhat.com> 1.0.6-1
314- Requires gnome-python2-gnome (bug #460021).
315- 1.0.6:
316  - More delete-event fixes.
317  - Fixed temporary file leak.
318  - Fixed dialog leaks.
319  - Small UI improvements for the New Printer dialog.
320  - Other small fixes.
321
322* Thu Aug 14 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-3
323- Include other fixes from upstream including:
324  - OpenPrinting API change (trac #74).
325  - libnotify API change for 'closed' signal.
326  - Notification for job authentication (trac #91).
327  - Glade delete-event fixes (trac #88).
328  - Pre-fill username in job authentication dialog (trac #87).
329
330* Wed Aug 13 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-2
331- Handle HTTP_FORBIDDEN.
332
333* Mon Aug 11 2008 Tim Waugh <twaugh@redhat.com> 1.0.5-1
334- 1.0.5.
335- Updated pycups to 1.9.41.
336
337* Thu Jul 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.4-1
338- 1.0.4.
339- Applied upstream patch for pycups to fix getPrinterAttributes when
340  requested_attributes is specified.
341
342* Tue Jul  8 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-2
343- Better debugging for pysmbc.
344
345* Mon Jun 30 2008 Tim Waugh <twaugh@redhat.com> 1.0.3-1
346- Updated pycups to 1.9.40.
347- 1.0.3.
348
349* Fri Jun 20 2008 Tim Waugh <twaugh@redhat.com>
350- Updated pysmbc to 1.0.4.
351
352* Tue Jun 10 2008 Tim Waugh <twaugh@redhat.com> 1.0.2-1
353- 1.0.2.
354
355* Mon Jun  9 2008 Tim Waugh <twaugh@redhat.com> 1.0.1-1
356- Updated pysmbc to 1.0.3.
357- 1.0.1 (bug #450119).
358
359* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com>
360- Requires notify-python (bug #450139).
361
362* Thu Jun  5 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-3
363- Applied patches from upstream (bug #450120).
364
365* Tue Jun  3 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-2
366- Applied patches from upstream (bug #449753).
367
368* Thu May 29 2008 Tim Waugh <twaugh@redhat.com>
369- Updated pycups to 1.9.39.
370- Updated libs summary.
371
372* Tue May 27 2008 Tim Waugh <twaugh@redhat.com> 1.0.0-1
373- 1.0.0.
374
375* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
376- Fixed small UI problem in SMB browser.
377
378* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
379- 0.9.93.
380
381* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.92-1
382- 0.9.92.
383
384* Tue May 20 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-3
385- Sync to trunk.
386- Updated pysmbc to 1.0.2.
387
388* Sun May 18 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-2
389- Fixed icon search path.
390
391* Fri May 16 2008 Tim Waugh <twaugh@redhat.com> 0.9.91-1
392- No longer requires system-install-packages (bug #444645).
393- Added pysmbc.  Build requires libsmbclient-devel.
394- Don't install consolehelper bits any more as they are no longer needed.
395- 0.9.91:
396  - User interface overhaul, part 2.
397
398* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.9.90-1
399- Updated pycups to 1.9.38.
400- 0.9.90:
401  - User interface overhaul, part 1.
402
403* Thu Apr  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.2-1
404- 0.7.82.2:
405  - Various bug fixes.
406  - Translation updates.
407
408* Mon Mar 17 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-3
409- Updated pycups to 1.9.37.
410- More fixes from upstream.
411
412* Wed Mar  5 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-2
413- Updated pycups to 1.9.36.
414- Some fixes from upstream.
415
416* Mon Mar  3 2008 Tim Waugh <twaugh@redhat.com> 0.7.82.1-1
417- Requires /usr/bin/system-install-packages not pirut (bug #435622).
418- 0.7.82.1:
419  - More trouble-shooting improvements.
420  - applet: notify user about failed jobs (bug #168370).
421
422* Tue Feb 19 2008 Tim Waugh <twaugh@redhat.com> 0.7.82-1
423- Updated to pycups-1.9.35.
424- 0.7.82:
425  - More trouble-shooting improvements.
426
427* Wed Feb 13 2008 Tim Waugh <twaugh@redhat.com> 0.7.81-1
428- 0.7.81:
429  - Trouble-shooting improvements and other minor fixes.
430
431* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-2
432- Rebuild for GCC 4.3.
433
434* Mon Feb  4 2008 Tim Waugh <twaugh@redhat.com> 0.7.80-1
435- Updated to pycups-1.9.34.
436- 0.7.80:
437  - Trouble-shooting support.
438
439* Fri Jan 25 2008 Tim Waugh <twaugh@redhat.com> 0.7.79-1
440- 0.7.79.
441
442* Wed Jan 23 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-5
443- Updated to pycups-1.9.33.
444
445* Wed Jan 16 2008 Tim Waugh <twaugh@redhat.com> 0.7.78-4
446- Use config-util from new usermode (bug #428406).
447
448* Thu Dec 20 2007 Tim Waugh <twaugh@redhat.com>
449- Requires notification-daemon (Ubuntu #176929).
450- Requires gnome-python2 for theme support (Ubuntu #176929).
451- Requires gnome-icon-theme for printer icon (Ubuntu #176929).
452
453* Mon Dec 17 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-3
454- Install Python egg-info file.
455- Updated pycups to 1.9.32.
456
457* Tue Nov 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-2
458- pycups: Applied patch from SVN to allow fetching printer attributes by URI.
459- Sync to SVN 1748.
460
461* Thu Nov 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.78-1
462- pycups: Fix job-sheets-default attribute.
463- Updated pycups to 1.9.31.
464- 0.7.78.
465
466* Wed Nov 21 2007 Tim Waugh <twaugh@redhat.com>
467- Applied patch to pycups to avoid reading uninitialised
468  memory (bug #390431).
469
470* Mon Nov 19 2007 Tim Waugh <twaugh@redhat.com>
471- Updated pycups to 1.9.30.
472
473* Tue Oct 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.77-1
474- 0.7.77:
475  - Tooltips for the button bar buttons (bug #335601).
476
477* Mon Oct 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.76-1
478- 0.7.76.
479
480* Thu Oct  4 2007 Tim Waugh <twaugh@redhat.com> 0.7.75-1
481- 0.7.75.
482
483* Wed Oct  3 2007 Tim Waugh <twaugh@redhat.com>
484- No need to run update-desktop-database because there are no MimeKey
485  lines in the desktop files.
486- Consistent macro style.
487
488* Tue Oct  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.4-1
489- Changed PreReq to Requires.
490- Mark console.apps file as a config file.
491- Mark pam file as a config file (not replaceable).
492- No need to ship empty NEWS file.
493- Give cupsd.py executable permissions to satisfy rpmlint.
494- Provides system-config-printer-gui.
495- Mark D-Bus configuration file as a config file.
496- Fixed libs summary.
497- Better buildroot tag.
498- Better defattr.
499- Preserve timestamps on explicitly install files.
500- Make example pycups program non-executable.
501- 0.7.74.4:
502  - Updated translations.
503  - Several small bugs fixed.
504
505* Thu Sep 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.3-1
506- 0.7.74.3:
507  - Updated translations.
508  - Other small bug fixes.
509
510* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
511- Pull in SVN patch from stable branch for foomatic recommended
512  drivers (bug #292021).
513
514* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
515- Pull in SVN patch from stable branch for 'Allow printing from
516  the Internet' check-box (bug #221003).
517
518* Wed Sep 19 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-1
519- Updated pycups to 1.9.27.
520- 0.7.74.2:
521  - When a class is removed on the server, remove it from the UI.
522  - When deleting a printer, select the default printer again.
523  - Select newly-copied printer.
524  - Updated translation (fi).
525  - Better --help message.
526  - Use strcoll to sort manufacturer names.
527  - Avoid duplicate 'recommended' marks.
528  - Remove duplicate device URIs.
529  - Handle IPP_TAG_NOVALUE attributes (for CUPS 1.3.x).
530
531* Wed Sep 12 2007 Tim Waugh <twaugh@redhat.com>
532- Updated pycups to 1.9.26.
533- Build requires epydoc.  Ship HTML documentation.
534
535* Fri Sep  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.1-1
536- 0.7.74.1:
537  - Updated Polish translation (bug #263001).
538  - Don't select the default printer after changes to another printer have
539    been made.
540  - Always construct URI from input fields when changing device (bug #281551).
541  - Avoid busy-cursor traceback when window is not yet displayed.
542
543* Thu Aug 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.74-1
544- Updated pycups to 1.9.25.
545- 0.7.74:
546  - Fixed New Class dialog.
547  - UI fixes.
548
549* Sat Aug 25 2007 Tim Waugh <twaugh@redhat.com>
550- More specific license tag.
551
552* Fri Aug 24 2007 Tim Waugh <twaugh@redhat.com> 0.7.73-1
553- 0.7.73.
554
555* Fri Aug 10 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-2
556- Ship the applet's desktop file.
557
558* Wed Aug  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.72-1
559- 0.7.72:
560  - Fixed my-default-printer traceback.
561  - Improvements to New Printer wizard (Till Kamppeter).
562
563* Fri Aug  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.71-1
564- 0.7.71:
565  - Don't discard make/model-matched devices when there are ID-matched
566    devices (Till Kamppeter).
567  - Fixed fallback if no text-only driver is available (Till Kamppeter).
568  - Initialise the make/model list when an ID match failed (Till Kamppeter).
569  - Better error-handling in default-print application (Ubuntu #129901).
570  - UI tweak in admin tool (Ubuntu #128263).
571  - Handle socket: URIs (Ubuntu #127074).
572
573* Mon Jul 23 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-2
574- Obsoletes/provides desktop-printing.
575
576* Mon Jul  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.70-1
577- Requires pirut for system-install-packages.
578- 0.7.70:
579  - Increased GetReady->NewPrinter timeout.
580  - More binary names mapped to package named.
581  - Run system-install-packages to install missing drivers (bug #246726).
582  - Less debug output.
583  - Desktop file fixes for KDE (bug #247299).
584
585* Thu Jun 28 2007 Tim Waugh <twaugh@redhat.com> 0.7.69-1
586- No longer requires PyXML (bug #233146).
587- Moved applet to main package.
588- 0.7.69:
589  - Use HardwareSettings category for my-default-printer desktop
590    file (bug #244935).
591  - Removed unused code.
592  - Filter PPDs by natural language (bug #244173).
593
594* Mon Jun 25 2007 Tim Waugh <twaugh@redhat.com>
595- The applet requires dbus-x11 (Ubuntu #119570).
596
597* Fri Jun 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.68-1
598- 0.7.68:
599  - Fixed the notification bubbles.
600  - Ship my-default-printer utility.
601
602* Fri Jun  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.67-1
603- Don't put TrayIcon or SystemSetup categories in the desktop file.
604- Updated pycups to 1.9.24.
605- 0.7.67:
606  - Fixed desktop files to have capital letters at the start of each
607    word in the Name field (bug #242859).
608  - Fixed crash when saving unapplied changes.
609  - Fixed Device ID parser to always split the CMD field at commas.
610  - New PPDs class means we no longer parse the foomatic XML database.
611
612* Wed May 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.66-1
613- 0.7.66:
614  - Allow job-hold-until to be set (bug #239776).
615  - Implement new printer notifications.
616
617* Tue May 22 2007 Tim Waugh <twaugh@redhat.com> 0.7.65-1
618- Build requires xmlto.
619- Updated to pycups-1.9.22.
620- 0.7.65:
621  - Use urllib for quoting/unquoting (Val Henson, Ubuntu #105022).
622  - Added kn translation.
623  - Better permissions on non-scripts.
624  - Added man pages.
625  - Applet: status feedback.
626  - Applet: fixed relative time descriptions.
627  - Applet: limit refresh frequency.
628
629* Mon Apr 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.63.1-1
630- 0.7.63.1:
631  - Small applet fixes.
632
633* Thu Apr  5 2007 Tim Waugh <twaugh@redhat.com> 0.7.63-1
634- 0.7.63:
635  - Translation updates.
636  - Checked in missing file.
637
638* Wed Apr  4 2007 Tim Waugh <twaugh@redhat.com>
639- Updated to pycups-1.9.20 for printer-state-reasons fix.
640
641* Mon Apr  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.62-1
642- 0.7.62:
643  - Use standard icon for admin tool desktop file.
644  - Fixed env path in Python scripts.
645  - Applet: stop running when the session ends.
646  - Prevent a traceback in the SMB browser (bug #225351).
647  - 'Manage print jobs' desktop file.
648
649* Fri Mar 30 2007 Tim Waugh <twaugh@redhat.com> 0.7.61-1
650- 0.7.61:
651  - Fixed retrieval of SMB authentication details (bug #203539).
652
653* Tue Mar 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.60-1
654- Updated to pycups-1.9.19.
655- Avoid %%makeinstall.
656- 0.7.60:
657  - Handle reconnection failure.
658  - New applet name.
659
660* Mon Mar 26 2007 Tim Waugh <twaugh@redhat.com> 0.7.59-1
661- 0.7.59:
662  - Fixed a translatable string.
663  - Set a window icon (bug #233899).
664  - Handle failure to start the D-Bus service.
665  - Ellipsize the document and printer named (bug #233899).
666  - Removed the status bar (bug #233899).
667  - Added an icon pop-up menu for 'Hide' (bug #233899).
668
669* Wed Mar 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.57-1
670- Added URL tag.
671- 0.7.57:
672  - Prevent traceback when removing temporary file (Ubuntu #92914).
673  - Added print applet.
674
675* Sun Mar 18 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-2
676- Updated to pycups-1.9.18.
677
678* Fri Mar 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.56-1
679- 0.7.56:
680  - Parse Boolean strings correctly in job options.
681  - Small command-set list/string fix (bug #230665).
682  - Handle hostname look-up failures.
683  - Updated filter-to-driver map.
684  - Don't parse printers.conf (bug #231826).
685
686* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.55-1
687- 0.7.55:
688  - Use converted value for job option widgets.
689
690* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.54-1
691- 0.7.54:
692  - Removed debugging code.
693
694* Tue Feb 27 2007 Tim Waugh <twaugh@redhat.com> 0.7.53-1
695- No longer requires rhpl (since 0.7.53).
696- 0.7.53:
697  - Use gettext instead of rhpl.translate.
698  - Better layout for PPD options.
699  - Added scrollbars to main printer list (bug #229453).
700  - Set maximum width of default printer label (bug #229453).
701  - Handle applying changes correctly when switching to another
702    printer (bug #229378).
703  - Don't crash when failing to fetch the PPD (bug #229406).
704  - Make the text entry boxes sensitive but not editable for remote
705    printers (bug #229381).
706  - Better job options screen layout (bug #222272).
707
708* Tue Feb 13 2007 Tim Waugh <twaugh@redhat.com> 0.7.52-1
709- 0.7.52:
710  - Sort models using cups.modelSort before scanning for a close
711    match (bug #228505).
712  - Fixed matching logic (bug #228505).
713
714* Fri Feb  9 2007 Tim Waugh <twaugh@redhat.com> 0.7.51-1
715- 0.7.51:
716  - Prevent display glitch in job options list when clicking on a printer
717    repeatedly.
718  - List conflicting PPD options, and embolden the relevant tab
719    labels (bug #226368).
720  - Fixed typo in 'set default' handling that caused a traceback (bug #227936).
721  - Handle interactive search a little better (bug #227935).
722
723* Wed Feb  7 2007 Tim Waugh <twaugh@redhat.com> 0.7.50-1
724- 0.7.50:
725  - Fixed hex digits list (bug #223770).
726  - Added bs translation.
727  - Don't put the ellipsis in the real device URI (bug #227643).
728  - Don't check for existing drivers for complex command lines (bug #225104).
729  - Allow floating point job options (bug #224651).
730  - Prevent shared/published confusion (bug #225081).
731  - Fixed PPD page size setting.
732  - Avoid os.remove exception (bug #226703).
733  - Handle unknown job options (bug #225538).
734
735* Tue Jan 16 2007 Tim Waugh <twaugh@redhat.com> 0.7.49-1
736- 0.7.49:
737  - Fixed a traceback in the driver check code.
738  - Fixed a typo in the conflicts message.
739  - Handle InputSlot/ManualFeed specially because libcups does (bug #222490).
740
741* Mon Jan 15 2007 Tim Waugh <twaugh@redhat.com> 0.7.48-1
742- 0.7.48:
743  - Updated translations.
744
745* Fri Jan 12 2007 Tim Waugh <twaugh@redhat.com> 0.7.47-1
746- 0.7.47:
747  - Fixed minor text bugs (bug #177433).
748  - Handle shell builtins in the driver check (bug #222413).
749
750* Mon Jan  8 2007 Tim Waugh <twaugh@redhat.com> 0.7.46-1
751- 0.7.46:
752  - Fixed page size problem (bug #221702).
753  - Added 'ro' to ALL_LINGUAS.
754
755* Wed Jan  3 2007 Tim Waugh <twaugh@redhat.com> 0.7.45-1
756- Updated to pycups-1.9.17.
757- 0.7.45:
758  - Fixed traceback in driver check.
759
760* Tue Jan  2 2007 Tim Waugh <twaugh@redhat.com> 0.7.44-1
761- 0.7.44:
762  - Fixed traceback in error display (bug #220136).
763  - Preserve case in model string when dumping debug output.
764
765* Thu Dec 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.43-1
766- 0.7.43:
767  - Don't check against IEEE 1284 DES field at all.
768  - Merged device matching code (bug #219518).
769  - Catch non-fatal errors when auto-matching device.
770  - Fixed driver checking bug involving pipelines (bug #220347).
771  - Show PPD errors (bug #220136).
772
773* Mon Dec 11 2006 Tim Waugh <twaugh@redhat.com> 0.7.42-1
774- 0.7.42:
775  - Fixed typo in command set matching code.
776  - Case-insensitive matching when Device ID not known to database.
777
778* Thu Dec  7 2006 Jeremy Katz <katzj@redhat.com> - 0.7.41-2
779- build against python 2.5
780
781* Thu Dec  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.41-1
782- Updated pycups to 1.9.16.
783- 0.7.41:
784  - Reconnect smoothly after uploading new configuration.
785  - Update lpoptions when setting default printer if it conflicts with
786    the new setting (bug #217395).
787  - Fixed typo in show_HTTP_Error (bug #217537).
788  - Don't pre-select make and model when not discoverable for chosen
789    device (bug #217518).
790  - Set Forward button sensitive on Device screen in new-printer
791    dialog (bug #217515).
792  - Keep Server Settings selected after applying changes if it was selected
793    before.
794  - Set Connecting dialog transient for main window.
795  - Center Connecting dialog on parent.
796  - Optional 'reason' argument for cupshelpers.Printer.setEnabled.
797  - Describe devices that have no optional parameters.
798
799* Thu Nov 30 2006 Tim Waugh <twaugh@redhat.com>
800- Provide pycups feature.
801
802* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.40-1
803- 0.7.40:
804  - Removed username:password from hint string because we add that in
805    afterwards.
806  - Don't set button widths in create-printer dialog (bug #217025).
807
808* Tue Nov 21 2006 Tim Waugh <twaugh@redhat.com> 0.7.39-1
809- 0.7.39:
810  - Busy cursor while loading foomatic and PPD list (bug #215527).
811  - Make PPD NickName selectable.
812  - Added SMB hint label on device screen (bug #212759).
813
814* Tue Nov 14 2006 Tim Waugh <twaugh@redhat.com> 0.7.38-1
815- Updated pycups to 1.9.15.
816- 0.7.38:
817  - Fixed a bug in the 'ieee1284'/'ppd-device-id' parsing code.
818
819* Mon Nov 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.37-1
820- 0.7.37:
821  - Allow cancellation of test pages (bug #215054).
822
823* Fri Nov 10 2006 Tim Waugh <twaugh@redhat.com> 0.7.36-1
824- 0.7.36:
825  - Match against commandset (bug #214181).
826  - Parse 'ieee1284' foomatic autodetect entries (bug #214761).
827  - Don't remove foomatic PPDs from the list (bug #197331).
828
829* Tue Nov  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.35-1
830- 0.7.35.
831
832* Thu Nov  2 2006 Tim Waugh <twaugh@redhat.com>
833- Updated to pycups-1.9.14 (bug #213136).
834
835* Tue Oct 31 2006 Tim Waugh <twaugh@redhat.com>
836- Update desktop database (bug #213249).
837
838* Tue Oct 24 2006 Tim Waugh <twaugh@redhat.com>
839- Build requires Python 2.4.
840
841* Mon Oct  2 2006 Tim Waugh <twaugh@redhat.com> 0.7.32-1
842- Updated to pycups-1.9.13 for HTTP_FORBIDDEN.
843- 0.7.32:
844  - Handle HTTP errors during connection (bug #208824).
845  - Updated translations (bug #208873).
846
847* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.31-1
848- 0.7.31:
849  - Select recommended driver automatically (bug #208606).
850  - Better visibility of driver list (bug #203907).
851
852* Fri Sep 29 2006 Tim Waugh <twaugh@redhat.com> 0.7.30-1
853- 0.7.30:
854  - Translations fixed properly (bug #206622).
855  - Button widths corrected (bug #208556).
856
857* Tue Sep 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.28-1
858- 0.7.28.  Translations fixed (bug #206622).
859
860* Wed Aug 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.27-1
861- Build requires intltool.
862- 0.7.27.
863
864* Wed Aug 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.26-1
865- 0.7.26.  Fixes bug # 203149.
866
867* Mon Aug 14 2006 Florian Festi <ffesti@redhat.com> 0.7.25-1
868- 0.7.25. (bug #202060)
869
870* Fri Aug 11 2006 Tim Waugh <twaugh@redhat.com>
871- Fixed description (bug #202189).
872
873* Thu Aug  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.24-1
874- 0.7.24.
875
876* Mon Jul 24 2006 Tim Waugh <twaugh@redhat.com> 0.7.23-1
877- 0.7.23.  Fixes bug #197866.
878
879* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.7.22-1.1
880- rebuild
881
882* Fri Jul  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.22-1
883- 0.7.22.
884
885* Wed Jul  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.21-1
886- Updated to pycups-1.9.12.
887- 0.7.21.
888
889* Mon Jul  3 2006 Tim Waugh <twaugh@redhat.com> 0.7.20-1
890- 0.7.20.
891
892* Fri Jun 30 2006 Tim Waugh <twaugh@redhat.com> 0.7.19-1
893- 0.7.19.
894- Remove foomatic pickle file post-install.
895
896* Tue Jun 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.18-1
897- 0.7.18.
898- Ship translations with libs subpackage.
899
900* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.17-1
901- 0.7.17.
902
903* Fri Jun 23 2006 Tim Waugh <twaugh@redhat.com> 0.7.16-1
904- 0.7.16, now with SMB browser.
905
906* Thu Jun 22 2006 Tim Waugh <twaugh@redhat.com> 0.7.15-1
907- 0.7.15.
908- Build requires gettext-devel.
909- Ship translations.
910
911* Tue Jun 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.14-1
912- 0.7.14.
913
914* Mon Jun 19 2006 Tim Waugh <twaugh@redhat.com> 0.7.13-1
915- 0.7.13.
916
917* Fri Jun  9 2006 Tim Waugh <twaugh@redhat.com> 0.7.12-1
918- 0.7.12.
919
920* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-3
921- Fix libs dependency.
922
923* Thu Jun  1 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-2
924- Moved the gtk_html2pango module to the libs package (needed by
925  foomatic.py).
926
927* Wed May 31 2006 Tim Waugh <twaugh@redhat.com> 0.7.11-1
928- Split out system-config-printer-libs.
929- Updated to system-config-printer-0.7.11.
930
931* Sat May 27 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-2
932- Requires gobject2 (bug #192764).
933
934* Fri May 26 2006 Tim Waugh <twaugh@redhat.com> 0.7.10-1
935- Require foomatic (bug #192764).
936- Updated to system-config-printer-0.7.10.
937
938* Thu May 25 2006 Tim Waugh <twaugh@redhat.com> 0.7.9-1
939- Updated to pycups-1.9.11.
940- Updated to system-config-printer-0.7.9.
941
942* Mon May 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.8-1
943- Updated to pycups-1.9.10.
944- Updated to system-config-printer-0.7.8.
945
946* Fri May  5 2006 Tim Waugh <twaugh@redhat.com>
947- Fix pycups segfault.
948
949* Fri May  5 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-2
950- Ship PAM and userhelper files.
951- Requires usermode.
952- Added missing options.py file.
953- Fix getClasses() in pycups.
954
955* Thu May  4 2006 Tim Waugh <twaugh@redhat.com> 0.7.7-1
956- Updated to system-config-printer-0.7.7.
957- Updated to pycups-1.9.9.
958- Desktop file.
959- Requires PyXML.
960
961* Fri Apr 28 2006 Tim Waugh <twaugh@redhat.com>
962- Make it actually run.
963
964* Fri Apr 21 2006 Tim Waugh <twaugh@redhat.com>
965- Build requires CUPS 1.2.
966
967* Thu Apr 20 2006 Tim Waugh <twaugh@redhat.com> 0.7.5-1
968- Updated to pycups-1.9.8.  No longer need threads patch.
969- Updated to system-config-printer-0.7.5.
970
971* Sat Apr 15 2006 Tim Waugh <twaugh@redhat.com>
972- Updated to pycups-1.9.7.
973
974* Thu Apr 13 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-2
975- Obsoletes: system-config-printer-gui <= 0.6.152
976
977* Wed Apr 12 2006 Tim Waugh <twaugh@redhat.com> 0.7.4-1
978- Updated to system-config-printer-0.7.4.
979
980* Fri Apr  7 2006 Tim Waugh <twaugh@redhat.com> 0.7.3-1
981- Added threads patch from pycups CVS.
982- Updated to system-config-printer-0.7.3.
983
984* Tue Apr  4 2006 Tim Waugh <twaugh@redhat.com>
985- Updated to pycups-1.9.6.
986
987* Fri Mar 24 2006 Tim Waugh <twaugh@redhat.com>
988- Updated to pycups-1.9.5.
989
990* Fri Mar 17 2006 Tim Waugh <twaugh@redhat.com>
991- Package the actual system-config-printer command.
992
993* Thu Mar 16 2006 Tim Waugh <twaugh@redhat.com> 0.7.1-1
994- Include s-c-printer tarball.
995- Updated to pycups-1.9.4.
996
997* Wed Mar 15 2006 Tim Waugh <twaugh@redhat.com> 0.7.0-1
998- Initial spec file.
Note: See TracBrowser for help on using the repository browser.