source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 3330

Revision 3330, 6.0 KB checked in by Takemikaduchi, 13 years ago (diff)

fix: failed to build package

Line 
1Name:           shotwell
2Version:        0.8.1
3Release:        2%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14Patch0:         workaround_desktop.patch
15Patch1:         shotwell-0.8.1-vala.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  GConf2-devel
20BuildRequires:  LibRaw-devel
21BuildRequires:  WebKit-gtk-devel
22BuildRequires:  dbus-glib-devel
23BuildRequires:  desktop-file-utils
24BuildRequires:  gettext
25BuildRequires:  gtk2-devel
26BuildRequires:  gstreamer-devel
27BuildRequires:  hal-devel
28BuildRequires:  json-glib-devel
29BuildRequires:  libexif-devel
30BuildRequires:  libgee-devel
31BuildRequires:  libgphoto2-devel
32BuildRequires:  libgudev1-devel
33BuildRequires:  libgexiv2-devel >= 0.2.0
34BuildRequires:  libsoup-devel
35BuildRequires:  libxml2-devel
36BuildRequires:  sqlite3-devel
37BuildRequires:  unique-devel
38BuildRequires:  vala-devel >= 0.9.5
39
40%description
41Shotwell is a new open source photo organizer designed for the GNOME desktop
42environment. It allows you to import photos from your camera, view and edit
43them, and share them with others.
44
45%description -l ja
46Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
47画像整理ソフトです。
48あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
49他の人々と共有するなどができます。
50
51%prep
52%setup -q -n %{name}-%{version}
53#%patch0 -p1
54%patch1 -p1
55
56%build
57./configure --prefix=/usr --disable-schemas-install --assume-pkgs
58sed -i -e 's/\\n/\n/g' configure.mk
59sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
60sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
61make %{?_smp_mflags}
62
63
64%install
65rm -rf $RPM_BUILD_ROOT
66export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
67export XDG_DISABLE_MAKEFILE_UPDATES=1
68make install DESTDIR=$RPM_BUILD_ROOT
69
70desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
71desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
72
73%find_lang %{name}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%post
79touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
80update-desktop-database &> /dev/null || :
81export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
82gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
83
84%pre
85if [ "$1" -gt 1 ]; then
86  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
87  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
88fi
89
90%preun
91if [ "$1" -eq 0 ]; then
92  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
93  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
94fi
95
96%postun
97if [ $1 -eq 0 ] ; then
98  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
99  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
100fi
101update-desktop-database &> /dev/null || :
102
103%posttrans
104gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
105
106%files -f %{name}.lang
107%defattr(-,root,root,-)
108%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
109%{_sysconfdir}/gconf/schemas/shotwell.schemas
110%{_bindir}/shotwell
111%{_datadir}/gnome/help/
112%{_datadir}/shotwell
113%{_datadir}/applications/shotwell.desktop
114%{_datadir}/applications/shotwell-viewer.desktop
115%{_datadir}/icons/hicolor/*
116%exclude %{_datadir}/icons/hicolor/icon-theme.cache
117
118
119%changelog
120* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
121- add Patch1 (shotwell-0.8.1-vala.patch)
122
123* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
124- new upstream release
125- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
126
127* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
128- rebuilt with rpm-4.8.1 for pkg-config
129- fixed %%changelog in Tue Sep 14 2010
130
131* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
132- new upstream release
133- changed source URL
134- added Patch0 to work around desktop file incorrect comment
135- changed BuildRequires: vala-devel >= 0.9.5
136
137* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
138- new upstream release
139
140* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
141- new upstream release
142- changed BuildRequires: libgexiv2-devel >= 0.2.0
143
144* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
145- fixed LIB_DIRS in libraw-config (for lib64)
146
147* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
148- new upstream release
149- added BuildRequires: LibRaw-devel, libgexiv2-devel
150
151* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
152- new upstream release
153
154* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
155- new upstream release
156- added BuildRequires:  libgudev1-devel
157- applied new naming policy to spec
158
159* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
160- new upstream release
161- proved Japanese description
162
163* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
164- new upstrema release
165
166* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
167- intial build for VineSeed
168
169* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
170* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
171- Update to 0.3.2
172
173* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
174- Version 0.3.0
175
176* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
177- Rebuild against new libgee
178
179* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
180- Bring icon cache handling in sync with current guidelines
181
182* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
183- Initial packaging
Note: See TracBrowser for help on using the repository browser.