source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 4055

Revision 4055, 6.1 KB checked in by kudoh, 13 years ago (diff)
Line 
1Name:           shotwell
2Version:        0.8.1
3Release:        3%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14#Patch0:         workaround_desktop.patch
15Patch1:         shotwell-0.8.1-vala.patch
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18
19BuildRequires:  GConf2-devel
20BuildRequires:  LibRaw-devel
21BuildRequires:  LibRaw-static
22BuildRequires:  WebKit-gtk-devel
23BuildRequires:  dbus-glib-devel
24BuildRequires:  desktop-file-utils
25BuildRequires:  gettext
26BuildRequires:  gtk2-devel
27BuildRequires:  gstreamer-devel
28BuildRequires:  hal-devel
29BuildRequires:  json-glib-devel
30BuildRequires:  libexif-devel
31BuildRequires:  libgee-devel
32BuildRequires:  libgphoto2-devel
33BuildRequires:  libgudev1-devel
34BuildRequires:  libgexiv2-devel >= 0.2.0
35BuildRequires:  libsoup-devel
36BuildRequires:  libxml2-devel
37BuildRequires:  sqlite3-devel
38BuildRequires:  unique-devel
39BuildRequires:  vala-devel >= 0.9.5
40
41%description
42Shotwell is a new open source photo organizer designed for the GNOME desktop
43environment. It allows you to import photos from your camera, view and edit
44them, and share them with others.
45
46%description -l ja
47Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
48画像整理ソフトです。
49あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
50他の人々と共有するなどができます。
51
52%prep
53%setup -q -n %{name}-%{version}
54#%patch0 -p1
55%patch1 -p1
56
57%build
58./configure --prefix=/usr --disable-schemas-install --assume-pkgs
59sed -i -e 's/\\n/\n/g' configure.mk
60sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
61sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
62make %{?_smp_mflags}
63
64
65%install
66rm -rf $RPM_BUILD_ROOT
67export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
68export XDG_DISABLE_MAKEFILE_UPDATES=1
69make install DESTDIR=$RPM_BUILD_ROOT
70
71desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
72desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
73
74%find_lang %{name}
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79%post
80touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
81update-desktop-database &> /dev/null || :
82export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
83gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
84
85%pre
86if [ "$1" -gt 1 ]; then
87  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
88  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
89fi
90
91%preun
92if [ "$1" -eq 0 ]; then
93  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
94  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
95fi
96
97%postun
98if [ $1 -eq 0 ] ; then
99  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
100  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
101fi
102update-desktop-database &> /dev/null || :
103
104%posttrans
105gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
106
107%files -f %{name}.lang
108%defattr(-,root,root,-)
109%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
110%{_sysconfdir}/gconf/schemas/shotwell.schemas
111%{_bindir}/shotwell
112%{_datadir}/gnome/help/
113%{_datadir}/shotwell
114%{_datadir}/applications/shotwell.desktop
115%{_datadir}/applications/shotwell-viewer.desktop
116%{_datadir}/icons/hicolor/*
117%exclude %{_datadir}/icons/hicolor/icon-theme.cache
118
119
120%changelog
121* Sat Jun 04 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-3
122- dropt Patch0
123- added BuildRequires: LibRaw-static
124
125* Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 0.8.1-2
126- add Patch1 (shotwell-0.8.1-vala.patch)
127
128* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
129- new upstream release
130- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
131
132* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
133- rebuilt with rpm-4.8.1 for pkg-config
134- fixed %%changelog in Tue Sep 14 2010
135
136* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
137- new upstream release
138- changed source URL
139- added Patch0 to work around desktop file incorrect comment
140- changed BuildRequires: vala-devel >= 0.9.5
141
142* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
143- new upstream release
144
145* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
146- new upstream release
147- changed BuildRequires: libgexiv2-devel >= 0.2.0
148
149* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
150- fixed LIB_DIRS in libraw-config (for lib64)
151
152* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
153- new upstream release
154- added BuildRequires: LibRaw-devel, libgexiv2-devel
155
156* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
157- new upstream release
158
159* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
160- new upstream release
161- added BuildRequires:  libgudev1-devel
162- applied new naming policy to spec
163
164* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
165- new upstream release
166- proved Japanese description
167
168* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
169- new upstrema release
170
171* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
172- intial build for VineSeed
173
174* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
175* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
176- Update to 0.3.2
177
178* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
179- Version 0.3.0
180
181* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
182- Rebuild against new libgee
183
184* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
185- Bring icon cache handling in sync with current guidelines
186
187* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
188- Initial packaging
Note: See TracBrowser for help on using the repository browser.