source: projects/specs/trunk/s/shotwell/shotwell-vl.spec @ 2491

Revision 2491, 5.7 KB checked in by kudoh, 13 years ago (diff)
Line 
1Name:           shotwell
2Version:        0.8.1
3Release:        1%{?_dist_release}
4Summary:        A photo organizer for the GNOME desktop
5Summary(ja):    GNOME デスクトップ向けの画像整理ソフト
6
7Group:          Applications/Graphics
8# LGPLv2+ for the code
9# CC-BY-SA for some of the icons
10License:        LGPLv2+ and CC-BY-SA
11URL:            http://www.yorba.org/shotwell/
12Source0:        http://www.yorba.org/download/shotwell/0.8/shotwell-%{version}.tar.bz2
13# svn co svn://svn.yorba.org/shotwell/branches/shotwell-0.4, make dist
14Patch0:         workaround_desktop.patch
15
16BuildRoot:      %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires:  GConf2-devel
19BuildRequires:  LibRaw-devel
20BuildRequires:  WebKit-gtk-devel
21BuildRequires:  dbus-glib-devel
22BuildRequires:  desktop-file-utils
23BuildRequires:  gettext
24BuildRequires:  gtk2-devel
25BuildRequires:  gstreamer-devel
26BuildRequires:  hal-devel
27BuildRequires:  json-glib-devel
28BuildRequires:  libexif-devel
29BuildRequires:  libgee-devel
30BuildRequires:  libgphoto2-devel
31BuildRequires:  libgudev1-devel
32BuildRequires:  libgexiv2-devel >= 0.2.0
33BuildRequires:  libsoup-devel
34BuildRequires:  libxml2-devel
35BuildRequires:  sqlite3-devel
36BuildRequires:  unique-devel
37BuildRequires:  vala-devel >= 0.9.5
38
39%description
40Shotwell is a new open source photo organizer designed for the GNOME desktop
41environment. It allows you to import photos from your camera, view and edit
42them, and share them with others.
43
44%description -l ja
45Shotwell は GNOME デスクトップ環境用に設計された新しいオープンソースの
46画像整理ソフトです。
47あなたのカメラから写真を取り込んだり、それらを表示・編集したり、
48他の人々と共有するなどができます。
49
50%prep
51%setup -q -n %{name}-%{version}
52#%patch0 -p1
53
54%build
55./configure --prefix=/usr --disable-schemas-install --assume-pkgs
56sed -i -e 's/\\n/\n/g' configure.mk
57sed -i -e 's/^CFLAGS=.*$/CFLAGS=%{optflags}/' Makefile
58sed -i -e 's|LIB_DIRS=.*$|LIB_DIRS=%{_libdir}|' libraw-config
59make %{?_smp_mflags}
60
61
62%install
63rm -rf $RPM_BUILD_ROOT
64export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
65export XDG_DISABLE_MAKEFILE_UPDATES=1
66make install DESTDIR=$RPM_BUILD_ROOT
67
68desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell.desktop
69desktop-file-validate $RPM_BUILD_ROOT%{_datadir}/applications/shotwell-viewer.desktop
70
71%find_lang %{name}
72
73%clean
74rm -rf $RPM_BUILD_ROOT
75
76%post
77touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
78update-desktop-database &> /dev/null || :
79export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
80gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
81
82%pre
83if [ "$1" -gt 1 ]; then
84  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
85  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
86fi
87
88%preun
89if [ "$1" -eq 0 ]; then
90  export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
91  gconftool-2 --makefile-uninstall-rule %{_sysconfdir}/gconf/schemas/shotwell.schemas > /dev/null || :
92fi
93
94%postun
95if [ $1 -eq 0 ] ; then
96  touch --no-create %{_datadir}/icons/hicolor &>/dev/null
97  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
98fi
99update-desktop-database &> /dev/null || :
100
101%posttrans
102gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor &>/dev/null || :
103
104%files -f %{name}.lang
105%defattr(-,root,root,-)
106%doc README COPYING MAINTAINERS NEWS THANKS AUTHORS
107%{_sysconfdir}/gconf/schemas/shotwell.schemas
108%{_bindir}/shotwell
109%{_datadir}/gnome/help/
110%{_datadir}/shotwell
111%{_datadir}/applications/shotwell.desktop
112%{_datadir}/applications/shotwell-viewer.desktop
113%{_datadir}/icons/hicolor/*
114
115
116%changelog
117* Wed Jan 12 2011 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.8.1-1
118- new upstream release
119- added BuildRequires: gstreamer-devel, json-glib-devel, libsoup-devel, libxml2-devel
120
121* Tue Sep 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-2
122- rebuilt with rpm-4.8.1 for pkg-config
123- fixed %%changelog in Tue Sep 14 2010
124
125* Tue Sep 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.2-1
126- new upstream release
127- changed source URL
128- added Patch0 to work around desktop file incorrect comment
129- changed BuildRequires: vala-devel >= 0.9.5
130
131* Fri Aug 27 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.1-1
132- new upstream release
133
134* Sat Aug 21 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.7.0-1
135- new upstream release
136- changed BuildRequires: libgexiv2-devel >= 0.2.0
137
138* Thu Jul 22 2010 Shu KONNO <owa@bg.wakwak.com> - 0.6.1-2
139- fixed LIB_DIRS in libraw-config (for lib64)
140
141* Wed Jul 14 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.1-1
142- new upstream release
143- added BuildRequires: LibRaw-devel, libgexiv2-devel
144
145* Wed May 12 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.2-1
146- new upstream release
147
148* Sat Mar 13 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.5.0-1
149- new upstream release
150- added BuildRequires:  libgudev1-devel
151- applied new naming policy to spec
152
153* Wed Jan 20 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.3-1
154- new upstream release
155- proved Japanese description
156
157* Thu Jan 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.2-1
158- new upstrema release
159
160* Wed Dec 30 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.4.1-1
161- intial build for VineSeed
162
163* Fri Dec 18 2009 Matthias Clasen <mclasen@redhat.com> - 0.4.0-0.1.20091218svn
164* Thu Nov 12 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.2-1
165- Update to 0.3.2
166
167* Tue Nov  3 2009 Matthias Clasen <mclasen@redhat.com> - 0.3.0-1
168- Version 0.3.0
169
170* Thu Aug 20 2009 Michel Salim <salimma@fedoraproject.org> - 0.2.0-3
171- Rebuild against new libgee
172
173* Sun Aug 12 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-2.fc12
174- Bring icon cache handling in sync with current guidelines
175
176* Sun Aug  9 2009  Matthias Clasen <mclasen@redhat.com> - 0.2.0-1.fc12
177- Initial packaging
Note: See TracBrowser for help on using the repository browser.