source: projects/specs/trunk/r/rrdtool/rrdtool-vl.spec @ 12333

Revision 12333, 7.5 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

graphviz-2.42.2-1

rrdtool-1.7.2-1

ruby-2.6.5-1

subversion-1.13.0-1

vim-8.2.0390-1

Line 
1
2# Basic Information
3Name:           rrdtool
4Summary:        RRDtool - Round Robin Database tool
5Summary(ja):    RRDtool - ラウンドロビンデータベースツール
6Version:        1.7.2
7Release:        1%{?_dist_release}
8Group:          Applications/Databases
9License:        GPLv2+ with exceptions
10
11URL:            http://oss.oetiker.ch/rrdtool/
12Source0:        http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
13Patch3:         rrdtool-1.6.0-ruby-2-fix.patch
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-root
16# Dependency
17BuildRequires:  glib2-devel
18BuildRequires:  glibc-devel
19BuildRequires:  libdbi-devel
20BuildRequires:  libxml2-devel
21BuildRequires:  lua-devel
22BuildRequires:  pango-devel
23BuildRequires:  perl(ExtUtils::MakeMaker)
24BuildRequires:  python-devel
25BuildRequires:  python-setuptools
26BuildRequires:  ruby-devel
27BuildRequires:  tcl-devel
28
29Vendor:         Project Vine
30Distribution:   Vine Linux
31Packager:       yasumichi
32
33
34%description
35It is pretty easy to gather status information from all sorts of things,
36ranging from the temperature in your office to the number of octets which
37have passed through the FDDI interface of your router. But it is not so
38trivial to store this data in a efficient and systematic manner. This is
39where RRDtool kicks in. It lets you log and analyze the data you gather from
40all kinds of data-sources (DS). The data analysis part of RRDtool is based
41on the ability to quickly generate graphical representations of the data
42values collected over a definable time period.
43
44#%%description -l ja
45
46%package devel
47Summary:        Libraries and include files of RRDtool
48Group:          Development/Libraries
49Requires:       %{name} = %{version}-%{release}
50
51%description devel
52Libraries and include files of RRDtool
53
54
55%package doc
56Summary: RRDtool documentation
57Summary(ja): RRDtool のドキュメント
58Group: Applications/Documentation
59BuildArch: noarch
60
61%description doc
62RRD is the Acronym for Round Robin Database. RRD is a system to store and
63display time-series data (i.e. network bandwidth, machine-room temperature,
64server load average). This package contains documentation on using RRD.
65
66
67%package tcl
68Summary:        RRDTool modules for tcl
69Group:          Development/Libraries
70Requires:       %{name} = %{version}-%{release}
71
72%description tcl
73RRDTool bindings for Tcl.
74
75
76%package -n perl-rrdtool
77Summary:        Perl RRDtool bindings
78Summary(ja):    RRDTool の perl バインディング
79Group:          Development/Libraries
80Requires:       %{name} = %{version}-%{release}
81Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
82
83%description -n perl-rrdtool
84The Perl RRDTool bindings.
85
86
87%package -n python-rrdtool
88Summary:        Python RRDTool bindings
89Summary(ja):    RRDTool の Python バインディング
90Group:          Development/Libraries
91Requires:       %{name} = %{version}-%{release}
92
93%description -n python-rrdtool
94RDTool bindings for python.
95
96
97%package -n python3-rrdtool
98Summary:        Python3 RRDTool bindings
99Summary(ja):    RRDTool の Python3 バインディング
100Group:          Development/Libraries
101BuildRequires: python3-devel
102BuildRequires: python3-rpm-macros
103BuildRequires: python3-setuptools
104Requires:       %{name} = %{version}-%{release}
105
106%description -n python3-rrdtool
107RDTool bindings for python3.
108
109
110%package -n ruby-rrdtool
111Summary:        Ruby RRDTool bindings
112Summary(ja):    RRDTool の ruby バインディング
113Group:          Development/Libraries
114Requires:       %{name} = %{version}-%{release}
115
116%description -n ruby-rrdtool
117RRDtool bindings for Ruby.
118
119
120%prep
121%setup -q
122%patch3 -p1 -b .ruby-2-fix
123autoreconf -vif
124
125%build
126%configure \
127    --disable-rpath \
128    --disable-static \
129    --enable-perl-site-install \
130    --with-perl-options="INSTALLDIRS=vendor" \
131    --enable-ruby \
132    --enable-ruby-site-install \
133    --with-pic
134
135# Fix another rpath issue
136%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
137    bindings/perl-shared/Makefile.PL
138
139# Remove Rpath from Ruby
140%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
141    bindings/ruby/extconf.rb
142sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
143
144perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
145%{__make} %{?_smp_mflags}
146
147%{__make} %{?_smp_mflags} -C bindings python PYTHON=%{__python3}
148
149%install
150%{__rm} -rf ${RPM_BUILD_ROOT}
151%{__make} install DESTDIR=${RPM_BUILD_ROOT}
152pushd bindings/python
153%{py3_install}
154popd
155
156# Install ruby module by force
157mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
158make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
159
160# We only want .txt and .html files for the main documentation
161rm -rf docs_to_be_included
162mkdir -p docs_to_be_included/html docs_to_be_included/txt
163mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
164mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
165
166# Put perl docs in perl package
167rm -rf docs_perl
168mkdir -p docs_perl/html
169mv docs_to_be_included/html/RRD*.html docs_perl/html/
170
171# Clean up
172%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
173%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
174%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
175%{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
176%{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
177
178%find_lang %{name}
179
180%clean
181%{__rm} -rf ${RPM_BUILD_ROOT}
182
183%post -p /sbin/ldconfig
184
185%postun -p /sbin/ldconfig
186
187%files -f %{name}.lang
188%defattr(-,root,root)
189#doc COPYING NEWS README TODO
190%{_bindir}/rrd*
191%{_libdir}/lua/*/rrd.so.*
192%{_libdir}/librrd*.so.*
193%{_mandir}/man1/*.1*
194%{_datadir}/rrdtool/examples/cgi-demo.cgi
195
196%files devel
197%defattr(-,root,root)
198%{_includedir}/rrd*.h
199%{_libdir}/lua/*/rrd.so
200%{_libdir}/librrd.so
201%{_libdir}/pkgconfig/librrd.pc
202%{_mandir}/man3/librrd.3*
203
204%files doc
205%defattr(-,root,root,-)
206%license COPYRIGHT LICENSE
207%doc CONTRIBUTORS TODO NEWS THREADS
208%doc docs_to_be_included/html docs_to_be_included/txt
209
210%files tcl
211%defattr(-,root,root)
212%doc bindings/tcl/README
213#%{_datadir}/rrdtool/ifOctets.tcl
214#%{_datadir}/rrdtool/pkgIndex.tcl
215%{_libdir}/tclrrd*.so
216%{_libdir}/rrdtool/*.tcl
217
218%files -n perl-rrdtool
219%defattr(-,root,root)
220%{perl_vendorlib}/RRDp.pm
221%{perl_vendorarch}/RRDs.pm
222%{perl_vendorarch}/auto/RRDs/RRDs.so
223%{_datadir}/rrdtool/examples/*.pl
224%{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
225%{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
226%{_mandir}/man3/RRD?.3pm*
227
228%files -n python-rrdtool
229%defattr(-,root,root)
230%license bindings/python/COPYING
231%doc bindings/python/AUTHORS bindings/python/README
232%{python_sitearch}/rrdtool-*-py*.egg-info
233%{python_sitearch}/rrdtool.so
234
235%files -n python3-rrdtool
236%defattr(-,root,root)
237%license bindings/python/COPYING
238%doc bindings/python/AUTHORS bindings/python/README
239%{python3_sitearch}/rrdtool-*-py*.egg-info
240%{python3_sitearch}/rrdtool.*.so
241%{_datadir}/rrdtool/examples/*.py
242
243%files -n ruby-rrdtool
244%defattr(-,root,root,-)
245%doc bindings/ruby/README
246%{ruby_vendorarchdir}/RRD.so
247
248%changelog
249* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
250- new upstream release.
251- built with ruby-2.6.5.
252- added python3 support.
253
254* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
255- new upstream release.
256- rebuilt with perl-5.26.
257- rebuilt with ruby-2.4.6.
258- updated Patch3.
259
260* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
261- rebuild with ruby-2.2.3
262
263* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
264- rebuild with libdbi-0.9.0
265
266* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
267- new upstream release.
268- added Group tag to subpackages
269- added ruby subpackages
270- split documents into subpackages
271- added %%post and %%postun section
272
273* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
274- new upstream release.
275
276* Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
277- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.