source: projects/specs/trunk/r/rrdtool/rrdtool-vl.spec @ 12477

Revision 12477, 7.7 KB checked in by tomop, 4 years ago (diff)

updated 11 packages

libxml2-2.9.10-4

newt-0.52.21-2

python-docutils-0.16-2

python-inotify-0.9.6-3

python-lxml-4.5.2-2

python-pykf-0.3.4-8

python-2.7.18-1

rhpxl-1.9-10

rrdtool-1.7.2-3

system-config-date-1.9.61-3

system-config-network-1.6.2-2

Line 
1
2# Basic Information
3Name:           rrdtool
4Summary:        RRDtool - Round Robin Database tool
5Summary(ja):    RRDtool - ラウンドロビンデータベースツール
6Version:        1.7.2
7Release:        3%{?_dist_release}
8Group:          admin-tools,graphics
9Vendor:         Project Vine
10Distribution:   Vine Linux
11Packager:       yasumichi
12
13License:        GPLv2+ with exceptions
14URL:            http://oss.oetiker.ch/rrdtool/
15Source0:        http://oss.oetiker.ch/%{name}/pub/%{name}-%{version}.tar.gz
16Patch3:         rrdtool-1.6.0-ruby-2-fix.patch
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19# Dependency
20BuildRequires:  glib2-devel
21BuildRequires:  glibc-devel
22BuildRequires:  libdbi-devel
23BuildRequires:  libxml2-devel
24BuildRequires:  lua-devel
25BuildRequires:  pango-devel
26BuildRequires:  perl(ExtUtils::MakeMaker)
27BuildRequires:  python-devel
28BuildRequires:  python-setuptools
29BuildRequires:  ruby-devel
30BuildRequires:  tcl-devel
31
32%description
33It is pretty easy to gather status information from all sorts of things,
34ranging from the temperature in your office to the number of octets which
35have passed through the FDDI interface of your router. But it is not so
36trivial to store this data in a efficient and systematic manner. This is
37where RRDtool kicks in. It lets you log and analyze the data you gather from
38all kinds of data-sources (DS). The data analysis part of RRDtool is based
39on the ability to quickly generate graphical representations of the data
40values collected over a definable time period.
41
42#%%description -l ja
43
44
45%package devel
46Summary:        Libraries and include files of RRDtool
47Group:          system
48Requires:       %{name} = %{version}-%{release}
49
50%description devel
51Libraries and include files of RRDtool
52
53
54%package doc
55Summary: RRDtool documentation
56Summary(ja): RRDtool のドキュメント
57Group: documentation
58BuildArch: noarch
59
60%description doc
61RRD is the Acronym for Round Robin Database. RRD is a system to store and
62display time-series data (i.e. network bandwidth, machine-room temperature,
63server load average). This package contains documentation on using RRD.
64
65
66%package tcl
67Summary:        RRDTool modules for tcl
68Group:          programming
69Requires:       %{name} = %{version}-%{release}
70
71%description tcl
72RRDTool bindings for Tcl.
73
74
75%package -n perl-rrdtool
76Summary:        Perl RRDtool bindings
77Summary(ja):    RRDTool の perl バインディング
78Group:          programming
79Requires:       %{name} = %{version}-%{release}
80Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
81
82%description -n perl-rrdtool
83The Perl RRDTool bindings.
84
85
86%package -n python-rrdtool
87Summary:        Python RRDTool bindings
88Summary(ja):    RRDTool の Python バインディング
89Group:          programming
90Requires:       %{name} = %{version}-%{release}
91Requires:       python(abi) = %{python_version}
92
93%description -n python-rrdtool
94RDTool bindings for python.
95
96
97%package -n python3-rrdtool
98Summary:        Python3 RRDTool bindings
99Summary(ja):    RRDTool の Python3 バインディング
100Group:          programming
101BuildRequires:  python3-devel
102BuildRequires:  python3-rpm-macros
103BuildRequires:  python3-setuptools
104Requires:       %{name} = %{version}-%{release}
105Requires:       python(abi) = %{python3_version}
106
107%description -n python3-rrdtool
108RDTool bindings for python3.
109
110
111%package -n ruby-rrdtool
112Summary:        Ruby RRDTool bindings
113Summary(ja):    RRDTool の ruby バインディング
114Group:          programming
115Requires:       %{name} = %{version}-%{release}
116
117%description -n ruby-rrdtool
118RRDtool bindings for Ruby.
119
120
121%prep
122%setup -q
123%patch3 -p1 -b .ruby-2-fix
124autoreconf -vif
125
126
127%build
128%configure \
129    --disable-rpath \
130    --disable-static \
131    --enable-perl-site-install \
132    --with-perl-options="INSTALLDIRS=vendor" \
133    --enable-ruby \
134    --enable-ruby-site-install \
135    --with-pic
136
137# Fix another rpath issue
138%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$rp||g' \
139    bindings/perl-shared/Makefile.PL
140
141# Remove Rpath from Ruby
142%{__perl} -pi.orig -e 's|-Wl,--rpath -Wl,\$\(EPREFIX\)/lib||g' \
143    bindings/ruby/extconf.rb
144sed -i 's|/ruby/extconf.rb|/ruby/extconf.rb --vendor |' bindings/Makefile
145
146perl -pi -e 's/(rrdcached_LDADD =)/$1 \$(ALL_LIBS) /' src/Makefile
147%{__make} %{?_smp_mflags}
148
149%{__make} %{?_smp_mflags} -C bindings python PYTHON=%{__python3}
150
151
152%install
153%{__rm} -rf ${RPM_BUILD_ROOT}
154%{__make} install DESTDIR=${RPM_BUILD_ROOT}
155pushd bindings/python
156%{py3_install}
157popd
158
159# Install ruby module by force
160mkdir -p $RPM_BUILD_ROOT/%{ruby_vendorarchdir}
161make -C bindings/ruby install DESTDIR=$RPM_BUILD_ROOT
162
163# We only want .txt and .html files for the main documentation
164rm -rf docs_to_be_included
165mkdir -p docs_to_be_included/html docs_to_be_included/txt
166mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/html/* docs_to_be_included/html/
167mv $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}/txt/* docs_to_be_included/txt/
168
169# Put perl docs in perl package
170rm -rf docs_perl
171mkdir -p docs_perl/html
172mv docs_to_be_included/html/RRD*.html docs_perl/html/
173
174# Clean up
175%{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}-*
176%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/lua/*/rrd.la
177%{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/librrd*.la
178%{__rm} -f ${RPM_BUILD_ROOT}%{perl_archlib}/perllocal.pod
179%{__rm} -f ${RPM_BUILD_ROOT}%{perl_vendorarch}/auto/*/.packlist
180
181chmod -x ${RPM_BUILD_ROOT}%{_datadir}/rrdtool/examples/*.py
182
183%find_lang %{name}
184
185
186%clean
187%{__rm} -rf ${RPM_BUILD_ROOT}
188
189
190%post -p /sbin/ldconfig
191%postun -p /sbin/ldconfig
192
193
194%files -f %{name}.lang
195%defattr(-,root,root)
196#doc COPYING NEWS README TODO
197%{_bindir}/rrd*
198%{_libdir}/lua/*/rrd.so.*
199%{_libdir}/librrd*.so.*
200%{_mandir}/man1/*.1*
201%{_datadir}/rrdtool/examples/cgi-demo.cgi
202
203%files devel
204%defattr(-,root,root)
205%{_includedir}/rrd*.h
206%{_libdir}/lua/*/rrd.so
207%{_libdir}/librrd.so
208%{_libdir}/pkgconfig/librrd.pc
209%{_mandir}/man3/librrd.3*
210
211%files doc
212%defattr(-,root,root,-)
213%license COPYRIGHT LICENSE
214%doc CONTRIBUTORS TODO NEWS THREADS
215%doc docs_to_be_included/html docs_to_be_included/txt
216
217%files tcl
218%defattr(-,root,root)
219%doc bindings/tcl/README
220#%{_datadir}/rrdtool/ifOctets.tcl
221#%{_datadir}/rrdtool/pkgIndex.tcl
222%{_libdir}/tclrrd*.so
223%{_libdir}/rrdtool/*.tcl
224
225%files -n perl-rrdtool
226%defattr(-,root,root)
227%{perl_vendorlib}/RRDp.pm
228%{perl_vendorarch}/RRDs.pm
229%{perl_vendorarch}/auto/RRDs/RRDs.so
230%{_datadir}/rrdtool/examples/*.pl
231%{_datadir}/rrdtool/examples/rrdcached/RRDCached.pm
232%{_datadir}/rrdtool/examples/rrdcached/rrdcached-size.pl
233%{_mandir}/man3/RRD?.3pm*
234
235%files -n python-rrdtool
236%defattr(-,root,root)
237%license bindings/python/COPYING
238%doc bindings/python/README*
239%{python_sitearch}/rrdtool-*-py*.egg-info
240%{python_sitearch}/rrdtool.so
241
242%files -n python3-rrdtool
243%defattr(-,root,root)
244%license bindings/python/COPYING
245%doc bindings/python/README*
246%{python3_sitearch}/rrdtool-*-py*.egg-info
247%{python3_sitearch}/rrdtool.*.so
248%{_datadir}/rrdtool/examples/*.py
249
250%files -n ruby-rrdtool
251%defattr(-,root,root,-)
252%doc bindings/ruby/README
253%{ruby_vendorarchdir}/RRD.so
254
255
256%changelog
257* Wed Aug 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-3
258- fixed dependency.
259
260* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-2
261- rebuilt with python-3.8.
262
263* Mon Mar 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.2-1
264- new upstream release.
265- built with ruby-2.6.5.
266- added python3 support.
267
268* Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
269- new upstream release.
270- rebuilt with perl-5.26.
271- rebuilt with ruby-2.4.6.
272- updated Patch3.
273
274* Sun Sep 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-3
275- rebuild with ruby-2.2.3
276
277* Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.9-2
278- rebuild with libdbi-0.9.0
279
280* Mon Jan  5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.4.9-1
281- new upstream release.
282- added Group tag to subpackages
283- added ruby subpackages
284- split documents into subpackages
285- added %%post and %%postun section
286
287* Tue Jul  1 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.8-1
288- new upstream release.
289
290* Fri Feb 17 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 1.4.7-1
291- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.